16:00:13 <adrian_otto> #startmeeting Solum Team Meeting
16:00:16 <openstack> Meeting started Tue Aug 26 16:00:13 2014 UTC and is due to finish in 60 minutes.  The chair is adrian_otto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:19 <openstack> The meeting name has been set to 'solum_team_meeting'
16:00:24 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Solum#Agenda_for_2014-08-26_2200_UTC Our Agenda
16:00:32 <adrian_otto> #topic Roll Call
16:00:35 <adrian_otto> Adrian Otto
16:00:38 <datsun180b> Ed Cranford
16:00:39 <ravips> Ravi Sankar Penta
16:00:43 <devkulkarni> Devdatta Kulkarni
16:00:44 <gpilz> Gilbert Pilz
16:00:44 <muralia> Murali Allada
16:01:10 <stannie1> Pierre Padrixe
16:01:20 <roshanagr> Roshan Agrawal
16:01:43 <james_li> james li
16:02:42 <adrian_otto> welcome everyone. Let's begin
16:02:50 <adrian_otto> #topic Announcements
16:02:54 <ravips> I will be on ETO from Aug 29th to Sep 12th, so will miss the next 2 meetings
16:02:56 <diga_> Hi
16:03:06 <adrian_otto> ravips: enjoy your time off!!
16:03:15 <datsun180b> have fun!
16:03:18 <adrian_otto> I'll count that as Announcement #1
16:03:26 <devkulkarni> have fun ravips
16:03:32 <ravips> thanks :)
16:03:46 <adrian_otto> Announcement #2 is:
16:03:48 <adrian_otto> Our team has expressed an intent to pursue incubation for Solum.
16:03:55 <adrian_otto> One of the criteria for exiting incubation is showing production usage of the software from a project team.
16:04:03 <adrian_otto> Rackspace is now using Solum in a production capacity in the delivery of one of it's managed services.
16:04:12 <diga_> ok
16:04:12 <adrian_otto> I look forward to announcing other production uses of Solum as I learn about them.
16:04:42 <adrian_otto> thanks to all our contributors for helping to make this possible
16:05:08 <adrian_otto> Announcement #3 is:
16:05:10 <adrian_otto> Release 2014.2.1 (+python.solumclient 1.2.1) cut.
16:05:21 <adrian_otto> #link http://tarballs.openstack.org/solum/solum-2014.2.1.tar.gz Solum 2014.2.1 Release Tarball
16:05:27 <adrian_otto> #link http://tarballs.openstack.org/solum/solum-2014.2.1.tar.gz Solum 2014.2.1 Release Tarball
16:05:35 <muralia> woot!
16:05:42 <adrian_otto> I still have some administrative shoveling to do in Launchpad
16:05:53 <datsun180b> that's a good verb for that
16:06:20 <adrian_otto> but *applause* for another release for both solum and python-solumclient that include a lot of our blood sweat and tears
16:06:29 <adrian_otto> the bug fixlists are impressive
16:06:46 <adrian_otto> Announcement #4 is:
16:06:58 <adrian_otto> #link http://openstacksv.com/ Openstack Silicon Valley 2014-09-16
16:07:14 <adrian_otto> this is an OpenStack event happening in Northern California next month
16:07:30 <adrian_otto> I will be attending. It happens to fall on a Tuesday, so it will conflict with our team meeting
16:08:04 <adrian_otto> I'd like to plan to take one of two actions: 1) Cancel out 9/16 team meeting -or- 2) Select a pro-tem chair to run it while I am out
16:08:09 <adrian_otto> what are your preferences?
16:08:29 <devkulkarni> keep the meeting so that there is continuity
16:08:36 <datsun180b> i say keep the pattern, #2
16:08:41 <ravips> option-2 preferred
16:08:42 <james_li> +1
16:08:48 <muralia> +1
16:08:52 <adrian_otto> ok, in that case, I will take volunteers to chair
16:08:57 <stannie> #2
16:09:11 <devkulkarni> I can do it
16:09:20 <adrian_otto> devkulkarni: thanks.
16:09:22 <datsun180b> i've got prior experience! i'll even file the minutes in the right directory this time
16:09:25 <adrian_otto> any objections?
16:09:46 <devkulkarni> datsun180b: cool. I will pick your brain then :)
16:10:07 <adrian_otto> ok, so devkulkarni can be the chair, and if he does not appear on time, then datsun180b will assume the role for him.
16:10:08 <datsun180b> dev's got this
16:10:18 <devkulkarni> sounds good
16:10:26 <adrian_otto> #agreed devkulkarni will chair our team meeting on 2014-09-16
16:10:40 <adrian_otto> Announcement #5 is:
16:10:51 <adrian_otto> All Bug/Task tickets have been triaged. Please check to see if you have any marked INCOMPLETE.
16:11:08 <adrian_otto> #link https://bugs.launchpad.net/solum/+bugs Our Bug List for Solum
16:11:44 <adrian_otto> so now is the time to scan the backlog of bugs and tasks, and to get me your input for what should be included in juno-3. I have some guidance from you already.
16:12:06 <adrian_otto> it's not too late to make a case for including anything you are willing to allocate engineering resources towards.
16:12:30 <devkulkarni> is there a link for juno-3 that you can share with all?
16:12:48 <adrian_otto> devkulkarni: not yet. That is one of the shoveling items I need to do
16:13:17 <devkulkarni> okay.
16:13:30 <adrian_otto> ok, so that concludes our announcements. (that was a bunch!)
16:13:38 <adrian_otto> #topic Review Action Items
16:13:40 <devkulkarni> while we are discussing juno, could we curate juno-2
16:13:42 <adrian_otto> (none)
16:13:44 <stannie> so what has been written by roshan in the wiki/ml is not the final roadmap for juno-3 right ?
16:14:05 <adrian_otto> stannie: not final, but that is my guideline, yes
16:14:08 <stannie> ok
16:14:18 <roshanagr> stannnie: that is meant to be a basis for discussionm not final
16:14:20 <adrian_otto> if you have strong feelings about adjusting anything, let's talk
16:14:41 <adrian_otto> we have room for that in Open Discussion today
16:14:47 <adrian_otto> #topic Blueprint/Task Review
16:15:00 <adrian_otto> #link https://bugs.launchpad.net/solum/+bug/1358462 Java+Tomcat Language Pack
16:15:02 <uvirtbot> Launchpad bug 1358462 in solum "Create Java+Tomcat language pack to run Java web applications" [Undecided,Incomplete]
16:15:07 <adrian_otto> Should we develop a Java language pack? Are existing Build Packs sufficient?
16:15:41 <devkulkarni> adrian_otto: so we need some investigation about whether CF Javabuildpack would work as is in Solum or not
16:15:45 <adrian_otto> the reason I am raising this for discussion is because similar work appears to be happening in other open source projects that we may be able to leverage.
16:15:55 <adrian_otto> here is a link for that:
16:16:06 <adrian_otto> #link http://blog.cloudfoundry.org/2013/09/06/introducing-the-cloud-foundry-java-buildpack/ CF Java BuildPack
16:16:14 <roshanagr> Java is a popular language so should support that our of box in Solum.
16:16:22 <adrian_otto> my understanding is that at least one also exists for Heroku
16:16:34 <adrian_otto> roshanagr: agreed.
16:16:44 <devkulkarni> so we already support Java runtime via cedarish stack
16:16:45 <roshanagr> We do need to work out if we want to build our own docker image for it, or leverage CF build pack
16:16:53 <ravips> yeah, I agree if there is an existing buildpack we can leverage thta
16:16:57 <adrian_otto> my question is whether we accomplish that by leveraging prior art, or making our own equivalent(s)
16:17:02 <gpilz> it would be uber-cool if I could run the VitaMinder example on both nCAMP and Solum
16:17:22 <adrian_otto> I also recognize that OpenShift has good support for JBOSS
16:17:30 <devkulkarni> gpilz: what all things do you need for that app to run? jdk version/maven/tomcat ?
16:17:33 <adrian_otto> so it might make sense to explore that too
16:17:40 <roshanagr> leveraging prior art (say CF build pack) is worth exploring
16:17:42 <devkulkarni> adrian_otto: sure
16:18:02 <adrian_otto> recognizing that a JBOSS runtime and a Tomcat runtime are rather different.
16:18:06 <roshanagr> how do we think of TomCat
16:18:16 <ravips> openshift cartridges is curently on v2 (yaml format) and v3 format will support dockerfile
16:18:49 <roshanagr> I think Java Tomcat 7 would be nice
16:19:13 <devkulkarni> roshanagr: sure.. I guess one problem with picking a specific tool and specific version
16:19:31 <devkulkarni> is there is a high probability that we will become outdated soon..
16:19:40 <gpilz> +1 Tomcat 7 - known quantity
16:20:15 <devkulkarni> what we should aim at is doing something that we are currently doing for Python/Ruby.. have a 'requirements.txt' kind of thing in the repo and then use it to build the runtime with the required tools
16:20:25 <adrian_otto> the root of my question really comes down to whether we want the support/maintenance commitment that comes with developing an LP for a given language
16:20:30 <devkulkarni> the only thing that would not really change is jdk version (which will be somewhat stable)
16:20:37 <adrian_otto> should that be carried by the open source project, or the cloud operators?
16:21:09 <devkulkarni> open source project like ours will be always short handed trying to support
16:21:10 <gpilz> seems like a core set of LPs should be carried by the project
16:21:15 <devkulkarni> all the lps that people may want
16:21:26 <devkulkarni> we should provide reference LPs
16:21:31 <adrian_otto> projects in the CI/CD space leave hands off of this, and projects in the PaaS space seem to take this on.
16:21:33 <devkulkarni> with ability to create custom LPs
16:21:41 <stannie> by the opensource project is fine but we have to make sure it's up to date with the latest security fixes (always some troubles with java :/)
16:21:44 <roshanagr> adrian_otto: to your point, are you suggesting we add support for "custom language packs" and democratise what does into the language pack
16:22:11 <devkulkarni> roshanagr: we already have support for custom language pack
16:22:17 <adrian_otto> I want us to make a concious decision to enter the world of language specific LP's
16:22:23 <devkulkarni> (the API part still needs some work)
16:22:32 <adrian_otto> or a deliberate decision not to
16:22:53 <roshanagr> devkulkarni: good to know !
16:23:07 <devkulkarni> I suggest we provide some reference packs (Java 8 with Tomcat 7, for ex)
16:23:18 <devkulkarni> and then provide the custom language pack API
16:23:34 <devkulkarni> which would enable consumers of a particular instance of Solum to create their own LPs
16:23:43 <devkulkarni> and register them in their own Glance
16:23:50 <devkulkarni> to be used in their plan files
16:23:53 <adrian_otto> devkulkarni: one possible drawback to that approach is that we may be incorrectly perceived as an XYZ language only solution
16:24:11 <stannie> in CF what is cool is that you can fork the LP source and then extend the LP with your specific changes
16:24:21 <adrian_otto> just like Heroku was before they produced reference Build Packs for a variety of languages
16:24:38 <devkulkarni> adrian_otto: valid point
16:24:38 <adrian_otto> in fact that was DotCloud's point of differentiation
16:25:08 <devkulkarni> so one way to get around that will be to not tie the LPs that we provide with the Solum codebase itself
16:25:17 <adrian_otto> yes
16:25:35 <adrian_otto> the language specific LP's could be isolated from Solum in that way
16:25:49 <adrian_otto> to exhibit an arms-length relationship
16:25:53 <devkulkarni> right
16:26:08 <roshanagr> adrian+otto: I like your suggested approach
16:26:10 <devkulkarni> also to emphasize that the provided LPs are just for example
16:26:11 <gpilz> adrian: does anyone really think anyone does language-specific PaaS anymore?
16:26:20 <adrian_otto> and it would lend itself to delegating control to other groups for maintenance of them
16:26:33 <adrian_otto> so the Ruby experts can own one, and the Java experts can own another, etc.
16:26:52 <ravips> are we saying separate repo that will have reference implementations?
16:27:09 <adrian_otto> gpilz: you would be surprised how misguided most of the public is when given limited information
16:27:19 <devkulkarni> gpilz: actually yes.. I have heard folks going to particular PaaS because that PaaS has the best support for Python
16:27:42 <adrian_otto> ravips: yes, that's an option for us
16:27:45 <devkulkarni> ravips: yes
16:27:58 <adrian_otto> another approach might be to place them in contrib for now
16:28:07 <adrian_otto> and label them very clearly as references
16:28:20 <devkulkarni> yep. that's where we currently have the Dockerfiles for Chef and Go
16:28:49 <ravips> okay
16:29:26 <devkulkarni> ravips: mind adding some links to that bug about OpenShift cartridges?
16:29:47 <devkulkarni> whenever you get a chance
16:29:49 <adrian_otto> ok, so maybe what we can do is start with a contrib approach
16:30:25 <adrian_otto> and revisit this again once we have had some more time to consider the ramifications of including or moving that code to other projects
16:30:26 <ravips> #link http://openshift.github.io/documentation/openshift-pep-010-docker-cartridges.html
16:30:42 <devkulkarni> thanks ravips
16:30:49 <adrian_otto> anyone object to starting with this compromise?
16:30:53 <devkulkarni> adrian_otto: sounds good to me
16:31:14 <ravips> I like that
16:31:20 <stannie> +1
16:31:30 <muralia> +1
16:31:34 <adrian_otto> roshanagr: ?
16:31:37 <gpilz> +1
16:31:39 <roshanagr> +1
16:31:42 <roshanagr> like it
16:31:45 <james_li> +1
16:31:48 <adrian_otto> ok, good, one moment for the #agreed
16:32:49 <adrian_otto> #agreed Language specific language packs may be added to our contrib directory, labeled clearly as reference implementations, and shall be evaluated for movement to dedicated projects if/when they are used for production purposes and require ongoing maintenance.
16:33:23 <adrian_otto> ok, that satisfied my interest in this. I hope you all like that too.
16:33:35 <devkulkarni> +1
16:33:41 <adrian_otto> ok, so we are still in bug/BP/task review
16:34:02 <adrian_otto> I want to draw core reviewer attention to one review in particular…
16:34:12 <adrian_otto> https://review.openstack.org/111846
16:34:33 <adrian_otto> #link https://review.openstack.org/111846 Add barbican/mistral devstack integration for functionaltests
16:35:03 <adrian_otto> I suggest we get any final feedback in for this work, and proceed to merging once it's acceptable
16:35:08 <adrian_otto> ahead of other priorities
16:35:13 <datsun180b> looks like it's already got 2 approves, it's zuul is just hammered right now
16:35:19 <adrian_otto> there is other work that is depending on it
16:35:26 <adrian_otto> ok, good, that happened this morning then
16:35:34 <datsun180b> that Toggle CI button is nice
16:35:48 <adrian_otto> thanks ravips for getting that in
16:35:57 <devkulkarni> +1 thanks ravips
16:36:01 <ravips> thanks you all for your reviews
16:36:05 <datsun180b> that review is also carrying a bugfix from image handler
16:36:18 <adrian_otto> ok, are there other work items that need team discussion or attention?
16:36:32 <devkulkarni> ravips's other patch (private git repo)
16:36:38 <datsun180b> yeah that's a big one
16:37:02 <devkulkarni> we all should try to get it in before ravips leaves for vacation (he has already gone through many rebases)
16:37:22 <datsun180b> agreed
16:37:40 <adrian_otto> #link https://review.openstack.org/109468 Plan create/show will display artifact public ssh keys if present
16:37:44 <adrian_otto> is that the one you meant?
16:38:08 <devkulkarni> #link https://review.openstack.org/#/c/105605/
16:38:11 <devkulkarni> that one
16:38:22 <devkulkarni> ravips: Jenkins is complaining on it
16:38:33 <muralia> this should get fixed when the first one gets merged
16:38:38 <datsun180b> likely it's that image states ordering bug
16:38:57 <ravips> yes, this one is dependent on previous pull request
16:39:30 <devkulkarni> the previous one being the one with barbican client?
16:39:35 <ravips> yes
16:39:40 <devkulkarni> ok
16:39:47 <datsun180b> http://logs.openstack.org/05/105605/12/check/gate-solum-devstack-dsvm/a39ff5b/console.html.gz devstack setup failed, looks like upstream deps
16:39:48 <adrian_otto> I don't see anything in the dependencies section for 105605
16:40:51 <ravips> adrian_otto: how to add dependecies to PR?
16:41:14 <datsun180b> cross-project, i don't think you can
16:41:14 * ravips still learning gerrit tool
16:41:54 <adrian_otto> ravips: I have not done it after the fact… the way I have done it is by checking out the parent branch, and then modifying it. and submitting it as a separate review
16:42:02 <adrian_otto> then it happens automatically
16:42:16 <stannie> ravips: do you mean dependencies to a patch ? you have to submit a review with multiple commits
16:42:22 <datsun180b> within the same project, dependency ordering is git patch ordering
16:42:24 <adrian_otto> but it's not important since the other chance is in the merge queue already
16:42:33 <ravips> ah, ok I will try that next time
16:42:36 <adrian_otto> I'll order a recheck on 105605 once that merges
16:42:40 <devkulkarni> right.. we don't need it now
16:42:40 <adrian_otto> so don't worry about it
16:42:52 <ravips> okay
16:42:56 <datsun180b> er commit ordering anyway
16:43:10 <stannie> you just have to make sure you've different change-ids in your patch
16:43:33 <ravips> ok, understood..thx
16:43:47 <adrian_otto> ok, any other things we should bird dog?
16:43:58 <datsun180b> you can watch your meters fill up at http://status.openstack.org/zuul/ just filter on "solum" and expand the job boxes
16:44:26 <adrian_otto> ok, let's proceed to Open Discussion then
16:44:33 <adrian_otto> #topic Open Discussion
16:44:45 <devkulkarni> Paris — do we have a slot for Solum?
16:45:19 <adrian_otto> not yet.
16:45:38 <adrian_otto> My submissions for Summit sessions (main conference) for Solum were all rejected (4 of them)
16:45:47 <datsun180b> boo
16:45:52 <muralia> :(
16:45:56 <adrian_otto> the only one accepted was my multi-cloud containers talk
16:45:58 <devkulkarni> do they give feedback reviews?
16:46:14 <adrian_otto> once the call for submisions for OpenSource at OpenStack opens, we can apply for that.
16:46:34 <adrian_otto> I am confident that we will get that again like we did in Atlanta
16:46:35 <devkulkarni> and these are not part of the main conference?
16:46:49 <adrian_otto> that is part of the main conference, but it is not considered a Session
16:46:58 <adrian_otto> it's not part of the Design Summit though
16:47:25 <adrian_otto> and we can still apply to have Design Summit sessions to discuss our various project integration concerns
16:47:31 <devkulkarni> I see.. we should soon start articulating what next things we would want to discuss while at Paris
16:47:43 <adrian_otto> that usually opens for submissions and voting about a month before the event
16:48:54 <devkulkarni> ok
16:49:37 <adrian_otto> on another tiopic, Solum team members should be aware of this
16:49:51 <adrian_otto> #link #link https://review.openstack.org/114044 OpenStack Containers Service Spec Proposal
16:50:32 <adrian_otto> this is an effort within the OpenStack Compute project to add a new API service for containers to work in harmony with Nova
16:50:36 <devkulkarni> cool. thanks for sharing
16:50:57 <adrian_otto> since we all use containers a lot, it would be nice to have your input on that proposal
16:51:04 <devkulkarni> would this API be part of nova or separate from it?
16:51:23 <adrian_otto> devkulkarni: it would be a separate API that treats Nova as an upstream
16:51:53 <ravips> is this proposal in review or it got accepted by nova team?
16:52:12 <adrian_otto> it has been agreed to in concept by the Nova team, and we are iterating on it now
16:52:25 <ravips> okay
16:53:05 <adrian_otto> that review is not intended to merge into nova-specs, because it will have it's own repo soon.
16:53:20 <adrian_otto> it's there temporarily for collaboration purposes
16:54:24 <adrian_otto> whoops its != it's (sloppy grammar, Adrian)
16:55:09 * adrian_otto five minute bell
16:57:00 <adrian_otto> ok, anything else for today?
16:57:56 <adrian_otto> thanks everyone for attending. I'll see you here again next week. Our next meeting is on 2014-09-02 at 2200 UTC.
16:58:03 <adrian_otto> #endmeeting