22:00:19 <adrian_otto1> #startmeeting Solum Team Meeting
22:00:20 <openstack> Meeting started Tue Oct 14 22:00:19 2014 UTC and is due to finish in 60 minutes.  The chair is adrian_otto1. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:00:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:00:23 <openstack> The meeting name has been set to 'solum_team_meeting'
22:00:23 <adrian_otto1> #link https://wiki.openstack.org/wiki/Meetings/Solum Our Agenda
22:00:29 <adrian_otto1> #topic Roll Call
22:00:32 <adrian_otto1> Adrian Otto
22:00:33 <datsun180b> Ed Cranford
22:01:29 <adrian_otto1> hi datsun180b
22:01:34 <datsun180b> howdy
22:01:36 <dimtruck> Dimitry Ushakov
22:02:10 <PaulCzar> o/
22:04:13 <adrian_otto1> hi dimtruck and PaulCzar
22:04:25 <adrian_otto1> is Devdatta joining us today?
22:05:29 <PaulCzar> I think he's travelling home ?
22:05:37 <adrian_otto1> ok, then let's begin
22:05:37 <PaulCzar> so he might join from there
22:05:44 <adrian_otto1> #topic Announcements
22:05:50 <adrian_otto1> upcoming meetings.
22:06:00 <adrian_otto1> We have a bunch of Tuesdays with interesting things happening
22:06:10 <adrian_otto1> next tuesday I will be out on vacation.
22:06:39 <adrian_otto1> the Tuesday after that (Oct 28) I will be speaking at Zendcon
22:07:13 <datsun180b> oh i'll be out next tuesday too
22:07:36 <adrian_otto1> the Tuesday after that we are at the Paris summit (Election Day)
22:07:59 <adrian_otto1> the Tuesday after that is Veterans day
22:10:29 <adrian_otto2> Sorry, my internet connection was interrupted by local construction work here at my office. So, it might make sense to think about the upcoming schedule
22:10:50 <adrian_otto2> which meetings to hold with an alternate chair, and which ones to skip (if any)
22:11:20 <adrian_otto2> let's start with 2014-10-21. Is there a team member who would like to hold and chair that meeting?
22:12:06 <adrian_otto2> anyone still with me?
22:12:11 <datsun180b> just me!
22:12:13 <PaulCzar> I'm here
22:12:19 <dimtruck> me too
22:12:22 <adrian_otto2> ok, good, thanks guys.
22:12:40 <dimtruck> i can do it
22:12:45 <dimtruck> on 10-21
22:12:46 <datsun180b> I already said I'm out next Tuesday
22:13:09 <adrian_otto1> ok, any objections to dimtruck acting as chair on 2014-10-21?
22:13:17 <PaulCzar> I won't be available to attend or chair
22:13:28 <adrian_otto1> #agreed dimtrruck will be our chair on 2014-10-21
22:13:32 <dimtruck> yay!
22:13:41 <adrian_otto1> ok, how about 2014-10-28
22:13:43 <datsun180b> thanks dimtruck
22:13:48 <adrian_otto1> that's the week before the Summit.
22:14:02 <PaulCzar> i nominate devdatta to run it
22:14:13 <datsun180b> i'd second if he were here to accept it
22:14:31 <adrian_otto1> well, we can just put that on our agenda for next week
22:14:51 <adrian_otto1> and you can decide at that point whether to hold it or cancel it, and if we hold it who will run it.
22:15:04 <adrian_otto1> I propose we skip the week of the Summit
22:15:23 <datsun180b> i don't think anyone will disagree with you
22:15:27 <adrian_otto1> and then regroup the week after that, ignoring the fact that it's a holiday for some.
22:15:49 <adrian_otto1> ok, any other announcements from team members?
22:16:22 <datsun180b> gil said he'd be 20 minutes late; i imagine this meeting might end before he gets here
22:16:30 <adrian_otto1> #topic Review Action Items
22:16:33 <datsun180b> he had two things that might count more as actions though
22:16:36 * adrian_otto1 adrian_otto to ask on ML if current Solum contributors would like to explore adjusting our meeting schedule, or keeping it the same.
22:16:45 <adrian_otto1> Status: Incomplete
22:16:52 <adrian_otto1> I will carry this forward on the agenda
22:17:02 <adrian_otto1> #action adrian_otto to ask on ML if current Solum contributors would like to explore adjusting our meeting schedule, or keeping it the same.
22:17:22 <adrian_otto1> we can revisit this topic in action item review on the 21st.
22:17:30 <adrian_otto1> I will be on an airplane at that time
22:17:53 <adrian_otto1> #topic Blueprint/Task Review
22:18:14 <adrian_otto1> Does anyone have specific work items they would like to raise for team discussion
22:18:21 <datsun180b> Yes, one from Gil:
22:18:24 <datsun180b> #link https://review.openstack.org/#/c/126748/
22:18:33 <datsun180b> he's rebased his CAMP review on recent master
22:19:03 <PaulCzar> I need to rebase this again - https://review.openstack.org/#/c/102646/
22:19:03 <adrian_otto1> ok
22:19:22 <PaulCzar> I've been busy on other rax stuff and haven't had the time to test it thoroughly again
22:19:26 <datsun180b> Oh and he also wanted me to ask about "devdatta was supposed to open a bug about the fact that the Accept header handling for json vs. yaml on the plan resources didn't comply with HTTP"
22:20:20 <PaulCzar> also need to find new owners for https://review.openstack.org/#/c/103937/ and https://review.openstack.org/#/c/119955
22:20:28 <PaulCzar> or abandon them
22:21:17 <adrian_otto1> so I voted on Gil's patch
22:21:21 <adrian_otto1> next is: https://review.openstack.org/102646
22:21:36 <adrian_otto1> that's in merge conflict which will presumably clear once you rebase, right PaulCzar?
22:21:42 <PaulCzar> correct
22:21:53 <adrian_otto1> ok, so we will defer to your action on that one
22:21:58 <PaulCzar> but its old enough probably need to do a thorough test through it
22:22:01 <gpilz> back
22:22:33 <datsun180b> gpilz: you got half your +2s looks like
22:22:37 <PaulCzar> working on a deploy to our production solum environment tomorrow ... after that can spend time on it.
22:22:38 <adrian_otto1> next is https://review.openstack.org/103937
22:22:50 <adrian_otto1> seeking a new owner
22:23:22 <adrian_otto1> any takers?
22:23:25 <datsun180b> friendliness eh
22:23:43 <adrian_otto1> PaulCzar: I suggest you put a comment on it putting it up for adoption
22:23:53 <adrian_otto1> and if nobody picks it up, then I will abandon it for you
22:23:55 <PaulCzar> will do
22:24:07 <datsun180b> as long as it doesn't get abandoned it won't go anywhere, and any of us can add new patches to it
22:24:14 <adrian_otto1> taht's a new power that cores now have (since recent Gerrit upgrades)
22:24:34 <dimtruck> I can own it (just had to read through it)
22:25:04 <adrian_otto1> next is: https://review.openstack.org/119955
22:25:28 <PaulCzar> that one can probably be abandoned,  there's not a lot of meat to it
22:25:53 <adrian_otto1> yes, that sounds like the right approach to me. Any alternate views to hear on this topic?
22:26:36 <adrian_otto1> ok, any further discussion on work items?
22:27:10 <datsun180b> gil's here now but his other item was about our Accept handler
22:27:11 <adrian_otto1> #topic Cutting Juno Release
22:27:33 <adrian_otto1> datsun180b: that did not make it on the agenda, so we can hear that in Open Discussion
22:27:47 <datsun180b> just doing what i promised
22:27:52 <adrian_otto1> this is the time in the cycle where I tag a release
22:27:55 <gpilz> thanx
22:28:12 <adrian_otto1> does anyone have a problem with tagging what we have in the repo right now?
22:28:41 <adrian_otto1> I'll move for a #agreed to tag our release, and begin focus on Kilo
22:28:46 <adrian_otto1> thoguhts?
22:28:47 <datsun180b> weeeeell dimtruck and i are actively working on a bug with using shelve
22:29:05 <datsun180b> namely that if you try it it will fail and you will cry
22:29:23 <adrian_otto1> datsun180b: when would be a reasonable expectation to have a fix merged?
22:29:34 <adrian_otto1> would it be about this time next week?
22:29:37 <adrian_otto1> sooner or later?
22:29:37 <datsun180b> oh easy
22:29:51 <datsun180b> i'll have to ask him, i think it's already logged on LP
22:29:51 <adrian_otto1> ok, so we can regroup on it when I return to work next wednesday
22:30:00 <adrian_otto1> and we'll have the release cut prior to Paris
22:30:04 <datsun180b> aaaaand my unit test fix works, shipping shortly
22:30:37 <adrian_otto1> ok, I am also around tomorrow, but might be scheduled a bit tight to fit that in
22:30:49 <adrian_otto1> anyone opposed to preparing our release on Oct 22?
22:31:22 <adrian_otto1> ok, I'll mark my calendar accordingly
22:31:35 <adrian_otto1> #topic October Elections
22:31:52 <adrian_otto1> it's time to decide if we will hold an election
22:32:18 <adrian_otto1> or set a deadline for challengers to file a statement of intent to run for election
22:32:39 <adrian_otto1> for our PTL
22:33:01 <adrian_otto1> thoughts on this?
22:33:09 <datsun180b> Do you intend to run?
22:33:16 <adrian_otto1> yes.
22:33:38 <datsun180b> all righty
22:34:02 <PaulCzar> what about we hold an election the week before the summit, and require statement of intent the week before that
22:34:06 <PaulCzar> which is probably next week ?
22:34:13 <adrian_otto1> if we repeat what we did last time, we just need to set an open period where candidacy emails will be recognized
22:34:23 <adrian_otto1> and if no challengers emerge, then no election is required.
22:34:31 <datsun180b> sounds good
22:35:34 <adrian_otto1> ok, so we can have the open period until Oct 27 at UTC 0:00.
22:35:43 <adrian_otto1> oh, actually
22:36:17 <adrian_otto1> that shold probably be Oct 21, if there is a challenger, then campaign can be until Oct27, and election on Oct 28.
22:36:28 <PaulCzar> +1 ship it
22:36:32 <datsun180b> agree
22:36:46 <adrian_otto1> ok, any disagreement?
22:37:38 <adrian_otto1> #action adrian_otto to email ML for open candidacy until Oct 21 UTC 0:00 for PTL challengers (consistent with rules form last election period)
22:38:12 <adrian_otto1> and we can declare an election date if there are any challengers by the deadline
22:38:27 <adrian_otto1> as our team meeting will follow the deadline on the same day
22:38:33 <adrian_otto1> ok
22:38:37 <adrian_otto1> #topic Open Discussion
22:38:47 <adrian_otto1> Gil, you have something for us about Accept headers
22:38:52 <gpilz> yes
22:38:57 <gpilz> sorry to be so disorganized
22:39:06 <adrian_otto1> np
22:39:28 <gpilz> there was a patch that made it possible to receive plan resources in either JSON or YAML
22:39:40 <gpilz> I don't have the change number on me
22:40:31 <gpilz> I was reviewing it with devdatta and noticed that the code didn't properly implement RFC 2116
22:40:53 <gpilz> devdatta made the case that we should let the patch go, and file a bug against it later
22:41:00 <gpilz> i'm trying to figure out where we are in that process
22:41:44 <adrian_otto1> ok
22:41:54 <adrian_otto1> so, I"m not aware of such a bug
22:42:00 <adrian_otto1> but I can take a look
22:42:03 <datsun180b> #link https://review.openstack.org/#/c/115685/3 and down that chain
22:42:13 <adrian_otto1> any links to bugs in there?
22:42:32 <datsun180b> #link https://launchpad.net/bugs/1331093
22:42:33 <uvirtbot> Launchpad bug 1331093 in solum "Plan API should return json/yaml as accept header specifies" [Critical,In progress]
22:42:45 <gpilz> so this hasn't been merged yet?
22:42:52 <adrian_otto1> datsun180b: thanks!
22:42:53 <datsun180b> looks like it's open
22:43:04 <adrian_otto1> yep
22:43:16 <adrian_otto1> ping Pierre for current status
22:43:20 <gpilz> okay
22:43:27 <gpilz> can I pick this up and finish it?
22:43:47 <adrian_otto1> once you touch base with him, and offer, that is allowed
22:43:53 <gpilz> okay
22:43:54 <gpilz> thanks
22:43:57 <adrian_otto1> our only concern should be not to interfere with his active work
22:44:16 <adrian_otto1> based on the age of this, tht risk is pretty low
22:44:33 <adrian_otto1> Any other business for today?
22:44:53 <datsun180b> got that bugfix for shelve in
22:45:00 * datsun180b dusts hands off
22:45:03 <adrian_otto1> whoot!
22:45:08 <adrian_otto1> well done datsun180b
22:45:28 <adrian_otto1> ok, let's wrap up
22:45:35 <PaulCzar> thanks everyone!
22:45:38 <adrian_otto1> thanks everyone for attending
22:45:38 <dimtruck> thanks!
22:45:46 <adrian_otto1> #endmeeting