22:00:19 <devkulkarni> #startmeeting Solum Team Meeting
22:00:20 <openstack> Meeting started Tue Oct 28 22:00:19 2014 UTC and is due to finish in 60 minutes.  The chair is devkulkarni. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:00:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:00:25 <openstack> The meeting name has been set to 'solum_team_meeting'
22:00:36 <devkulkarni> #link https://wiki.openstack.org/wiki/Meetings/Solum Our Agenda
22:00:57 <devkulkarni> #topic Roll Call
22:00:59 <adrian_otto> Adrian Otto
22:01:00 <datsun180b> Ed Cranford
22:01:05 <devkulkarni> Devdatta
22:01:25 <muralia> murali allada
22:01:36 <gpilz> Gilbert Pilz
22:01:37 <james_li> james li
22:02:11 <devkulkarni> #topic Announcements
22:02:32 <roshanagr> Roshan Agrawal
22:02:33 <devkulkarni> I have one announcement. adrian_otto will continue to serve as Solum's PTL. congratulations :)
22:02:50 <gpilz> My condolences Adrian
22:03:06 <muralia> congrats
22:03:17 <devkulkarni> hi roshanagr
22:03:28 <roshanagr> hi devkulkarni
22:03:35 <roshanagr> congrats Adrian
22:03:43 <datsun180b> sounds like last week's meeting was eventful
22:03:46 <devkulkarni> adrian_otto: floor is yours  to address the team..
22:04:42 <devkulkarni> okay. we can come back to that point in the open discussion..
22:04:50 <devkulkarni> #topic Review Action Items
22:04:59 <devkulkarni> we have lots of action items this week
22:05:07 <devkulkarni> devkulkarni to follow up with ravips regarding bash script to python conversion
22:05:28 <devkulkarni> I tried to catch ravips but was not successful. I will try again this week
22:05:39 <devkulkarni> lets carry that forward
22:05:48 <devkulkarni> #action devkulkarni to follow up with ravips regarding bash script to python conversion
22:06:00 <devkulkarni> 2) dimtruck to follow up on bugs 1359516 and investigate for any specific issues in replacing simple_server with mod_wsgi
22:06:01 <uvirtbot> Launchpad bug 1359516 in solum "Needs to handle http header 'X-Forwarded-Proto'" [Undecided,Confirmed] https://launchpad.net/bugs/1359516
22:06:06 <devkulkarni> dimtruck, you around?
22:06:32 <devkulkarni> zz_dimtruck: ping
22:07:08 <devkulkarni> looks like dimtruck is not around. lets carry this forward for next week.
22:07:19 <devkulkarni> #action dimtruck to follow up on bugs 1359516 and investigate for any specific issues in replacing simple_server with mod_wsgi
22:07:20 <uvirtbot> Launchpad bug 1359516 in solum "Needs to handle http header 'X-Forwarded-Proto'" [Undecided,Confirmed] https://launchpad.net/bugs/1359516
22:07:34 <devkulkarni> the next action item is also for dimtruck.
22:08:00 <devkulkarni> lets skip that as well..
22:08:19 <devkulkarni> next one was for adrian_otto
22:08:22 <devkulkarni> adrian_otto to cut the final Juno release
22:09:14 <devkulkarni> probably he must be on it since next week is the Summit
22:09:59 <devkulkarni> till we hear about the Juno release, I would like us to carry that forward as well. Thoughts?
22:10:19 <datsun180b> sgtm
22:10:38 <james_li> yeah
22:10:48 <devkulkarni> ok. will carry that forward. #action adrian_otto to cut the final Juno release
22:11:01 <devkulkarni> #action dimtruck to report back results of multi-node devstack with solum setup
22:11:12 <devkulkarni> next one is gpilz to add no-ops if CAMP is not enabled
22:11:24 <devkulkarni> gpilz: floor is yours
22:11:33 <gpilz> haven't gotten to that yet
22:11:36 <gpilz> sorry
22:11:40 <devkulkarni> no worries
22:11:55 <gpilz> still struggling to get vagrant/devstack up
22:11:59 <devkulkarni> mind if we carry that to next meeting so that we don't forget about it?
22:12:14 <gpilz> i don't mind
22:12:28 <devkulkarni> gpilz: oh! lets talk about those issues in the open discussion.
22:12:34 <devkulkarni> okay, thanks.
22:12:43 <devkulkarni> #action gpilz to add no-ops if CAMP is not enabled
22:12:55 <devkulkarni> next up is mkam
22:13:01 <devkulkarni> mkam to add no-ops if BARBICAN is disabled
22:13:20 <devkulkarni> mkam: you around?
22:13:41 <datsun180b> careful you don't keep that trend up and spell HEAT in all caps
22:14:49 <devkulkarni> ok, lets carry that forward as well
22:15:11 <devkulkarni> #action mkam to add no-ops if barbican is disabled
22:15:27 <devkulkarni> moving on to the next topic
22:15:40 <devkulkarni> #topic Blueprint/Task Review
22:16:03 <devkulkarni> I don't have anything on the wiki. Is there any particular patch that requires immediate attention?
22:16:14 <devkulkarni> patch/blue print?
22:16:46 <datsun180b> did the barbi auth change get merged, james_li?
22:17:00 <devkulkarni> yes it did datsun180b
22:17:01 <james_li> it was merged this morning
22:17:21 <datsun180b> that's all that comes to mind then
22:17:40 <devkulkarni> there was a bug where TLOG was consuming docker image id
22:17:52 <devkulkarni> james_li fixed that and it also is now merged
22:18:17 <datsun180b> i imagine the shell scripts are something of a moving target for poor ravips
22:18:18 <devkulkarni> btw, our Jenkins gate is complaining
22:19:22 <devkulkarni> muralia: about this patch: https://review.openstack.org/#/c/125731/9
22:19:32 <muralia> yes
22:19:49 <muralia> i need to address some comments
22:19:50 <devkulkarni> james_li: about your comment of assembly being none
22:20:07 <muralia> yes, im working on it. got sidetracked with some auth related work
22:20:10 <devkulkarni> how do you suggest that should be addressed? will a simple null check be enough?
22:20:12 <datsun180b> oh i guess that one won't rebase out will it
22:20:37 <muralia> thats what i was thinking for a simple fix, but i want to look at it once more
22:20:50 <james_li> devkulkarni: muralia I put a -1 on that. I hope that can be fixed in either Ed's log patch or muralia's
22:20:52 <devkulkarni> muralia: no worries. I want to check with james_li how should the concern be addressed
22:20:59 <datsun180b> whatever you do, write it down so i can do the same thing for userlogs
22:21:09 <devkulkarni> james_li: you have another comment apart from the log comment
22:21:17 <datsun180b> james brought the same point up on my review
22:21:40 <devkulkarni> that is a good point which james_li is raising
22:21:43 <muralia> yes, now that james' patch when it first, i need to do the same so that tlog doesnt eat up the id
22:22:13 <muralia> i'll address both those issues and submit a patch soon
22:22:14 <james_li> muralia: that's great
22:22:14 <devkulkarni> muralia: yes. the tlog fix is clear. I am asking about james_li's other comment
22:22:21 <devkulkarni> cool
22:22:23 <devkulkarni> thanks muralia
22:22:45 <devkulkarni> is PaulCzar around today?
22:23:27 <devkulkarni> probably not. I want us to push the https://review.openstack.org/#/c/102646/ forward
22:23:49 <devkulkarni> looks like there are some comments from ravips on it
22:23:58 <devkulkarni> I will take that as an action item
22:24:22 <devkulkarni> #action devkulkarni to follow up with PaulCzar and ravips on the CoreOS+VM patch
22:24:50 <devkulkarni> any other patches?
22:25:04 <devkulkarni> that we should surface for the group to look at?
22:25:12 <gpilz> https://review.openstack.org/#/c/128768/
22:25:16 <gpilz> should be good to go
22:25:36 <devkulkarni> gpilz: okay. will take a look at it soon.
22:26:14 <devkulkarni> if there are no other patches to discuss, lets move on to the next topic
22:26:21 <devkulkarni> #topic Paris Summit
22:26:24 <gpilz> maybe we could spread the load to other reviewers as well?
22:27:23 <devkulkarni> gpilz: yes — the only issue is reading and understanding of the CAMP spec. Not that it is required, but reviews will make sense more if that context is kept in mind
22:27:52 <devkulkarni> and frankly I don't know how many of other reviewers have looked at the spec yet.
22:28:25 <devkulkarni> but yeah, muralia, james_li
22:28:41 <devkulkarni> feel free to review gpilz's patch
22:28:45 <muralia> yes. i'll take a look
22:28:53 <james_li> ok
22:28:55 <devkulkarni> cool. thanks muralia
22:29:06 <devkulkarni> so back to Paris summit
22:29:22 <devkulkarni> I understand that roshanagr, gpilz, and adrian_otto will be there
22:29:43 <devkulkarni> are there any specific topics that you all are planning to discuss?
22:29:49 <devkulkarni> roshanagr:?
22:30:00 <roshanagr> also folks from Numergy
22:30:12 <devkulkarni> that's right
22:30:23 <roshanagr> the attendance of Solum contributors is so thin at the Paris summit
22:30:35 <devkulkarni> true
22:30:41 <roshanagr> that not sure if it will be worthwhile to tackle project topics
22:30:49 <gpilz> < talks real loud so he counts for two people
22:30:49 <devkulkarni> fair enough
22:30:58 <devkulkarni> ha ha ha
22:30:59 <roshanagr> :-)
22:31:29 <devkulkarni> roshanagr: you do want to bring up topic about meeting time with stannie and julien_vey
22:31:54 <roshanagr> devkulkarni: sure
22:32:12 <devkulkarni> roshanagr: thanks
22:32:20 <roshanagr> the plan will be to participate in dependent projects design sessions, and raise Solum dependencies
22:32:53 <gpilz> do we need to co-ordinate?
22:32:55 <devkulkarni> yeah, that makes sense
22:33:08 <gpilz> are there simultaneous sessions where we should spread out?
22:33:08 <roshanagr> if you all have dependencies you know of (from Nova, Mistral, etc.) do surface them so those of us at the summit can bring them up
22:33:26 <devkulkarni> gpilz: it will be good to do that so that as a team we cover maximum number of dependent projects
22:33:34 <roshanagr> gpilz: I haven't looked through the session schedule yet
22:33:49 <roshanagr> but yes, spreading out is a good idea
22:33:57 <devkulkarni> roshanagr: Nova and Heat will be the most important ones imo
22:34:38 <devkulkarni> there is another related topic that I wanted to bring up
22:34:59 <devkulkarni> meeting next week.. I think the week of the summit there are no meetings.
22:35:23 <devkulkarni> it will be good if we make it formal, unless folks want to meet
22:35:41 <devkulkarni> thoughts?
22:35:49 <datsun180b> i think it's fair to skip next week's meeting
22:36:05 <devkulkarni> muralia, james_li:?
22:36:13 <james_li> agree
22:36:14 <muralia> +1, im not sure everyone will be available
22:36:15 <roshanagr> skip
22:37:06 <devkulkarni> #agreed we will not have meeting on November 4. We will continue with our schedule on November 11.
22:37:34 <devkulkarni> btw, does anyone have the etherpad for Paris handy?
22:37:49 <devkulkarni> I want to put that on main Solum wiki page
22:38:45 <devkulkarni> if there are no more points to discuss about Paris, lets move on to the next topi
22:38:47 <devkulkarni> topic
22:38:51 <devkulkarni> #topic Open Discussion
22:39:20 <devkulkarni> gpilz: vagrant issue.. what exactly is the issue that you are running into?
22:39:31 <datsun180b> do tell
22:39:46 <gpilz> https://review.openstack.org/#/c/128768/
22:39:48 <gpilz> oopas
22:39:53 <gpilz> one sec
22:40:02 <gpilz> http://paste.openstack.org/show/126174/
22:40:24 <gpilz> "Docker virt driver fails with ml2 linuxbridge driver"
22:40:39 <devkulkarni> have you updated solum?
22:40:39 <datsun180b> well that's new
22:40:53 <devkulkarni> I was seeing that in the worker logs when james_li's TLOG patch was not merged
22:41:10 <devkulkarni> never mind
22:41:22 <devkulkarni> I think you are not even trying to create any assembly here
22:41:27 <gpilz> I haven't updated solum
22:41:34 <gpilz> I've updated vagrant
22:41:49 <gpilz> do I need to rebase my solum stuff off of the latest master?
22:42:04 <devkulkarni> can you also update solum. there were two patches from james_li which got merged this morning. they were blockers
22:42:07 <datsun180b> yeah it's got a couple fixes
22:42:31 <gpilz> okay
22:43:19 <devkulkarni> that said, datsun180b, james_li, I don't think the above error is due to those missing bits in gil's environment
22:43:40 <devkulkarni> gpilz: are you seeing this error when you just do 'vagrant up', right?
22:44:13 <datsun180b> maybe not
22:44:31 <gpilz> vagrant up —provision devstack
22:45:00 <devkulkarni> gpilz: hmm.. okay. most likely even though you update solum above issue might not go away.
22:45:36 <gpilz> yeah - it doesn't seem very solum-ish
22:45:37 <devkulkarni> I have been trying out some changes with our vagrant setup but haven't seen this issue
22:46:00 <devkulkarni> at this point all I can say is we need to investigate. can I request you one thing?
22:46:12 <devkulkarni> can you create an issue on our vagrant-solum-env github repo
22:46:28 <devkulkarni> please add the error log to the issue so that we have a track of it
22:46:43 <datsun180b> we'll get to the bottom of it
22:46:59 <devkulkarni> +1
22:47:10 <gpilz> sure thing
22:47:20 <devkulkarni> thanks gpilz
22:47:27 <adrian_otto> devkulkarni: sorry I have been afk (at a conference)
22:47:41 <devkulkarni> adrian_otto: hi! no worries
22:47:52 <adrian_otto> I see from my scrollback that we plan to meet Nov 11. Would you like me to resume chair duties on that date. I am available.
22:47:55 <devkulkarni> floor is yours
22:48:07 <devkulkarni> oh yes. sure!
22:48:08 <adrian_otto> thanks for running things while I have been out!!
22:48:23 <adrian_otto> ok, super.
22:48:23 <devkulkarni> np
22:48:49 <devkulkarni> if you have few minutes to share your views for Paris/Kilo that would be super.
22:49:19 <dimtruck> hey devkulkarni
22:49:28 <adrian_otto> My high level view is to work on adoption and meeting the needs of users who adopt
22:49:29 <devkulkarni> dimtruck: you had two action items
22:49:53 <devkulkarni> adrian_otto: +1
22:49:55 <adrian_otto> so those who are using Solum in production will drive our priority list for the project task list
22:50:06 <dimtruck> i did - i'm sorry i'm late.  this bus has 0 internet :(.  would you guys mind if i push those back to next week?  it's very flaky here.
22:50:10 <adrian_otto> and we will take feedback about key features desired by our users
22:50:24 <devkulkarni> dimtruck: no worries. we already did :)
22:50:45 <devkulkarni> adrian_otto: makes sense
22:51:19 <devkulkarni> adrian_otto: in that regard
22:51:20 <adrian_otto> but I expect focus primarily on quality and fleshing out what we have, and less on new features for Kilo
22:51:31 <devkulkarni> we had an interesting request — multi-node solum setup
22:51:40 <devkulkarni> +10 for quality
22:51:51 <devkulkarni> dimtruck is investigating the multi-node setup
22:51:59 <adrian_otto> multi-node could be accomplished using an alternate heat template
22:52:32 <adrian_otto> a simple catalog of topologies with corresponding templates (that take input parameters) may work nicely for that need
22:52:53 <adrian_otto> the first of which is likely 3-tier-web
22:52:54 <devkulkarni> possibly. I think the request was more for the control plane
22:53:09 <adrian_otto> what controls are desired?
22:53:09 <devkulkarni> control plane of Solum
22:53:28 <devkulkarni> don't remember off the top of my head. I did create a wishlist bug
22:53:31 <adrian_otto> oh, to scale out the API/worker noddes?
22:53:35 <devkulkarni> right
22:53:49 <adrian_otto> ok, that should already be possible
22:54:04 <adrian_otto> maybe some documentation could help show how to do that
22:54:14 <devkulkarni> yep.
22:54:15 <dimtruck> here's what i've been trying to replicate with solum devstack: http://devstack.org/guides/multinode-lab.html
22:54:19 <datsun180b> yeah they should all play nice with each other
22:54:24 <devkulkarni> that's what I expect output of dimtruck's investigation
22:54:26 <adrian_otto> the worker pool is really easy to scale out
22:54:30 <datsun180b> though a handful of db functions should be moved to conductor
22:55:11 <devkulkarni> thanks for sharing the #link http://devstack.org/guides/multinode-lab.html dimtruck
22:55:56 <devkulkarni> okay. 5 minute warning
22:56:44 <devkulkarni> if there is nothing else, lets wish good luck to everyone attending Paris and reconvene on November 11th
22:57:18 <devkulkarni> thanks everyone for attending.
22:57:22 <devkulkarni> #endmeeting