22:01:14 <adrian_otto> #startmeeting Solum Team Meeting
22:01:15 <openstack> Meeting started Tue Nov 11 22:01:14 2014 UTC and is due to finish in 60 minutes.  The chair is adrian_otto. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:01:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:01:19 <openstack> The meeting name has been set to 'solum_team_meeting'
22:01:24 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Solum Our Agenda
22:01:30 <adrian_otto> #topic Roll Call
22:01:32 <adrian_otto> Adrian Otto
22:01:38 <muralia> Murali Allada
22:01:40 <ravips> Ravi Sankar Penta
22:01:52 <devkulkarni> devdatta kulkarni
22:01:58 <james_li> james li
22:02:43 <adrian_otto> #topic Announcements
22:02:55 <adrian_otto> none prepared. Any announcements from team members?
22:03:36 <dimtruck> Dimitry Ushakov
22:04:07 <adrian_otto> #topic Review Action Items
22:04:16 <adrian_otto> we have a whole bunch of stuff in here
22:04:22 <adrian_otto> I'll iterate the list
22:04:37 * adrian_otto devkulkarni to follow up with ravips regarding bash script to python conversion
22:04:47 <devkulkarni> ravips is on top of this already
22:04:47 <ravips> I will give an update on this
22:05:19 <ravips> I have done some ground work to convert bash to python for app build/unittest workflow
22:05:42 <adrian_otto> !! yay !!
22:05:44 <openstack> adrian_otto: Error: "!" is not a valid command.
22:05:58 <ravips> lp can be loaded dynamically and we don't have to change any solum worker api for new lp changes
22:06:20 <adrian_otto> Do we have documentation for how to do this?
22:06:34 <ravips> I have converted cedarish-docker, dockerfile-docker, chef-docker to python
22:06:54 <adrian_otto> user docs I mean
22:07:04 <ravips> we don't have readme but I have added comments in the code
22:07:26 <ravips> each class describes its purpose
22:07:28 <adrian_otto> ok, we should open a task to put on the backlog for making how-to docs for this
22:07:57 <adrian_otto> I am super happy we are getting this converted!!
22:08:14 <muralia> long overdue
22:08:14 <ravips> solum code is constantly moving and if anyone willing to help me will be great
22:08:43 <muralia> Awesome, I'll take a look at whats out there and see what I can add
22:09:03 <adrian_otto> we will also have additional team members joining us starting next week
22:09:04 <ravips> lots of pending work: need tons of test cases, most of the code is untested, need to convert remaining lp plugins
22:09:15 <ravips> mainly cedarish-vm, cedarish-vmslug, etc.
22:09:18 <adrian_otto> so we can farm out some of this to newcomers as well
22:10:08 <muralia> we might want to create tasks or bugs for each task, so that it'll be easy for someone to take one and work on it
22:10:10 <ravips> we anyone willing to  help, we can coordinate and move things forward to avoid any duplicate effort
22:10:14 <adrian_otto> ravips: any more on this subject?
22:10:27 <adrian_otto> muralia: +1
22:10:36 <ravips> nope..continue with the next topic
22:10:39 <adrian_otto> ok
22:10:46 * adrian_otto dimtruck to follow up on bugs 1359516 and investigate for any specific issues in replacing simple_server with mod_wsgi
22:10:47 <uvirtbot> Launchpad bug 1359516 in solum "Needs to handle http header 'X-Forwarded-Proto'" [Undecided,Confirmed] https://launchpad.net/bugs/1359516
22:11:02 <dimtruck> still in progress :(
22:11:11 <adrian_otto> ok if I carry it forward to next week?
22:11:14 <dimtruck> yes sir
22:11:22 <adrian_otto> #action dimtruck to follow up on bugs 1359516 and investigate for any specific issues in replacing simple_server with mod_wsgi
22:11:30 <adrian_otto> next is...
22:11:31 * adrian_otto dimtruck to report back results of multi-node devstack with solum setup
22:12:08 <dimtruck> preliminarily research showed that it will NOT be an issue for us
22:12:19 <dimtruck> however, to validate it fully, can we carry it forward one more week?
22:12:30 <dimtruck> the main bottleneck is barbican
22:12:30 <adrian_otto> #action dimtruck to report back results of multi-node devstack with solum setup
22:12:44 <dimtruck> that's the outstanding research topic
22:12:54 <adrian_otto> how is that a bottleneck? Can you elaborate?
22:13:21 <dimtruck> sure...we basically cannot store keys across multiple nodes right now
22:13:33 <dimtruck> err, sorry
22:13:39 <adrian_otto> using barbacan would help with that, right?
22:13:44 <dimtruck> right
22:13:54 <dimtruck> we default to shelve ...using barbican will fix it
22:13:56 <dimtruck> when they're ready
22:14:08 <devkulkarni> default to shelve in devstack, that is
22:14:22 <dimtruck> or we store it in our own solum db...
22:14:22 <adrian_otto> ok, what criteria will determine readiness?
22:14:48 <dimtruck> when they define their api's :)
22:15:07 <adrian_otto> to play devil's advocate
22:15:16 <adrian_otto> an API does exist, and API's are versioned
22:15:25 <adrian_otto> is there something we need in the API that does not yet exist?
22:15:33 <adrian_otto> or could we pin to an existing API version?
22:15:42 <dimtruck> we've had a few issues with pre 1.0 changes ... where they went from using a factory Secret to getSecretFactory
22:15:46 <dimtruck> in the same version
22:15:47 <ravips> may be we can use etcd distributed store instead of shelve
22:16:06 <adrian_otto> that's not secure storage
22:16:19 <adrian_otto> so it sounds like we need a stable API release from barbican
22:16:19 <devkulkarni> also, at that point why not just store it in solum db
22:16:25 <dimtruck> adrian_otto: correct
22:16:47 <dimtruck> we know they're hard at work defining it...but we just need some stability prior to calling this a solved problem
22:17:14 <adrian_otto> ok, that's clear. When will we expect a stable barbican API? Where are we tracking this so we don't lose sight of it?
22:17:41 <dimtruck> so we're tracking it with our tests :)
22:18:06 <adrian_otto> ok, so we have func tests against barbican that fail when they break the API?
22:18:12 <ravips> yes
22:18:15 <dimtruck> right
22:18:17 <adrian_otto> ok, that works.
22:18:26 <adrian_otto> any more on this topic?
22:18:31 <dimtruck> but it's not an explicit way of determining stability of the api
22:19:13 <adrian_otto> have we at least expressed our interest in an API that we can lock down?
22:19:13 <dimtruck> was there anything in the summit that pointed to a date when they can release?
22:19:19 <dimtruck> oh yes
22:19:40 <dimtruck> we've had those discussions and were even asked feedback on their current design from them
22:19:44 <dimtruck> on the barbican channel
22:19:52 <adrian_otto> I don't have Barbican news from the summit to share, sorry.
22:20:33 <dimtruck> after giving them the last feedback, they changed it out on us ;)
22:20:38 <adrian_otto> ok, so as long as we have expressed our interest in that, and have a way to know when it breaks… I see that as fine for now.
22:20:43 <dimtruck> awesome!!
22:21:06 <adrian_otto> do I speak for all of us on that, or should we see about doing something different?
22:21:30 <dimtruck> i'm in the same boat adrian_otto.  i think that's a good approach
22:21:37 <devkulkarni> sounds good to me
22:21:40 <muralia> ya
22:21:44 <adrian_otto> ok, I just wanted to check for any alternate views
22:21:57 <adrian_otto> next action item is:
22:21:58 * adrian_otto adrian_otto to cut the final Juno release
22:22:15 <adrian_otto> I will be ready for this before next Tuesday's meeting
22:22:17 <adrian_otto> so I willc arry it
22:22:23 <adrian_otto> #action adrian_otto to cut the final Juno release
22:22:56 <adrian_otto> This only takes about an hour on my end (mostly signing packages with crypto keys and copying stuff around)
22:23:06 * adrian_otto gpilz to add no-ops if CAMP is not enabled
22:23:20 <adrian_otto> there is a review for this, so I know gpilz did this work
22:23:41 <gpilz> yes, i did
22:23:48 <adrian_otto> https://review.openstack.org/128768
22:23:52 <adrian_otto> #link https://review.openstack.org/128768
22:24:01 <adrian_otto> so that action is complete
22:24:18 <adrian_otto> please review that patchset. I'd like to get this merged.
22:24:41 <devkulkarni> mkam added first set of no-ops. that review should also be available. or is it merged?
22:24:59 <gpilz> dev - it's merged
22:25:08 <gpilz> i rebased off it to get my changes to work
22:25:15 <devkulkarni> cool. thanks mkam!!
22:25:22 <mkam> no problem :)
22:25:27 <mkam> https://review.openstack.org/#/c/132109/
22:25:28 <gpilz> thanks, mkam, for doing the real work
22:25:34 <mkam> hahaha
22:25:51 <adrian_otto> last action was ACTION: mkam to add no-ops if BARBICAN is disabled
22:26:22 <adrian_otto> this action is complete, right?
22:26:26 <mkam> yes
22:26:42 <adrian_otto> ok, now we can move on
22:26:45 <adrian_otto> #topic Blueprint/Task Review
22:26:59 <adrian_otto> any tasks or BP's needing team discussion
22:27:53 <adrian_otto> #topic Paris Summit
22:28:05 <adrian_otto> we held a Solum design session
22:28:38 <adrian_otto> agreed on Kilo's focus to enable production use cases for Solum as the top priority.
22:28:54 <adrian_otto> Checked our roadmap and verified that it is correct for the next areas of focus
22:29:19 <adrian_otto> there were a bunch of sessions on containers related topics that were very well attended
22:30:05 <adrian_otto> pretty much every room was packed where a session relating to Containers or Docker was mentioned in the title or abstract were totally full, standing room only
22:30:15 <adrian_otto> so that's obviously a hot topic
22:30:32 <dimtruck> awesome!
22:30:37 <adrian_otto> project Magnum now has a Stackforge repo, and a bunch of new support
22:30:52 <adrian_otto> so Solum should be able to leverage that when it takes form
22:31:43 <adrian_otto> any questions about the Summit?
22:32:26 <adrian_otto> #topic Open Discussion
22:33:34 <dimtruck> what was the mood of the summit as a whole towards containers/paas?  I know docker is a hot topic but is that the sole solution people are looking at or is there a wide variety of tech being proposed?
22:33:49 <dimtruck> don't know if that's a specific enough question :)
22:34:19 <dimtruck> s/summit/community/
22:34:24 <adrian_otto> As expected, there are still OpenStack stakeholders who want openstack to remain small, and for an ecosystem to form around it
22:34:51 <adrian_otto> and there is (what appeared to me to be a larger majority) interested in actually growing both
22:35:13 <adrian_otto> I'm in that group wanting to grow both, so perhaps my bias was impacting my perception
22:35:23 <dimtruck> awesome!
22:35:37 <ravips> adrian_otto:  any notes/links on solum/containers related discussions @ paris summit
22:35:38 <adrian_otto> it was very clear that the OpenStack user community wants a containers story that's built in
22:35:48 <adrian_otto> not just a bolt on with running Docker yourself
22:36:10 <adrian_otto> I have not written up any blogs/notes
22:36:42 <ravips> okay, np
22:36:43 <adrian_otto> There are etherpads for the three design sessions I led
22:36:50 <adrian_otto> so we could track those down
22:37:11 <adrian_otto> one for Solum, and the following two:
22:37:27 <ravips> can you point me to the etherpad links?
22:37:38 <adrian_otto> #link http://kilodesignsummit.sched.org/event/9f47bddfffa9a1907f2334fa412afaf4#.VGIth-cl5Eg Ops Summit: What do we want from containers/docker?
22:38:01 <adrian_otto> first I will get you the session links
22:38:09 <adrian_otto> then we can find the etherpads
22:38:25 <ravips> got it, thanks
22:38:52 <adrian_otto> #link lodesignsummit.sched.org/event/4ea895d62545e557991dfc5b7405ceb9#.V Containers service (magnum)
22:39:41 <gpilz> ^^ that link doesn't resolve
22:40:21 <adrian_otto> #link http://kilodesignsummit.sched.org/event/4e2033ced61b8dadf7a2db1aee6d8123#.VGKQJOcmwjk Solum for OpenStack Design Session
22:40:47 <adrian_otto> irc://irc.freenode.net:6667/#link http://lodesignsummit.sched.org/event/4ea895d62545e557991dfc5b7405ceb9#.V Containers service (magnum)
22:40:59 <adrian_otto> try one more time
22:41:12 <adrian_otto> #link http://lodesignsummit.sched.org/event/4ea895d62545e557991dfc5b7405ceb9#.V Containers service (magnum)
22:41:22 <adrian_otto> ok, there, that should work
22:41:56 <gpilz> ^^^ just takes you to the Sched main page
22:41:58 <adrian_otto> #link https://wiki.openstack.org/wiki/Summit/Kilo/Etherpads
22:43:05 <adrian_otto> #link https://etherpad.openstack.org/p/kilo-containers-service Containers service (magnum)
22:43:35 <adrian_otto> #link https://etherpad.openstack.org/p/kilo-summit-ops-containers https://etherpad.openstack.org/p/kilo-summit-ops-containers
22:43:48 <adrian_otto> I hate cut+paste in this IRC client
22:44:20 <adrian_otto> #link https://etherpad.openstack.org/p/kilo-summit-ops-containers What do we want from containers/docker?
22:45:10 <adrian_otto> I don't see the Solum etherpad on there
22:46:12 <ravips> for kilo, to focus on production use cases, what are the high level topics we should address? roadmap has a lot of stuff
22:47:02 <gpilz> http://kilodesignsummit.sched.org/event/4ea895d62545e557991dfc5b7405ceb9#.V Containers service (magnum)
22:47:18 <adrian_otto> #link https://wiki.openstack.org/wiki/Solum/HighLevelRoadmap#Milestone_2015.1
22:47:33 <gpilz> #link http://kilodesignsummit.sched.org/event/4ea895d62545e557991dfc5b7405ceb9#.V Containers service (magnum)
22:48:31 <adrian_otto> so at a high level, the ability to use a heat template with multiple cloud resources
22:48:41 <adrian_otto> and the ability to plug in 3rd party services
22:49:05 <adrian_otto> ability to scale an assembly
22:49:39 <adrian_otto> dense packing is already done
22:50:05 <adrian_otto> and application isolation is a characteristic of the way the Heat template is generated.
22:50:22 <adrian_otto> we already have a Mono build pack
22:50:38 <adrian_otto> that one is a community build pack, and I'm not convinced it works very well
22:51:01 <adrian_otto> but I don't think we should work much on that since Microsoft and DOcker are working together on Windows support for Docker
22:51:11 <adrian_otto> we'd really like to follow that workstream instead
22:51:33 <ravips> we are not done with jenkins/trove integration in Juno, those will be pushed out?
22:51:50 <adrian_otto> yes, those carry forward
22:51:55 <ravips> ok
22:54:53 <adrian_otto> ok, let's wrap up
22:54:57 <adrian_otto> any parting thoughts?
22:55:44 <adrian_otto> thanks everyone for attending today. Our next meeting is Tuesday 2014-11-18 at 1600 UTC
22:55:50 <adrian_otto> #endmeeting