16:00:29 <adrian_otto> #startmeeting Solum Team Meeting
16:00:29 <openstack> Meeting started Tue Dec 2 16:00:29 2014 UTC and is due to finish in 60 minutes. The chair is adrian_otto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:30 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:33 <openstack> The meeting name has been set to 'solum_team_meeting'
16:00:46 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Solum#Agenda_for_2014-12-02_1600_UTC Our Agenda
16:00:51 <adrian_otto> #topic Roll Call
16:00:55 <adrian_otto> Adrian Otto
16:01:01 <nshaikh> Navid Shaikh
16:01:01 <gpilz> Gil Pilz
16:01:03 <datsun180b> Ed Cranford
16:01:10 <devkulkarni> Devdatta Kulkarni
16:01:36 <adrian_otto> hello everyone
16:01:42 <datsun180b> howdy
16:02:19 <jorgem> o/
16:02:41 <adrian_otto> we will begin in just a moment
16:03:11 <adrian_otto> if you do not type anything during roll call, that's okay, you can register your attendance at any time during the meeting by participating.
16:03:22 <adrian_otto> #topic Announcements
16:03:32 <adrian_otto> none prepared, any announcements from the team?
16:03:56 <akshayc_> hello everyone.... i am looking to join the team
16:04:18 <adrian_otto> akshayc_: welcome! Would you like to share a bit about yourself?
16:04:32 <devkulkarni> hi akshayc_: welcome. and welcome to nshaikh as well
16:05:26 <stannie> Hi, sorry missed roll call
16:05:27 <akshayc_> i have used openstack and i really liked it. i am looking for ways to contribute.
16:05:36 <adrian_otto> welcome stannie
16:05:47 <akshayc_> used personally, (not in production)
16:06:06 <adrian_otto> akshayc_: I have a blog for you to consider…
16:06:13 <adrian_otto> #link http://adrianotto.com/2014/08/how-to-be-awesome/ How to Be Awesome
16:06:19 <dimtruck> o/
16:06:30 <adrian_otto> dimtruck: just in time
16:06:34 <akshayc_> sure.... also i was looking at the bug list....
16:06:38 <adrian_otto> #topic Review Action Items
16:06:52 <adrian_otto> dimtruck to follow up on bugs 1359516 and investigate for any specific issues in replacing simple_server with mod_wsgi
16:06:53 <uvirtbot> Launchpad bug 1359516 in solum "Needs to handle http header 'X-Forwarded-Proto'" [Undecided,Confirmed] https://launchpad.net/bugs/1359516
16:07:24 <adrian_otto> dimtruck: any update on this?
16:07:30 <dimtruck> ugh, sorry - thanksgiving killed me :(
16:07:36 <dimtruck> can we push this forward one week
16:07:38 <adrian_otto> you are not alone
16:07:42 <adrian_otto> yes, I will carry it
16:07:45 <datsun180b> you're in good company
16:07:50 <adrian_otto> #action dimtruck to follow up on bugs 1359516 and investigate for any specific issues in replacing simple_server with mod_wsgi
16:08:00 <dimtruck> same :(
16:08:04 <dimtruck> i suck
16:08:05 <adrian_otto> SHould I carry this one also: dimtruck to report back results of multi-node devstack with solum setup
16:08:24 <dimtruck> yes please hahaha
16:08:26 <adrian_otto> #action dimtruck to report back results of multi-node devstack with solum setup
16:08:40 <adrian_otto> and like you, I was totally away from work...
16:08:44 <adrian_otto> #action adrian_otto to cut the final Juno release
16:08:55 <adrian_otto> I will complete that before we meet again
16:09:03 <adrian_otto> #topic Blueprint/Task Review
16:09:07 <devkulkarni> akshayc_: there are couple of bugs marked as low hanging fruit
16:09:20 <adrian_otto> this topic is to allow us to cover work tasks that require team collaboration
16:09:30 <akshayc_> ok.... i wlll take a look....
16:09:33 <adrian_otto> would anyone like to raise any?
16:09:39 <akshayc_> any inparticular you are refering to?
16:09:52 <akshayc_> nothing for now
16:09:57 <devkulkarni> don't remember any particular off the top of my head
16:10:01 <datsun180b> oh yeah
16:10:15 <datsun180b> so assembly logs is merged in solum but the logs command in client isn't. can i get a push on that?
16:10:25 <devkulkarni> datsun180b: sure
16:10:29 <datsun180b> #link https://review.openstack.org/#/c/131292/
16:10:45 <datsun180b> thanks
16:11:20 <adrian_otto> ok, any others before open discussion?
16:11:52 <adrian_otto> #topic Open Discussion
16:12:00 <adrian_otto> I have one topic for this section
16:12:10 <devkulkarni> I have one topic as well
16:12:37 <devkulkarni> I had added it to the agenda: #link https://wiki.openstack.org/wiki/Meetings/Solum#Agenda_for_2014-12-02_1600_UTC
16:12:39 <adrian_otto> mine is pertaining to cli refinements and implications on the object model, database
16:12:59 <devkulkarni> adrian_otto: you go first
16:13:02 <adrian_otto> (devkulkarni)
16:13:02 <adrian_otto> Proposal: Change alternating meeting times to a single meeting time. Proposed time: 4.00pm CDT every Tuesday.
16:13:02 <adrian_otto> Use #openstack-meeting-alt if available at that time every Tuesday. If not, use #solum.
16:13:10 <adrian_otto> this will be fast, so we will cover this first
16:13:14 <devkulkarni> ok
16:13:25 <adrian_otto> stannie: I'd like your input on the proposed time
16:13:27 <devkulkarni> so I was wondering if we could go back to a single meeting time
16:14:17 <stannie> do you have somewhere the proposed time in CET ? :)
16:14:30 <adrian_otto> one sec
16:14:51 <devkulkarni> I think it will be 11.00pm CET
16:14:54 <adrian_otto> #link http://www.worldtimebuddy.com/?pl=1&lid=8,100,6,12&h=8 Proposed Time
16:15:08 <adrian_otto> wait
16:15:13 <adrian_otto> one sec, I need to correct it
16:15:32 <adrian_otto> #link http://www.worldtimebuddy.com/?qm=1&lid=8,100,6,12&h=8&date=2014-12-2&sln=14-15 Proposed Time
16:15:40 <stannie> perfect then
16:15:41 <adrian_otto> so that's 11pm for Paris.
16:15:43 <stannie> thanks
16:15:57 <adrian_otto> no objections?
16:16:17 <datsun180b> so if that's tied to UTC then it'll shift for us in the states in the spring
16:16:38 <devkulkarni> but that will be 1 hour forward, so should not affect Paris, right?
16:17:19 <stannie> that will be fine
16:17:39 <adrian_otto> so that would be UTC 2200?
16:17:58 <datsun180b> that's what wtb says
16:18:15 <adrian_otto> so on alternating weeks that wold conflict with the containers team meeting
16:18:20 <devkulkarni> right!
16:18:22 <adrian_otto> which I also chair
16:18:45 <adrian_otto> so either I'd need to miss it on alternating weeks, or see about rescheduling them
16:18:51 <devkulkarni> we can do one hour earlier if that works for you and also if we have the channel available
16:18:59 <datsun180b> or you name a lieutenant for the off weeks?
16:19:02 <adrian_otto> another option would be to check on a slightly earlier time… perhaps 2100 UTC
16:19:23 <devkulkarni> I would say we consider 2100 UTC
16:19:37 <devkulkarni> if this channel is available we use it or we do it in solum on alternate weeks
16:19:43 <adrian_otto> datsun180b: I'm willing to do that
16:20:08 <datsun180b> of course like dev says we'd need a different channel too, and i think that could be confusing if we used two channels
16:20:10 <adrian_otto> there are enough meeting channels to choose from
16:20:25 <adrian_otto> so let's just zero in on a weekly date/time, and I'll get us a free channel to use
16:20:38 <datsun180b> sounds good. i have no problem with 2100Z
16:20:43 <devkulkarni> I am fine with 2100UTC
16:20:54 <adrian_otto> good, any objections to 2100Z?
16:21:20 <adrian_otto> ok, I'm proceeding to an agreed on this. Would you like to make next week the first?
16:21:33 <devkulkarni> yes. lets start from next week
16:21:34 <datsun180b> yes
16:21:37 <stannie> +1
16:21:41 <adrian_otto> since it's normally planned for 2200Z
16:21:47 <adrian_otto> ok, good
16:22:37 <adrian_otto> #agreed Future team meetings will be held at 2100 UTC in an availavle meeting channel to be announced by adrian_otto by email to the ML
16:23:05 <adrian_otto> #action adrian_otto to select IRC meeting channel for next team meeting(s)
16:23:30 <adrian_otto> #action adrian_otto to announce selected channel on ML, and update https://wiki.openstack.org/wiki/Meetings/Solum
16:23:36 <adrian_otto> thanks devkulkarni
16:23:49 <adrian_otto> so, we can advance to my open discussion topic
16:23:57 <adrian_otto> about cli refinement
16:24:07 <devkulkarni> thanks adrian_otto and everyone else for agreeing to change in meeting time
16:25:04 <adrian_otto> our first version of Solum the API was inspired by a desire to embrace open standards. We employed many of the concepts expressed in CAMP. gpilz contributed code for further CAMP compliance based on this API, and we now have a shared object model and database.
16:25:33 <adrian_otto> the terminology used in our current CLI mirrors the API closely
16:25:54 <adrian_otto> this results in a CLI that requires that the end user has a concept of the terminology used by CAMP
16:26:35 <adrian_otto> because CAMP has not been adopted by other systems used by today's software developers, we notice confusion when presenting the concepts of assemblies and plans for the first time
16:26:53 <adrian_otto> initially we expected the learning curve to be easily managed
16:27:34 <adrian_otto> that expectation has been met with challenge… the bottom line is that the concepts we are using to express the modeling of applications are not easily understood by our end users
16:27:45 <adrian_otto> to respond to that, we plan to refine the CLI further
16:28:10 <adrian_otto> working to adopt terminology that is already understood, and stepping away from the plan and assembly concepts
16:28:30 <adrian_otto> solum <verb> <noun>
16:28:41 <adrian_otto> or possible solum <noun> <verb>
16:28:48 <datsun180b> aww away from plan you say
16:28:48 <adrian_otto> where the noun is usually "app"
16:29:14 <adrian_otto> yes, have I captured the intent properly?
16:29:38 <datsun180b> you have, but i have a cli review choosing plan over app :c
16:30:01 <datsun180b> no big deal, don't let me distract
16:30:02 <adrian_otto> don't worry about what's currently in play
16:30:09 <devkulkarni> about <noun> <verb>, other OpenStack services have <noun>-<verb>
16:30:23 <devkulkarni> heat stack-create, for example
16:30:29 <devkulkarni> vs. solum app create
16:30:40 <adrian_otto> yes, the "openstack" client (aka OSC) uses the noun verb ordering. This is a detail we can work out later.
16:31:02 <devkulkarni> sure.. just wanted to bring that up since we are anyways thinking of changing the CLI
16:31:39 <adrian_otto> now, I'd prefer if refinements to the API don't require a wholesale overhaul to the object model and database, and perhaps even the existing API
16:31:44 <devkulkarni> so adrian_otto, the problem definition is clear.. what is the proposal?
16:31:57 <devkulkarni> okay.. you are explaining that..
16:31:59 <adrian_otto> I'm getting to that… sorry for being so verbose
16:32:20 <adrian_otto> it is tempting to chuck out the API, and make one that perfectly matches the "revised" CLI
16:32:21 <devkulkarni> no worries..
16:32:42 <adrian_otto> my question is can we first try making a refined CLI with minimal adjustments the existing API and things below it
16:33:00 <adrian_otto> to prove that it helps us solve the "uuuh what???" problem that we perceive today with newcomers
16:33:33 <gpilz> makes sense
16:33:39 <adrian_otto> and if that's clearly the preference, to gradually work to true that up as tech debt. Those who know me well know that I am reluctant to propose this sort of tech debt.
16:33:49 <devkulkarni> yes.. if we want to change this we should do it piece at a time.. The "uuhh what" problem will still manifest if users are directly going to interact with the API
16:34:07 <adrian_otto> and I recognize that users of the API wills till be confused because there would be differences between that and the CLI
16:34:12 <datsun180b> there's a lot of flexibility in what we can do with the CLI without having to make drastic changes to the api or the models
16:34:31 <adrian_otto> but I expect that most adopters of solum will make a decision on adoption primarily on the cli, not the API
16:34:34 <gpilz> users of the API can always look at the CLI code
16:35:18 <adrian_otto> devkulkarni: yes, exactly… and if we still have that problem, we should have this discussion again as it pertains to the API
16:35:43 <adrian_otto> slightly more reworking over time, but might allow us to try more using this approach
16:35:45 <gpilz> we should think about documenting the CLI code fairly well
16:35:51 <adrian_otto> +1
16:36:14 <adrian_otto> it should be really good at self documenting
16:36:47 <adrian_otto> running "solum" to get a list of all options, and "solum <thing>" to get help about <thing>
16:37:11 <devkulkarni> I am fine with this direction in general.. although it will be good to see the proposed nouns and verbs..
16:37:24 <gpilz> I meant in the sense of serving as an example on how to use the API
16:37:44 <adrian_otto> devkulkarni: I know Roshan has a first take on this, so let's bring that out for discussion
16:37:52 <adrian_otto> possibly next week
16:37:58 <devkulkarni> okay, that will be good
16:38:10 <adrian_otto> we can also add to the API
16:38:25 <adrian_otto> so say we add an "app" resource that is a facade over plans and assemblies
16:38:39 <adrian_otto> that's another way to strike a balance between the interests
16:39:12 <adrian_otto> and for those who want to use the API to get more granular, the other resources are there to choose from
16:39:38 <datsun180b> we have some measure of self-documentation https://gist.github.com/anonymous/a5de89a75a6ffe3291f8
16:39:46 <datsun180b> arguably it could be much more rich
16:40:03 <datsun180b> ignore my plan/app switcheroo
16:40:08 <adrian_otto> datsun180b: yes, that's it. We should see about how we can make that even better.
16:41:11 <datsun180b> argparse's help functions and error handling are, uh, "fun"
16:41:24 <adrian_otto> :-)
16:41:34 <datsun180b> it likes to exit(0) if you have the wrong number of args
16:41:59 <adrian_otto> ok, so let's keep this dialogue open. If it makes sense to give this a try, then perhaps we don't need to revisit it.
16:42:06 <datsun180b> anyway glad to help make the cli better to use once we nail down what 'better' is
16:42:18 <adrian_otto> if we hit some fundamental roadblocks, then let's come back to this and see what choices we have to address it
16:42:35 <devkulkarni> sounds like a plan
16:42:49 <gpilz> datsun - clearly it needs to stop surfacing "assembly" - no one knows what that is
16:43:11 <adrian_otto> I want everyone to feel like we are sourcing input from all of you, and take any objections into consideration before commitment to sharp changes in direction
16:43:47 <adrian_otto> so if we miss this goal, please let me know so I can try to correct for it
16:43:51 <gpilz> changes to the DB schema are a trigger point for me
16:44:05 <datsun180b> steps we had discussed earlier was to call plans plans to free up the word 'application', then build commands in terms of applications and melt the plan and assembly concepts out of the cli
16:44:37 <adrian_otto> datsun180b: sounds sensible
16:44:43 <datsun180b> focused on changing the cli experience without having to change the api
16:44:53 <adrian_otto> we could also reconsider "template" rather than plan
16:44:59 <datsun180b> sure
16:45:23 <adrian_otto> but to be clear, the CAMP API and Solum API are intentionally different, and will reman so
16:46:02 <adrian_otto> gpilz, I do expect that *some* change at the schema level may be needed, but I don't expect it to be major.
16:46:55 <gpilz> okay
16:46:58 <adrian_otto> are we happy with wrapping up this topic?
16:47:26 <datsun180b> do we want to formalize further discussion of it?
16:47:32 <devkulkarni> sure. lets discuss this next week again when Roshan's draft will be available
16:47:53 <adrian_otto> datsun180b: let's touch base with Roshan, and I'll put it on next weeks agenda to revisit.
16:47:54 <datsun180b> gotcha. i bet he's got some more fact-finding to do
16:48:17 <adrian_otto> we have some end user interviews to explore this from a research study perspective
16:48:24 <adrian_otto> I think we want to get some input from that angle too
16:49:24 <adrian_otto> ok, any more topics to touch on today?
16:49:46 <datsun180b> well how about our new conscripts
16:49:52 <datsun180b> how can we help you get started with solum?
16:50:37 <stannie> hmm
16:50:44 <stannie> we still have nova-docker issues in our devstack env
16:51:01 <stannie> the one hosted in rackerlabs' github
16:51:02 <adrian_otto> nshaikh and akshayc_
16:51:06 <adrian_otto> ^^
16:51:19 <stannie> so I guess newcomers will encounter this issue while trying to set their dev environment
16:51:52 <stannie> do we have a fix for that ?
16:51:56 <datsun180b> what issues?
16:52:08 <akshayc_> i was looking at some bugs....
16:52:22 <stannie> cannot create regular file `/etc/nova/rootwrap.d/docker.filters': No such file or directory
16:52:45 <datsun180b> strange OH i think i have an idea
16:52:51 <akshayc_> that will affect dev.... is there a link to that bug?
16:52:53 <stannie> oh this is due to the fact that 'docker-py' is not in global-requirements.txt
16:52:54 <gpilz> export NOVADOCKER_REPO=https://github.com/ed-/nova-docker.git
16:52:54 <gpilz> export NOVADOCKER_BRANCH=solum-pin
16:53:06 <datsun180b> yeah i was about to go dig for that nova-docker pin i made
16:53:24 <gpilz> ^^^ there it is
16:53:31 <stannie> thank you =)
16:53:40 <stannie> will try it
16:53:43 <datsun180b> we put a stake in nova-docker but then some of its upstream deps--oslo.concurrency--moved
16:54:04 <datsun180b> so i added a quick commit to cover that difference
16:55:01 <devkulkarni> global-requirements issue will still be there
16:55:18 <devkulkarni> for that we need to go back to the commit on nova-docker which does not use docker-py
16:55:27 <datsun180b> i thought we got docker-py by it being a dep of nova-docker?
16:56:55 <devkulkarni> #link https://github.com/rackerlabs/vagrant-solum-dev/issues/29
16:56:56 <adrian_otto> another option might be to make a (set of?) docker container(s) for running solum for dev, and those can be easily pinned to known good tags in the public docker registry
16:57:00 <datsun180b> well let me know, any of you, if your vagrant environment starts screaming
16:57:14 <datsun180b> we'll get to the bottom of those problems
16:57:36 <adrian_otto> that may actually start up much quicker than the vagrant setup we have now
17:00:27 <datsun180b> see you all in #solum
17:00:38 <akshayc_> ok
17:00:58 <adrian_otto> thanks for attending everyone
17:01:01 <adrian_otto> #endmeeting