21:09:11 <devkulkarni> #startmeeting Solum team meeting
21:09:11 <openstack> Meeting started Tue Dec 16 21:09:11 2014 UTC and is due to finish in 60 minutes.  The chair is devkulkarni. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:09:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:09:15 <openstack> The meeting name has been set to 'solum_team_meeting'
21:09:22 <devkulkarni> #topic Roll call
21:09:30 <james_li> james li
21:09:32 <devkulkarni> devdatta kulkarni
21:09:36 <gpilz> gil pilz
21:09:38 <akshayc> Akshay Chhajed
21:09:39 <ravips> ravi sankar penta
21:09:43 <muralia> murali allada
21:09:45 <devkulkarni> hi ravips
21:09:46 <devkulkarni> long time
21:09:52 <ravips> hi dev
21:09:54 <devkulkarni> hi akshay
21:09:56 <devkulkarni> hi gil
21:10:07 <gpilz> hi dev
21:10:16 <akshayc> hello devkulkarni
21:10:28 <devkulkarni> lets wait for a minute to see if anyone else joins us
21:10:34 <mkam> Melissa Kam
21:10:41 <devkulkarni> hey mkam
21:11:26 <devkulkarni> #topic announcements
21:11:42 <devkulkarni> does anyone have any announcements?
21:11:56 <devkulkarni> ravips: hope this time works for you
21:12:06 <ravips> yes
21:12:12 <devkulkarni> cool
21:12:16 <devkulkarni> how about you akshay?
21:12:46 <akshayc> i am stuck with different error now
21:12:59 <devkulkarni> I meant does the time work for you?
21:13:11 <devkulkarni> we will come to the error part soon
21:13:11 * ravips taking time off next week and won't be able to attend the meeting
21:13:18 <akshayc> ya.... i am fine with this time
21:13:32 <devkulkarni> okay.. cool.. thanks for the heads up ravips
21:13:57 <devkulkarni> okay.. lets move on to the action items
21:14:04 <devkulkarni> #topic Review Action items
21:14:12 <devkulkarni> #link http://eavesdrop.openstack.org/meetings/solum_team_meeting/2014/solum_team_meeting.2014-12-09-21.08.txt
21:14:44 <devkulkarni> james_li, muralia: can we try to push this forward https://review.openstack.org/#/c/140162/
21:14:53 <devkulkarni> this was one of the action items from last week
21:14:58 <muralia> sure
21:15:06 <devkulkarni> thanks muralia
21:15:51 <devkulkarni> were there any other action items that folks were carrying forward?
21:16:10 <devkulkarni> I remember I had one about identifying low hanging fruit bugs
21:16:16 <devkulkarni> I did that sometime back
21:16:41 <devkulkarni> muralia: what is the latest on the juno release? i remember you were coordinating that with adrian
21:17:07 <muralia> He's still working on it. I'm waiting for him to reply with a confirmation email.
21:17:16 <devkulkarni> okay, cool
21:17:18 <muralia> I know that he has been pon vacation for a few days
21:17:36 <james_li> devkulkarni: I think that patch is ready to go
21:17:56 <devkulkarni> james_li: cool.. will take a look
21:18:22 <devkulkarni> okay, if there are no other action items I will go to next topic
21:18:29 <devkulkarni> #topic Blueprint/Task review
21:18:37 <devkulkarni> In this I have one
21:18:49 <devkulkarni> it is ravi's patches
21:18:59 <devkulkarni> ravips: did you see the comments on your patches?
21:19:18 <ravips> yes, I did
21:19:48 <devkulkarni> do they make sense to you? any thoughts?
21:20:47 <devkulkarni> after we have done discussing ravi's patches, I would like to consider errors that akshayc is running into
21:20:48 <ravips> yes, definitely..I will respond to those comments
21:21:23 <ravips> I'm bit busy on my other tasks and won't be able to get to those soon...I would like to handover this task to someone who is interested in this task..any volunteers?
21:21:42 <devkulkarni> ravips: I see
21:22:17 <devkulkarni> if we don't get volunteers immediately that should be alright imo
21:22:44 <devkulkarni> ravips: how about this?
21:23:14 <devkulkarni> once you have responded to the comments, we can outline a path of what needs to happen next in the reviews
21:23:31 <ravips> sounds like a plan
21:23:32 <devkulkarni> and then mark it has an open wishlist bug for new contributors
21:23:50 <devkulkarni> cool
21:23:50 <akshayc> yep.... this will be good....
21:24:18 <devkulkarni> are there any disagreements?
21:24:26 <james_li> +1
21:24:29 <muralia> +1
21:25:31 <devkulkarni> #agreed ravips will respond to comments on his patches. devkulkarni, ravips, and others will outline in details what needs to happen next as part of the review. we will seek volunteers from the team to complete the work.
21:25:57 <devkulkarni> next up is the issue that akshayc is running into
21:26:06 <devkulkarni> akshayc: floor is yours
21:26:49 <akshayc> ok. i receive a 502 after ==> devstack: Status: Image is up to date for solum/slugtester:latest
21:27:07 <akshayc> i checked the code..... i can see the UI page....
21:27:28 <akshayc> but it gets stuck when i provide the github link
21:27:29 <devkulkarni> do you have detailed stack trace? what screen this is showing up in? worker?
21:28:06 <akshayc> error is vagrant up devstack command
21:28:26 <devkulkarni> oh.. you mean your vagrant up itself is failing?
21:28:40 <akshayc> yep.
21:28:55 <akshayc> but the demo UI is visible but not functional
21:29:10 <devkulkarni> but where are using specifying the github link?
21:29:12 <akshayc> where does the demo UI log?
21:29:16 <devkulkarni> oh you are trying the demo UI?
21:29:25 <akshayc> yep....
21:29:29 <devkulkarni> it used to be functional till Atlanta summit.
21:29:41 <gpilz> I have the same problem
21:29:43 <devkulkarni> after that we haven't really gone back and test it
21:29:51 <devkulkarni> gpliz: you are also trying the demo UI?
21:30:01 <devkulkarni> s/test/tested/
21:30:06 <gpilz> the vagrant devstack does seem to be useable despite these failures
21:30:27 <devkulkarni> vagrant devstack is definitely very useful
21:30:27 <gpilz> dev - no, I'm using the dev env devstack
21:30:40 <ravips> akshayc: gpilz: what errors are we seeing in vagrant provision/build logs (under /opt/stack/logs/)
21:30:52 <devkulkarni> gpilz: okay. so you are seeing the same problem as akshayc in your devstack setup?
21:30:56 <gpilz> yes
21:31:02 <devkulkarni> okay
21:31:21 <devkulkarni> ravips: they are not even getting there
21:31:34 <gpilz> what I'm trying to say is that, even if you get those errors
21:31:49 <gpilz> you should try to use the env anyway
21:31:54 <devkulkarni> right
21:32:00 <ravips> yes
21:32:07 <devkulkarni> akshayc: can I suggest something..
21:32:31 <akshayc> ya.... i was trying the same... despite the errors.... i see the UI.... but it gets stuck
21:32:32 <devkulkarni> once you do vagrant up, even if it fails, you should be able to login to the VM using vagrant ssh
21:33:00 <devkulkarni> once inside the VM, try source the openrc (source ~/devstack/openrc) and then ./stack.sh
21:33:11 <devkulkarni> s/source/sourcing/
21:33:25 <ravips> devkulkarni: ./unstack.sh and then ./stack.sh will be clean
21:33:25 <devkulkarni> I would not spend time with the demo UI
21:33:28 <akshayc> 2014-12-16 20:52:58.655 | stack.sh completed in 1668 seconds.
21:33:37 <devkulkarni> ravips: sure
21:33:41 <akshayc> ok
21:33:48 <devkulkarni> akshayc: that is great if stack.sh completed
21:34:11 <devkulkarni> can you login to a screen session and see if all the solum services are running correctly or not?
21:34:22 <devkulkarni> screen -x stack should drop you into a screen session
21:35:16 <devkulkarni> are nova, keystone, glance, swift, neutron, heat, solum* processes up and running?
21:35:19 <gpilz> there should be 36 things in screen
21:35:27 <akshayc> yep....
21:35:28 <devkulkarni> right
21:35:36 <devkulkarni> okay
21:35:52 <akshayc> i see .... .* 32$(L) solum-api  33$(L) solum-build-api  34$(L) solum-conductor  35$(L) solum-deployer   36$(L) solum-worker*
21:35:58 <devkulkarni> akshayc: can you try solum app create <plan_file> and then solum assembly create <assembly_name> <plan_uri>
21:36:18 <devkulkarni> akshayc: that is good sign.. looks like all solum services are running correctly
21:37:19 <devkulkarni> akshayc: you are very close to seeing an app deployed in your devstack setup
21:38:05 <akshayc> ok.... i willl try this... where does solum log? i do not see the logs....
21:38:06 <devkulkarni> akshayc: you can try that and let us know how it goes
21:38:37 <devkulkarni> logs are in /opt/stack/logs
21:38:56 <gpilz> akshayc: also you can see info on each service in that services window
21:38:58 <devkulkarni> akshayc: let us know in #solum if you run into any issues
21:39:15 <akshayc> yep. ok.
21:39:18 <devkulkarni> cool
21:39:31 <devkulkarni> is there any other task/blueprint that we should review?
21:39:31 <gpilz> so, for example, to see what is happening with the Solum API service, go to window 32 and look at stdout
21:39:59 <akshayc> ok gpilz
21:40:35 <devkulkarni> gpilz: you want to update us on your findings about concurrency and wsme/pecan
21:40:39 <devkulkarni> ?
21:40:45 <gpilz> sure
21:40:53 <gpilz> it isn't an issue
21:41:15 <gpilz> i know this because (a) i wrote a test that confirmed it doesn't happen
21:41:29 <devkulkarni> cool..
21:41:39 <gpilz> and ( b ) http://stackoverflow.com/questions/27411102/python-wsme-and-thread-safety
21:41:53 <devkulkarni> eventually we need to consider adding such concurrency tests to our tempest suite
21:41:54 <gpilz> (that one cost me)
21:42:02 <gpilz> dev - that would be a good idea
21:42:46 <devkulkarni> mkam: do you know if there are any standard concurrency testing tools being used by OpenStack?
21:42:54 <devkulkarni> within other OS projects?
21:44:01 <mkam> I don't know of any that are being used by OpenStack, but I can look into it
21:44:11 <devkulkarni> that would be nice
21:44:30 <devkulkarni> thanks mkam
21:44:59 <devkulkarni> okay are there other blueprints that we want to discuss?
21:45:25 <devkulkarni> if not I will go to next topic
21:45:32 <devkulkarni> #topic open discussion
21:46:22 <gpilz> I have an issue I'd like to discuss
21:46:28 <devkulkarni> sure
21:46:39 <gpilz> but it just applies to me, so we can save it if there is anything else anyone would like to talk about
21:47:24 <devkulkarni> I guess there are not any major topics on peoples minds
21:47:31 <gpilz> okay - I'm trying to figure out how to get pecan to handle an HTTP PATCH request
21:47:31 <devkulkarni> so gpilz, floor is yours
21:47:59 <gpilz> if anyone has any experience with anything like this (hacking pecan to support fringe methods) - I'd appreciate the help
21:49:39 <devkulkarni> in what context are you planning to use patch?
21:49:44 <devkulkarni> just curious
21:49:56 <ravips> ironic has similar problem: http://osdir.com/ml/openstack-dev/2014-02/msg02323.html
21:50:24 <gpilz> CAMP specifies the use of HTTP PATCH (with JSON Patch) to update individual attributes of a resource
21:50:38 <adrian_otto> PATCH allows you to update a resource without using POST with a full REST resource.  You could just specify the attributes you want to change.
21:51:02 <adrian_otto> or PUT
21:52:39 <devkulkarni> gpilz: I see
21:53:00 <devkulkarni> gpilz: for time being could PUT work for you?
21:53:21 <devkulkarni> ravips: how is ironic team resolving this?
21:53:27 <adrian_otto> the reason PATCH is preferred is it makes it easier for developers to code against
21:53:29 <gpilz> dev - yeah
21:53:37 <gpilz> I'm just trying to flesh out the impl is all
21:53:46 <devkulkarni> okay
21:53:56 <ravips> relevant snip "Ironic's API relies on HTTP PATCH to modify resources, which Pecan/WSME  does not abstract for us. We're using the python jsonpatch library to  parse these requests. I'm not aware of a similar python library for XML  support."
21:54:27 <devkulkarni> thanks ravips
21:54:39 <devkulkarni> gpilz: that settles it then
21:55:04 <gpilz> dev - actually (re-checking the spec) I *have* to implement PATCH to count as a CAMP impl
21:55:11 <gpilz> I'm sure pecan can do it
21:55:18 <gpilz> it's nothing if not flexible
21:55:24 <devkulkarni> probably you are right..
21:55:26 <gpilz> I'm just trying to shave off a day or two
21:55:43 <devkulkarni> may be hit some experts on pecan in this channel or on the openstack-dev list
21:55:56 <gpilz> thanks
21:57:47 <devkulkarni> okay thanks everyone for joining today's meeting
21:57:54 <devkulkarni> #endmeeting