21:00:20 <adrian_otto> #startmeeting Solum Team Meeting
21:00:22 <openstack> Meeting started Tue Jan  6 21:00:20 2015 UTC and is due to finish in 60 minutes.  The chair is adrian_otto. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:25 <openstack> The meeting name has been set to 'solum_team_meeting'
21:00:28 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Solum#Agenda_for_2015-01-06_2100_UTC Our Agenda
21:00:33 <adrian_otto> #topic Roll Call
21:00:35 <adrian_otto> Adrian Otto
21:00:42 <datsun180b> Ed Cranford
21:01:12 <devkulkarni> devdatta kulkarni
21:01:30 <keyvan_> Keyvan Sadeghi
21:01:47 <gpilz> Gilbert Pilz
21:01:54 <_ramin> Ramin Barati
21:02:18 <muralia> murali allada
21:02:39 <ravips> Ravi sankar penta
21:02:43 <james_li> james li
21:03:05 <adrian_otto> alright, good attendance today
21:03:20 <adrian_otto> #topic Announcements
21:03:31 <adrian_otto> 1) Welcome Ed Cranford (ed--cranford) to solum-core
21:03:38 <devkulkarni> congratulations ed
21:03:39 <datsun180b> that's me
21:03:40 <james_li> congrats
21:03:49 <datsun180b> thanks again
21:03:53 <gpilz> congratulations
21:03:55 <adrian_otto> Ed has consistently contributed in all forms to the Solum project, and is a valued member of our team.
21:04:19 <adrian_otto> I'd like to take this opportunity to thank you Ed for your contributions, and most of all for your sense of humor which I adore.
21:04:39 <datsun180b> keeps me sane
21:05:20 <adrian_otto> we look forward to your service as a core reviewer, thanks!!
21:05:20 <muralia> congrats ed
21:05:31 <datsun180b> don't worry, i'm already power-mad
21:05:43 <adrian_otto> there's the humor I love.
21:05:55 <adrian_otto> ok, so more announcmeents
21:06:00 <adrian_otto> 2) Review queue sweep
21:06:01 <phiche> yes congrats
21:06:26 <adrian_otto> for anyone that had an old review, you may have noticed that I set a bunch of them to Abandoned
21:06:47 <adrian_otto> this is *not* the same as a -2 vote, so if you have a review like that, you are encouraged to resubmit it
21:07:01 <datsun180b> after rebasing!
21:07:08 <adrian_otto> yes, exacrtly.
21:07:15 <adrian_otto> almost all of those needed rebases.
21:07:43 <adrian_otto> you will also notice that I have commented and or voted on every review
21:08:04 <adrian_otto> and I'd like to drain the list of pending patches to a nice short list
21:08:36 <adrian_otto> so I will be racheting up on that, and starting to poke for updates, etc.
21:08:54 <adrian_otto> so thanks for your attention on that subject.
21:09:11 <adrian_otto> I don't think we had any action items last week (I hope I did not forget anything assigned to me)
21:09:16 <adrian_otto> looking just to be sure.
21:09:45 <adrian_otto> oh, I have one to carry forward
21:09:52 <adrian_otto> #topic Review Action Items
21:10:01 <adrian_otto> #action adrian_otto to follow up with mistral devs to arrange a tagged release that we can use as a stable dependency.
21:10:27 <adrian_otto> #topic Blueprint/Task Review
21:10:45 <adrian_otto> do any team members have work items to discuss as a team?
21:11:05 <datsun180b> I want to help you shake up the buglist
21:11:07 <keyvan_> not sure, is this the right place?
21:11:18 <adrian_otto> datsun180b: yes, that's my next order of business
21:12:00 <keyvan_> sure, i meant voicing my own team, go on Ed
21:12:11 <adrian_otto> keyvan_: if you have anything relating to a Bug, Blueptint, or open Review, this is the place to raise it for team discussion
21:12:38 <adrian_otto> and if it's beyond the scope of this section, we can take it to the mailing list, or splinter off with a follow-up meeting
21:12:45 <datsun180b> oh that's as much as i wanted to mention on that; i'll start trying to reproduce them as i find free time
21:13:26 <keyvan_> so relating to the bug #link https://bugs.launchpad.net/solum/+bug/1308690 Improvement: Add a Dockerfile for deploying Solum
21:13:28 <uvirtbot> Launchpad bug 1308690 in solum "Improvement: Add a Dockerfile for deploying Solum" [Wishlist,Confirmed]
21:13:54 <adrian_otto> #link https://bugs.launchpad.net/solum/+bug/1308690 Improvement: Add a Dockerfile for deploying Solum
21:14:04 <adrian_otto> keyvan_: please proceed.
21:14:28 <keyvan_> we've been trying to figure out how Kolla works
21:14:45 <keyvan_> #link https://github.com/stackforge/kolla/ Kolla
21:15:47 <keyvan_> and I added a comment to the review #link https://review.openstack.org/87782 Make solum buildable into docker container
21:16:03 <keyvan_> but haven't heard back
21:17:21 <devkulkarni> keyvan_: so you are proposing to add a Docker file which will start all solum services (api, worker, deployer, conductor)?
21:17:23 <keyvan_> what Kolla does is to run a dockerfile, which simply installs an openstack service
21:17:36 <datsun180b> neat
21:18:10 <keyvan_> the there is a .sh script that configures the container
21:18:28 <devkulkarni> for the whole solum system to be operational though, we will have to run other services as well (keystone, mysql, rabbit, etc.).. all these will be run through their own Dockerfiles
21:19:00 <devkulkarni> would we contribute Solum's Dockerfile to Kolla then?
21:19:17 <adrian_otto> devkulkarni: yes.
21:19:25 <devkulkarni> and use Kolla to spin up entire system?
21:19:26 <keyvan_> Kolla handles all that, including checking the fingerprints to see whether a service already exists
21:19:27 <devkulkarni> ok
21:19:43 <adrian_otto> I suppose we should be able to use heat to drive Kolla, right?
21:20:15 <devkulkarni> possible.. but then that heat instance would need to be spun up first (outside of Kolla)
21:20:16 <adrian_otto> so we should have Solum Support in Kolla, and a quickstart guide that explains how to launch a solum environment using Kolla
21:20:30 <keyvan_> have a look at #link https://github.com/stackforge/kolla/blob/master/docker/horizon/start.sh kolla/docker/horizon/start.sh as an example
21:20:43 <adrian_otto> devkulkarni: yes, good point.
21:20:57 <keyvan_> ah sure we should have support for Kolla from the trend I'm seeing
21:21:01 <devkulkarni> keyvan_:  does kolla take care of configuring each service's rabbit and mysql endpoints correctly
21:21:03 <devkulkarni> ?
21:21:26 <_ramin> devkulkarni: tup
21:21:31 <_ramin> *yup
21:21:35 <akshayc> hi
21:21:36 <devkulkarni> _ramin: ok
21:21:53 <devkulkarni> in that case I think what you are proposing seems fine to me
21:21:56 <akshayc> sorry, i had a call
21:22:12 <keyvan_> haven't gone through all that just yet, but it surely creates the db admin and stuff
21:23:13 <devkulkarni> hi akshayc .. we are in blueprint review topic
21:23:14 <keyvan_> and Kolla seems to becoming an standard, see #link http://allthingsopen.com/2014/10/22/a-demonstration-of-kolla-docker-and-kubernetes-based-deployment-of-openstack-services-on-atomic/ A DEMONSTRATION OF KOLLA: DOCKER AND KUBERNETES BASED DEPLOYMENT OF OPENSTACK SERVICES ON ATOMIC
21:23:52 <devkulkarni> thanks for sharing the link keyvan_
21:23:59 <adrian_otto> the spirit of that bug ticket is to be able to run something like: git clone git://git.openstack.org/stackforge/solum ; cd solum ; docker build -t solum:latest . ; docker run -p N:N -d solum:latest
21:24:17 <adrian_otto> and that would have a working instance of Solum + devstack in a single container.
21:24:27 <devkulkarni> +1
21:24:27 <adrian_otto> the Kolla stuff could be *inside* there.
21:25:10 <keyvan_> that's not the spirit of Kolla though
21:25:37 <keyvan_> the dockerfile shall be ran from Kolla, Solum in our case
21:25:48 <adrian_otto> adding Solum support to kolla is so that solum can be part of a cloud bootstrapped with kolla
21:25:53 <keyvan_> then the .sh script configures the service
21:26:13 <adrian_otto> as an alternative to devstack
21:26:27 <keyvan_> sure, i see
21:26:28 <devkulkarni> so in Kolla world, each service will be run in its own container. is that correct?
21:26:36 <keyvan_> so what is right for us to do?
21:26:36 <adrian_otto> which may allow the equivalent of a "devstack" bootup in less time
21:26:53 <adrian_otto> devkulkarni: yes, that's the idea
21:26:58 <keyvan_> devkulkarni: yes
21:27:24 <gpilz> I count 36 screen windows in our DevStack
21:27:33 <adrian_otto> but keep in mind that containers can actually be nested
21:27:40 <gpilz> does that mean 36 Docker containers?
21:27:42 <adrian_otto> you can run docker within a docker container.
21:28:04 <adrian_otto> gpilz: only if you wanted all the services. We only require a few.
21:28:12 <keyvan_> that's up to how it's deployed, i guess
21:28:34 <devkulkarni> in our previous discussion around this, we were kind of aligning towards running all services in a single container — this was from ease of use point of view .. but I don't know if that would be possible.. if we go the Kolla route then there will be 36 containers (few or more depending on what all services we really need)
21:29:07 <adrian_otto> I see no reason why the various kolla containers could not be nested inside the solum container
21:29:08 <keyvan_> I wonder what the right course of action would be, to try to register Solum as a standard openstack service comes to my mind
21:29:42 <devkulkarni> adrian_otto: haven't looked at nested containers.. how do they work?
21:30:10 <keyvan_> imagine the scenario that openstack is installed by Kolla on a system
21:30:12 <adrian_otto> the top level container is started as a privileged container
21:30:34 <adrian_otto> then you can run the docker daemon inside that, and create additional sub-containers within
21:30:59 <akshayc> yep…. privileged container
21:31:05 <devkulkarni> I see. that route though seems independent of kolla
21:31:10 <akshayc> #link http://blog.docker.com/2013/09/docker-can-now-run-within-docker/
21:31:20 <adrian_otto> so let's say I create a container "solum", that runs a docker daemon, then within that I run a number of other containers that have the various services we cherry pick from Kolla
21:31:26 <adrian_otto> that's one way to do it.
21:31:32 <devkulkarni> akshayc: thanks for sharing the link
21:31:46 <adrian_otto> another way is just to set aside kolla for now, and just run devstack in the solum container
21:32:05 <keyvan_> adrian_otto : what's your opinion in the scenario I described above?
21:32:25 <adrian_otto> I should have mentioned in the Announcement section of our meeting that OpenStack Programs are being eliminated. See:
21:32:27 <adrian_otto> #link http://governance.openstack.org/resolutions/20141202-project-structure-reform-spec.html
21:33:14 <keyvan_> sure adrian, in that case we then run setup.py from solum, right?
21:33:31 <keyvan_> like what's been done in the previous patch?
21:33:39 <adrian_otto> my gut is telling me to keep it simple, and just run devstack in the container to start with
21:34:07 <adrian_otto> then we can iterate on that, making it more sophisticated (possibly using nested containers) if it makes a big difference in the time to start up
21:34:22 <devkulkarni> same here.. we can first start with simple case.. adding kolla to the mix can be done afterwards
21:34:28 <ravips> +1
21:34:29 <datsun180b> well that's something
21:34:42 <keyvan_> sure, so previous patch did exactly that, didn't it?
21:35:22 <devkulkarni> keyvan_:  you mean the patch that was submitted originally by PaulCzar?
21:36:02 <devkulkarni> will have to look..
21:36:24 <keyvan_> yes adrian_otto #link https://review.openstack.org/#/c/87782/1/Dockerfile,unified Dokerfile by Paul Czar
21:36:31 <adrian_otto> #link https://review.openstack.org/87782 Make solum buildable into docker container
21:37:17 <adrian_otto> so to understand this patch, you need to understand what the docker trusted build system is, and how it works
21:37:42 <devkulkarni> keyvan_: almost.. that patch seems to be starting up solum-api
21:37:44 <adrian_otto> basically it checks out new code with git, and runs a docker build against the Dockerfile in the code repo
21:37:58 <adrian_otto> and produces a container image that goes in the Docker public repository
21:38:08 <devkulkarni> we need to ensure that solum-worker, solum-conductor, solum-deployer are running as well
21:38:29 <adrian_otto> assuming we use the namespace solum, to run solum, you could just do "docker run -d solum:latest"
21:38:33 <adrian_otto> done, and done.
21:38:34 <keyvan_> i see now, so instead we want to git clone devstack?
21:39:10 <keyvan_> and then install solum on the container?
21:39:10 <adrian_otto> that would need to be defined in Solum's Dockerfile
21:39:50 <devkulkarni> sure.. something like: git clone devstack; git clone solum; copy devstack/lib/ from solum into devstack/lib; same for extras; and then CMD ./stack.sh
21:40:17 <keyvan_> sure, that's what i meant, run ./stack in the container is the ultimate goal?
21:40:47 <keyvan_> and then invoking solum setuap?
21:41:00 <devkulkarni> yes.. that way we will have all the required services (36 as per gpilz) running once the container is run
21:41:25 <keyvan_> cool, that'd make it wayyy easier :)
21:41:29 <devkulkarni> :)
21:41:44 <keyvan_> good for a start, +1
21:42:00 <adrian_otto> ok, any more work items requiring team discussion?
21:42:21 <adrian_otto> #topic Open Discussion
21:43:03 <akshayc> why does build fail?
21:43:05 <devkulkarni> how does the changes to programs (or going away from them) is going to play out? any ideas?
21:43:23 <devkulkarni> akshayc: which build? you mean building an assembly?
21:43:41 <adrian_otto> devkulkarni: I expect that means that projects like Solum enter the OpenStack namespace.
21:43:42 <akshayc> and work when I rebuild without any code changes? I meant jenkins build
21:43:54 <adrian_otto> and begin to take more of a first class status.
21:44:04 <akshayc> after submitting patch
21:44:05 <devkulkarni> interesting.
21:44:22 <adrian_otto> akshayc: there are a variety of reasons it happens
21:45:00 <adrian_otto> sometimes the jobs time out, sometimes we hit an error running functional tests (usually failures deleting resources)
21:45:18 <datsun180b> recently it was some bad md5 hashes from package mirrors, and a breaking change to tempest's requestclient
21:45:28 <datsun180b> that was just yesterday!
21:45:55 <adrian_otto> there are also a few versions of Python's "setuptools" that simply don't work
21:45:55 <datsun180b> also today james noticed our jenkins workspaces are in /opt/stack/new/solum and so the build scripts are all missing until we fix proj_dir for gerrit
21:46:11 <adrian_otto> I have been trying to merge a patch to exclude a few of the broken ones, but I'm in a catch-22.
21:46:26 <akshayc> hehe…. ok
21:46:36 <datsun180b> we've also got a race condition between update and delete
21:46:51 <adrian_otto> datsun180b: do we have an open bug on that?
21:47:03 * datsun180b throws hot potato at james_li
21:47:24 <adrian_otto> ^^ james_li
21:47:24 <james_li> datsun180b: adrian_otto: not yet I will file one shortly
21:47:33 <adrian_otto> thanks james_li
21:48:41 <datsun180b> i should probably put some of my review comments into proper bugs now that you mention filing
21:49:55 <akshayc> mistral client? was it discussed….
21:50:06 <adrian_otto> my general attitude about reviews is that if the commit makes the code better than it is now, even if it's not perfect, then I'm motivated to merge it. When we identify things that are nice-to-have we can open those as "wishlist" bugs with the tech-debt tag on them, and merge the code.
21:50:07 <akshayc> about having a specific commit to pin to
21:50:34 <adrian_otto> ideally assigned to the contributor who committed the patch.
21:50:48 <akshayc> sorry if that was discussed before I joined
21:50:59 <adrian_otto> akshayc: yes, I took an action item to touch base with the mistral team about that.
21:51:08 <adrian_otto> all we need is a tagged release that works with solum
21:51:21 <akshayc> ok….
21:51:24 <adrian_otto> so that we can use that as the dependency.
21:51:38 <adrian_otto> rather than depending on master, which changes all the time, and can break us.
21:51:55 <akshayc> yep…. good to have that….
21:52:19 <adrian_otto> there are more sophisticated approaches as well, such as adding a full Solum func test to the mistral gate jobs
21:52:36 <adrian_otto> but that has complexities and drawbacks that I'd rather not deal with right now
21:52:43 <akshayc> ok
21:53:04 <devkulkarni> agree.. akshayc: just curious, are you depending on mistral support from within solum?
21:53:13 <adrian_otto> if customizable Pipelines were central to Solum as the most important feature, I'd have a different attitude about that
21:53:51 <akshayc> i removed mistral and it still worked for my dev environment
21:53:58 <akshayc> examples worked I mean
21:54:06 <devkulkarni> just trying to understand why the mistral version came up in our discussions?
21:54:42 <devkulkarni> they should.. currently we are not using pipeline/pipeline handler
21:54:55 <devkulkarni> which is the main entry point for integrating with mistral
21:55:12 <akshayc> you can take a look at #link https://github.com/akshaychhajed/vagrant-solum-dev/tree/solum_stable_juno
21:55:15 <adrian_otto> yes, that's the only thing we use mistral for
21:55:32 <akshayc> i have been using this
21:56:16 <devkulkarni> ok
21:56:17 <akshayc> i will update it with mistral when we have the pin
21:56:40 <akshayc> let me know if i should make an changes to it
21:56:53 <adrian_otto> akshayc: ok, will do.
21:57:07 <devkulkarni> sure. although, what I meant was, is it necessary for us to pin to anything at all? are our tests breaking? if not, it might be okay to just work off of mistral's master
21:57:12 <akshayc> any*
21:57:36 <adrian_otto> devkulkarni: if you try to set up a solum-dev environment, half the time it fails because of mistral bugs
21:57:44 <akshayc> the build was breaking for me
21:57:47 <devkulkarni> got it
21:57:58 <akshayc> and another failure was swift timeout
21:58:04 <devkulkarni> yeah, then lets pin it to a stable release
21:58:21 <adrian_otto> yep
21:58:21 <devkulkarni> fwiw, in my devstack setup I never turn on mistral
21:58:26 <adrian_otto> ok, time to start wrapping up
21:58:29 <devkulkarni> or any of the services that we don't need
21:58:45 <adrian_otto> Our next meeting will be 2015-01-13 at 2100 UTC
21:58:55 <akshayc> swift:client_timeout moved from 60 to 600
21:58:56 <adrian_otto> devkulkarni: I will be on ETO, so can you plan to chair?
21:58:57 <akshayc> ok
21:59:05 <devkulkarni> adrian_otto: sure
21:59:09 <adrian_otto> thanks
21:59:24 <adrian_otto> #agreed devkulkarni will chair on 2015-01-13 at 2100 UTC
21:59:31 <adrian_otto> thanks for attending everyone
21:59:35 <adrian_otto> #endmeeting