21:01:06 <adrian_otto> #startmeeting Solum Team Meeting
21:01:07 <openstack> Meeting started Tue Jan 13 21:01:06 2015 UTC and is due to finish in 60 minutes.  The chair is adrian_otto. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:01:11 <openstack> The meeting name has been set to 'solum_team_meeting'
21:01:13 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Solum#Agenda_for_2015-01-13_2100_UTC Our Agenda
21:01:19 <adrian_otto> #topic Roll Call
21:01:21 <adrian_otto> Adrian Otto
21:01:29 <datsun180b> ed cranford
21:01:33 <mkam> Melissa Kam
21:01:37 <muralia> murali allada
21:01:38 <devkulkarni> devdatta kulkarni
21:02:09 <phiche> Philip Cheong
21:03:16 <adrian_otto> hello everyone. Welcome Philip.
21:03:53 <adrian_otto> #topic Announcements
21:04:26 <phiche> thanks :)
21:04:27 <adrian_otto> The OpenStack Foundation is holding an election. It is exceedingly important that we all vote in the election.
21:04:52 <adrian_otto> If you have not yet voted, please go look for the invitation sent to your inbox from Jonathan Bryce, and vote today.
21:04:54 <adrian_otto> I voted.
21:05:03 <dimtruck> Dimitry Ushakov
21:05:45 <adrian_otto> the reason this election is so important is that bylaws changes require 25% participation in order to count
21:06:01 <adrian_otto> and the board needs bylaws to be changed in order to function
21:06:12 <adrian_otto> so we all need to do our part this week to vote, thanks!
21:06:21 <devkulkarni> thanks for the heads up
21:06:37 <devkulkarni> do you have a link to the bylaws documentation handy somewhere?
21:06:51 <devkulkarni> is the new program changes part of the bylaws?
21:06:54 <adrian_otto> you are presented with a redline when you view your ballot
21:07:10 <adrian_otto> so you can show up to vote even if you have not reviewed the bylaws changes in advance
21:07:17 <datsun180b> curiously the redline i saw used blue to show changes to the documents
21:07:40 <muralia> #link https://wiki.openstack.org/wiki/Governance/Foundation/2014ProposedBylawsAmendment
21:07:46 <adrian_otto> however, if you don't know who you want to vote for for individual directors, you are only presented with a list of names on the ballot for that section, so you will want to look at the Candidate list
21:07:58 <adrian_otto> it might be worth linking that here for reference.
21:08:01 <devkulkarni> thanks muralia
21:09:01 <adrian_otto> #link http://www.openstack.org/election/2015-individual-director-election/CandidateList Candidate List for Individual Directors
21:09:24 <devkulkarni> when does the voting end?
21:09:30 <muralia> adrian_otto: what is the individual director role?
21:10:15 <adrian_otto> until Friday, January 16th, 2015 at 11:00am CST/1700
21:10:34 <adrian_otto> an individual director is a member of the Board of Directors of the OpenStack Foundation
21:10:53 <adrian_otto> these individuals make up 8 seats of the board, and are selected by the electorate
21:11:11 <datsun180b> just days away
21:11:13 <adrian_otto> there are other seat categories where a member is appointed
21:11:31 <adrian_otto> muralia: is that what you meant?
21:11:36 <muralia> yup. thanks
21:12:20 <adrian_otto> so you are given 8 votes, and you can distribute them among the candidates as you wish, giving all your votes to one candidate, or sharing them among multiple choices.
21:13:07 <adrian_otto> the top 8 vote getters become Directors, with one exception
21:13:36 <adrian_otto> a maximum of two directors from any single affiliation can serve on the board at once
21:14:07 <adrian_otto> so if a platinum or gold member has a appointed/selected a member already, only one additional director can prevail in the individual election.
21:14:14 <adrian_otto> from that same affiliation
21:14:19 <adrian_otto> does that make sense?
21:14:31 <muralia> yes
21:15:00 <adrian_otto> ok, any other announcements from team members?
21:15:46 <adrian_otto> #topic review action items
21:15:58 <adrian_otto> #action adrian_otto to follow up with mistral devs to arrange a tagged release that we can use as a stable dependency
21:16:19 <adrian_otto> my apologies for failing to complete this.
21:17:05 <adrian_otto> #topic Blueprint/Task Review
21:17:20 <datsun180b> oh i got one
21:17:24 <adrian_otto> #link https://review.openstack.org/#/c/146607/ Change 'app' commands to 'plan' commands
21:17:29 <datsun180b> way ahead of me
21:17:35 <adrian_otto> datsun180b: acknowledged
21:17:49 <adrian_otto> I will call on you before advancing to Open Discussion
21:18:13 <adrian_otto> so, would anyone like to speak to 146607?
21:18:35 <devkulkarni> I like the suggested change
21:18:49 <devkulkarni> I vote for moving forward with it
21:18:51 <datsun180b> there's a reason for this besides keeping the names and commands square
21:18:52 <muralia> me too.
21:18:58 <james_li> +1
21:19:10 <adrian_otto> datsun180b: please share reasoning
21:19:16 <datsun180b> that is, my next step is to add a handful of commands that refer to an app and do more than just manipulate a plan or an assembly
21:19:48 <adrian_otto> Ed, you put a -1 review on this
21:19:52 <datsun180b> ultimately the goal is to tuck away the details of what a plan and and assembly and a component all are, so a user is really only dealing with applications
21:19:58 <adrian_otto> next time you can put Workflow-1 on it
21:20:19 <datsun180b> oh whooops
21:20:24 <adrian_otto> which would allow voting without causing "disagreement" stats to accumulate for voters, but block merge
21:20:34 <adrian_otto> maybe that's what you meant to do?
21:20:42 <datsun180b> well i can abandon/resub if the metrics are important
21:20:50 <adrian_otto> no biggie
21:20:50 <datsun180b> takes about three clicks and two commands
21:20:54 <adrian_otto> just for future
21:20:57 <datsun180b> noted
21:21:28 <datsun180b> so, any dissenting opinions about renaming those plan commands?
21:22:03 <devkulkarni> no objection from me
21:22:15 <adrian_otto> really this is just removing ambiguity in the terminology
21:22:30 <adrian_otto> so I'll pursue a #agreed on this unless I hear an opposing point of view
21:22:35 <datsun180b> cool
21:22:43 <datsun180b> hoped it would be seen as straightforward
21:23:22 <adrian_otto> #agreed We reached a consensus about clarifying the "app" and "plan" terminology as proposed in https://review.openstack.org/146607. We support this approach.
21:23:48 <adrian_otto> ok, I see ed- changed his vote on that
21:24:07 <adrian_otto> so feel free to +2+A
21:24:27 <datsun180b> i'm not made of stone, a man can change his mind
21:24:34 <adrian_otto> ok, we have a few reviews that need love
21:24:42 <adrian_otto> #link https://review.openstack.org/#/c/115687/
21:25:39 <datsun180b> oh wow that one's all green now, i'll throw in on it
21:25:47 <adrian_otto> so the question for this group of contributions is if we are not voting on these for a reason, in which case they should be abandoned, or do we just need a nudge to have a look at them
21:26:07 <datsun180b> i was only holding off because they were a chain and the head had some troubles
21:26:11 <adrian_otto> I had a feeling that problematic gates were causing a lack of voting
21:26:13 <devkulkarni> I think we were waiting for Jenkins to be green
21:26:31 <datsun180b> and gil mentioned some kind of change for pecan to change the accept behavior in a bigger way
21:26:48 <datsun180b> though that doesn't mean denying legit code
21:26:52 <devkulkarni> right.. I was hoping gpilz will be around today to weigh in on those reviews
21:26:53 <adrian_otto> well, let's handle that iteratively
21:27:24 <adrian_otto> if there is a better way to address the concern, the right instrument is a patch submitted as a gerrit review
21:27:40 <datsun180b> ^ +1
21:28:27 <adrian_otto> Gil's input probably relates to supporting PATCH, which PEcan+WSME does not support out of the box
21:28:42 <adrian_otto> which is related, but not the same subject as this bug
21:28:54 <adrian_otto> #link https://review.openstack.org/#/q/status:open+project:stackforge/solum+branch:master+topic:bug/1331093,n,z
21:29:16 <datsun180b> reminds me, i should see if gtree still works
21:29:17 <adrian_otto> so I urge for reviewers to look at the above list for merge consideration
21:30:42 <adrian_otto> devkulkarni: were there others outside of this set for team discussion today?
21:31:31 <devkulkarni> adrian_otto: no, those were the main ones
21:31:39 <gpilz> sorry I'm late
21:35:09 <adrian_otto> the openstack bot appears to be on the other side of the split
21:35:09 <adrian_otto> so let's wait a moment to see if this heals
21:36:03 <adrian_otto> ok, we have the bot back, and the user list rebounded, so I think we are set to go again
21:36:21 <adrian_otto> everyone please wave for me o/
21:36:58 <datsun180b> \o/
21:37:13 * gpilz waves
21:37:18 <devkulkarni> here
21:37:27 <phiche> ello
21:37:55 <adrian_otto> do I have muralia?
21:38:00 <muralia> yes
21:38:26 <adrian_otto> ok, and mkam?
21:38:30 <james_li> here
21:38:52 <adrian_otto> good, and james_li
21:38:53 <mkam> I'm back
21:38:53 <adrian_otto> here we go again
21:39:20 <adrian_otto> ok, I am going to end our meeting now while I still can.
21:39:30 <adrian_otto> we only has Open Discussion remaining
21:39:32 <devkulkarni> ok, sounds good
21:39:42 <adrian_otto> so lets do that in #solum to the extend that discussion is possible
21:39:58 <adrian_otto> s/extend/extent/
21:40:05 <muralia> ok
21:40:08 <adrian_otto> sorry for the disruption
21:40:22 <datsun180b> well you did cause it
21:40:37 <adrian_otto> no
21:40:44 <datsun180b> of course you didn't
21:40:46 <adrian_otto> that would be like poking myself in the eye
21:40:50 <adrian_otto> ;-)
21:41:12 <adrian_otto> Our next meeting is 2015-01-20 at UTC 2100
21:41:40 <adrian_otto> I will join you for that, or arrange with devkulkarni or another delegate to chair if I must be absent
21:41:52 <adrian_otto> current travel plan has me on the ground in time to start the meeting
21:41:58 <adrian_otto> see you all then, thanks everyone
21:42:03 <adrian_otto> #endmeeting