21:03:54 <adrian_otto> #startmeeting Solum Team Meeting
21:03:55 <openstack> Meeting started Tue Mar 31 21:03:54 2015 UTC and is due to finish in 60 minutes.  The chair is adrian_otto. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:03:56 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:03:59 <openstack> The meeting name has been set to 'solum_team_meeting'
21:04:02 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Solum#Agenda_for_2015-03-31_2100_UTC Our Agenda
21:04:07 <adrian_otto> #topic Roll Call
21:04:09 <james_li> james li
21:04:13 <datsun180b> ed cranford
21:04:14 <adrian_otto> Adrian Otto
21:04:21 <kebray> Ketih Bray
21:04:22 <muralia> murali allada
21:04:28 <devkulkarni> devdatta kulkarni
21:04:36 <gpilz> Gilbert Pilz
21:05:19 <adrian_otto> hello james_li, datsun180b, kebray, muralia, devkulkarni, gpilz
21:05:19 <mkam> Melissa Kam
21:05:25 <adrian_otto> hello mkam
21:05:27 <muralia> o/
21:05:50 <adrian_otto> #topic Announcements
21:05:59 <adrian_otto> 1) adrian_otto will be away on 2015-04-07. Devdatta has graciously agreed to char for us on that day.
21:06:28 <adrian_otto> any other announcements from team members? (we will touch on PTL election further down in the agenda)
21:07:02 <datsun180b> nothing here
21:07:06 <adrian_otto> #topic Joining OpenStack
21:07:26 <adrian_otto> ok, Solum was started in October of 2013
21:07:31 <devkulkarni> I know that we had started out with that intention
21:07:53 <adrian_otto> soon after we polled the contributors and asked if we would like to pursue incubation
21:08:05 <adrian_otto> and that question was answered with a resounding YES
21:08:17 <adrian_otto> since then, the governance process for OpenStack has evolved
21:08:45 <adrian_otto> and we are at a point now where we are in perfect qualification for inclusion into the OpenStack project list
21:09:10 <devkulkarni> adrian_otto: do you have a list of things that the TC look at somewhere handy?
21:09:24 <adrian_otto> #link https://git.openstack.org/cgit/openstack/governance/tree/reference/new-projects-requirements.rst Requirements for new OpenStack Projects applications
21:09:35 <devkulkarni> thank you
21:09:50 <adrian_otto> if we applied, there is a very good chance of acceptance.
21:10:27 <devkulkarni> what are current views on application-layer projects like solum?
21:10:35 <devkulkarni> I know that there was some push back sometime back
21:10:42 <adrian_otto> the question is if the current contributors are still interested in this. I have recently advanced the Magnum project through this process, and I'm willing to repeat it for Solum
21:10:54 <adrian_otto> that attitude has changed
21:11:18 <adrian_otto> we (as OpenStack) now believe in a "Big Tent" approach
21:11:33 <adrian_otto> which strives to be more inclusive and encourage the community to grow and thrive
21:11:52 <devkulkarni> I see..
21:11:57 <adrian_otto> it would commit us to remaining true to the four opens described in the link I posted above
21:12:07 <gpilz> adrian: are you looking to resolve this issue today?
21:12:14 <muralia> Are there any other projects, other than Solum, that fall into the application layer/Top layer
21:12:15 <adrian_otto> it would also allow us to be part of the OpenStack elections rather than potentially holding our own
21:12:43 <devkulkarni> adrian_otto: what about dependencies on projects that may not be yet in the big tent?
21:12:47 <adrian_otto> Murano was recently included. It's a bit different, but that may be a point of discussion.
21:12:54 <muralia> ok
21:13:03 <devkulkarni> I know that Solum does not have such dependency right now
21:13:12 <adrian_otto> all of our libraries must have open source licenses that allow for redistribution
21:13:14 <devkulkarni> but by being in the big tent would it restrict us in the future?
21:13:37 <adrian_otto> maturity of the softwaere is not indicated by inclusion into the Big Tent, It is handled by a TAG.
21:14:18 <adrian_otto> #link https://git.openstack.org/cgit/openstack/governance/tree/reference/tags OpenStack Project Tags
21:14:40 <adrian_otto> so upon initial inclusion, Solum would have no tags
21:14:48 <kebray> devkulkarni, the choicei to fork and run will always be there.  So, there's always an unrestrivite (albeit unopen) way to go.
21:14:49 <devkulkarni> so, to just take an example, we could depend on mistral even though it may not yet be in the big tent
21:15:04 <adrian_otto> devkulkarni: yes, that dependency is a question
21:15:19 <adrian_otto> we don't know yet whether that will be an issue
21:15:25 <devkulkarni> ok
21:15:38 <adrian_otto> Mistral may be applying as well, in which case that may tie acceptance together.
21:15:53 <adrian_otto> or we might need to carve it our of Solum.
21:15:57 <adrian_otto> *out
21:16:11 <devkulkarni> sure. what about diversity?
21:16:19 <adrian_otto> again, diversity is a tag
21:16:27 <devkulkarni> I don't see any specific point regarding that in the new-projects-requirements.txt
21:16:35 <adrian_otto> so it is not required for inclusion, whereas it was required for incubation
21:16:40 <adrian_otto> incubation no longer exists.
21:16:55 <devkulkarni> oh okay.
21:17:15 <devkulkarni> and once in the big tent we will have to follow the release cycle, right?
21:17:25 <adrian_otto> no, actually we don;t
21:17:44 <adrian_otto> we only need to follow the release cycle if we seek the integrated-release tag
21:17:58 <adrian_otto> and in all honesty the chance of that for any new project is very slim
21:18:37 <devkulkarni> okay..
21:18:53 <adrian_otto> so, I'll pose the question to the present contributors
21:19:00 <adrian_otto> would you like to join OpenStack?
21:19:21 <devkulkarni> on the face of it I don't see any issues not to go that route .. do we need to make the decision today or can come back to it when you are back the week after?
21:19:21 <gpilz> I would appreciate some time to discuss this with my colleagues
21:19:26 <adrian_otto> or would you like to table the question and revisit it after you have more time to consider it?
21:19:31 <gpilz> one week?
21:19:53 <adrian_otto> I'm happy to revisit it later
21:19:55 <devkulkarni> table it for two weeks.. pick it up after you are back
21:20:12 <adrian_otto> that will be the summit
21:20:13 <gpilz> +1
21:20:14 <datsun180b> sounds good
21:20:19 <adrian_otto> wait, let me check this calendar
21:20:33 <gpilz> summit is in may
21:20:40 <gpilz> we're still in march
21:20:51 <datsun180b> barely
21:20:55 <adrian_otto> yes, that will work, 2 weeks.
21:20:57 <gpilz> i know calendar arithmetic is tricky but …
21:21:30 <adrian_otto> I will record an action item to put it on the (not next but following) agenda
21:21:59 <adrian_otto> #action adrian_otto to add Joining OpenStack as an agenda item for 2015-04-14 team meeting
21:22:12 <adrian_otto> ok
21:22:15 <adrian_otto> next up is
21:22:18 <adrian_otto> #topic Solum PTL Election
21:22:46 <adrian_otto> last week I had proposed using a private email to contributors to indicate candidacy announcement during this meeting
21:23:06 <adrian_otto> after further consideration, I decided not to act on that agreement because it did not feel right to me
21:23:38 <adrian_otto> I dod not think it was transparent enough, and I wanted to revisit it with you to find something that we can agree on as an open and transparent call for candidacy
21:23:46 <adrian_otto> and I think I have a good idea of how to do that.
21:24:13 <adrian_otto> in the past, Solum's calls for candidacy have followed the close of the OpenStack elections
21:24:32 <adrian_otto> one such election is coming up:
21:24:34 <adrian_otto> #link https://wiki.openstack.org/wiki/PTL_Elections_April_2015 OpenStack Election
21:24:51 <adrian_otto> now..
21:25:08 <adrian_otto> there is a problem with Stackforge projects from the perspective of OpenStack
21:25:18 <adrian_otto> they all need to coordinate and hold their own elections
21:25:53 <adrian_otto> and if they all announce elections *before* the OpenStack election, that can lead to fatigue and possible confusion within the electorate
21:26:04 <devkulkarni> makes sense
21:26:06 <adrian_otto> voters may think elections have passed when they have not
21:26:21 <adrian_otto> and that results in a depressed voter turnout for the official election
21:26:40 <adrian_otto> and that's a serious problem because if we have < 10% turnout (we are very close) the election may not count
21:26:48 <adrian_otto> and that's a real PITA to deal with
21:27:04 <adrian_otto> so my suggestion is that we repeat exactly what we did last time
21:27:12 <adrian_otto> Proposed candidacy April 16-22, and Election (if needed) April 23-29.
21:27:24 <adrian_otto> that opens candidacy after the OpenStack election closes
21:27:29 <kebray> adrian_otto, when voting for PTL, is it only contributors to that project that can vote, or can any OpenStack contributor vote?
21:28:00 <adrian_otto> for us the electorate is contributors over the past two releases
21:28:12 <kebray> contributors to just Solum, or any OpenStack project?
21:28:19 <adrian_otto> Solum only
21:28:26 <adrian_otto> there are 19 of you
21:28:31 <adrian_otto> including me
21:28:34 <kebray> ok... and, we need 10% of contributors for past two cycles to turn out, correct?
21:28:39 <adrian_otto> no
21:28:48 <adrian_otto> so in our case
21:29:11 <adrian_otto> if we hold a candidacy, and there are no new candidates, the incumbent remains in service
21:29:24 <adrian_otto> if there is at least one new candidate, there is an election
21:29:43 <adrian_otto> in the case of an election, the candidate with the most votes wins, unless there is a tie
21:29:57 <adrian_otto> in that case there is a tie breaking formula used
21:30:18 <adrian_otto> only OpenStack has the 10% threshold
21:30:34 <adrian_otto> in our case 2 voters would meet that anyway, so it's a nonissue
21:30:46 <kebray> Ok, got it.  thanks!
21:30:58 <adrian_otto> further…
21:31:15 <adrian_otto> I suggest that we use the openstack-dev mailing list to announce calls for candidacy
21:31:32 <adrian_otto> and that we post it on our Wiki page
21:31:55 <adrian_otto> that way there is a clear indication that Solum selects it's own leadership
21:32:22 <devkulkarni> this approach makes sense.. especially if we are planning to approach the big tent
21:32:30 <adrian_otto> the procedure we agreed on in our last meeting would fail to meet that objective, as the public would not be able to see what is happening
21:33:36 <adrian_otto> ok, any thoughts about this?
21:33:44 <adrian_otto> opposing viewpoint
21:34:06 <adrian_otto> I owe you an apology for not following through with my agreed action, but I feel it was the right thing to do.
21:34:08 <devkulkarni> I think this is a good plan
21:34:11 <muralia> +1
21:34:14 <kebray> +1.. .good plan.
21:34:31 <james_li> +1
21:34:45 <gpilz> +1
21:34:51 <datsun180b> sounds fine
21:35:05 <adrian_otto> ok, let me record this with an #agreed
21:36:23 <adrian_otto> #agreed Solum will hold its own PTL election if needed. Lack of any new candidates will result in continued service by the current PTL. Call for candidates to be sent out on openstack-dev ML with [Solum] topic tag. Candidacy Window April 16-22, and Election (if needed) April 23-29.
21:37:02 <adrian_otto> Anita Kuno will be the election official, as she has no stake in this election
21:37:26 <adrian_otto> ok?
21:37:39 <devkulkarni> +1
21:37:40 <adrian_otto> I can still undo the above agreed if I did not get it just right
21:37:44 <muralia> sure
21:37:55 <kebray> looks good.
21:38:53 <adrian_otto> #action adrian_otto to announce candidacy window to openstack-dev on April 15th before 12:00 AM April 16th US/Pacific.
21:39:06 <adrian_otto> #undo
21:39:07 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x98d8f50>
21:39:14 <adrian_otto> that should be UTC
21:39:30 <adrian_otto> adrian_otto to announce candidacy window to openstack-dev on April 15th before 12:00 AM April 16th UTC
21:39:54 <adrian_otto> thanks everyone, I know all this governance business can be exhausting
21:40:12 <adrian_otto> #topic Tagging or next release
21:40:36 <adrian_otto> so I think soon we will be ready to bundle up a release… possibly later this week.
21:40:58 <adrian_otto> that will come in handy to aid in any potential OpenStack governance proposal
21:41:21 <adrian_otto> thought about that? I think the CLI changes are the bits worth waiting for, right?
21:41:28 <devkulkarni> yes
21:41:35 <datsun180b> there shouldn't be much more but onesie fixes there
21:42:03 <adrian_otto> ok, if you let me know when you think it's ready, I'm happy to go ahead with it
21:42:09 <datsun180b> for the api i think i've got a little more validation to add, but not a lot of heavy lifting
21:42:47 <adrian_otto> that's great!
21:43:25 <adrian_otto> any more on this topic?
21:43:39 <adrian_otto> #topic Review Action Items
21:43:44 <adrian_otto> (none)
21:43:51 <adrian_otto> #topic Open Discussion
21:44:11 <adrian_otto> I skipped task review
21:44:19 <adrian_otto> sorry about that… creature of habit.
21:44:33 <adrian_otto> do we have work items to discuss as a team today?
21:44:48 <adrian_otto> If not, you are welcome to raise other topics.
21:44:48 <datsun180b> nothing on fire
21:45:22 <devkulkarni> that's right.
21:45:22 <adrian_otto> how are we doing with core reviewers
21:45:30 <devkulkarni> oh on that topic..
21:45:31 <adrian_otto> should we be seeking any more?
21:45:47 <devkulkarni> did you get a chance to reach out to the inactive cores?
21:46:03 <adrian_otto> no, I did not
21:46:22 <adrian_otto> that might make sense just after the upcoming release
21:46:28 <datsun180b> we have about 8 tasks open now, and they're all started by core, and the oldest update is the 11th of this month
21:46:32 <adrian_otto> so they can have something to refresh with
21:46:42 <datsun180b> i think we've got a pretty good balance at present
21:46:42 <devkulkarni> sure.
21:47:05 <datsun180b> ah, there's one by dimtruck, overlooked that with tired eyes
21:47:26 <dimtruck> :)
21:47:58 <datsun180b> and we know why that's delayed
21:49:24 <adrian_otto> ok, I do have one other topic for open discussion…
21:50:11 <adrian_otto> Open Cloud Ecosystem replaces the "other project track" at the OpenStack Design Summit.
21:50:26 <adrian_otto> #link https://www.openstack.org/summit/vancouver-2015/open-cloud-ecosystem Open Cloud Ecosystem
21:50:43 <adrian_otto> I am planning to apply on behalf of Solum, if you all agree that makes sense. Thoughts?
21:51:25 <muralia> +1
21:51:27 <kebray> Yes.  Please do.
21:51:29 <devkulkarni> sure
21:51:32 <muralia> i guessing nothing else other than the name of the program has changed.
21:52:16 <adrian_otto> it's putting other projects at an arms length
21:52:58 <adrian_otto> the Open Cloud Ecosystem Lounge is different
21:53:03 <devkulkarni> adrian_otto: I am confused about one thing.. there seem to be already some talks scheduled #link https://openstacksummitmay2015vancouver.sched.org/overview/type/related+oss+projects#.VRsXCjvF-Hl
21:53:13 <adrian_otto> BoF sessions are slightly different
21:53:59 <adrian_otto> that's the #1 item in the list. Those are general session tracts. Call for participation closed in February. I submitted Solum, but it was not selected.
21:54:55 <devkulkarni> oh! you will be submitting to the lounge or BoF
21:55:16 <adrian_otto> Lounge and BoF I think.
21:55:39 <adrian_otto> in the past we did what is now called Collaboration Days with a half day session
21:56:02 <adrian_otto> I don't think enough of us are attending to justify that.
21:56:21 <adrian_otto> but I could be persuaded otherwise.
21:57:24 <adrian_otto> ok, should we wrap up for today?
21:57:40 <datsun180b> think so
21:58:02 <devkulkarni> its almost time
21:58:09 <adrian_otto> our next meeting will be 2015-04-07 at 2100 UTC, chair will be devkulkarni. Take care!
21:58:11 <datsun180b> thanks as always for running the show
21:58:22 <adrian_otto> #endmeeting