21:00:21 <devkulkarni> #startmeeting Solum Team Meeting
21:00:21 <openstack> Meeting started Tue Apr  7 21:00:21 2015 UTC and is due to finish in 60 minutes.  The chair is devkulkarni. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:24 <openstack> The meeting name has been set to 'solum_team_meeting'
21:00:32 <devkulkarni> #topic Roll Call
21:00:36 <devkulkarni> devdatta kulkarni
21:00:37 <james_li_> james li
21:00:38 <muralia> murali allada
21:00:39 <mkam> Melissa Kam
21:00:39 <datsun180b> Ed Cranford
21:00:44 <gpilz> Gilbert Pilz
21:01:04 <devkulkarni> hey everyone
21:01:16 <muralia> hey hey
21:01:17 <devkulkarni> #link https://wiki.openstack.org/wiki/Meetings/Solum
21:01:36 <devkulkarni> I don't have any agenda prepared for today
21:01:58 <devkulkarni> we can go through the set of topics that we usually go through..
21:02:36 <devkulkarni> #topic Announcements
21:02:47 <devkulkarni> Any announcements anyone?
21:04:11 <devkulkarni> last week we were discussing about joining OpenStack
21:04:34 <devkulkarni> Any thoughts on that.. I know that we said that we will come back to that next week when Adrian is back
21:05:09 <muralia> I'm ok with it. Slum does have a place in the big tent model.
21:05:12 <gpilz> I'm still processing that
21:05:49 <devkulkarni> I am in the same boat as gpilz.. haven't thought through yet.. agree with muralia as well
21:06:27 <devkulkarni> I would encourage everyone to take time to think about it this week
21:06:42 <devkulkarni> this topic will be the main topic next week
21:07:15 <devkulkarni> Actually, since we are in the announcement topic - there was one thing that I just remembered
21:07:28 <devkulkarni> Adrian cut a release of python-solumclient last friday
21:07:45 <devkulkarni> At high-level it has following features:
21:08:08 <devkulkarni> 1) Better support for app creation input
21:08:19 <devkulkarni> 2) App logs support
21:08:40 <devkulkarni> 3) Support for setting up two factor authentication for github repositories
21:09:00 <devkulkarni> Anything I am missing datsun180b?
21:09:22 <muralia> how about languagepack commands? were they in the last release too?
21:09:23 <datsun180b> i don't think 3 is accurate
21:09:54 <devkulkarni> muralia: yes — they were there earlier too.. but may be we never announced them formally.. so yes — lp commands
21:10:06 <datsun180b> more that the github experience in our app-create flow can now use basic auth and even use 2fa
21:10:12 <devkulkarni> datsun180b: okay.. I think partially we are there
21:10:32 <datsun180b> shortly (tests pending!) we'll also have oath tokens
21:10:32 <devkulkarni> datsun180b: ah ! thanks for the clarification
21:10:34 <devkulkarni> datsun180b: cool !!
21:10:55 <devkulkarni> so definitely lot of new things..
21:11:12 <devkulkarni> also, if you have not yet checked out — the documentation on readthedocs has been updated as well
21:11:22 <devkulkarni> #link https://solum.readthedocs.org/en/latest/getting_started/index.html
21:12:10 <devkulkarni> the only unfortunate thing is our devstack setup is not yet able to deploy. It used to before, but we haven't kept up with the latest changes. I am working on it
21:12:44 <devkulkarni> any other announcements? if not, we can move to the next topic.
21:13:25 <devkulkarni> #topic Review action items
21:13:48 <devkulkarni> I think we had an action item for adrian from last meeting
21:14:03 <devkulkarni> Since he is not around today, lets just carry that forward.
21:14:14 <devkulkarni> #action adrian_otto to add Joining OpenStack as an agenda item for 2015-04-14 team meeting
21:15:14 <devkulkarni> Any other action item from earlier meetings that we want to discuss?
21:15:43 <muralia> no, the main thing was the new CLI release.
21:15:52 <devkulkarni> cool.
21:16:14 <datsun180b> on that note, thanks adrian for jumping on that as soon as we asked you cut a new client
21:16:23 <devkulkarni> +1
21:17:27 <devkulkarni> okay.. we can move to the next topic I guess then
21:17:50 <devkulkarni> #topic Blueprint/Task Review
21:18:29 <devkulkarni> Come to think of it, I feel we should stop calling this topic as "Blueprint/Task Review"
21:18:40 <devkulkarni> We haven't been using BPs in a consistent manner..
21:19:11 <devkulkarni> we have been using launchpad bugs
21:19:34 <datsun180b> we've been doing a lot of bug fixes as of late though
21:19:45 <datsun180b> i'm winding up to throw a spec/bp down soon
21:19:52 <devkulkarni> We need to cleanup the list of bps..
21:19:58 <devkulkarni> #link https://blueprints.launchpad.net/solum/
21:20:06 <muralia> I can talk about what im working on.
21:20:18 <devkulkarni> muralia: coo..
21:20:24 <devkulkarni> stage is yours
21:20:25 <muralia> I'm currently working on a patch to support Keystone version 2.
21:20:48 <muralia> keystone v2 make solum defcore compliant and a lot of vendors might be looking for that
21:21:27 <muralia> gpilz: im touching some of your camp code too. please take a look once i submit the patch
21:21:37 <gpilz> okay
21:21:46 <muralia> I'm introducting a new config value in the keystone section
21:22:18 <muralia> i'll be called version and i'll initialize the right version of the client using that value
21:22:38 <muralia> right now in our code we have direct references to keystone v3 client all over the place.
21:22:47 <muralia> i'll be changing that
21:23:09 <muralia> thats it
21:23:30 <james_li_> muralia: +1 thats consistent with other openstack projects, glance at least
21:23:39 <muralia> cool
21:23:46 <devkulkarni> that will be helpful muralia
21:24:09 <devkulkarni> any other updates from others on what they are working on?
21:25:00 <datsun180b> nothing i haven't already mentioned
21:25:08 <devkulkarni> okay.
21:25:26 <james_li_> datsun180b: your bp is about the app resource?
21:25:30 <devkulkarni> from my side, I have been busy with fixing CLI bugs and getting deployer logs
21:25:40 <datsun180b> james_li_: right, at least it will be
21:25:57 <james_li_> maybe not too much details at the beginning
21:26:35 <james_li_> I want to see what is in your mind about the high level, i.e. what needs to be done
21:26:56 <datsun180b> of course
21:27:00 <james_li_> and changed in our api model
21:27:00 <james_li_> cool
21:27:29 <datsun180b> first i'm going to work out all the app commands we have, the 'verbs' and their responses
21:27:48 <james_li_> yeah
21:27:53 <datsun180b> then use that to figure out what we need to store and what shape it should be--history and buildids and such will work in there
21:28:19 <datsun180b> and square that with the resources we have at present
21:28:27 <datsun180b> that last step will likely be the hardest
21:28:45 <james_li_> sounds like a plan :)
21:28:56 <datsun180b> no we're doing away with those
21:28:59 <datsun180b> :D
21:29:04 <james_li_> :)
21:29:08 <devkulkarni> :D
21:29:17 <datsun180b> puns!
21:29:25 <devkulkarni> james_li_: any updates on what you have been upto lately?
21:29:40 <gpilz> via la plan!
21:29:40 <james_li_> some bug fixing
21:29:50 <james_li_> thats fine
21:30:41 <devkulkarni> james_li_: cool
21:31:15 <devkulkarni> Its good that we have been at least consistent with creating bugs and referencing them in the commit messages
21:31:44 <devkulkarni> that way we have tracking of those in launchpad and in our commit history
21:32:17 <devkulkarni> gpilz: any updates from your side?
21:32:58 <gpilz> nope
21:33:07 <devkulkarni> cool.
21:33:21 <devkulkarni> so I guess we can move to open discussion then..
21:33:28 <devkulkarni> #topic Open Discussion
21:39:04 <devkulkarni> looks like there are not topics today
21:39:09 <devkulkarni> should we end the meeting?
21:39:15 <datsun180b> i say so
21:39:16 <muralia> yes
21:39:34 <devkulkarni> james_li_, gpilz, mkam?
21:39:44 <james_li_> yeah
21:39:56 <mkam> I'm good with ending :)
21:40:00 <datsun180b> see you all in #solum
21:40:05 <devkulkarni> cool
21:40:10 <devkulkarni> #endmeeting