21:00:47 <adrian_otto> #startmeeting Solum Team Meeting
21:00:48 <openstack> Meeting started Tue Apr 14 21:00:47 2015 UTC and is due to finish in 60 minutes.  The chair is adrian_otto. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:49 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:51 <openstack> The meeting name has been set to 'solum_team_meeting'
21:00:54 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Solum#Agenda_for_2015-04-14_2100_UTC Our Agenda
21:01:00 <adrian_otto> #topic Roll Call
21:01:07 <adrian_otto> Adrian Otto
21:01:21 <datsun180b> Ed Cranford
21:01:32 <mkam> Melissa Kam
21:02:11 <adrian_otto> hello datsun180b and mkam
21:02:16 <james_li> james li
21:02:30 <devkulkarni> devdatta kulkarni
21:02:35 <muralia> murali allada
21:02:48 <adrian_otto> hello james_li, devkulkarni, and muralia
21:03:03 <muralia> o/
21:03:18 <james_li> Hi Adrian
21:03:31 <kebray> \o
21:03:50 <adrian_otto> hello kebray
21:04:41 <adrian_otto> #topic Announcements
21:04:50 <adrian_otto> (no prepared announcements) Any announcements from team members?
21:05:27 <adrian_otto> devkulkarni: thanks for chairing last week when I was away
21:05:40 <adrian_otto> is there anything you'd like to cover from last week before we proceed?
21:05:58 <devkulkarni> adrian_otto: sure thing. hope you had a good trip
21:06:14 <devkulkarni> we ended up discussing mostly what we all have been up to
21:06:24 <kebray> adrian_otto, is it time for session proposal submissions?  e.g. I want to propose glance session discussion on container registry
21:06:25 <adrian_otto> indeed, I saw some extremely large redwood (Sequoia) trees
21:06:37 <devkulkarni> nice!
21:06:53 <adrian_otto> kebray, I will address that as the first item in open discussion if that's okay
21:07:17 <kebray> sure thing
21:07:22 <adrian_otto> let's touch on the topic we tabled two weeks back
21:07:24 <adrian_otto> #topic Joining OpenStack
21:07:44 <adrian_otto> in the past, openstack contributors expressed an interest in becoming an OpenStack project.
21:08:08 <adrian_otto> another project that I work on, Magnum has recently joined, so I am very familiar with the current procedure to enter
21:08:36 <adrian_otto> I asked how we all view this question today, and we decided to regroup after further cosideration
21:08:51 <adrian_otto> Do our contributors want to join OpenStack?
21:08:55 <adrian_otto> how do you all view this?
21:09:08 <datsun180b> I'm for it
21:09:18 <adrian_otto> Solum contributors (correction for above)
21:09:18 <muralia> I think it would be great. I'm all for it. A community of contributors is always great.
21:09:40 <devkulkarni> Yes — it will be agood thing
21:09:49 <james_li> I vote yes too
21:10:06 <mkam> I'm voting yes as well
21:10:29 <adrian_otto> thanks datsun180b, muralia, devkulkarni, james_li, and mkam
21:10:52 <adrian_otto> gpilz is not here today
21:11:05 <adrian_otto> I wanted his input as well
21:11:45 * adrian_otto pauses to see if I can find gpilz out of band
21:12:11 <kebray> +1 from me.. I vote yes.
21:12:34 <adrian_otto> thanks kebray.
21:12:48 <adrian_otto> okay, so that's consistent with the sentiment that was set a while back
21:13:08 <adrian_otto> so the natural follow-up question is if we should proceed with that effort now, or later?
21:13:29 <devkulkarni> later, as in after the summit?
21:13:30 <adrian_otto> an advantage of proceeding now is that the rules are a known quantity
21:13:47 <adrian_otto> devkulkarni: good question, I'll explain how this works
21:14:09 <adrian_otto> adding a project to the openstack projects.yaml file is done with a governance review
21:14:23 <adrian_otto> this is a patch to a git repo that is voted on using Gerrit by the OpenStack TC
21:14:48 <adrian_otto> if that "application" is successful, the merge results in the new project being added to the project list
21:15:06 <adrian_otto> after that, we submit different patches to move the source tree from stackforge to openstack
21:15:14 <adrian_otto> that goes into the project config repo
21:15:41 <adrian_otto> so step 1 needs to be approved by the TC at one of their regular meetings
21:15:58 <adrian_otto> that normally happens on a weekly cadence
21:16:25 <adrian_otto> so we could join the project list before the summit as long as the TC meeting proceed, and that governance item is added to the agenda for voting
21:16:28 <adrian_otto> make sense?
21:16:36 <devkulkarni> got it.. how does the TC evaluate a project?
21:16:49 <devkulkarni> if that happens before the summit that would be awesome!
21:16:55 <adrian_otto> there is a set of criteria… let me show that to you (getting the link)
21:17:06 <adrian_otto> it is too late for us to be part of the Design Summit
21:17:23 <adrian_otto> but we would have a place at subsequent design summits
21:17:50 <adrian_otto> #link https://git.openstack.org/cgit/openstack/governance/tree/reference/new-projects-requirements.rst New Project Requirements
21:17:58 <devkulkarni> makes sense.. the reason I asked if before or after summit is — I don't know how busy TC is from now till the summit..
21:18:06 <adrian_otto> this is the criteria the TC currently uses to evaluate new projects
21:18:21 <devkulkarni> but if the meetings are happening on a regular weekly cadence then it does not matter
21:18:28 <muralia> also, once approved, do we have a deadline for moving it from stackforge to openstack? I'm not sure what that involves, it might be a considerable amount of effort?
21:18:30 <adrian_otto> most of the TC members are also developers, and we are in a code freeze for Kilo currently
21:18:40 <adrian_otto> so this may actually be a good time
21:18:46 <devkulkarni> oh I see
21:18:49 <devkulkarni> that is a good
21:18:51 <devkulkarni> point
21:18:58 <adrian_otto> with the exception of those scrampling to assemble the integrated release
21:19:13 <adrian_otto> those Stackers are very busy right now
21:19:31 <devkulkarni> muralia: I was about to ask that.. we should take input from mkam dimitry to see how that change might affect our downstream processes
21:19:43 <devkulkarni> adrian_otto: makes sense
21:19:53 <adrian_otto> April 21 at UTC 20:00 is the next TC meeting
21:20:14 <adrian_otto> so we could have feedback as early as our next team meeting
21:20:26 <devkulkarni> adrian_otto: that sounds great. I think we should do that.
21:20:35 <devkulkarni> I am just little worried about this point "The project aligns with the OpenStack Mission:"
21:21:01 <adrian_otto> The OpenStack Mission: to produce the ubiquitous Open Source Cloud Computing platform that will meet the needs of public and private clouds regardless of size, by being simple to implement and massively scalable.
21:21:16 <devkulkarni> I know that previously there were some line of thought that the mission should only be limited to core infra level services
21:21:38 <adrian_otto> that perspective has evolved
21:21:57 <adrian_otto> 2 cases in point: Magnum and Murano are now in the project list.
21:22:01 <devkulkarni> okay.. after re-reading it..I think we satisfy "or directly building on an existing OpenStack infrastructure service" part
21:22:08 <devkulkarni> oh that's right
21:22:14 <adrian_otto> the prevailing philosophy is "big tent"
21:22:23 <adrian_otto> meaning inclusive rather than exclusive
21:22:37 <devkulkarni> Magnum still falls squarely into the infra domain, so the issue would not have come up for it
21:22:40 <devkulkarni> right
21:23:07 <adrian_otto> we should expect questions about any similarity between Solum and Murano
21:23:28 <adrian_otto> and that question can be addressed by clearly outlining the difference in the governance proposal commit message
21:23:41 <adrian_otto> ok, sounds like we are in agreement to proceed in the short term
21:23:49 <kebray> Murano is just a catalog, right?  ;-)
21:24:31 <kebray> I think we are differentiated is better way to state my point.
21:24:45 <adrian_otto> #link https://git.openstack.org/cgit/openstack/governance/tree/reference/projects.yaml#n806 Murano Mission
21:25:55 <adrian_otto> any opposing viewpoints to consider?
21:26:31 <kebray> some small overlap in the application lifecycle mangaement... where, I can argue that they aren't application lifecycle management, they are application _environment_ lifecycle mangement, per the first part of the murano mission statement.
21:27:13 <adrian_otto> I suggest that we use language that accurately describes what Solum now does, which is automation of the SDLC
21:27:22 <kebray> solum manages the app, murano manages the application componentry environment (if desired), or can just leverage Heat template.
21:27:32 <adrian_otto> Murano is concerned with the deployment lifecycle
21:27:34 <kebray> adrian_otto, that makes sense.
21:28:00 <devkulkarni> right.. I may be wrong but Murano probably does not build an application
21:28:17 <devkulkarni> it deploys already built applications..
21:28:23 <adrian_otto> so we can work together to revise the mission statement to take into consideration Solum's gradual evolution
21:28:56 <adrian_otto> would you like to spend any time collaborating on that today?
21:29:03 <devkulkarni> long time back we had created this: #link https://etherpad.openstack.org/p/solum-mission
21:30:02 <kebray> adrian_otto, there are also notes from previous summits where the Murano team helped write clear distinction between Heat, Murano, and Solum.  We should probably dig that up before reworking it here today.
21:30:03 <adrian_otto> #link https://etherpad.openstack.org/p/solum-mission Solum Mission Statement Work Product
21:30:11 <adrian_otto> great link devkulkarni
21:30:33 <adrian_otto> good point kebray
21:30:49 <devkulkarni> kebray: yes — I remember reading an email sometime back on the difference
21:31:09 <adrian_otto> ok, let's advance through our prepared agenda for today, and we can revisit the mission statement subject as a team discussion in #solum
21:31:14 <muralia> Can we collaborate over email, theres a lot to read and think about here?
21:31:27 <adrian_otto> yes, absolutely.
21:31:48 <devkulkarni> instead of email, may be a gerrit review?
21:31:56 <kebray> adrian_otto I found the etherpad link in my bookmarks, but it's no longer a valid URL :-(
21:32:00 <muralia> even better
21:32:10 <adrian_otto> devkulkarni: that would be a great way of collaborating on it
21:32:14 <datsun180b> i don't know about that, i think an email thread is fine
21:32:33 <kebray> i.e.  https://wiki.openstack.org/wiki/Design_Summit/Juno/Etherpads#Cross-Project
21:32:39 <muralia> ys, or a google doc for comments and versioning
21:32:40 <adrian_otto> we can use an etherpad as a drafting tool
21:32:54 <datsun180b> if it's a review, the wall is too high for anyone that's not a CLA-signed contributor
21:33:24 <devkulkarni> any tool that will allow in-line comments and tracking of revisions should be good
21:33:29 <adrian_otto> using a review would be a good way to vote on a final draft though
21:33:57 <adrian_otto> when we set the mission statement for Heat, we just used an etherpad
21:34:20 <datsun180b> that sounds fine then
21:34:29 <adrian_otto> and based on the remarks in that, and a related email thread, that was enough
21:34:40 <adrian_otto> ok
21:34:43 <adrian_otto> next topic
21:34:51 <adrian_otto> #topic Tagging or next release
21:35:00 <adrian_otto> Are we ready to tag our next release?
21:35:13 <adrian_otto> if not, what work items should we be sure to merge first?
21:35:40 <devkulkarni> There are couple of patches outstanding
21:35:43 <datsun180b> presently i'm going after bugs and qol
21:35:45 <devkulkarni> and one or two more coming in
21:36:18 <adrian_otto> might we be ready later this week?
21:36:32 <devkulkarni> I think so, yes
21:36:35 <muralia> yes
21:36:45 <muralia> lets target friday
21:37:01 <adrian_otto> ok, I'll check in with you friday on IRC
21:37:21 <muralia> sure
21:37:26 <adrian_otto> #topic Review Action Items
21:37:36 <adrian_otto> were there any from last week devkulkarni?
21:38:01 <devkulkarni> no, there were none.
21:38:13 <adrian_otto> thanks
21:38:20 <adrian_otto> #topic Blueprint/Task Review
21:38:34 <adrian_otto> any work items requiring team discussion today?
21:38:35 <devkulkarni> oh yes.. there was one points
21:38:52 <devkulkarni> while discussing the BP/Task review topic
21:39:10 <devkulkarni> we felt that we have kind of gone away from using BPs in a consistent manner
21:39:27 <devkulkarni> we are more using bugs than BPs
21:39:45 <devkulkarni> so one thought/suggestion was for us to clean up the BPs and then start using them again, or
21:39:56 <devkulkarni> change the topic name to 'Task Review'
21:40:09 <adrian_otto> that's easy
21:40:18 <datsun180b> considering i created one today and am staring at the half-written spec, i'm going to agree with option cleanup-and-keep-using
21:40:35 <adrian_otto> ok
21:40:37 <devkulkarni> datsun180b: you created a BP or a spec?
21:40:42 <datsun180b> yes
21:40:57 <devkulkarni> which one did you create?
21:40:58 <datsun180b> both, that is
21:41:01 <devkulkarni> oh okay
21:41:20 <devkulkarni> I can take an action item to clear up the BPs
21:41:23 <muralia> We should clean up older ones. But we should use BP's only if we are adding new features.
21:42:21 <adrian_otto> it's also handy to use a bp if you want to track a gerrit topic
21:42:29 <adrian_otto> so it's useful for big refactors too
21:42:29 <datsun180b> i only disagree with "only" in that statment muralia
21:42:38 <muralia> :)
21:43:25 <devkulkarni> we need this cleanup also considering that we might get more eyes once we start interfacing with the TC
21:43:42 <adrian_otto> ok, so I can comb through what's there, and we can purge out things that are not in our current scope of work
21:43:51 <devkulkarni> sounds good
21:44:13 <adrian_otto> #action adrian_otto to spring clean our blueprints
21:44:33 <adrian_otto> ok, so do any work items require team dicussion?
21:44:43 <devkulkarni> we should probably do something similar for bugs as well.
21:44:47 <datsun180b> agreed
21:44:51 <devkulkarni> either triage them or close them
21:45:03 <datsun180b> some of them are old enough that they've been taken care of
21:45:20 <datsun180b> just not marked
21:45:24 <adrian_otto> #action adrian_otto to spring clean our bug list
21:45:47 <devkulkarni> +1
21:46:34 <adrian_otto> ok, before we advance to Open Discussion, kebray had a topic "I want to propose glance session discussion on container registry"
21:46:50 <adrian_otto> so lets discuss that
21:47:09 <adrian_otto> in the past, the Design Summit used a CFP format to decide on session topics
21:47:25 <adrian_otto> that methodology was changed starting at the Paris summit
21:47:42 <adrian_otto> and instead, each project uses etherpads, and IRC collaboration to set the topic list
21:48:01 <adrian_otto> so there is no formal process to put a glance session discussion together
21:48:25 <adrian_otto> instead, we approach the glance team, and arrange to collaborate on that topic at the summit in the most appropriate venue
21:48:32 <devkulkarni> kebray can probably check with glance folks
21:49:36 <adrian_otto> ok, LMK if that needs further disucsison
21:49:43 <adrian_otto> #topic Open Discussion
21:51:33 <adrian_otto> maybe we don't have any more topics to cover today?
21:51:55 <muralia> yup.
21:51:57 <datsun180b> guess not
21:51:57 <devkulkarni> from my side — nothing more for today
21:52:40 <adrian_otto> ok, thanks everyone for attending. Our next team meeting will be 2015-04-21 at 2100 UTC. See you then!
21:52:49 <adrian_otto> #endmeeting