21:00:21 <adrian_otto> #startmeeting Solum Team Meeting
21:00:22 <openstack> Meeting started Tue May  5 21:00:21 2015 UTC and is due to finish in 60 minutes.  The chair is adrian_otto. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:25 <openstack> The meeting name has been set to 'solum_team_meeting'
21:00:28 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Solum#Agenda_for_2015-05-05_2100_UTC Our Agenda
21:00:34 <adrian_otto> #topic Roll Call
21:00:37 <datsun180b> ed cranford
21:00:38 <adrian_otto> Adrian Otto
21:00:43 <mkam> Melissa Kam
21:00:45 <muralia> murali allada
21:00:53 <devkulkarni> devdatta kulkarni
21:01:17 <adrian_otto> I am having a little internet trouble, so if I am slow responding just carry on, please
21:02:11 <adrian_otto> hello datsun180b mkam muralia devkulkarni
21:02:21 <devkulkarni> hello adrian_otto
21:04:44 <adrian_otto> #topic Announcements
21:04:47 <adrian_otto> 1) Reminder: There will be no team meeting on 2015-05-19 due to the OpenStack Summit.
21:05:08 <akshayc> ok
21:05:14 <adrian_otto> that concludes prepared announcements. Are there any other announcements from team members?
21:05:18 <devkulkarni> hi akshayc
21:05:26 <james_li> james li
21:05:27 <akshayc> hi devkulkarni
21:06:42 <adrian_otto> #topic Review Action Items
21:06:56 <adrian_otto> #action adrian_otto to spring clean our blueprints
21:07:10 <adrian_otto> #action adrian_otto to spring clean our bug list
21:07:26 <adrian_otto> #action adrian_otto to email the dev list concluding the Solum PTL Election
21:07:46 <devkulkarni> adrian_otto: just a fyi, sometime last week I looked at some of the bugs and marked them as either resolved or in progress
21:07:49 <adrian_otto> my hope is to conclude these upon tagging a release
21:07:50 <devkulkarni> hope you don't mind
21:07:59 <adrian_otto> thanks!
21:08:08 <adrian_otto> yes, can use all the help I can get
21:08:12 <devkulkarni> I was in the middle of submitting a patch for my bug and so while I was at it, did a few
21:08:17 <adrian_otto> are we ready to tag a release of solum?
21:08:29 <devkulkarni> I think so..
21:08:31 <adrian_otto> that will help to clear our all the fix committed tickets
21:08:35 <devkulkarni> muralia: what about your patch?
21:08:43 <devkulkarni> does not need to get in?
21:08:51 <muralia> which one? the keystone one?
21:08:55 <devkulkarni> yeah..
21:09:04 <adrian_otto> we can wait if we are not ready
21:09:13 <muralia> no it doesnt. its just improvement and does not block anything
21:09:22 <datsun180b> muralia: ahem
21:09:36 <devkulkarni> james_li, datsun180b, mkam: thoughts?
21:10:09 <adrian_otto> we can always tag another as a fast follow
21:10:17 <datsun180b> well i'd like to get the trigger changes into solum but admittedly it's not mandatory yet
21:10:30 <datsun180b> it can always come in another release
21:10:47 <devkulkarni> mkam/james_li: ?
21:10:52 <muralia> i good with that
21:11:07 <james_li> better to have mine: https://review.openstack.org/#/c/170313/
21:11:10 <adrian_otto> ok, so I will take an action to tag a release if there are no objections.
21:11:30 <devkulkarni> adrian_otto: may be after we merge james_li's patch?
21:11:39 <adrian_otto> ok
21:11:54 <james_li> I will fix the gate by today
21:12:03 <devkulkarni> james_li: +1
21:12:21 <james_li> I think most of the team has already reviewed it
21:12:41 <adrian_otto> ok, so if you email me when you are ready, I can do my part
21:12:54 <james_li> thanks adrian_otto
21:13:08 <adrian_otto> #topic BP/Task Review
21:13:35 <adrian_otto> any work items requiring team discussion (maybe https://review.openstack.org/#/c/170313/ perhaps?)
21:14:21 <devkulkarni> sure.. james_li can give high-level description of the patch
21:15:01 <james_li> it separates the storage of DU image loc and tag
21:15:19 <james_li> so we don't need to concat the two things into one big string
21:15:30 <james_li> so improves reliability.
21:16:04 <james_li> very straightforward
21:16:28 <adrian_otto> brb, switching connections.
21:17:09 * adrian_otto1 back again
21:17:14 <devkulkarni> james_li: +1
21:17:52 <adrian_otto1> ok, anything else to cover on tas review?
21:17:56 <adrian_otto1> *task
21:18:18 <james_li> https://review.openstack.org/#/c/163120/
21:18:28 <james_li> that one seems sitting there for a while
21:18:42 <james_li> muralia: ^^
21:18:47 <muralia> yes, this is one of the next few things im going to work on.
21:19:02 <muralia> basically, we've added a lot of plan validation in the CLI
21:19:27 <muralia> we need to move it to the API. I'm ok with someone else taking ownership of this patch whil im working on other things
21:19:49 <datsun180b> what's it need besides a rebase anyway
21:20:21 <muralia> this patch was written way before we added things like plan name validation, port number validation and so many other things in the CLI
21:20:29 <devkulkarni> I think we should hold onto to the validation till we get the app resource
21:20:39 <muralia> sure
21:20:52 <devkulkarni> muralia: what if we abandon this patch?
21:20:55 <muralia> I'm ok with abandoning this and creating a new patch
21:21:10 <muralia> doing it now
21:21:12 <devkulkarni> no need to create a new one till we get the app resource in place
21:21:43 <muralia> done
21:22:00 <james_li> devkulkarni: +1
21:22:15 <datsun180b> that makes sense
21:22:49 <devkulkarni> akshayc: you around?
21:23:29 <devkulkarni> looks like really bad connection adrian_otto
21:23:38 <adrian_otto> yeah, sorry about that
21:23:48 <devkulkarni> no worries..
21:24:02 <devkulkarni> so we decided to abandon that patch which was doing API side validation for plans
21:24:12 <devkulkarni> we will pick the validation story once we have the app resource
21:24:59 <adrian_otto> ok, should we advance to open discussion?
21:25:05 <devkulkarni> sure
21:25:06 <datsun180b> and i'd like to get back to that following my trigger changes
21:25:17 <adrian_otto> #topic Open Discussion
21:25:31 <devkulkarni> is gpilz around today?
21:25:54 <devkulkarni> looks like not..
21:26:24 <adrian_otto> no, he is not
21:26:29 <devkulkarni> there were few camp related functional tests which were failing recently, so wanted to check with him if he had any suggestions
21:26:47 <adrian_otto> let me see if I can find him
21:26:58 <devkulkarni> or we can reach out to him on solum later
21:27:06 <gpilz> yo
21:27:14 <gpilz> sorry
21:27:23 <adrian_otto> aha!
21:27:26 <gpilz> I can look into those
21:27:35 <gpilz> do you want to get into it now?
21:27:39 <adrian_otto> gpilz: do you know where to find what's troubling us?
21:27:58 <adrian_otto> we are in open discussion, so if you have anything to share this is a good time for it
21:28:02 <devkulkarni> may be it was a false alarm..
21:28:05 <muralia> gpliz: I was working on a new pluggable model for the keystone integration in Solum.
21:28:25 <muralia> and I was adding support for keystone v2 upstream. this was making a few camp tests fail
21:28:31 <muralia> functional tests.
21:28:53 <gpilz> can I pick up what you have committed so far and see for myself?
21:28:53 <muralia> im not sure how to fix them,
21:29:23 <muralia> sure, i'm still work on it, but theres a WIP patch out there
21:29:36 <muralia> are camp tests enabled in our gates?
21:29:44 <devkulkarni> I think not
21:29:52 <gpilz> all the camp functional tests are no-ops if you don't enable camp
21:29:58 <gpilz> we put that in awhile ago
21:30:10 <muralia> do they run today?
21:30:15 <muralia> in our gates
21:30:37 <devkulkarni> no, they don't run on our gates
21:30:44 <muralia> ok
21:31:17 <mkam> I thought they were enabled by default
21:31:25 <muralia> in anycase, I'll ping you if I need help gpliz
21:31:31 <gpilz> okay
21:31:32 <mkam> https://github.com/stackforge/solum/blob/master/functionaltests/api/base.py#L61
21:31:33 <devkulkarni> oh! may be you are right mkam
21:31:48 <devkulkarni> good catch mkam
21:32:04 <mkam> we can change that to false if we want :)
21:32:13 <gpilz> that's okay
21:32:31 <devkulkarni> okay to change it to False?
21:32:34 <gpilz> i'd rather know when CAMP breaks if that is okay
21:32:43 <gpilz> no
21:32:43 <devkulkarni> sure
21:32:52 <adrian_otto> another approach is to use a nonvoting gate for that
21:33:13 <devkulkarni> lets see if gpilz and muralia can get to green tests..
21:33:14 <adrian_otto> so you get an indication that it's busted, but it will not block a merge
21:33:21 <devkulkarni> if that happens then we won't have to change anything
21:33:28 <muralia> yes
21:33:28 <adrian_otto> but it's better to just have the tests enabled and working all the time
21:33:35 <adrian_otto> devkulkarni: +1
21:33:39 <muralia> +1
21:34:58 <adrian_otto> ok, anything else to discuss today?
21:35:07 <adrian_otto> if not we can adjourn
21:35:14 <devkulkarni> sounds good
21:35:18 <muralia> sure
21:35:24 <adrian_otto> great, thanks everyone for attending.
21:35:31 <devkulkarni> thanks adrian_otto
21:35:34 <adrian_otto> #endmeeting