21:00:51 <adrian_otto> #startmeeting Solum Team Meeting
21:00:53 <openstack> Meeting started Tue Jun 16 21:00:51 2015 UTC and is due to finish in 60 minutes. The chair is adrian_otto. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:54 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:57 <openstack> The meeting name has been set to 'solum_team_meeting'
21:01:01 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Solum#Agenda_for_2015-06-16_2100_UTC Our Agenda
21:01:06 <adrian_otto> #topic Roll Call
21:01:11 <adrian_otto> Adrian Otto
21:01:25 <datsun180b> Ed Cranford
21:01:32 <james_li> james li
21:01:40 <datsun180b> some of the folks in austin are on their way home, prompted by a tornado watch
21:01:58 <adrian_otto> oh, no
21:02:13 <adrian_otto> I hope that does not cause too much trouble there
21:03:12 <datsun180b> are you double-booked for cross-project right now?
21:04:32 <adrian_otto> datsun180b: me?
21:04:52 <datsun180b> yes, and i guess you've likely been this whole time
21:05:14 <adrian_otto> so we have datsun180, james_li, and me
21:05:33 <gpilz> gilbert pilz
21:05:37 <gpilz> (sorry)
21:05:41 <adrian_otto> hi gpilz
21:05:50 <adrian_otto> ok, so that's enough to start with
21:06:01 <adrian_otto> #topic Announcements
21:06:21 <adrian_otto> 1) We released Solum 2015.1.0 (Kilo) this past week
21:06:54 <adrian_otto> 2) We applied to become an OpenStack Project:
21:06:55 <adrian_otto> #link https://review.openstack.org/190949 Governance Review to Add Solum to OpenStack Projects List
21:07:08 <kebray> keith bray here
21:07:13 <adrian_otto> It was on the agenda for the TC meeting which just concluded:
21:07:27 <adrian_otto> #link http://eavesdrop.openstack.org/meetings/tc/2015/tc.2015-06-16-20.02.html TC Minutes with link to full logs
21:08:08 <adrian_otto> even though affiliation diversity is not a decision criteria for new projects, the TC is concerned about it so it's time to do community building work.
21:08:44 <datsun180b> I didn't gather it was a deal-breaker, but it is something we should work on
21:08:46 <adrian_otto> we have 4/7 required votes so far
21:09:13 <adrian_otto> it's technically irrelevant, but I think we all would appreciate wider diversity.
21:09:19 <adrian_otto> so let's work on that a bit
21:09:41 <datsun180b> It's difficult because I can only indirectly influence that balance
21:09:43 <adrian_otto> questions on the motion?
21:10:23 <datsun180b> I'm glad they didn't have many qualms with our approach and they didn't question our stability that I saw
21:10:32 <adrian_otto> datsun180b: diversity will improve if people know about the project
21:10:58 <adrian_otto> and know that it's actually a real thing that its contributors are committed to
21:11:46 <datsun180b> Should we make or update a getting-started-with-developing doc?
21:11:59 <adrian_otto> 3) I will be on vacation from 6/19 to 7/5 returning to work again on 7/6
21:12:22 <adrian_otto> datsun180b: yes, those sorts of efforts will help onboard new contributors
21:12:54 <adrian_otto> so I've asked Devdatta if he can chair our meetings, and he said yes.
21:13:07 <adrian_otto> so I'll mark the next agenda accordingly.
21:13:16 <adrian_otto> any announcements from team members?
21:13:27 <adrian_otto> hello kebray and dimtruck
21:13:34 <kebray> hello
21:14:06 <adrian_otto> #topic Review Action Items
21:14:24 <adrian_otto> 1) adrian_otto to spring clean our blueprints (COMPLETE)
21:14:39 <adrian_otto> 2) adrian_otto to spring clean our bug list (COMPLETE)
21:14:50 <datsun180b> ten labors remain, herakles
21:14:52 <adrian_otto> 3) devkulkarni to file a bug to investigate solum-magnum integration outlining the various options, relevant documentation, etc.
21:15:05 <adrian_otto> #link https://blueprints.launchpad.net/solum/+spec/magnum-integration Magnum Integration for App Deployment
21:15:10 <adrian_otto> Status: COMPLETE
21:15:23 <adrian_otto> that concludes action items… none to carry forward.
21:15:32 <adrian_otto> #topic Blueprint/Task Review
21:15:49 <adrian_otto> Bug Ststs: 0 Critical, 4 High, 8 Medium, 22 Low, 45 Wishlist
21:15:51 <adrian_otto> #link https://launchpad.net/solum/+milestone/2015.1.1 34 bugs targeted for Liberty
21:16:20 <adrian_otto> please help me decide if we should keep the following, or who they should be assigned to:
21:16:22 <adrian_otto> High Importance Bugs (Are these all still valid? If so, let's get them all assigned)
21:16:35 <adrian_otto> #link https://bugs.launchpad.net/solum/+bug/1321546 docker prepare script does not install docker before running docker command
21:16:37 <openstack> Launchpad bug 1321546 in Solum "docker prepare script does not install docker before running docker command" [High,In progress] - Assigned to James Li (james-li-3)
21:16:46 <adrian_otto> assigned, great!
21:16:53 <adrian_otto> james_li: is this up to date?
21:17:04 <datsun180b> likely it'll be absorbed by his bash-to-python work
21:17:28 <james_li> adrian_otto: yeah let's keep around for now and I will look into it
21:17:46 <adrian_otto> ok, Thanks! next
21:17:49 <adrian_otto> #link https://bugs.launchpad.net/solum/+bug/1339298 rpc server occasionally cannot read messages from rabbitmq on gate node
21:17:50 <openstack> Launchpad bug 1339298 in Solum "rpc server occasionally cannot read messages from rabbitmq on gate node" [High,Triaged] - Assigned to James Li (james-li-3)
21:18:00 <adrian_otto> also assigned to james-li
21:18:11 <james_li> same for his one too :)
21:18:16 <adrian_otto> next
21:18:17 <adrian_otto> #link https://bugs.launchpad.net/solum/+bug/1441828 Error in uploading built DU to glance
21:18:18 <openstack> Launchpad bug 1441828 in Solum "Error in uploading built DU to glance" [High,Triaged] - Assigned to Devdatta (devdatta-kulkarni)
21:18:39 <adrian_otto> devkulkarni is in transit, right?
21:18:44 <devkulkarni> here
21:18:50 <adrian_otto> oh, welcome devkulkarni!
21:18:56 <devkulkarni> I will have to check if this bug is still valid
21:19:06 <devkulkarni> let it be assignment to me
21:19:08 <adrian_otto> ok, I'll let you look while I pull up the next…
21:19:09 <devkulkarni> thanks adrian_otto
21:19:16 <adrian_otto> #link https://bugs.launchpad.net/solum/+bug/1462130 Concurrency bug for multiple deployments within same second
21:19:17 <openstack> Launchpad bug 1462130 in Solum "Concurrency bug for multiple deployments within same second" [High,Triaged] - Assigned to Devdatta (devdatta-kulkarni)
21:19:28 <devkulkarni> that one I just assigned to me
21:19:30 <adrian_otto> this one seemed valid, and recent
21:19:39 <james_li> yeah
21:19:49 <adrian_otto> feel free to re-assign as needed
21:19:51 <devkulkarni> yes — we have to change our columns to have subsecond time granularity
21:20:07 <adrian_otto> that concludes our list of High priority bugs
21:20:17 <adrian_otto> here are the Medium ones:
21:20:21 <adrian_otto> Orphan Medium Bugs (Let's get these assigned)
21:20:35 <adrian_otto> were all orphaned as of the time I made the agenda earlier
21:20:42 <adrian_otto> #link https://bugs.launchpad.net/solum/+bug/1293738 Improvement: Check duplicate when creating/registering a language_pack
21:20:42 <openstack> Launchpad bug 1293738 in Solum "Improvement: Check duplicate when creating/registering a language_pack" [Medium,Triaged]
21:21:03 <adrian_otto> that one struck me as an easy fix
21:21:09 <devkulkarni> muralia might have already fixed it
21:21:18 <datsun180b> i hope the fix isn't just in the cli
21:21:32 <devkulkarni> datsun180b: good point
21:21:41 <datsun180b> either way it should be relatively simple
21:21:42 <devkulkarni> we need to check that.. I don't remember
21:21:59 <devkulkarni> for now, we can assign it to muralia imo
21:22:04 <adrian_otto> ok, I added a comment accordingly
21:22:08 <adrian_otto> ok, will assign
21:22:26 <adrian_otto> done
21:22:39 <adrian_otto> next is:
21:22:40 <adrian_otto> #link https://bugs.launchpad.net/solum/+bug/1302552 Tech Debt: Convert bash scripts in contrib into python code and add tests
21:22:41 <openstack> Launchpad bug 1302552 in Solum "Tech Debt: Convert bash scripts in contrib into python code and add tests" [Medium,Triaged]
21:22:50 <devkulkarni> that goes to james_li
21:22:54 <james_li> I am working on this one
21:22:58 <adrian_otto> ok, assigning
21:23:08 <datsun180b> i don't think it's fair to call it a bug
21:23:28 <adrian_otto> it is a task
21:23:55 <datsun180b> oh that's just the bot then
21:24:18 <adrian_otto> next is
21:24:27 <adrian_otto> #link https://bugs.launchpad.net/solum/+bug/1382660 Create installation instructions
21:24:29 <openstack> Launchpad bug 1382660 in Solum "Create installation instructions" [Medium,Triaged]
21:24:43 <adrian_otto> I wondered if this was actually completed already
21:24:55 <devkulkarni> it probably is..
21:24:56 <adrian_otto> devkulkarni: you worked on this recently, yes?
21:25:11 <devkulkarni> adrian_otto: no.. I was working on getting our devstack setup working
21:25:20 <adrian_otto> oh, ok
21:25:25 <datsun180b> didn't dimitry, too? he's not anywhere i can ask him
21:25:26 <adrian_otto> volunteers to own this one?
21:25:32 <devkulkarni> but nick silkey and dimtruck might have worked on playbooks to get a multinode setup
21:25:41 <adrian_otto> dimtruck was here
21:26:02 <devkulkarni> I guess we can volunteer dimtruck (dimitry) for this
21:26:03 <adrian_otto> ok, I will assign to dimtruck for now, and he can orphan it again if justified
21:26:24 <adrian_otto> assigned.
21:26:35 <adrian_otto> #link https://bugs.launchpad.net/solum/+bug/1451483 Languagepack name too long to deploy app
21:26:36 <openstack> Launchpad bug 1451483 in Solum "Languagepack name too long to deploy app" [Medium,Triaged]
21:26:47 <adrian_otto> this one struck me as another easy fix
21:27:03 <devkulkarni> I think datsun180b was already on it sometime back
21:27:15 <adrian_otto> datsun180b: are you willing to have this one?
21:27:19 <datsun180b> well i'm in the same vein with some plan checking. sure, hand it over
21:27:32 <adrian_otto> what's your launchpad id?
21:27:35 <datsun180b> ed--cranford
21:27:46 <adrian_otto> tx datsun180b
21:27:57 <adrian_otto> assigned.
21:27:59 <adrian_otto> next is...
21:28:07 <datsun180b> to know a man's true name is to have power over him
21:28:10 <adrian_otto> #link https://bugs.launchpad.net/solum/+bug/1340297 solum assembly delete does not delete heat-stack/nova instance on failure
21:28:10 <openstack> Launchpad bug 1340297 in Solum "solum assembly delete does not delete heat-stack/nova instance on failure" [Medium,Triaged]
21:28:27 <adrian_otto> this one will require some thought to solve well
21:28:29 <devkulkarni> adrian_otto: this one might be obsolete
21:28:34 <adrian_otto> oh?
21:28:54 <devkulkarni> reading
21:29:07 <adrian_otto> can we arrange for one of us to test it (with a simulated failure)?
21:29:36 <devkulkarni> you can assign that to me
21:29:43 <adrian_otto> datsun180b: I promise not to abuse the power of your name ;-)
21:29:49 <adrian_otto> tx devkulkarni
21:29:58 <devkulkarni> I think we are taking care of this.. I will verify
21:30:13 <adrian_otto> assigned.
21:30:20 <adrian_otto> that concludes the medium priority bugs
21:30:28 <adrian_otto> all other orphans are Low or Incomplete
21:30:42 <adrian_otto> Bugs to Discuss
21:30:54 <james_li> Thanks adrian_otto
21:30:54 <adrian_otto> we had an ML discussion about this one
21:31:05 <adrian_otto> #link http://lists.openstack.org/pipermail/openstack-dev/2015-June/066842.html ML Thread about log deletion
21:31:21 <adrian_otto> it was related to thoughts that came form this defect:
21:31:23 <adrian_otto> #link https://bugs.launchpad.net/solum/+bug/1463986 App deletion logs left in Swift after successful deletion
21:31:24 <openstack> Launchpad bug 1463986 in Solum "App deletion logs left in Swift after successful deletion" [Undecided,Incomplete]
21:31:43 <adrian_otto> that needs further input to triage I think
21:31:47 <devkulkarni> adrian_otto: I think your concern about interactive input is valid
21:32:15 <devkulkarni> and I am +1 on changing the help message
21:32:31 <adrian_otto> were you all happy with the proposed solution outlined in my recent post to the ML today?
21:32:32 <devkulkarni> can be done when muralia adds the flag
21:32:37 <datsun180b> option one: remove all interactivity. option two: probe for interactive terminal and fail if it's not available
21:32:45 <adrian_otto> yes, I think we can wait until that flag is implemented
21:32:59 <adrian_otto> we will need a blueprint or task ticket to track that feature
21:33:08 <adrian_otto> is there already one (I don't remember seeing one)
21:33:16 <datsun180b> at minimum we should have the flag
21:33:28 <devkulkarni> or, do you want to track that in the above referenced bug itself?
21:33:34 <kebray> the flag is good-enogh for me for now.
21:33:45 <adrian_otto> no, because the current bug is actually a defect
21:33:53 <adrian_otto> and the new flag is a wishlist item
21:33:58 <adrian_otto> I will take an action item to add it
21:34:00 <devkulkarni> ok, makes sense
21:34:03 <adrian_otto> who would like to own it?
21:34:33 <devkulkarni> I am sure muralia would volunteer for it if he were here :)
21:35:08 <james_li> +1 devkulkarni
21:35:21 <adrian_otto> #action adrian_otto to create a bug/task ticket to track the addition of a flag to keep logs on app deletion, assigned to muralia
21:35:25 <adrian_otto> ok, thanks
21:35:37 <adrian_otto> #link https://bugs.launchpad.net/solum/+bug/1434293 top-level name should not be in the planfile
21:35:38 <openstack> Launchpad bug 1434293 in Solum "top-level name should not be in the planfile" [Undecided,Incomplete]
21:35:50 <adrian_otto> this one raised the question (again, sorry) about name uniqueness
21:35:51 <datsun180b> oh plan "app"s
21:36:12 <adrian_otto> dimtruck was kind enough to summarize our previous decision point in this thread:
21:36:25 <adrian_otto> #link http://lists.openstack.org/pipermail/openstack-dev/2015-June/066843.html ML Thread about app name uniqueness
21:36:47 <adrian_otto> any thoughts on this?
21:36:52 <datsun180b> i think the hardest part about dupe names is our plan "app"s don't have any recourse to rename except rebuilding them
21:36:55 <adrian_otto> gpilz: I was curious if you had a point of view
21:37:10 <datsun180b> i don't think we need to enforce name uniqueness in new apps since you can just rename them anyway
21:37:40 <gpilz> I agree with ed
21:37:46 <adrian_otto> but plan names need to be unique?
21:38:02 <datsun180b> yeah, but they're on the conveyor belt from toy story 3
21:38:14 <adrian_otto> heh, funny.
21:38:24 <gpilz> don't plans have an id?
21:38:33 <gpilz> isn't 'id' the unique thing?
21:38:33 <adrian_otto> yes, they have a uuid and a name
21:38:36 <datsun180b> they do
21:39:05 <datsun180b> at present we still complain "hey that name refers to >1 resource, try again with the uuid"
21:39:08 <gpilz> how many unique attributes do you need?
21:39:24 <datsun180b> and that change may be younger than this bug
21:40:06 <datsun180b> wait scratch that bit about a bug, that came out of nowhere
21:40:57 <datsun180b> anyway i'm of the opinion we don't need to enforce unique names for our resources
21:41:04 <gpilz> +1
21:41:13 <adrian_otto> so should we keep bug https://bugs.launchpad.net/solum/+bug/1434293 or convert that to a BP for new features?
21:41:14 <openstack> Launchpad bug 1434293 in Solum "top-level name should not be in the planfile" [Undecided,Incomplete]
21:41:35 <adrian_otto> thanks gpilz
21:41:44 <adrian_otto> thanks datsun180b
21:41:46 <datsun180b> obselete, i'm working to get away from plans in their current form
21:41:49 <devkulkarni> does it matter if it is a bug vs. bp?
21:41:58 <adrian_otto> ok, so I am marking it as such and we can move on
21:42:08 <adrian_otto> no, it does not matter
21:42:14 <datsun180b> referring to the app-resource work that is
21:42:35 <devkulkarni> ok.. we can mark it obsolete, but I know muralia had some opinions
21:42:48 <adrian_otto> in general bugs are task level things or defects, and we prefer now to use BP's for new features that are more than a straightforward task,a nd may require work from multiple contributors
21:42:59 <adrian_otto> we can bring it back
21:43:06 <adrian_otto> …later if we want
21:43:10 <devkulkarni> if required we can revisit it.. I am fine either ways — can see argument from both sides
21:43:18 <adrian_otto> the current status is incomplete
21:43:23 <adrian_otto> so I am going to leave it alone
21:43:42 <adrian_otto> and we can purge this out later if there is no further discussion to have on it
21:44:45 <adrian_otto> assigned to Murali with a question re: disposal of that bug
21:45:00 <adrian_otto> Blueprints to Discuss
21:45:08 <adrian_otto> #link https://blueprints.launchpad.net/solum/+spec/app-resource App Resource
21:45:14 <adrian_otto> this BP is in progress
21:45:30 <adrian_otto> I want to scope it to Liberty
21:45:36 <adrian_otto> objections?
21:45:45 <datsun180b> none
21:45:46 <devkulkarni> no objections
21:45:55 <james_li> fine with me
21:46:17 <datsun180b> first review is to lay down the resources, i'm working on that. murali's got the second phase, using the new resources to drive our logic
21:46:44 <adrian_otto> ok, I marked it as Started and scoped it to L2
21:46:46 <datsun180b> the *first* resources
21:46:52 <adrian_otto> Liberty milestone 2
21:47:01 <datsun180b> after that there's the workflow and history resources, by whatever name
21:47:04 <james_li> datsun180b: how many phases do we have?
21:47:27 <adrian_otto> Please link bug/task tickets back to the blueprint
21:47:38 <adrian_otto> you do this by editing the blueprint and putting in the bug numbers
21:47:50 <datsun180b> i can do that
21:47:54 <adrian_otto> thanks datsun180b
21:48:05 <adrian_otto> I have a few more
21:48:07 <adrian_otto> #link https://blueprints.launchpad.net/solum/+spec/environments Environments
21:48:18 <adrian_otto> do we want to begin work on this in Liberty?
21:48:31 <adrian_otto> if not, I will not target it yet
21:49:00 <devkulkarni> may be.. we need to at least change its description to align with the new app and workflow resources
21:49:14 <devkulkarni> lets hold off on targeting it yet for L
21:49:31 <adrian_otto> #action adrian_otto to update description of https://blueprints.launchpad.net/solum/+spec/environments to match current terminology
21:49:54 <adrian_otto> #link https://blueprints.launchpad.net/solum/+spec/solum-camp-api CAMP API
21:50:14 <adrian_otto> gpilz: when should we plan for completion of that BP?
21:50:26 <adrian_otto> is it fair to target it to one of the liberty milestones?
21:50:32 <adrian_otto> 2 months each
21:50:41 <gpilz> I need about 6 weeks
21:50:52 <adrian_otto> ok, so I will put it on liberty-2
21:50:54 <gpilz> does that sound excessive?
21:50:56 <adrian_otto> and we can revisit as needed
21:51:33 <adrian_otto> done
21:51:51 <adrian_otto> #link https://blueprints.launchpad.net/solum/+spec/stage-logs Stage Logs
21:52:06 <adrian_otto> datsun180b: update on this?
21:52:24 <adrian_otto> should it be targeted to liberty-1?
21:52:31 <datsun180b> obselete. some ideas were worked into app-resource
21:52:37 <adrian_otto> oh, ok
21:52:43 <adrian_otto> marking as such
21:52:51 <devkulkarni> imo, it is completed
21:53:06 <devkulkarni> the logs for each stage are available in tenant's cloud files container
21:53:25 <adrian_otto> ok
21:53:41 <james_li> yeah, tenant logger implemented by Dev
21:53:48 <datsun180b> oh i see
21:53:54 <adrian_otto> ok, time for open discussion then
21:54:03 <adrian_otto> #topic Open DIscussion
21:54:04 <datsun180b> i had a different approach in mind for all of that
21:54:13 <datsun180b> but call it done if you like, less work for me
21:54:43 <james_li> datsun180b: take a look at TenantLogger class, glad to see any improvements on it
21:54:45 <adrian_otto> datsun180b: Let's give what we have a try, and if we dislike it we can revisit
21:54:58 <datsun180b> oh it's fine as is
21:55:44 <datsun180b> guess i was getting my wires crossed with my functional test spec
21:56:01 <adrian_otto> are there other aspirations that we should track for Liberty in blueprints?
21:56:08 <james_li> datsun180b: oh you have that one
21:57:03 <datsun180b> i think the app resource will keep me plenty busy
21:58:01 <adrian_otto> cool
21:58:11 <adrian_otto> thanks everyone for attending today
21:58:23 <james_li> thanks adrian_otto!
21:58:35 <datsun180b> timed it just about right
21:59:11 <adrian_otto> our next meeting is Tuesday 2015-06-23 at 2100 UTC. I will be out, but devkulkarni will chair.
21:59:25 <adrian_otto> have a great day
21:59:29 <adrian_otto> #endmeeting