21:02:58 <adrian_otto> #startmeeting Solum Team Meeting
21:02:59 <openstack> Meeting started Tue Jul  7 21:02:58 2015 UTC and is due to finish in 60 minutes.  The chair is adrian_otto. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:03:01 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:03:03 <openstack> The meeting name has been set to 'solum_team_meeting'
21:03:37 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Solum Our (outdated) Agenda
21:03:43 <adrian_otto> #topic Roll Call
21:03:45 <adrian_otto> Adrian Otto
21:03:55 <datsun180b> ed cranford
21:04:32 <dimtruck> Dimitry Ushakov
21:05:02 <datsun180b> skeleton crew today
21:05:37 <mkam> Melissa Kam
21:06:24 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Solum#Agenda_for_2015-07-07_2100_UTC Our (updated) Agenda
21:06:50 <adrian_otto> hello datsun180b, dimtruck, and mkam
21:07:23 <dimtruck> hello!
21:07:25 <adrian_otto> are we expecting others?
21:07:45 <dimtruck> james li should join in a bit
21:07:58 <james_li> james li
21:08:03 <adrian_otto> hello james_li
21:08:11 <james_li> Hi adrian_otto
21:08:14 <adrian_otto> #topic Announcements
21:08:19 <adrian_otto> (none prepared)
21:08:30 <adrian_otto> any announcements from team members?
21:08:58 <datsun180b> nothing special from me. gates are clear, jobs are running in jenkins, and the first phase of the app-resource overhaul is merged
21:09:06 <james_li> nothing from me
21:09:18 <adrian_otto> great!
21:09:23 <dimtruck> nothing from me except for the fact that operator's guide is in progress
21:09:31 <dimtruck> i'll be making a patch to our docs later this week
21:09:45 <james_li> thanks dimtruck
21:09:55 <adrian_otto> #topic Review Action Items
21:09:57 <adrian_otto> 1) devkulkarni to check how to make solum's heat deployer pluggable to support different kinds of resources in different operational environments
21:10:02 <adrian_otto> Status of this?
21:10:23 <datsun180b> last i heard he was still working on it. since he's not here, carry forward?
21:10:28 <james_li> we are going to have a discussion on that tomorrow with heat team
21:10:30 <adrian_otto> #action devkulkarni to check how to make solum's heat deployer pluggable to support different kinds of resources in different operational environments
21:10:42 <datsun180b> then there we go
21:10:47 <adrian_otto> in #solum?
21:11:11 <adrian_otto> that's a good topic to invite heat community members to our meeting to disucss
21:11:46 <adrian_otto> or start an ML thread explaining the use case and requesting input
21:11:55 <james_li> devdatta will lead the discussion, not sure where he plans to have it
21:12:13 <adrian_otto> is there a blueprint for it?
21:12:26 <james_li> probably not yet
21:12:49 <adrian_otto> I do not see a blueprint on it.
21:13:34 <adrian_otto> is Devdatta out today?
21:13:40 <datsun180b> he is
21:13:43 <james_li> yes
21:13:51 <adrian_otto> but we are expecting him back tomorrow?
21:14:01 <datsun180b> i believe so
21:14:12 <james_li> he said so
21:14:18 <dimtruck> correct, he'll be in tomorrow
21:14:47 <adrian_otto> #action adrian_otto to follow up with devdatta-kulkarni about filing a heat plugability blueprint
21:14:56 <adrian_otto> thanks
21:15:31 <adrian_otto> #topic Blueprint/Task Review
21:16:05 <adrian_otto> any blueprints, bugs, or tasks that would benefit from team discussion today?
21:16:36 <datsun180b> not from me, heads down on the workflow resource presently
21:16:40 <dimtruck> i don't have anything
21:16:49 <adrian_otto> datsun180b: you have a review that has not seen any revisions for a month: https://review.openstack.org/188864
21:17:01 <adrian_otto> is that still WIP, or should it be abandoned?
21:17:28 <datsun180b> well it was put up there as WIP so murali could get some work done on top of the solum app resource
21:17:53 <datsun180b> i don't want to release the new app commands and deprecate the old ones until the new ones actually get work done
21:18:30 <adrian_otto> #link https://review.openstack.org/189929 Protocol for app update that preserves app's URL
21:18:30 <datsun180b> i'm still working on it locally; i'll abandon it and resub later
21:18:55 <adrian_otto> the spec for this could use more eyes/comments on review
21:19:13 <datsun180b> i definitely need to look over that spec
21:20:03 <adrian_otto> specifically, is there a way to implement this that's not specific to RAX? Could it also work with Neutron LB?
21:20:54 <datsun180b> i bet we can, but i think dev knows for certain
21:22:13 <adrian_otto> the only requirement is that the LB resource in heat have a way to be drained, and deleted
21:22:33 <adrian_otto> I mean drained/updated to delete the obviated backend node
21:23:19 <adrian_otto> I think this is what Devdatta wnated to talk to the Heat devs about
21:23:45 <adrian_otto> so that a single heat resource could be backended by an OpenStack load balancer, or a RAX LB
21:24:06 <datsun180b> maybe it won't happen in two steps but i bet there's a way to approximate it
21:25:25 <adrian_otto> any others for discussion?
21:26:23 <datsun180b> not from me
21:26:49 <adrian_otto> #topic Open Discussion
21:27:23 <datsun180b> well i've got one
21:27:36 <adrian_otto> what's the status of moving Solum from stackforge to openstack git namespace?
21:27:37 <dimtruck> I got one too
21:28:03 <datsun180b> oh let's talk about the namespace move first
21:28:22 <dimtruck> yes
21:28:57 <dimtruck> i am not sure where we are in the move
21:29:05 <dimtruck> datsun180b: do you remember who was tasked with it?
21:29:13 <datsun180b> i don't
21:29:16 <dimtruck> I /think/ it was devkulkarni but not certain
21:29:38 <datsun180b> i have a feeling the first task is finding the contact to create the solum and python-solumclient repos in github under openstack
21:29:56 <dimtruck> good point
21:30:03 <dimtruck> adrian_otto: who can help us with that?
21:30:08 <adrian_otto> you do that using an openstack-config review
21:30:26 <datsun180b> then splice the stackforge repos over to openstack and start to update our infra/configs references to use the new locations
21:30:43 <adrian_otto> you specify the current repo as the upstream for the new one
21:31:00 <adrian_otto> it gets imported automatically.
21:31:14 <dimtruck> understood.  I can follow up with dev and see if he started on that task.  If not, i can take care of the openstack-config review.
21:31:15 <adrian_otto> but we do need to pair this with changes to documentation about how to develop on Solum
21:31:16 <datsun180b> that's mighty convenient
21:31:28 <adrian_otto> thanks dimtruck
21:31:45 <datsun180b> we'll need to sweep the whole codebase and the vagrant repo for mentions of stackforge
21:31:54 <dimtruck> yeah, i can take care of that.
21:31:58 <dimtruck> (if dev's not doing it already)
21:32:05 <datsun180b> and what about our sample apps repos? those aren't stackforge are they
21:32:11 <dimtruck> no sir
21:32:15 <datsun180b> then we're okay there
21:32:23 <dimtruck> if you're talking about rackspace sample apps, those are abstracted
21:32:28 <adrian_otto> dimtruck, can you take an action item on that?
21:32:32 <dimtruck> will do
21:33:33 <adrian_otto> #action dimtruck to check with devdatta-kulkarni aboutthe stauts of the namespace migration to the openstack git namespace, and file openstack-config reviews as needed if they have not already been created.
21:33:38 <adrian_otto> dimtruck: is that fair?
21:33:57 <dimtruck> yes sir!
21:34:54 <adrian_otto> ok, so both dimtruck and datsun180b have open discussion topics?
21:35:05 <adrian_otto> thanks dimtruck
21:35:09 <dimtruck> perfect!
21:35:10 <datsun180b> mine's better suited to #solum
21:35:13 <dimtruck> you're welcome
21:37:00 <adrian_otto> dimtruck: you had another topic?
21:37:10 <dimtruck> yes sir.
21:37:14 <adrian_otto> proceed
21:37:47 <dimtruck> We've had some interest in operating solum from last week.  We have some documentation from Rackspace that i'm trying to port to OpenStack but wanted to hear other people's opinions about what should/should not go into that document
21:38:02 <dimtruck> i'm going from the perspective of "here's how you can run solum infrastructure properly"
21:38:10 <adrian_otto> ok
21:38:21 <dimtruck> and proven since rackspace has been doing that for the past few months
21:39:03 <dimtruck> this came from several requests we've heard of how to operate solum and the lack of documentation on that front
21:39:15 <adrian_otto> anything that's generally useful versus specific to a single vendor is appropriate, I'd think.
21:39:21 <dimtruck> cool!
21:39:31 <dimtruck> most of our stuff is definitely portable
21:39:59 <dimtruck> maybe it's a better open discussion once the patch is out there for the community to review :)
21:40:28 <adrian_otto> ok, fair enough. At least that way we'll have something concrete to consider.
21:41:02 <dimtruck> right, exactly
21:41:39 <adrian_otto> ok, anything else to cover today?
21:41:53 <datsun180b> nah, i'll take mine to #solum when we've got more folks
21:42:03 <adrian_otto> ok, thanks datsun180b
21:42:47 <datsun180b> url design is hardly exciting
21:42:50 <adrian_otto> Our next meeting will be on Tuesday 2015-07-14 at 2100 UTC. See you then!
21:43:05 <adrian_otto> #endmeeting