21:00:42 <adrian_otto> #startmeeting Solum Team Meeting
21:00:43 <openstack> Meeting started Tue Jul 14 21:00:42 2015 UTC and is due to finish in 60 minutes.  The chair is adrian_otto. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:44 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:46 <openstack> The meeting name has been set to 'solum_team_meeting'
21:00:47 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Solum#Agenda_for_2015-07-14_2100_UTC Our Agenda
21:00:53 <adrian_otto> #topic Roll Call
21:00:55 <adrian_otto> Adrian Otto
21:00:57 <randallburt> o/
21:01:00 <devkulkarni> devdatta kulkarni
21:01:11 <adrian_otto> hello randallburt and devkulkarni
21:01:11 <mkam> Melissa Kam
21:01:21 <gpilz> Gilbert Pilz
21:01:23 <devkulkarni> hi adrian_otto
21:01:29 <adrian_otto> hello mkam, and gpilz
21:01:41 <james_li> james li
21:01:58 <randallburt> Randall Burt (who did it wrong already)
21:02:10 <adrian_otto> you can wave if you prefer
21:02:20 <randallburt> force of habit :)
21:02:23 <adrian_otto> hello james_li
21:03:27 <adrian_otto> #topic Announcements
21:03:29 <adrian_otto> (none prepared). Any announcements form team members?
21:03:34 <adrian_otto> s/form/from/
21:04:19 <adrian_otto> #topic Review Action Items
21:04:26 <adrian_otto> 1) devkulkarni to check how to make solum's heat deployer pluggable to support different kinds of resources in different operational environments
21:04:33 <randallburt> uh, I didn't do what I was supposed to
21:04:35 <adrian_otto> Status: randallburt to propose a spec
21:04:48 <randallburt> sorry. will sort it before the weeks out
21:04:49 <adrian_otto> do we have a link to the spec review?
21:04:55 <randallburt> adrian_otto:  ^^
21:05:02 <adrian_otto> ok, then I will just carry this one
21:05:28 <hogepodge> o/
21:05:34 <adrian_otto> #action randallburt to propose a spec for how to make solum's heat deployer pluggable to support different kinds of resources in different operational environments
21:05:39 <randallburt> oh, devkulkarni can you send me those photos from our brainstorm session?
21:05:41 <adrian_otto> hello hogepodge
21:05:48 <devkulkarni> randallburt: sure, will do
21:05:51 <randallburt> thanks!
21:05:55 <adrian_otto> 2) adrian_otto to follow up with devdatta-kulkarni about filing a heat plugability blueprint
21:05:59 <adrian_otto> Status: COMPLETE
21:06:09 <adrian_otto> resolved as above.
21:06:14 <devkulkarni> yep
21:06:23 <adrian_otto> 3) dimtruck to check with devdatta-kulkarni aboutthe stauts of the namespace migration to the openstack git namespace, and file openstack-config reviews as needed if they have not already been created.
21:06:23 <randallburt> adrian_otto:  can we get a link? would like to know more about "heat pluggabiliy"
21:06:41 <adrian_otto> randallburt: this is exactly the same topic
21:06:49 <randallburt> ah, k. thanks adrian_otto
21:06:52 <devkulkarni> randallburt: same topic as you are going to propose spec for
21:06:55 <adrian_otto> last week we did not have a resource to reference
21:06:57 <randallburt> gotcha
21:06:58 <adrian_otto> your spec will be that
21:07:12 <adrian_otto> #link https://bugs.launchpad.net/solum/+bug/1472409 Rename stackforge/solum to openstack/solum
21:07:12 <openstack> Launchpad bug 1472409 in Solum "Task: Rename stackforge/solum to openstack/solum" [Wishlist,In progress] - Assigned to Devdatta (devdatta-kulkarni)
21:07:24 <adrian_otto> Status: COMPLETE
21:07:30 <adrian_otto> any questions on this one?
21:07:36 <devkulkarni> I have submitted a patch: https://review.openstack.org/#/c/201287/
21:07:56 <devkulkarni> I am working with Andreas on it.
21:08:14 <adrian_otto> ok, anything more to convey to the team on this one?
21:08:17 <devkulkarni> you can check the comments by Andreas on the patch
21:08:26 <devkulkarni> no, that is all
21:09:02 <adrian_otto> no action from me is needed on that topic, correct?
21:09:09 <dimtruck> \o sorry i'm late
21:09:11 <devkulkarni> as far as I understand
21:09:27 <devkulkarni> had to make a change to governance to add other solum projects, which I have submitted
21:09:31 <adrian_otto> sometimes the project-config reviewers ask for the PTL to vote on those, so if you need that just let me know.
21:09:39 <devkulkarni> yes, will do
21:09:39 <adrian_otto> ok, cool
21:09:55 <adrian_otto> #topic Blueprint/Task Review
21:10:11 <adrian_otto> Any work items that we'd like to discuss as a team today?
21:10:22 <devkulkarni> I would like to check up with randallburt and james_li on where we are with their respective patches
21:10:29 <randallburt> eyes on #link https://review.openstack.org/#/c/200451/ and its dependent would be appreciated. I'm working on Ed's original patch to fix test bugs and will rebase, but the code for those patches shouldn't change. (Bug
21:10:42 <randallburt> Bug #1473256
21:10:42 <openstack> bug 1473256 in Solum "Error message leaking SQL queries" [Undecided,In progress] https://launchpad.net/bugs/1473256 - Assigned to Randall Burt (randall-burt)
21:11:31 <adrian_otto> randallburt: is it clear what's jamming the gate for that?
21:11:34 <devkulkarni> randallburt: this is different than the mock patch right?
21:11:55 <randallburt> adrian_otto:  yes. I've sorted the dependency issue with mock and am fixing other tests that the update broke
21:12:01 <randallburt> devkulkarni:  ^^ yep
21:12:04 <devkulkarni> adrian_otto: gates are currently blocked due to the mock issue
21:12:32 <devkulkarni> randallburt: so we need to get the mock patch in first I guess, right?
21:12:32 <adrian_otto> Are you sure it's Mock and not the Devstack Keysone v2->v3 change?
21:12:37 <randallburt> devkulkarni:  yep
21:12:38 <devkulkarni> oh!
21:12:43 <randallburt> adrian_otto:  yes
21:12:48 <devkulkarni> that happened too?
21:13:05 <randallburt> well, the thing I'm fixing isn't related to keystone changes anyway
21:13:05 <adrian_otto> yes, Devstack currently breaks all projects using Keystone v2 APIs
21:13:06 <devkulkarni> adrian_otto: out devstack gate is passing
21:13:14 <adrian_otto> I can't remember if we are using v3 or not
21:13:17 <devkulkarni> s/out/our
21:13:26 <mkam> we're using v3
21:13:31 <devkulkarni> solum is using v3
21:13:43 <adrian_otto> ok, so that's a nonissue then
21:14:12 <devkulkarni> randallburt: so going back to the mock patch.. lets get that one merged if it is ready
21:14:18 <adrian_otto> ok, so let's merge that patch
21:14:21 <james_li> my patches https://review.openstack.org/#/q/owner:james-li-3+status:open,n,z are blocked by the mock issue, and also by an oslo_config migration patch I am working on currently
21:14:32 <randallburt> devkulkarni:  I will submit it as soon as tests pass locally
21:14:44 <devkulkarni> randallburt: sounds good. will keep an eye out for that
21:14:55 <adrian_otto> #link https://review.openstack.org/200697 Replace mock.assert_called_once with mock.called
21:15:03 <adrian_otto> randallburt: is that the one you meant?
21:15:03 <devkulkarni> james_li: ok
21:15:20 <randallburt> adrian_otto:  yes. I'm fixing that one
21:15:34 <adrian_otto> ok
21:15:47 <randallburt> james_li:  you'll need to rebase on that one when I can get it sorted
21:15:57 <james_li> sure
21:16:42 <randallburt> may take a little while longer since it broke more than just the asserts
21:17:28 <adrian_otto> randallburt: did you want to spend a little time now on that?
21:19:12 <adrian_otto> hello kebray
21:19:13 <randallburt> adrian_otto:  I am :D
21:19:18 <adrian_otto> tx randallburt
21:20:24 <randallburt> oh, you mean explanation? Basically we were mocking things like mock.someattribute.somemethod.return_value = something for class level things. Appearently that worked at one time, but doesn't any more for instances created from the mock class.
21:20:50 <randallburt> either that or our tests were broken before the update to mock
21:21:04 <randallburt> either way, tests don't pass until its fixed everywhere
21:21:05 <devkulkarni> randallburt: could be the latter
21:21:10 <adrian_otto> actually, I just meant that we are not in a hurry today, so you were welcome to split attention to revise that patchset
21:21:25 <randallburt> adrian_otto:  k, am/will do
21:21:36 <adrian_otto> cool, thanks
21:21:46 <adrian_otto> ok, other work items to discuss in the interim?
21:22:20 <devkulkarni> I think those were the main ones
21:22:33 <randallburt> devkulkarni:  I don't think so, because I'm having to fix tests that were in merged patches only a few days before the mock breakage
21:22:39 <adrian_otto> hello dimtruck
21:22:47 <adrian_otto> I marked your action item as complete
21:22:47 <dimtruck> hello :)
21:22:53 <adrian_otto> ok,
21:22:56 <dimtruck> yes sir.  i saw that
21:22:59 <adrian_otto> #topic Open Discusssion
21:23:02 <devkulkarni> randallburt: I see. makes sense then it must be the former
21:24:22 <devkulkarni> for the open discussion I want to provide updates on the openstack submissions for tokyo.. we had discussed it in one of the earlier meetings.. there are at least 4 presentations being submitted on solum and related topics
21:25:29 <devkulkarni> 1) on overall solum which I have registered; 2) on languagepacks which muralia has registered; 3) on performance reliability security which james_li has registered; 4) on continuous integration which dimtruck and mkam has registered
21:26:15 <dimtruck> #4 is with our friends from prod sec
21:26:26 <dimtruck> so that includes openstack's bandit, for example
21:26:31 <devkulkarni> fyi, tomorrow is the deadline.
21:26:35 <devkulkarni> dimtruck: right
21:26:45 <devkulkarni> what is openstack bandit?
21:27:05 <mkam> devkulkarni: https://wiki.openstack.org/wiki/Security/Projects/Bandit
21:27:28 <mkam> static code analysis for security issues
21:27:29 <devkulkarni> cool
21:27:41 <devkulkarni> did not know we are using bandit in our CI setup
21:27:47 <dimtruck> for a few months now :)
21:27:57 <devkulkarni> nice
21:28:00 <adrian_otto> keep in mind that Rackspace's travel budget for Tokyo is relatively restrictive, so not everyone who attended the last summit will be able to go.
21:28:03 <dimtruck> we've been growing  with them
21:28:14 <adrian_otto> gpilz: will you be attending in Tokyo?
21:28:44 <devkulkarni> dimtruck: cool.. is the rackspace security team working on bandit?
21:29:14 <gpilz> adrian - that is my intention
21:29:30 <dimtruck> devkulkarni: correct
21:29:31 <adrian_otto> gpilz: ok
21:29:34 <dimtruck> one of many
21:29:49 <devkulkarni> nice
21:30:24 <devkulkarni> dimtruck: ops guide :)?
21:30:44 <devkulkarni> let me know if you need any help on that..
21:30:55 <dimtruck> yes - let's take that post meeting
21:31:02 <randallburt> 1) install devstack ….
21:31:07 <dimtruck> maybe tomorrow morning?
21:31:09 <dimtruck> hahahaha
21:31:11 <dimtruck> randallburt: yes
21:31:11 <devkulkarni> randallburt: ha ha
21:31:17 <dimtruck> how did you know?
21:31:35 <randallburt> :D
21:31:38 <devkulkarni> randallburt: we had some folks for asking for an operations guide for solum
21:31:51 <randallburt> I imagine so. Good news, that
21:32:05 <devkulkarni> dimtruck: sounds good.. we can discuss in #solum sometime tomorrow
21:32:40 <dimtruck> coolness
21:32:50 <devkulkarni> dimtruck, mkam: heads up on our repo changes
21:32:52 <dimtruck> i have a doc i want to run by you
21:33:04 <dimtruck> oh yes...we'll have to update internal flows
21:33:05 <devkulkarni> when that happens we will have to fix our CI systems
21:33:22 <devkulkarni> will keep everyone in the loop on that in #solum
21:33:45 <dimtruck> ok
21:34:35 <devkulkarni> mkam, james_li:
21:34:49 <devkulkarni> do we expect performance to get affected by the python patches?
21:34:56 <devkulkarni> any thoughts?
21:35:19 <devkulkarni> looks like james_li is not at his desk
21:36:34 <devkulkarni> dimtruck: when we change CI, please remind me of changing vagrant-solum-dev too
21:37:00 <mkam> there's nothing I can think of that would be a potential performance issue, but I can't say for sure until after we run tests
21:37:09 <dimtruck> devkulkarni: ok
21:37:34 <adrian_otto> devkulkarni: what do you think about pulling that into the main solum tree now?
21:37:41 <devkulkarni> mkam: ok, .. and the tests are currently blocked because the patches are not passing upstream gates, right?
21:38:04 <devkulkarni> adrian_otto: you mean vagrant-solum-dev? I think that would be nice
21:38:15 <adrian_otto> yes
21:38:56 <devkulkarni> I can take an action item for that (or you can assign that to me).. may not get around to doing that immediately (so will have to carry it forward in a few meetings, but that should be fine)
21:39:03 <mkam> devkulkarni: it's actually due to that permissions issue we're having with docker-py
21:39:11 <adrian_otto> I'll just make a bug ticket for that one
21:39:15 <devkulkarni> mkam: oh, is it?
21:39:26 <devkulkarni> adrian_otto: sounds good. and assign that to me
21:39:46 <devkulkarni> dimtruck, mkam: I thought we had some clue on the docker-py issue. no?
21:40:22 <dimtruck> not yet
21:40:28 <dimtruck> still debugging
21:40:49 <dimtruck> james_li: is it reproduceable on devstack?
21:41:16 <dimtruck> i guess maybe that's a question for #solum
21:41:20 <james_li> dimtruck: it is about virtualenv I think
21:41:29 <dimtruck> so you don't see it on devstack
21:41:36 <james_li> I did not
21:41:41 <dimtruck> ok
21:41:58 <adrian_otto> #link https://bugs.launchpad.net/solum/+bug/1474568 Task: Move vagrant-solum-dev from github to main source tree
21:41:58 <openstack> Launchpad bug 1474568 in Solum "Task: Move vagrant-solum-dev from github to main source tree" [Wishlist,Triaged] - Assigned to Devdatta (devdatta-kulkarni)
21:42:01 <dimtruck> devkulkarni: we'll need to debug more
21:42:12 <devkulkarni> dimtruck: sounds like it..
21:42:13 <dimtruck> i can create a launchpad bug for it
21:42:23 <devkulkarni> dimtruck: yes, that will be good
21:42:32 <dimtruck> because it might affect anyone trying to run solum in virtualenv
21:43:01 <devkulkarni> james_li, dimtruck: is the issue only related to the way we run performance tests, or it is more general?
21:43:09 <dimtruck> more general
21:43:18 <dimtruck> it's a functional issue, not load
21:43:18 <devkulkarni> as in, will it affect staging/prod environments as well?
21:43:21 <dimtruck> yes
21:43:22 <dimtruck> definitely
21:43:33 <dimtruck> it'll affect anyone running docker py in higher envs
21:43:51 <devkulkarni> hmm.. so then we need to get it resolved asap. will pinging folks on docker-py channel help?
21:44:01 <devkulkarni> (may be one of you have already done that)
21:44:02 <james_li> devkulkarni: it only affects when we switch to the new code
21:44:12 <james_li> bash code still runs fine
21:44:19 <dimtruck> right
21:44:20 <devkulkarni> james_li: right
21:44:40 <james_li> all because docker-py cannot talk to daemon
21:44:42 <devkulkarni> james_li: but looks like we won't be able to get your python conversion merged if this issue is not resolved.
21:44:43 <devkulkarni> right?
21:45:03 <randallburt> devkulkarni:  why not if it passes on devstack?
21:45:09 <james_li> devkulkarni: I don't think it is a problem in code
21:45:34 <james_li> it is a problem of how we packaging and running solum artifact
21:45:39 <devkulkarni> randallburt: good point.. if it passes devstack and other gates then we can surely get it merged
21:45:52 <randallburt> james_li:  that was my impression as well. limited to virtual env and permissions, correct?
21:46:04 <devkulkarni> but may affect our staging and prod environments at rax
21:46:14 <james_li> randallburt: yes
21:46:37 <randallburt> devkulkarni:  different issue altogether then. patches can merge even if we have to fix our internal packaging to make it work :)
21:46:46 <james_li> devkulkarni: no if we don't switch to the new worker handler
21:46:54 <devkulkarni> randallburt: yes, fair enought
21:47:08 <devkulkarni> james_li: that's right, you have made it configurable
21:47:08 * randallburt just pokes in between test runs
21:47:11 <devkulkarni> nice
21:47:35 <devkulkarni> dimtruck: going back to how to debug docker-py
21:47:40 <james_li> devkulkarni: yes we have control in solum.conf
21:47:49 <devkulkarni> have you or james_li reached out to someone on their channel?
21:48:24 <dimtruck> i have not
21:48:28 <dimtruck> i can
21:48:38 <james_li> dimtruck: we could ask Nick first
21:48:56 <dimtruck> james_li: good idea
21:49:07 <dimtruck> we will run it by our internal operations
21:49:14 <devkulkarni> dimtruck: I think we should once you have done your due diligence and debugging
21:49:19 <dimtruck> ok
21:49:32 <devkulkarni> dimtruck, james_li: sounds like a plan then
21:49:56 <devkulkarni> I don't have any other topics
21:50:21 <dimtruck> me neither
21:50:41 <james_li> nothing from me
21:50:45 <devkulkarni> adrian_otto: probably you can call it..
21:55:49 <adrian_otto> thanks everyone for attending. Out next meting is 2015-07-21 at 2100 UTC
21:55:55 <adrian_otto> #endmeeting