21:09:53 <adrian_otto> #startmeeting Solum Team Meeting
21:09:54 <openstack> Meeting started Tue Jul 21 21:09:53 2015 UTC and is due to finish in 60 minutes.  The chair is adrian_otto. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:09:55 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:09:57 <openstack> The meeting name has been set to 'solum_team_meeting'
21:10:25 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Solum#Agenda_for_2015-07-21_2100_UTC Our Agenda
21:10:31 <adrian_otto> #topic Roll Call
21:10:35 <datsun180b> Ed Cranford
21:10:35 <adrian_otto> Adrian Otto
21:10:35 <james_li> james li
21:10:37 <devkulkarni> Devdatta Kulkarni
21:11:03 <adrian_otto> #topic Announcements
21:11:20 <adrian_otto> No prepared announcements. Any announcements from team members?
21:11:21 <devkulkarni> dimtruck: meeting has started
21:12:02 <mkam> Melissa Kam
21:12:02 <adrian_otto> #topic Review Action Items
21:12:10 <adrian_otto> 1) devkulkarni to check how to make solum's heat deployer pluggable to support different kinds of resources in different operational environments
21:12:14 <adrian_otto> Status: complete
21:12:28 <devkulkarni> randallburt has submitted a spec for this
21:12:30 <adrian_otto> #link: https://review.openstack.org/#/c/202254/ Spec for deployer plugins
21:12:35 <devkulkarni> yep that one ^^
21:12:45 <adrian_otto> cool, thanks!
21:12:46 <devkulkarni> please review it whenever you all get a chance
21:12:55 <adrian_otto> 2) adrian_otto to follow up with devdatta-kulkarni about filing a heat plugability blueprint
21:12:58 <adrian_otto> Status: complete
21:13:09 <devkulkarni> I left it there
21:13:14 <adrian_otto> 3) dimtruck to check with devdatta-kulkarni aboutthe stauts of the namespace migration to the openstack git namespace, and file openstack-config reviews as needed if they have not already been created.
21:13:16 <devkulkarni> but could have been removed from the wiki
21:13:24 <devkulkarni> ok, on this I have two updates
21:13:43 <devkulkarni> so first is the review https://review.openstack.org/#/c/201287/
21:13:43 <adrian_otto> ok, looks like this one is complete. Proceed devkulkarni
21:13:52 <adrian_otto> #link https://bugs.launchpad.net/solum/+bug/1472409 Rename stackforge/solum to openstack/solum
21:13:53 <openstack> Launchpad bug 1472409 in Solum "Task: Rename stackforge/solum to openstack/solum" [Wishlist,In progress] - Assigned to Devdatta (devdatta-kulkarni)
21:13:54 <uvirtbot> Launchpad bug 1472409 in solum "Task: Rename stackforge/solum to openstack/solum" [Wishlist,In progress]
21:13:55 <uvirtbot> Launchpad bug 1472409 in solum "Task: Rename stackforge/solum to openstack/solum" [Wishlist,In progress] https://launchpad.net/bugs/1472409
21:14:07 <devkulkarni> I haven't gotten around to chasing that -1 from Jenkins yet.
21:14:26 <devkulkarni> I know what the fix is but have been busy with our downstream CI and deployment stuff.
21:14:36 <devkulkarni> I will get back to fixing the Jenkins -1 soon.
21:14:49 <devkulkarni> Apart from that, there is this: https://review.openstack.org/#/c/201693/
21:15:01 <devkulkarni> adrian_otto: we need your +1 on this one
21:15:16 <adrian_otto> ok
21:15:23 <devkulkarni> check dhellman's comment on that patch
21:15:59 <devkulkarni> once both these reviews are merged then we should be good I guess
21:16:14 <devkulkarni> I will pursue both these this week
21:16:27 <james_li> cool
21:16:28 <adrian_otto> ok, voted on that
21:16:34 <devkulkarni> awesome!
21:16:52 <devkulkarni> will keep all updated when the switch to openstack org happens
21:16:56 <devkulkarni> if it happens this week
21:17:10 <adrian_otto> ok, ready for Blueprint/Task Review?
21:17:10 <devkulkarni> that is all on this topic
21:17:20 <adrian_otto> #topic Blueprint/Task Review
21:17:20 <devkulkarni> sure
21:17:27 <adrian_otto> devkulkarni: Give status update on the vagrant setup (currently not starting up)
21:17:39 <devkulkarni> so our vagrant environment is currently not starting up
21:17:51 <devkulkarni> datsun180b: you were briefly looking into it yesterday I believe?
21:18:06 <devkulkarni> any insights/suggestions on what we need to do to fix?
21:18:09 <datsun180b> That's right, the best I could determine is the docker registry hadn't started
21:18:13 <datsun180b> But docker had
21:18:25 <devkulkarni> so vagrant up never completed successfully, right?
21:18:53 <devkulkarni> I was seeing this behavior couple of days back
21:19:06 <datsun180b> The machine can be powered up and most everything is there, but running devstack to give us our dev environment ultimately fails
21:19:28 <devkulkarni> yeah. that was what I was seeing as well
21:19:46 <datsun180b> I haven't had the time recently to do much more investigation, unfortunately
21:20:07 <datsun180b> What I'd do next is get on the box and follow the progress of ./stack.sh a little more closely
21:20:20 <devkulkarni> datsun180b: thats okay.. I will try to get to this one soon.
21:20:23 <datsun180b> Sorry I don't have much more of a game plan
21:20:28 <devkulkarni> that makes sense..
21:20:43 <devkulkarni> datsun180b: may ping you when I am debugging the issue
21:20:53 <datsun180b> That's fine with me
21:20:57 <devkulkarni> thanks datsun180b
21:21:27 <devkulkarni> adrian_otto: we can go to next point
21:21:39 <adrian_otto> devkulkarni: Would like to sync up with james_li on the status of bash to python patches. Check what help is needed to move it forward.
21:22:14 <devkulkarni> james_li I believe you were blocked by our config generator
21:22:41 <james_li> adrian_otto: devkulkarni: yeah I need more time on migrating to oslo config generator
21:23:05 <james_li> which blocks my bash2python patches to be merged
21:23:10 <devkulkarni> james_li: is there any help that I can provide?
21:23:11 <dimtruck> hi!  i'm sorry - i was moving around and couldn't get online.
21:23:21 <devkulkarni> dimtruck: no worries
21:23:26 <adrian_otto> dimtruck, the next agenda item involved you, so stay tuned.
21:23:35 * dimtruck gulps
21:23:52 <james_li> devkulkarni: I can show you how heat and glance did for that config migration if you want
21:24:14 <devkulkarni> james_li: if you create bug for the config generator issue and add how heat and glance approach, then I can take that up
21:24:27 <james_li> ok sounds good
21:24:37 <adrian_otto> james_li: are you willing to take an action item for that?
21:24:53 <james_li> adrian_otto: yes I will create a bug for that
21:25:15 <adrian_otto> #action james_li to file a bug about the config generator explaining how heat and glance solved this. Assign it to devkulkarni.
21:25:37 <adrian_otto> ok, we are still in task review. Just completed 2/4
21:25:48 <adrian_otto> 3) devkulkarni: Would like to sync up with dimtruck on the status of ops guide. Check what help is needed to move it forward.
21:26:02 <dimtruck> i'm about to push a patch for this
21:26:10 <devkulkarni> dimtruck: +1
21:26:13 <dimtruck> i need to talk to devkulkarni about the use of conductor service
21:26:26 <dimtruck> in our infrastructure
21:26:30 <devkulkarni> dimtruck: we can sync up
21:26:34 <dimtruck> ok, great!
21:26:42 <dimtruck> other than that, i ahve the notes written up.
21:26:46 <adrian_otto> that concludes 3/4
21:26:50 <adrian_otto> 4) devkulkarni: Would like to sync up with datsun180b on the workflow resource. Check what help is needed.
21:26:59 <datsun180b> present
21:27:12 <devkulkarni> datsun180b: saw your wip patch
21:27:28 <datsun180b> I've submitted a pair of WIPs toward implementing the workflow resource
21:27:30 <devkulkarni> was wondering if you can add a link to your spec to the commit message
21:27:38 <datsun180b> #link https://review.openstack.org/#/c/204164/
21:27:45 <devkulkarni> did you submit one for cli as well? nice!
21:27:46 <datsun180b> #link https://review.openstack.org/#/c/204165/
21:28:30 <devkulkarni> datsun180b: will start looking through these soon
21:28:42 <devkulkarni> datsun180b: thanks for getting these patches out
21:29:14 <adrian_otto> any more on this topic? I can proceed to open discussion when we are ready.
21:29:22 <devkulkarni> that is all on this topic
21:29:23 <datsun180b> Nothing to add
21:29:30 <adrian_otto> #topic Open Discussion
21:29:47 <devkulkarni> I don't have any topic today
21:30:26 <adrian_otto> ok, we can wrap up if we don't have more to cover.
21:30:35 <devkulkarni> fine with me
21:30:47 * adrian_otto pausing for another minute
21:31:13 <adrian_otto> Our next team meeting is scheduled for 2015-07-28
21:31:25 <adrian_otto> does it make sense to go to every other week?
21:31:37 <adrian_otto> or should we keep the weekly schedule?
21:31:52 <devkulkarni> for now I think we can still keep weekly.. gives a time to sync up
21:32:02 <adrian_otto> ok
21:32:13 <datsun180b> It's like laundry, all it will do is accumulate
21:32:26 <adrian_otto> Our next team meeting is scheduled for Tuesday 2015-07-28 at 2100 UTC.
21:32:26 <devkulkarni> :)
21:32:29 <adrian_otto> see you then!
21:32:36 <adrian_otto> #endmeeting