21:00:46 <adrian_otto> #startmeeting Solum Team Meeting
21:00:46 <openstack> Meeting started Tue Jul 28 21:00:46 2015 UTC and is due to finish in 60 minutes.  The chair is adrian_otto. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:48 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:50 <openstack> The meeting name has been set to 'solum_team_meeting'
21:01:28 <adrian_otto> #link https://wiki.openstack.org/wiki/Meetings/Solum#Agenda_for_2015-07-28_2100_UTC Our Agenda
21:01:33 <adrian_otto> #topic Roll Call
21:01:36 <adrian_otto> Adrian Otto
21:01:39 <gpilz1> Gilbert W. Pilz Jr.
21:01:41 <datsun180b> Ed Cranford
21:01:44 <devkulkarni> Devdatta Kulkarni
21:01:49 <priti> Priti Changlani
21:02:11 <james_li> james li
21:02:26 <adrian_otto> hello gpilz1, datsun180b, devkulkarni, priti, and james_li
21:02:33 <devkulkarni> hi adrian_otto
21:03:17 <adrian_otto> #topic Announcements
21:03:28 <adrian_otto> none prepared. Any announcements from team members?
21:03:54 <adrian_otto> #topic Review Action Items
21:04:14 <adrian_otto> now I have only one action item from last meetings minutes, but two are in the agenda. What happened?
21:04:23 <adrian_otto> I have this one:
21:04:27 <adrian_otto> james_li to file a bug about the config generator explaining how heat and glance solved this. Assign it to devkulkarni.
21:04:41 <adrian_otto> •	Status: Completed (https://bugs.launchpad.net/solum/+bug/1476839)
21:04:42 <openstack> Launchpad bug 1476839 in Solum "migrate to oslo config generation" [Undecided,New]
21:04:43 <uvirtbot> Launchpad bug 1476839 in solum "migrate to oslo config generation" [Undecided,New]
21:04:43 <devkulkarni> adrian_otto: the additional two in the agenda are from before
21:04:44 <uvirtbot> Launchpad bug 1476839 in solum "migrate to oslo config generation" [Undecided,New] https://launchpad.net/bugs/1476839
21:04:55 <devkulkarni> I did not remove them as I wanted to provide updates on them
21:05:00 <adrian_otto> ok
21:05:01 <devkulkarni> actually only one
21:05:03 <adrian_otto> so here is the other:
21:05:10 <adrian_otto> dimtruck to check with devdatta-kulkarni about the stauts of the namespace migration to the openstack git namespace, and file openstack-config reviews as needed if they have not already been created.
21:05:19 <devkulkarni> yes — wanted to provide update on that
21:05:19 <adrian_otto> #link https://bugs.launchpad.net/solum/+bug/1472409 Rename stackforge/solum to openstack/solum
21:05:20 <openstack> Launchpad bug 1472409 in Solum "Task: Rename stackforge/solum to openstack/solum" [Wishlist,In progress] - Assigned to Devdatta (devdatta-kulkarni)
21:05:21 <uvirtbot> Launchpad bug 1472409 in solum "Task: Rename stackforge/solum to openstack/solum" [Wishlist,In progress]
21:05:22 <uvirtbot> Launchpad bug 1472409 in solum "Task: Rename stackforge/solum to openstack/solum" [Wishlist,In progress] https://launchpad.net/bugs/1472409
21:05:28 <adrian_otto> Status: Following up with infra-team on (https://review.openstack.org/#/c/201287/)
21:05:42 <devkulkarni> yes — basically that is the update
21:05:56 <adrian_otto> #link https://review.openstack.org/#/c/201693/ Add missing solum projects to reference/projects.yaml
21:06:37 <devkulkarni> another related update is that recently TC approved a change that any new project can directly start in openstack org. they want to deprecate stackforge org
21:06:48 <adrian_otto> I have noticed that OpenStack CI is running exceedingly slow
21:06:49 <devkulkarni> let me see if I can find that review
21:07:11 <adrian_otto> just about every patch I've looked at since yesterday is awaiting a jenkins vote
21:07:11 <devkulkarni> #link https://review.openstack.org/#/c/192016/
21:07:29 <datsun180b> last i checked zuul had a 300+ job queue
21:07:32 <devkulkarni> you mean across projects?
21:08:12 <adrian_otto> yes, across projects
21:08:27 <devkulkarni> 300+ .. wow
21:08:42 <adrian_otto> so don't hold your breath ;-)
21:08:50 <datsun180b> 315 at the moment
21:08:53 <devkulkarni> ha ha.. true
21:08:56 <james_li> we need intel's cluster
21:09:14 <devkulkarni> james_li: :)
21:09:15 <adrian_otto> well that's definitely coming
21:09:30 <adrian_otto> but usually the problem is not system capacity. It's brittle software.
21:09:47 <adrian_otto> #topic Blueprint/Task Review and Discussion
21:09:59 <adrian_otto> 1) Resolving issues with using oslo_config generator (devkulkarni, james_li)
21:10:15 <devkulkarni> james_li: wanted to chat with you about this issue
21:10:32 <james_li> devkulkarni and I made some discussions via comments on that bug page
21:11:06 <devkulkarni> ok — I just checked them.. here is the #link https://bugs.launchpad.net/solum/+bug/1476839
21:11:06 <openstack> Launchpad bug 1476839 in Solum "migrate to oslo config generation" [Undecided,New]
21:11:07 <uvirtbot> Launchpad bug 1476839 in solum "migrate to oslo config generation" [Undecided,New]
21:11:08 <uvirtbot> Launchpad bug 1476839 in solum "migrate to oslo config generation" [Undecided,New] https://launchpad.net/bugs/1476839
21:11:24 <james_li> devkulkarni: are you now clear about the steps?
21:11:47 <devkulkarni> james_li: I think so.
21:11:55 <james_li> cool
21:12:20 <devkulkarni> adrian_otto: we can proceed to the next point
21:12:53 <adrian_otto> 2) Pluggable deployer spec (https://review.openstack.org/#/c/202254/) (james_li, randallburt)
21:13:20 <james_li> overall the spec looks good to me
21:13:36 <devkulkarni> james_li: randallburt was supposed to join us today but had something to take care of.
21:13:44 <devkulkarni> james_li: i thought you had few comments..
21:13:46 <james_li> I just have some thoughts about the proposal for API change
21:14:26 <james_li> since randall is not here, I can add some comments in the spec
21:14:50 <devkulkarni> james_li: yes — that will be good.. we can follow up through the comments
21:14:57 <devkulkarni> out of curiosity
21:14:58 <james_li> yeah
21:15:06 <devkulkarni> what were your thoughts?
21:15:37 <devkulkarni> for me — one suggestion to randallburt was to not use the term 'flavor'
21:15:51 <devkulkarni> as it has an established meaning in the OpenStack ecosystem
21:15:54 <james_li> I understand the reason behind the api change, but I am just thinking it could have a better name :)
21:16:06 <devkulkarni> fair enough
21:16:07 <james_li> devkulkarni: yeah I am thinking the same
21:16:09 <adrian_otto> +1 not to use flavor
21:16:24 <datsun180b> style or variant maybe?
21:16:43 <devkulkarni> adrian_otto, datsun180b: please take a look at the spec whenever you get a chance as well
21:16:44 <datsun180b> "option" has other context, and so does "configuration"
21:17:04 <devkulkarni> so randallburt was thinking more along the lines of "architectural-flavor"
21:17:14 <adrian_otto> "variant" work for me
21:17:44 <devkulkarni> as in "infrastructure variant"?
21:18:24 <devkulkarni> may be infrastructure/architecture style
21:18:32 <devkulkarni> just thinking out loud..
21:18:43 <datsun180b> that's why we have this meeting
21:19:12 <devkulkarni> why not just template?
21:19:17 <adrian_otto> you could also refer to it as a template
21:19:29 <adrian_otto> because that's literally what it is
21:19:39 <devkulkarni> yes, thats what I was thinking
21:19:51 <devkulkarni> why to invent a different term..
21:20:11 <adrian_otto> just call it what it is
21:20:17 <devkulkarni> +1
21:20:26 <adrian_otto> we had this debate back when the term blueprint was preferred by some
21:20:50 <adrian_otto> we concluded "template" was the right term back then as well
21:20:52 <datsun180b> template++
21:20:56 <james_li> +1
21:21:04 <devkulkarni> take an agreed then? :)
21:21:23 <adrian_otto> #agreed we will refer to architectural variants as architectural templates
21:21:33 <adrian_otto> will that suffice?
21:21:34 <devkulkarni> awesome!
21:21:37 <devkulkarni> yep
21:21:37 <adrian_otto> ok, cool
21:21:56 <adrian_otto> last on the agenda for this section is:
21:22:01 <adrian_otto> 4) Vagrant setup not working. Discuss options to fix it (devkulkarni, datsun180b)
21:22:14 <devkulkarni> so here is the status
21:22:36 <devkulkarni> in our Vagrant setup docker daemon is not starting up.. and this causes none of the other services to start
21:22:50 <devkulkarni> james_li and I have been discussing some options to fix the issue
21:23:12 <adrian_otto> do we know why docker does not start?
21:23:29 <datsun180b> that aufs change didn't do the trick?
21:23:37 <devkulkarni> it probably is something in docker version 1.7, which nova-docker pulls in (it pulls in the latest)
21:23:49 <devkulkarni> datsun180b: probably not
21:24:04 <devkulkarni> I will let you know soon.. I have just started running the VM again
21:24:21 <devkulkarni> so lets see
21:24:46 <devkulkarni> we need all vagrant setup up and running so that datsun180b's workflow related work can be moved forward
21:24:54 <devkulkarni> so my priority is to get that to work
21:25:07 <devkulkarni> s/all/our/
21:25:36 <devkulkarni> so datsun180b, james_li if you have any suggestions/insights send them to me
21:26:26 <datsun180b> i'll spend some time trying to find and fill in those potholes
21:26:52 <devkulkarni> datsun180b: greatly appreciated
21:27:59 <devkulkarni> datsun180b: I have a question about workflow
21:28:04 <datsun180b> shoot
21:28:20 <adrian_otto> #topic Open Dicusssion
21:28:42 <devkulkarni> do you have the the exact cli commands that you have been using for testing the new app model and the workflow changes
21:29:12 <datsun180b> solum app register /opt/stack/solum/examples/apps/(i forget).yaml
21:29:31 <datsun180b> solum app update <app name> --name <new name>
21:29:38 <datsun180b> solum app deploy <app name>
21:29:51 <datsun180b> off the top of my head
21:29:51 <devkulkarni> so those haven't change, right?
21:29:58 <datsun180b> i sure hope not!
21:30:01 <devkulkarni> ok
21:30:10 <devkulkarni> how about for workflow?
21:30:32 <devkulkarni> I know that you have those WIPs where you have implemented resources
21:30:44 <devkulkarni> how were you interacting with them? via cli? via curl?
21:30:55 <datsun180b> via cli
21:30:59 <devkulkarni> if it was curl, do you have the structure of the request somewhere
21:31:03 <devkulkarni> oh okay
21:31:07 <datsun180b> solum workflow list <app name>
21:31:24 <datsun180b> and the CLI has a --json flag and a --debug flag to help you create curls
21:31:47 <datsun180b> not really a fan of prettytable because parsing it isn't fun
21:32:22 <devkulkarni> ok. so for workflows, apart from 'list' was there any other command implemented in your wip?
21:32:46 <datsun180b> solum workflow show <app> <workflow>
21:32:51 <devkulkarni> cool
21:33:06 <datsun180b> now for that one i was working so both uuids and incrementals would work for the workflow
21:33:34 <datsun180b> so you could say "show me my wordpress's workflow number 2"
21:33:52 <datsun180b> oh and to save your fingers, "wf" is an accepted abbreviation in the cli
21:34:02 <devkulkarni> got it..
21:34:25 <adrian_otto> oh wf
21:34:30 <adrian_otto> as long as it's not wtf
21:34:46 <devkulkarni> ha ha ha
21:34:50 <adrian_otto> time to wrap up today?
21:35:04 <devkulkarni> sure.. datsun180b will ping in solum
21:35:24 <adrian_otto> before we adjourn
21:35:49 <adrian_otto> oh, nm.
21:35:54 <adrian_otto> time to adjourn
21:36:22 <adrian_otto> our next meeting is Tuesday 2015-08-04 at 2100 UTC. See you then!
21:36:27 <adrian_otto> #endmeeting