17:00:09 <devkulkarni> #startmeeting Solum Team Meeting
17:00:10 <openstack> Meeting started Tue Nov 3 17:00:09 2015 UTC and is due to finish in 60 minutes. The chair is devkulkarni. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:13 <openstack> The meeting name has been set to 'solum_team_meeting'
17:00:16 <devkulkarni> #topic Roll Call
17:00:20 <devkulkarni> Devdatta Kulkarni
17:00:21 <datsun180b> ed cranford
17:00:27 <devkulkarni> hi datsun180b
17:00:33 <datsun180b> howdy
17:00:33 <devkulkarni> nice to see you
17:00:51 <datsun180b> and you. surely it's not just the two of us today?
17:00:52 <devkulkarni> lets give few minutes for folks to join
17:01:07 <devkulkarni> no, I think folks are wrapping up other meeting
17:01:11 <devkulkarni> meetings
17:01:23 <devkulkarni> I know that magnum meeting is just before our meeting
17:02:30 <devkulkarni> hi muralia
17:02:39 <muralia> hey dev.
17:02:48 <devkulkarni> datsun180b is here too
17:03:17 <devkulkarni> I was saying that lets wait for couple of minutes to allow folks to join in
17:03:24 <devkulkarni> in the mean while, here is agenda for today:
17:03:27 <devkulkarni> #link https://wiki.openstack.org/wiki/Meetings/Solum#Agenda_for_2015-11-03_1700_UTC
17:05:47 <devkulkarni> alright. I will get started
17:06:08 <devkulkarni> so first up is the Tokyo summit
17:06:16 <devkulkarni> #Announcement
17:06:21 <devkulkarni> Mitaka summit experience
17:06:39 <devkulkarni> So it was a good summit for me
17:07:07 <devkulkarni> Unlike Atlanta, where we all had attended several Solum discussion sessions, there was only one session for Solum this time
17:07:23 <devkulkarni> About 20 folks had rsvped
17:07:36 <devkulkarni> #link https://www.openstack.org/summit/tokyo-2015/schedule/design-summit
17:07:52 <devkulkarni> not all of them came to the session
17:08:04 <devkulkarni> but few did show up
17:08:11 <muralia> nice
17:08:35 <devkulkarni> and we had good discussion about Solum's current capabilities and the kind of use cases they were trying to address
17:08:38 <devkulkarni> hi vijendar
17:08:41 <muralia> did any of the old contributors show up?
17:08:42 <devkulkarni> we have just got started
17:08:45 <vijendar> hi all
17:09:02 <devkulkarni> no, unfortunately I did not see any of the old folks
17:09:21 <devkulkarni> in fact I did not find any familiar faces throughout the summit in any of the sessions
17:09:30 <devkulkarni> that was actually surprising to me
17:09:32 <devkulkarni> hi pt_15
17:09:38 <devkulkarni> we have just got started
17:09:46 <devkulkarni> the summit venue was distributed
17:09:49 <pt_15> hi devkulkarni
17:10:07 <devkulkarni> the design sessions were in one hotel, while the talks/presentations were in a different hotel
17:10:21 <devkulkarni> I was mostly attending the talks/presentations
17:10:41 <devkulkarni> except for our solum session which was scheduled in the hotel where design summit was being held
17:11:27 <devkulkarni> I saw that there were several talks focussing on some variation of paas, ci/cd, source code to deployment, application containers, container scheduling, container security, etc.
17:11:39 <devkulkarni> I attended almost all of these
17:12:40 <devkulkarni> seeing that folks are building custom solutions for application deployment using containers, I felt that solum would be a very attractive solution for such groups/folks
17:12:56 <devkulkarni> so I have already reached to out some of them
17:13:06 <devkulkarni> and will reach out to others today/tomorrow
17:13:35 <devkulkarni> explaining the current solum features/capabilities, how it is built around all the native openstack services
17:14:02 <devkulkarni> so in that sense it was exciting
17:14:32 <muralia> ya
17:14:33 <devkulkarni> lets see if we can get some of these folks on board with either using solum or contributing to it
17:14:51 <devkulkarni> which brings me to my presentation
17:15:21 <devkulkarni> the main point that I made was to explain the value proposition of solum and an appeal to operators and developers to give it a try
17:15:35 <devkulkarni> I have uploaded the presentation to slideshare
17:15:38 <devkulkarni> #link http://www.slideshare.net/devkulkarni/solum-openstack-paas-alm
17:16:03 <devkulkarni> before leaving for the summit, I was also able to cut a video of the latest capabilities
17:16:17 <devkulkarni> check out the video whenever you get a chance
17:16:19 <devkulkarni> #link https://vimeo.com/143425822
17:16:47 <devkulkarni> datsun180b you would be happy to see that the demo video contains workflow example
17:16:56 <datsun180b> nice
17:17:00 <devkulkarni> yep
17:17:23 <devkulkarni> I might do a short write up on summit experience, impressions, thoughts
17:17:56 <devkulkarni> also to include some of the talks that I think some of you would be really interested in
17:18:15 <devkulkarni> for instance, there was talk by ibm folks on docker security
17:18:53 <devkulkarni> it was very relevant to the kind of issues that we had encountered in solum-worker for building LPs and DUs
17:19:02 <devkulkarni> you all will find it very interesting
17:19:27 <muralia> cool
17:19:42 <muralia> looking forward to it. were those talks recorded?
17:21:29 <devkulkarni> sorry, machine just restarted
17:21:33 <devkulkarni> muralia: yes
17:21:39 <muralia> ok good
17:21:39 <devkulkarni> that talk was recorded
17:21:47 <devkulkarni> only the design summit sessions/talks were not recorded
17:21:56 <devkulkarni> so solum talk is not recorded
17:22:30 <devkulkarni> alright, ping me if you want to more about the summit from solum pov
17:22:53 <devkulkarni> next announcement is
17:22:56 <devkulkarni> Bug cleanup
17:23:02 <devkulkarni> #link https://bugs.launchpad.net/solum/+bugs?orderby=status&start=0
17:23:17 <devkulkarni> Yesterday I spent some time going through our bug list in solum
17:23:24 <devkulkarni> and cleaned it up
17:23:36 <devkulkarni> now every bug has a tag
17:23:55 <devkulkarni> I have added tags such as 'solum-api', solum-worker, etc.
17:24:32 <devkulkarni> these basically indicate the service the bug is supposed to be either present or should be addressed in
17:24:59 <devkulkarni> vijendar, pt_15: I would encourage you to use the tags to filter the bugs
17:25:44 <devkulkarni> imo, the bugs which are tagged solum-*, functional-tests, and documentation are probably the most important one for us right now
17:25:45 <vijendar> devananda: sure. thanks for cleanup
17:26:04 <vijendar> devkulkarni: ^^
17:26:05 <devkulkarni> vijendar: np. actually is was good that you asked me about it
17:26:05 <pt_15> devkulkarni: ok, sure :)
17:26:59 <devkulkarni> actually while we are discussing about bugs, I want to jump ahead and check about a topic that I have listed in open discussion
17:27:47 <devkulkarni> I was thinking that, now that we have bugs curated, what do you all feel about a bug squash day/half-day sometime before the end of the year?
17:28:23 <devkulkarni> especially, muralia and datsun180b, do you guys might have half day may for this event?
17:28:42 <vijendar> devkulkarni: sound good to me
17:29:01 <devkulkarni> I could check if we can arrange something in racker rally room in austin office for those of us who are in austin
17:29:02 <muralia> sure. i can help
17:29:19 <devkulkarni> cool.. that is awesome muralia and vijendar
17:29:42 <devkulkarni> datsun180b: how about you? any chance this might work for you?
17:30:03 <datsun180b> i don't know that I'll be able to lean in on that
17:30:19 <devkulkarni> sure datsun180b
17:30:26 <devkulkarni> I can understand
17:30:55 <devkulkarni> muralia, vijendar: let me check with james_li as well if he might be interested/available
17:31:52 <vijendar> ok
17:32:08 <devkulkarni> alright. this is good. datsun180b you can join us if you have time..
17:32:16 <devkulkarni> we will be on irc as well
17:32:29 <devkulkarni> so pt_15 you can join us as well if you have time
17:32:46 <devkulkarni> I will propose couple of days and send out an email
17:32:51 <pt_15> devkulkarni: sure, that would be great! :D
17:34:23 <devkulkarni> muralia, vijendar: for me, preferred date is sometime before November 25th. I will be traveling to India from thanks giving onwards and will be back in Austin after new years. I will be working from Pune for couple of weeks. so it should be okay if we plan something in december. But if we plan something before november 25th, we can all be in racker rally room hacking together
17:35:09 <devkulkarni> let me know if sometime before november 25th would work for you
17:35:17 <devkulkarni> don't have to be right now
17:35:30 <devkulkarni> you can let me know sometime in next couple of days
17:35:34 <muralia> ok
17:35:36 <vijendar> ok
17:35:48 <devkulkarni> cool.. thanks muralia, vijendar
17:36:01 <devkulkarni> alright, lets move on to next topic
17:36:13 <devkulkarni> #topic Review Action Items
17:36:23 <devkulkarni> devkulkarni to figure out how to retire solum readthedocs
17:36:32 <devkulkarni> this is still pending
17:36:37 <devkulkarni> will carry it forward
17:36:47 <devkulkarni> #action devkulkarni to figure out how to retire solum readthedocs
17:37:04 <devkulkarni> #topic Blueprint/Bug Review and Discussion
17:37:13 <devkulkarni> 1) Gate is broken
17:37:32 <devkulkarni> looks like the devstack gate is still broken
17:37:38 <vijendar> yes
17:38:00 <vijendar> devkulkarni: are you going to look into that?
17:38:14 <devkulkarni> vijendar do you have the link for your patch for which dvsm is failing?
17:38:28 <devkulkarni> vijendar: yes, I will be looking into it today/tomorrow
17:38:57 <devkulkarni> muralia, datsun180b: in the meanwhile, please review the log patches submitted by vijendar
17:38:59 <devkulkarni> on api and cli
17:39:06 <muralia> sure
17:39:26 <devkulkarni> I would like to get them merged soon
17:39:31 <vijendar> https://review.openstack.org/#/c/237088/
17:39:43 <vijendar> this one is failing the devstack gate
17:39:56 <devkulkarni> that is the last thing remaining before we can call the app and workflow resource implementation done
17:40:13 <muralia> will wait for +1 from jenkins
17:40:39 <datsun180b> looks like some recent devstack failures are due to the deprecation of devstack/libs and devstack/extras.d
17:41:37 <devkulkarni> datsun180b: which one in particular? we know that that deprecation is going to eventually cause solum to break, but that is still about 4 to 5 weeks out
17:41:58 <devkulkarni> the gate failure just before the summit week was due to tempest-lib
17:42:08 <datsun180b> http://logs.openstack.org/46/239446/2/check/gate-solum-devstack-dsvm/07f99e8/console.html.gz just picked the first failed review and looked through the logs
17:42:28 <datsun180b> there's some complaining that those two directories no longer exist
17:43:28 <devkulkarni> datsun180b: ok, I see that error
17:43:51 <devkulkarni> that is easy to fix
17:44:15 <devkulkarni> I thought I had fixed it in my patch before the summit
17:44:21 <devkulkarni> let me check
17:44:29 <datsun180b> that might just be an old review that hasn't been refreshed since
17:45:02 <devkulkarni> https://github.com/openstack/solum/blob/master/functionaltests/pre_test_hook.sh
17:45:20 <devkulkarni> no, it has been removed
17:45:29 <devkulkarni> I mean't, no it has not been removed
17:46:05 <devkulkarni> we are not using barbican right now, so I might just remove those lines
17:46:38 <devkulkarni> datsun180b: although, I don't think those errors are what vijendar's patch is failing on
17:46:59 <datsun180b> which of vijendar's patches?
17:47:35 <devkulkarni> #link http://logs.openstack.org/88/237088/4/check/gate-solum-devstack-dsvm/758dd7d/
17:48:18 <datsun180b> response = ask('Proceed (y/n)? ', ('y', 'n'))
17:48:21 <datsun180b> well that's something
17:48:42 <datsun180b> looks like pip thinks it's running in an interactive terminal
17:49:07 <devkulkarni> yeah, I had seen that in my patch to upgrade tempest-lib
17:49:29 <datsun180b> it's the pip cache on jenkins
17:49:30 <devkulkarni> but the job was proceeding forward
17:49:56 <datsun180b> /home/jenkins/.cache/pip/http
17:50:28 <devkulkarni> so you are saying, we should use pip install with no interaction option and a flag that indicates cache should not be used?
17:50:40 <datsun180b> well maybe it's a red herring
17:50:50 <devkulkarni> no, I think it is a good suggestion
17:51:04 <devkulkarni> at least something to begin with
17:51:14 <devkulkarni> I will try it as the first option
17:51:23 <datsun180b> these logs have captured the request and response content in stdout, what's with that
17:51:24 <devkulkarni> also, will get rid of barbican lines
17:51:47 <datsun180b> must be tempest I guess
17:51:55 <devkulkarni> yeah, I had noticed that.. looks like tempest-lib is spitting them out
17:51:57 <devkulkarni> yeah
17:52:33 <devkulkarni> alright, I think this was good discussion datsun180b
17:52:52 <devkulkarni> just couple more points for today
17:52:53 <datsun180b> looks like it's just IndexOutOfRange during lp delete
17:53:16 <devkulkarni> datsun180b: yes, it was that I remember
17:53:29 <devkulkarni> but that error must be happening due to some other issue
17:53:38 <devkulkarni> as those tests have been working fine
17:54:19 <devkulkarni> still, will look closely at what is going on
17:54:37 <devkulkarni> we need to fix the gate asap so that vijendar and pt_15's patches can land
17:55:02 <devkulkarni> the last topic that I had was about solum-release
17:55:30 <devkulkarni> there have been lot of changes to the way release management is being planned for the mitaka cycle
17:55:42 <devkulkarni> you must have seen emails from dhellman in this regard
17:56:22 <devkulkarni> I am thinking of tagging a release of solum and python-solumclient once we land vijendar's patches
17:56:39 <devkulkarni> that will logically complete the app and workflow transition work
17:57:01 <devkulkarni> so that was all I had
17:57:10 <devkulkarni> #topic Open Discussion
17:57:34 <devkulkarni> pt_15: how is your devstack setup coming along?
17:57:44 <devkulkarni> vijendar: is devstack working for you?
17:57:59 <vijendar> devkulkarni: yes. it is working
17:58:05 <devkulkarni> cool
17:58:29 <pt_15> devkulkarni: I haven't been able to try out the alternate method yet, I will try it out this week
17:58:43 <devkulkarni> pt_15: sure, sounds good
17:59:15 <devkulkarni> ping me if you are running into issues
17:59:45 <pt_15> devkulkarni: sure, I will :)
17:59:46 <devkulkarni> based on what vijendar tried, I know that straight vagrant is now back to working condition
18:00:18 <devkulkarni> so if you have a machine that has enough memory and good network connectivity then vagrant would be easiest
18:00:29 <devkulkarni> vijendar: how much memory are you allocating to your vagrant vm?
18:00:49 <vijendar> 7GB
18:00:54 <devkulkarni> I see
18:01:09 <devkulkarni> pt_15: you can try setting your vagrant file's vm setting to that
18:01:14 <devkulkarni> and see if it works for you
18:01:24 <devkulkarni> alright, we are past the meeting hour
18:01:29 <devkulkarni> see you in solum
18:01:38 <devkulkarni> thanks everyone for attending today
18:01:42 <devkulkarni> #endmeeting