17:02:07 <devkulkarni> #startmeeting Solum Team Meeting
17:02:07 <openstack> Meeting started Tue Dec 1 17:02:07 2015 UTC and is due to finish in 60 minutes. The chair is devkulkarni. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:02:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:02:11 <openstack> The meeting name has been set to 'solum_team_meeting'
17:02:22 <devkulkarni> #topic Roll Call
17:02:26 <james_li> james li
17:02:27 <devkulkarni> Devdatta Kulkarni
17:02:27 <muralia> o/
17:02:37 <datsun180b> ed cranford
17:02:37 <devkulkarni> morning james_li, muralia
17:02:41 <devkulkarni> hi ed
17:02:52 <muralia> woohoo! good to see everyone.
17:03:01 <devkulkarni> yep!! :)
17:03:07 <james_li> devkulkarni: are you in India now?
17:03:13 <devkulkarni> james_li: yes
17:03:14 <ashishjain> Ashish Jain
17:03:18 <devkulkarni> hi Ashish
17:03:27 <ashishjain> Hi dev
17:03:31 <devkulkarni> I am in Pune, India till year end
17:03:43 <devkulkarni> will be back in Austin on Jan 4
17:03:54 <devkulkarni> here is link to agenda for today's meeting
17:03:58 <devkulkarni> #link https://wiki.openstack.org/wiki/Meetings/Solum#Agenda_for_2015-12-01_1700_UTC
17:04:14 <devkulkarni> notice that the agenda has lot of open reviews
17:04:14 <devkulkarni> here is link to agenda for today's meeting
17:04:19 <james_li> devkulkarni: cool
17:04:35 <devkulkarni> good to see all of you cores around today
17:05:29 <devkulkarni> lets give another minute for folks to join
17:06:12 <devkulkarni> alright, lets proceed to the next topic
17:06:18 <devkulkarni> #topic Announcements
17:06:51 <devkulkarni> As last time, I would like to mention that I am in India for December
17:07:08 <devkulkarni> I will be working next week and the week after that
17:07:35 <devkulkarni> I will be around for all of our meetings
17:07:55 <devkulkarni> unless we all decide to cancel the meeting on December 29th
17:08:02 <devkulkarni> what do you think about that?
17:08:20 <devkulkarni> I am fine either ways
17:08:53 <datsun180b> I'll vote skip, but only because I know I'll be out of town
17:09:04 <muralia> me too. im going to be out of town as well
17:09:18 <devkulkarni> james_li, ashishjain?
17:09:18 <vijendar> +1 skip
17:09:23 <devkulkarni> hi vijendar
17:09:31 <devkulkarni> thanks for the input
17:09:35 <ashishjain> Should be okay dev to cancel it I also plan to go out
17:09:38 <vijendar> hi devkulkarni
17:10:06 <devkulkarni> cool.. looks like we have a majority on cancelling the meeting on December 29th
17:10:13 <devkulkarni> lets do that.
17:10:53 <devkulkarni> #action devkulkarni to announce meeting cancellation of the meeting on December 29th
17:11:08 <devkulkarni> any other announcements?
17:11:37 <devkulkarni> will wait for 30 seconds before proceeding
17:11:54 <james_li> devkulkarni: I am fine
17:12:00 <devkulkarni> thanks james_li
17:12:16 <devkulkarni> #topic Blueprint/Bug Review and Discussion
17:12:24 <devkulkarni> we have several patches for review today
17:12:43 <devkulkarni> please check them on this link https://wiki.openstack.org/wiki/Meetings/Solum#Agenda_for_2015-12-01_1700_UTC
17:13:05 <devkulkarni> lets use this time to review these
17:13:06 <ashishjain> To me the patch looks good-> https://review.openstack.org/#/c/250015/
17:13:25 <ashishjain> Only thing is I have to apply once to my workspace and test it out.
17:14:52 <devkulkarni> ahishjain: cool
17:15:08 <devkulkarni> could you then give a +1 when you are done testing
17:15:34 <ashishjain> sure I will give it a try tonight.
17:15:38 <devkulkarni> we can arrange for another core to approve it once you have given your +1
17:15:45 <ashishjain> yeah
17:15:46 <devkulkarni> ashishjain: sounds good
17:16:44 <devkulkarni> datsun180b: could you take a look at the patches which are converting plans to apps
17:16:53 <datsun180b> sure
17:17:00 <devkulkarni> thanks
17:17:30 <devkulkarni> these patches are converting the test examples from the older plan model to the newer app model
17:18:27 <ashishjain> okay
17:22:48 <devkulkarni> will open up for open discussion in about 10 minutes
17:23:54 <datsun180b> what's the default run command for python lp apps?
17:24:22 <datsun180b> ah, nevermind, that's for #solum not here
17:24:48 <devkulkarni> datsun180b: we can discuss it here
17:24:55 <devkulkarni> which particular example are you referring to?
17:25:02 <datsun180b> looking at eric's appfile conversions
17:25:20 <devkulkarni> ok, let me check
17:27:31 <devkulkarni> datsun180b: isn't in the new model we have 'languagepack' and not 'language_pack'?
17:27:47 <datsun180b> can't rightly recall
17:27:55 <devkulkarni> ** checking in solum/examples/apps **
17:28:12 <devkulkarni> https://github.com/openstack/solum/blob/master/examples/apps/cherrypy.yaml
17:28:39 <datsun180b> well i know it's not languageopack
17:30:01 <devkulkarni> datsun180b: true :)
17:30:10 <devkulkarni> I am adding few other comments
17:31:17 <devkulkarni> datsun180b: I have a slightly unrelated question..
17:31:25 <datsun180b> sure
17:31:50 <devkulkarni> how did you change your email address to gmail address still keeping +2 privileges?
17:32:01 <datsun180b> I had to ask infra for a favor
17:32:12 <devkulkarni> oh I see
17:32:49 <datsun180b> There was a manual change to a database row. I think it's tied to your openID which is tied to your email IIRC
17:33:29 <devkulkarni> wow
17:34:04 <devkulkarni> I had to reset my OpenID password, but never received password recovery email on rax email address
17:34:18 <devkulkarni> so ended up creating a new account
17:34:48 <devkulkarni> I only have +1/-1 privileges on this account
17:34:55 <ashishjain> done adding my review comments to https://review.openstack.org/#/c/250015/
17:35:41 <datsun180b> That sounds like a matter with LP and not openstack, but I hope you can recover the account
17:36:14 <devkulkarni> ashishjain: cool
17:36:43 <devkulkarni> datsun180b: would you mind exercising your +2 rights on the above patch :)
17:37:13 <datsun180b> on 250015?
17:37:51 <devkulkarni> yep
17:37:57 <devkulkarni> https://review.openstack.org/#/c/250015/
17:38:11 <datsun180b> approved
17:38:21 <devkulkarni> datsun180b: awesome
17:38:34 <devkulkarni> vijendar: thanks for submitting the patch to fix this issue
17:38:47 <devkulkarni> and thanks ashishjain for verifying it
17:39:06 <vijendar> :)
17:39:24 <ashishjain> devkulkarni :)
17:40:49 <devkulkarni> opening up for open discussion
17:41:08 <devkulkarni> #topic Open Discussion
17:42:02 <ashishjain> I have a question on integration of solum to kolla
17:42:12 <ashishjain> is it ongoing?
17:42:33 <devkulkarni> ahishjain: we want to actually
17:42:52 <devkulkarni> ashishjain: do you have any experience with it?
17:42:59 <ashishjain> actually I was looking at a very old discussion http://eavesdrop.openstack.org/meetings/solum_team_meeting/2015/solum_team_meeting.2015-01-06-21.00.log.html
17:43:26 <ashishjain> devkulkarni: we are using it for openstack deployment
17:44:30 <devkulkarni> I see.. given your understanding of kolla and solum, how do you see the process of adding kolla support to solum?
17:45:02 <devkulkarni> what is required to do this?
17:45:18 <devkulkarni> my understanding was that, we need to create docker containers for solum services
17:45:34 <ashishjain> I think we need to create docker containers for solum services
17:45:38 <ashishjain> yes you are correct
17:45:42 <devkulkarni> probably one for rabbit and one for mysql
17:45:56 <ashishjain> They already have a mysql container
17:45:59 <devkulkarni> how do we wire all these services?
17:46:04 <devkulkarni> oh nice
17:46:06 <ashishjain> aah okay got it
17:46:31 <ashishjain> Do you want a separate mysql or the one which comes with kolla(galera) should be fine?
17:46:51 <ashishjain> rabbitmq is also already present I guess
17:46:51 <devkulkarni> I think the one which comes with kolla should be fine
17:47:02 <devkulkarni> oh okay
17:47:04 <ashishjain> okay than we have these components
17:47:35 <devkulkarni> in that case we need to build Dockerfiles and containers for solum-api, solum-worker, solum-conductor, and solum-deployer
17:47:45 <ashishjain> devkulkarni: let me get back with more findings on that
17:47:58 <devkulkarni> and probably a wrapper script to start all these and wire them together
17:48:09 <devkulkarni> ashishjain: cool, that would be nice
17:48:24 <ashishjain> yes ansible scripts probably can be used to wire them
17:49:02 <ashishjain> so for now since we do not have kolla integration with solum
17:49:08 <devkulkarni> oh okay. in fact, while writing above, I realized that solum's micro-service feature would need to do something very similar
17:49:34 <ashishjain> how shall we proceed with solum installation on something which is based on kolla
17:49:58 <ashishjain> Kolla uses haproxy and uses it to load balance say for example a multinode deployment
17:50:23 <ashishjain> where each node is running most of the services which needs to load balanced
17:51:51 <devkulkarni> ashishjain: sorry, not following what you mean..
17:52:17 <ashishjain> devkulkarni: sorry let me re-iterate
17:52:24 <devkulkarni> ok
17:53:08 <ashishjain> Openstack is installed as a multinode while using kolla
17:53:25 <devkulkarni> oh I see
17:53:33 <ashishjain> where in you can configure most of the services to be run on more than one node in a active-active setup
17:53:50 <ashishjain> for example neutron-server, keysytone etc
17:53:58 <ashishjain> are being run on more than one node
17:54:12 <ashishjain> This all is load balanced using ha proxy
17:54:19 <ashishjain> Now comes the question
17:54:51 <ashishjain> How can solum be deployed on multinode & be registered with load balancer.
17:55:05 <ashishjain> I think this will be our approach -
17:56:11 <ashishjain> devkulkarni: Here solum will not be deployed in docker container
17:56:14 <devkulkarni> probably each solum service will need to be load balanced using ha-proxy
17:56:26 <ashishjain> but as a standalone mode, that is for time being
17:56:40 <ashishjain> till the containerization is completed
17:57:29 <devkulkarni> by standalone mode, you mean running all the solum-services as we do currently
17:57:38 <devkulkarni> without containerizing them
17:57:42 <ashishjain> correct
17:58:08 <ashishjain> so how do you integrate a container & non-container deployment on a multinode using haproxy
17:58:24 <ashishjain> where non-container deployment is for soum
17:58:33 <ashishjain> solum & rest of the services are containerized
17:58:58 <ashishjain> I think it should be seamless only hitch I see is probably adding it to haproxy load balancer
17:59:03 <devkulkarni> could neutron networking help?
17:59:21 <devkulkarni> ashishjain: agree
17:59:52 <devkulkarni> we are almost out of time
17:59:54 <ashishjain> Once we are able to manually do so, I think containerization should not be tough
18:00:18 <devkulkarni> yeah, probably you are right
18:00:27 <devkulkarni> alright, its top of the hour
18:00:36 <devkulkarni> thanks all for joining the meeting today
18:00:39 <devkulkarni> see you next week
18:00:40 <ashishjain> devkulkarni: I got few more things to discuss with you will catch up with you in irc
18:00:44 <ashishjain> cya thanks
18:00:51 <devkulkarni> ashishjain: sounds good
18:00:54 <devkulkarni> #endmeeting