17:00:07 <devkulkarni> #startmeeting Solum Team Meeting
17:00:09 <openstack> Meeting started Tue Dec 15 17:00:07 2015 UTC and is due to finish in 60 minutes.  The chair is devkulkarni. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:13 <openstack> The meeting name has been set to 'solum_team_meeting'
17:00:16 <devkulkarni> #topic Roll Call
17:00:21 <devkulkarni> Devdatta Kulkarni
17:00:22 <datsun180b> ed cranford
17:00:29 <devkulkarni> morning ed
17:00:32 <datsun180b> howdy
17:00:39 <ashishjain> Ashish Jain
17:00:47 <devkulkarni> hi Ashish
17:00:53 <ashishjain> Hi Dev
17:00:56 <devkulkarni> here is link to today's agenda: https://wiki.openstack.org/wiki/Meetings/Solum
17:01:05 <devkulkarni> #link https://wiki.openstack.org/wiki/Meetings/Solum
17:01:32 <james_li> james li
17:01:42 <devkulkarni> hi james
17:01:52 <james_li> Hi devkulkarni
17:01:56 <devkulkarni> we have Ed and Ashish as well
17:02:22 <devkulkarni> great to see you all today datsun180b, james_li, ashishjain
17:02:54 <devkulkarni> hi vijendar
17:03:01 <vijendar> Hi Dev
17:03:14 <devkulkarni> we have a quorum.. lets begin
17:03:23 <devkulkarni> here is agenda for today:
17:03:27 <devkulkarni> #link https://wiki.openstack.org/wiki/Meetings/Solum
17:03:56 <devkulkarni> #topic Announcements
17:04:14 <devkulkarni> (devkulkarni) I am doing a workshop tomorrow on contributing to OpenStack at Wipro in Pune on invitation from ashishjain. Will share my notes after the workshop.
17:04:31 <ashishjain> wow thanks for the announcement devkulkarni
17:04:42 <devkulkarni> my pleasure ashishjain
17:04:57 <devkulkarni> hopefully the workshop goes fine
17:05:00 <ashishjain> We all are very excited
17:05:10 <devkulkarni> I am excited too
17:05:13 <ashishjain> yeah I am sure it will be an awesome workshop
17:05:47 <devkulkarni> vijendar, datsun180b, james_li, ashishjain: in the open discussion session lets brainstorm if there are any low-hanging-fruit bugs that I can take to the workshop
17:06:01 <devkulkarni> for folks to try submitting a patch for
17:06:12 <devkulkarni> the workshop is scheduled for 3 hours.
17:06:19 <vijendar> ok
17:06:30 <devkulkarni> it might be a stretch to do a patch submission from scratch
17:06:52 <devkulkarni> but if someone is interested, we should have some bugs handy
17:07:03 <ashishjain> yeah, correct
17:07:13 <devkulkarni> I have a few ideas
17:07:30 <devkulkarni> would be interested to hear if you have any thoughts as well
17:07:36 <ashishjain> I hope folks are able to setup devstack
17:08:01 <devkulkarni> ashishjain: yeah.. that in itself can be a big first achievement
17:08:08 <ashishjain> solum vagrant development environment
17:08:10 <ashishjain> yeah
17:08:27 <james_li> If people have interesting apps and want to try deploy with solum, thats great too
17:08:37 <devkulkarni> james_li: great point
17:08:46 <ashishjain> yeah good point
17:08:58 <james_li> help solum ecosystem grow :)
17:09:08 <devkulkarni> yeah, trying out apps using solum can also be part of the overall openstack development experience
17:09:09 <devkulkarni> yep
17:09:23 <ashishjain> yeah james_li
17:09:34 <devkulkarni> james_li: you might be thrilled to know that ashishjain and his team are very interested in solum
17:09:47 <james_li> thats great!
17:10:04 <devkulkarni> ashishjain: may be you want to share some of your views on how and where your team/org sees value from solum?
17:10:18 <ashishjain> Sure
17:10:25 <devkulkarni> I think it will be great for other team members to hear
17:10:29 <devkulkarni> cool
17:10:46 <devkulkarni> also, if you can give a brief background on Wipro that will be great to give some context
17:10:55 <ashishjain> Alright
17:11:16 <devkulkarni> cool.. floor is yours
17:11:40 <ashishjain> Wipro is a services company with a size of almost 150,000 employees
17:12:14 <ashishjain> with our offices in almost 70+ countries
17:12:38 <ashishjain> Their is no limit to the expertise we have got, as we have people working on almost every domain
17:12:53 <ashishjain> and almost every aspect of software industry
17:13:41 <ashishjain> We have been doing open source for quite sometime but mostly as a user of open source
17:14:01 <ashishjain> but now the organisation is seriously venturing into giving it back to the various communities
17:14:35 <ashishjain> and we have almost 5000+ members who are seriously focusing on open source software
17:15:03 <ashishjain> we have got communities on big data(hadoop,spark), nodejs, openstack, docker and many more
17:15:27 <ashishjain> and we have a dedicated group called open source Centre Of Excellence
17:16:04 <ashishjain> All the above  internal communities are being driven by COE
17:16:45 <ashishjain> I belong to COE and as part of COE we plan to use OpenStack as our cloud for all the deployments
17:18:13 <ashishjain> When I say deployment we look forward to running Big Data(Hadoop, spark), Middleware ( app servers), Log, Security, Monitoring and many more
17:18:21 <ashishjain> on openstack
17:18:45 <devkulkarni> I see
17:18:45 <ashishjain> As part of this we have done some work already as I discussed with you devkulkarni @tokyo
17:18:54 <devkulkarni> yep
17:19:28 <ashishjain> where we were able to deploy some of our applications using nova-docker, heat, monitor it and even autoscale ( by feeding metrics to ceilometer)
17:19:44 <ashishjain> Solum resembles at a lot to what we have already done and what we plan to do in future
17:20:01 <devkulkarni> that is really great to hear
17:20:03 <ashishjain> and the road map also aligns with our road map
17:20:22 <devkulkarni> +1
17:20:37 <vijendar> good
17:20:52 <devkulkarni> vijendar, james_li, datsun180b: thoughts/comments?
17:20:55 <ashishjain> moreover we would also love to have integrations possible to other frameworks for CI as we as CD
17:21:08 <ashishjain> which devkulkarni has suggested is very much possible
17:21:25 <datsun180b> that diversity flag is history
17:21:27 <ashishjain> fir example jenkins, junit, maven, ant, amazon etc
17:21:35 <ashishjain> fir=for
17:21:38 <devkulkarni> yes, that should be possible.
17:21:44 <devkulkarni> +1 datsun180b :)
17:21:52 <ashishjain> and that is what is really exciting about solum
17:22:07 <ashishjain> But I know their is lot to be done, atleast be able to  deploy multi container app
17:22:09 <james_li> great to know ashishjain :)
17:22:27 <ashishjain> which will really make solum useful to lot of organisation
17:22:44 <ashishjain> so thats all about our thoughts
17:23:00 <ashishjain> thanks james_li devkulkarni vijendar datsun180b
17:23:03 <devkulkarni> ashishjain: yes, that is one of the major features which I want us to focus on in this cycle
17:23:22 <devkulkarni> thanks ashishjain for providing your perspective and thoughts about solum
17:23:33 <ashishjain> my pleasure devkulkarni
17:24:04 <devkulkarni> alright.. let me move on to the next topic
17:24:18 <devkulkarni> #topic Review Action Items
17:24:38 <devkulkarni> all the three action items are pending.. I did not get chance to work on them
17:24:42 <devkulkarni> so I will just carry them forward
17:24:53 <devkulkarni> #action devkulkarni to figure out details about diverse-affiliation tag associated with solum.
17:25:02 <devkulkarni> #action devkulkarni to send a note to openstack-dev mailing list that our meeting on December 29th is cancelled
17:25:12 <devkulkarni> #action devkulkarni to figure out how to retire solum readthedocs site
17:25:59 <devkulkarni> #topic Blueprint/Bug Review and Discussion
17:26:13 <devkulkarni> there are couple of patches on which devstack tests are failing
17:26:20 <devkulkarni> #link https://review.openstack.org/#/c/249432/
17:26:33 <devkulkarni> #link https://review.openstack.org/#/c/254344/
17:26:50 <ashishjain> Regarding 254344 their were 7 failures
17:27:04 <ashishjain> 1 was functionaltests.api.v1.test_app.TestAppController.test_app_delete_not_found
17:27:10 <ashishjain> which has been fixed
17:27:12 <datsun180b> beat me to it
17:27:34 <ashishjain> and their are 6 more failures
17:27:41 <devkulkarni> ashishjain: I see
17:27:42 <ashishjain> all on language packs
17:27:44 <ashishjain> functionaltests.api.v1.test_language_pack.TestLanguagePackController.test_language_packs_create
17:27:50 <ashishjain> this is the first one
17:28:02 <devkulkarni> ashishjain: this was the test about which we were talking about earlier, right?
17:28:03 <ashishjain> and all of them fail because of same reason
17:28:10 <ashishjain> yea devkulkarni
17:28:23 <ashishjain> "etails: {"debuginfo": null, "faultcode": "Server", "faultstring": "list index out of range"}"
17:28:46 <devkulkarni> ashishjain: you also investigated the likely cause, right?
17:28:54 <devkulkarni> it is in language_pack_handler?
17:29:33 <ashishjain> yeah
17:29:43 <ashishjain> this fails here
17:29:54 <ashishjain> https://github.com/openstack/solum/blob/master/functionaltests/api/v1/test_language_pack.py
17:29:57 <ashishjain> line number 83
17:30:15 <ashishjain> the reason is /opt/stack/solum/solum/api/handlers/language_pack_handler.py(57)
17:30:37 <devkulkarni> looking
17:31:27 <ashishjain> in raw_content artifacts is empty
17:31:46 <devkulkarni> ashishjain: hmm.. looks like I had recently added a comment there
17:31:53 <ashishjain> and the build is failing after I apply my change
17:32:18 <ashishjain> moreover
17:32:51 <ashishjain> If I run "create lp -> create app -> deploy app -> delete app -> delete lp" all is fine without any failures
17:33:10 <ashishjain> the above is after I apply my patch
17:33:40 <devkulkarni> yes.. in language_pack_handler
17:34:26 <ashishjain> yes their is a comment from you
17:34:51 <ashishjain> and one more thing
17:35:19 <ashishjain> the Workflow.delete which is being used to remove all entries is same as what was earlier in the code
17:35:56 <devkulkarni> hmm..
17:36:11 <ashishjain> https://review.openstack.org/#/c/254344/2/solum/api/handlers/app_handler.py
17:36:21 <ashishjain> line number 58
17:36:27 <ashishjain> has been moved to
17:37:21 <ashishjain> one minute trying to load the heat changes
17:37:35 <devkulkarni> yeah, its in heat.py
17:37:54 <ashishjain> correct
17:38:15 <devkulkarni> I am guessing that failing tests are probably using some data setup in a previous test
17:38:28 <ashishjain> https://review.openstack.org/#/c/254344/2/solum/deployer/handlers/heat.py
17:38:33 <ashishjain> line number 313
17:38:48 <ashishjain> yeah looks like
17:40:04 <devkulkarni> ashishjain: I will try to apply your patch and run tests and see what is going on
17:40:24 <devkulkarni> probably sometime on thursday or friday
17:40:28 <ashishjain> okay actually one more test will fail other than lp
17:40:36 <ashishjain> which is not covered in the current patch
17:40:41 <ashishjain> so just ignore that failure
17:40:41 <devkulkarni> oh okay
17:40:48 <devkulkarni> which one is that?
17:40:52 <ashishjain> functionaltests.api.v1.test_app.TestAppController.test_app_delete_not_found
17:41:02 <ashishjain> the fix is in my workspace
17:41:09 <ashishjain> and have not uploaded it to gerrit
17:41:19 <ashishjain> because I am yet to fix other failures
17:41:51 <devkulkarni> I suggest you amend the commit and upload it to gerrit
17:42:06 <devkulkarni> that way, when I try your patch, only the languagepack tests will be failing
17:42:11 <ashishjain> okay, but it may again fail ( is that okay)
17:42:14 <ashishjain> okay I will do that
17:42:23 <devkulkarni> yes, that is okay
17:42:38 <ashishjain> sure will do it
17:42:48 <devkulkarni> cool thanks ashishjain
17:43:07 <datsun180b> it's totally okay to resubmit patches
17:43:15 <datsun180b> i think my record is in the 40s for a single review
17:43:30 <ashishjain> cool datsun180b
17:43:34 <devkulkarni> +1 datsun180b :)
17:43:48 <ashishjain> :)
17:44:06 <devkulkarni> the other patch which is failing devstack gate is https://review.openstack.org/#/c/249432/
17:44:15 <devkulkarni> this is actually just a docs change patch
17:45:16 <devkulkarni> I am not seeing which tests are failing though: http://logs.openstack.org/32/249432/7/check/gate-solum-devstack-dsvm/5018285/logs/devstacklog.txt.gz
17:45:39 <datsun180b> looks environmental
17:45:43 <devkulkarni> oh just saw this: http://logs.openstack.org/32/249432/7/check/gate-solum-devstack-dsvm/5018285/logs/devstacklog.txt.gz#_2015-12-09_17_08_13_674
17:46:03 <devkulkarni> Can not generate /tmp/solum//solum.conf.sample
17:46:26 <devkulkarni> may be we should just re-trigger the tests
17:46:29 <datsun180b> that error comes from an re match group
17:47:19 <datsun180b> i bet some code's trying re.match(needle, haystack).group() in one line
17:47:40 <devkulkarni> oh okay
17:48:04 <devkulkarni> I have just re-triggered tests
17:48:42 <devkulkarni> if the issue is environmental then probably retrying tests will fix it
17:49:56 <devkulkarni> alright.. I will keep an eye out for that patch
17:50:16 <devkulkarni> in the mean time lets move with next topic
17:51:00 <devkulkarni> Deleting DU image on app delete (#link https://bugs.launchpad.net/solum/+bug/1517588)
17:51:00 <openstack> Launchpad bug 1517588 in Solum "delete-heat-stack-when-app-is-deleted" [High,In progress] - Assigned to Ashish (ashish-jain14)
17:51:20 <devkulkarni> basically, ashishjain and I were discussing about app delete
17:51:31 <devkulkarni> and in that context the question came up of what to do about the app's image
17:52:03 <devkulkarni> you can read about my comments on this here: https://bugs.launchpad.net/solum/+bug/1517588/comments/6
17:52:03 <openstack> Launchpad bug 1517588 in Solum "delete-heat-stack-when-app-is-deleted" [High,In progress] - Assigned to Ashish (ashish-jain14)
17:52:45 <devkulkarni> datsun180b: I remember we had discussed about this topic earlier when you were drafting the app and workflow spec
17:53:05 <devkulkarni> does my comment on the bug align with what we were discussing back then?
17:53:41 <datsun180b> i should think so
17:53:53 <devkulkarni> cool
17:54:00 <datsun180b> cf docker's rmi command
17:54:18 <devkulkarni> yep
17:54:34 <devkulkarni> so that was the main point that I wanted to discuss on this topic
17:54:39 <vijendar> devkulkarni:  you comment makes sense
17:54:56 <vijendar> devkulkarni: your*
17:54:56 <devkulkarni> cool.. thanks vijendar for the feedback
17:55:16 <devkulkarni> alright.. we have five minutes
17:55:30 <devkulkarni> let me quickly go through the remaining two points for today
17:55:44 <devkulkarni> 3) Micro-service architecture spec
17:55:51 <devkulkarni> #link https://review.openstack.org/#/c/254729/
17:55:56 <james_li> devkulkarni: I will review it
17:56:05 <devkulkarni> awesome!! thanks james_li
17:56:22 <vijendar> devkulkarni:  is it possible to add sample app file micro-service spec with multiple containers?
17:56:26 <devkulkarni> datsun180b, vijendar, ashishjain: you also take a look through the spec
17:56:59 <devkulkarni> vijendar: you mean, provide a sample app file?
17:57:04 <ashishjain> devkulkarni: sure I am halfway through it will try to complete it soon
17:57:08 <vijendar> devkulkarni: I mean, sample app file
17:57:16 <vijendar> devkulkarni: correct
17:57:20 <devkulkarni> vijendar: good question..
17:57:21 <datsun180b> i need to start over reading it, got distracted last week
17:57:24 <ashishjain> yeah I actually looked into [3]
17:57:49 <devkulkarni> yes, I will add one
17:57:50 <ashishjain> it would be great to have a sample app file
17:57:56 <devkulkarni> ashishjain: agree
17:58:01 <devkulkarni> [3] is the current app file
17:58:05 <vijendar> devkulkarni: I was trying to visualize how the app file would look like with multi-service/micro-serivice
17:58:06 <ashishjain> yeah
17:58:29 <devkulkarni> vijendar: awesome.. if you have any suggestions please feel free to add it
17:58:50 <devkulkarni> let me create a etherpad real quick for us to share and brainstorm on the app file format
17:58:50 <vijendar> devkulkarni: sure
17:59:20 <devkulkarni> vijendar, datsun180b, james_li, ashishjain: https://etherpad.openstack.org/p/solum-multi-container-app-file
17:59:36 <vijendar> devkulkarni: cool. thanks
17:59:38 <devkulkarni> vijendar: feel free to add your thoughts about sample app file to it
17:59:52 <devkulkarni> we can discuss about the spec next time
17:59:56 <devkulkarni> its almost time
18:00:02 <devkulkarni> #topic Open Discussion
18:00:30 <devkulkarni> please add any low-hanging-fruit bugs to https://etherpad.openstack.org/p/solum-low-hanging-fruit-bugs
18:00:41 <devkulkarni> we did not get a chance to discuss about the bugs today
18:01:07 <devkulkarni> but some of you who are in USA might want to take some time today to suggest some bugs for the workshop tomorrow
18:01:20 <devkulkarni> I will check the etherpad tomorrow morning
18:01:32 <devkulkarni> alright.. we are one minute past the meeting time
18:01:34 <devkulkarni> I will end now
18:01:48 <devkulkarni> thanks datsun180b, vijendar, james_li, ashishjain for attending today
18:01:51 <devkulkarni> see you next week
18:01:55 <devkulkarni> #endmeeting