17:00:18 <devkulkarni> #startmeeting Solum Team Meeting
17:00:18 <openstack> Meeting started Tue Mar 15 17:00:18 2016 UTC and is due to finish in 60 minutes.  The chair is devkulkarni. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:23 <openstack> The meeting name has been set to 'solum_team_meeting'
17:00:26 <devkulkarni> #topic Roll Call
17:00:28 <devkulkarni> Devdatta Kulkarni
17:00:52 <ashishjain> Ashish Jain
17:01:05 <james_li> james li
17:01:26 <devkulkarni> hi james_li ashishjain
17:01:33 <devkulkarni> here is the agenda for today's meeting:
17:01:33 <ashishjain> hi devkulkarni
17:01:36 <james_li> Hi devkulkarni
17:01:39 <devkulkarni> https://wiki.openstack.org/wiki/Meetings/Solum#Agenda_for_2016-03-15_1700_UTC
17:01:52 <devkulkarni> I hope vijendar will join us soon
17:02:02 <vijendar> o/
17:02:08 <devkulkarni> cool
17:02:11 <devkulkarni> hi vijendar
17:02:17 <devkulkarni> we have ashishjain and james_li with us
17:02:23 <devkulkarni> lets begin
17:02:30 <devkulkarni> #topic Announcements
17:02:38 <devkulkarni> 1) PTL Elections
17:02:43 <devkulkarni> http://lists.openstack.org/pipermail/openstack-dev/2016-March/089032.html
17:02:48 <devkulkarni> Candidate proposals due by March 17 23:59 UTC
17:03:14 <devkulkarni> I will submit my candidacy before the deadline
17:03:37 <devkulkarni> If any of you want to also submit, make sure that you keep the deadline in mind
17:03:52 <devkulkarni> last time for some of the projects, folks missed the deadline
17:04:21 <devkulkarni> 2) Ashish Jain to present at IndiaHacks hackathon
17:04:30 <devkulkarni> https://www.hackerearth.com/indiahacks-conference/
17:04:41 <devkulkarni> ashishjain: do you want to update the team about this event?
17:04:44 <ashishjain> Yeah
17:04:47 <devkulkarni> cool
17:04:59 <ashishjain> This is in continuation with the hackathon which started a month back,
17:05:12 <devkulkarni> I see
17:05:32 <devkulkarni> how did the hackathon go ashishjain?
17:05:33 <ashishjain> this is the offline event where there are lot of eminent speakers from lot of organisations - Snapdeal, SAP and many more
17:05:42 <devkulkarni> cool
17:05:48 <ashishjain> Not sure about that devkulkarni
17:05:55 <devkulkarni> yeah, the speaker panel looks amazing
17:06:09 <ashishjain> I have been nominated for hangout section
17:06:17 <devkulkarni> that's awesome ashishjain
17:06:22 <ashishjain> which is going to be around 20 minutes
17:06:42 <ashishjain> I am going to talk about openstack and will use solum as examples wherever required
17:06:48 <devkulkarni> is a hangout session on video, or they are just calling it a hangout session but in reality it will be presentation session?
17:06:54 <devkulkarni> +1 ashishjain
17:07:06 <devkulkarni> let us know if you need any help from us
17:07:23 <ashishjain> my focus will be mainly on contributions and experiences I have gained till now working on open stack and especially from SOLUM
17:07:28 <ashishjain> Sure devkulkarni,
17:07:43 <devkulkarni> ashishjain: I am sure it will be a great session
17:07:49 <devkulkarni> also now you can demo it
17:07:50 <devkulkarni> :)
17:07:57 <ashishjain> I would need help from all of you to provide some interesting references, articles on OpenStack and Solum
17:08:02 <ashishjain> Yeah devkulkarni
17:08:11 <ashishjain> absolutely I can demo some of the stuff too
17:08:25 <devkulkarni> ashishjain: sure, I can send you some pointers/references
17:08:46 <devkulkarni> do let us know how it goes afterwards
17:08:53 <ashishjain> While I may google out lot of stuff, but something from you all may be very helpful
17:09:03 <ashishjain> devkulkarni, looks like I missed a q
17:09:24 <ashishjain> so hangout session will be probably sitting around and discussion some thing
17:09:31 <devkulkarni> ah I see
17:09:33 <ashishjain> may be they provide a screen to project something
17:09:42 <devkulkarni> I see
17:09:44 <ashishjain> it will probably be vidoegraphed
17:09:48 <devkulkarni> oh cool
17:09:51 <ashishjain> I will share the link if there is one
17:10:02 <devkulkarni> yeah, that will be really nice
17:10:10 <ashishjain> yeah,
17:10:22 <ashishjain> dress rehearsal for austin
17:10:23 <ashishjain> :)
17:10:36 <devkulkarni> I am thinking that we should have a common place to host all such solum specific talks/material
17:10:48 <devkulkarni> agree — this will be a good dress rehearsal for austin
17:10:53 <ashishjain> yeah that would be nice
17:11:04 <devkulkarni> let me create a section on our wiki
17:11:48 <ashishjain> yup
17:11:51 <devkulkarni> #action devkulkarni to create a section on our wiki to link articles, talks, etc.  related to solum from team members
17:12:07 <devkulkarni> alright..
17:12:14 <devkulkarni> the third item in announcements is
17:12:20 <devkulkarni> 3) Updates on end-to-end application deployment in devstack
17:12:27 <devkulkarni> - Vagrant repo updated: https://github.com/rackerlabs/vagrant-solum-dev
17:12:35 <devkulkarni> - Steps updated
17:12:40 <devkulkarni> https://github.com/devdattakulkarni/solum-provenance/blob/master/steps-to-enable-solum-with-devstack
17:13:13 <devkulkarni> I have updated our vagrant repo by cleaning out some stuff and adding pins to nova neutron and nova-docker
17:13:38 <ashishjain> Devkulkarni, it is successful now I have tested it sometime back
17:13:40 <devkulkarni> the steps listed in the solum-provenance repo was also updated with these pings
17:13:52 <devkulkarni> ashishjain: that is really good to know
17:13:54 <ashishjain> devkulkarni, thanks a lot for fixing all this up
17:14:07 <devkulkarni> ashishjain: thanks for the patience
17:14:07 <ashishjain> I was struggling to build this up from last one week
17:14:24 <ashishjain> there are around 3 changes
17:14:29 <devkulkarni> ashishjain: actually this is the first time that you have got an app in READY state, right?
17:14:31 <ashishjain> which I had to do
17:14:37 <devkulkarni> oh okay
17:14:41 <devkulkarni> what were the changes?
17:14:52 <ashishjain> devkulkarni, no I got it in some instances but it was never consistent
17:14:52 <devkulkarni> I can update the steps and vagrant
17:15:01 <ashishjain> one change is with respect to nova
17:15:06 <devkulkarni> ashishjain: ah I see
17:15:14 <ashishjain> scheduler_driver = filter_scheduler
17:15:25 <ashishjain> I keep this as is,
17:15:29 <devkulkarni> I see
17:15:40 <devkulkarni> yeah, probably it should be that way
17:15:46 <ashishjain> 2nd change is, that only n-cpu fails
17:15:52 <ashishjain> and not n-sch
17:16:01 <devkulkarni> yeah, I had noticed that
17:16:04 <devkulkarni> makes sense
17:16:44 <ashishjain> lastly, I wouldnt say it as a change but I had to modify examples/apps/cherrypy.yaml
17:16:45 <devkulkarni> was there a third change?
17:16:52 <devkulkarni> oh that's right
17:17:04 <devkulkarni> we just merged a patch yesterday with fixing cherrypy
17:17:17 <ashishjain> where trigger action was test instead of unittest
17:17:22 <devkulkarni> it was not passing the schema validation
17:17:23 <ashishjain> aah okay
17:17:23 <devkulkarni> yep
17:17:30 <ashishjain> this is all
17:17:36 <devkulkarni> somebody had tried it recently and had filed a bug
17:17:44 <devkulkarni> cool
17:17:46 <ashishjain> okay
17:18:10 <devkulkarni> ashishjain: I would encourage you to try deploying same app multiple times, and creating and deploying new apps
17:18:26 <devkulkarni> would be interested in knowing how many of those deploys were successful
17:18:26 <ashishjain> sure I will try that out
17:18:40 <ashishjain> yeah I agree, we need to test the IPV4 fix as well
17:19:10 <devkulkarni> if all the deploys work, we would know that we have fixed the random app deploy issue
17:19:20 <ashishjain> absolutely
17:19:26 <devkulkarni> so yeah, do let me know how it goes
17:19:43 <devkulkarni> alright.. let me go to next topic
17:19:56 <devkulkarni> #topic Patches for Review
17:20:02 <devkulkarni> Update example apps
17:20:06 <devkulkarni> https://review.openstack.org/#/c/292554/
17:20:13 <devkulkarni> this patch is already merged
17:20:23 <devkulkarni> but let me give an update about this patch
17:20:36 <devkulkarni> I am trying to clean up our examples directory
17:20:49 <devkulkarni> I have added a README
17:21:00 <devkulkarni> if you add new example apps, please update the README
17:21:19 <james_li> good point
17:21:41 <devkulkarni> james_li: I am thinking of adding the java sample app that we had created sometime back
17:21:42 <ashishjain> this is nice devkulkarni
17:22:01 <ashishjain> I will see if I can contribute some apps to thsi
17:22:12 <devkulkarni> ashishjain: that will be really awesome
17:22:21 <devkulkarni> now that you have a working environment
17:22:25 <ashishjain> but this will be only a single container app
17:22:26 <ashishjain> yeah
17:22:37 <devkulkarni> ashishjain: yes, these will still be single container apps
17:22:59 <devkulkarni> but they will still be useful in showcasing the capabilities
17:23:16 <ashishjain> yeah
17:23:21 <devkulkarni> if we can add apps for php, nodejs, java that will be nice
17:23:37 <devkulkarni> we already have a nodejs app, but I ran into an issue with it
17:23:48 <devkulkarni> I will share that when we talk about bugs
17:24:09 <devkulkarni> ashishjain: please contribute any other app that you might have in mind
17:24:17 <devkulkarni> more the better
17:24:18 <ashishjain> sure devkulkarni
17:24:36 <devkulkarni> ok, lets discuss about some recent bugs
17:24:48 <devkulkarni> #topic Bug Review
17:24:54 <devkulkarni> New Bugs
17:25:01 <devkulkarni> 1) Nodejs sample app encountering error in nova.
17:25:06 <devkulkarni> https://bugs.launchpad.net/solum/+bug/1557085
17:25:06 <openstack> Launchpad bug 1557085 in Solum "error-deploying-nodejs-application" [Undecided,New]
17:25:34 <devkulkarni> I cleaned the app file for nodejs app, and tried to deploy it
17:25:51 <devkulkarni> the deployment failed with a nova error
17:25:54 <devkulkarni> listed above
17:26:54 <devkulkarni> another bug which I filed this morning is
17:27:12 <devkulkarni> 2) app delete not deleting apps for failed deployments
17:27:18 <devkulkarni> https://bugs.launchpad.net/solum/+bug/1557613
17:27:18 <openstack> Launchpad bug 1557613 in Solum "app-delete-not-deleting-app-for-failed-deployments" [High,New]
17:28:08 <devkulkarni> what is happening for this is that, if for some reason app deployment has failed, the subsequent 'app delete' is encountering exceptions in solum-deployer
17:28:16 <devkulkarni> vijendar: have you seen this issue before?
17:29:38 <vijendar> devkulkarni: no
17:29:48 <devkulkarni> vijendar: oh okay
17:30:14 <devkulkarni> I planning to debug it to see what is going on
17:30:48 <devkulkarni> will update the bug with findings
17:30:52 <devkulkarni> 3) App delete receiving stack not found
17:30:58 <devkulkarni> https://bugs.launchpad.net/solum/+bug/1548382
17:30:58 <openstack> Launchpad bug 1548382 in Solum "app-delete-receiving-stack-not-found" [Critical,New] - Assigned to Vijendar Komalla (vijendar-komalla)
17:31:15 <devkulkarni> I believe this is fixed with your recent patch vijendar, right?
17:31:27 <vijendar> devkulkarni: I think so
17:31:36 <vijendar> devkulkarni: will validate
17:31:39 <devkulkarni> I think so too
17:31:43 <devkulkarni> yeah that will be nice
17:31:47 <devkulkarni> I will validate it too
17:31:55 <devkulkarni> we can close the bug after that
17:32:01 <vijendar> sure
17:32:20 <devkulkarni> those were the new bugs
17:32:38 <devkulkarni> ashishjain: you might want to update the bug that you had created about nova commits
17:32:52 <devkulkarni> you can put the commit that is working for you in the bug comment
17:33:11 <ashishjain> sure devkulkarni
17:33:12 <devkulkarni> and then mark the bug as 'Invalid'
17:33:19 <ashishjain> yup
17:33:24 <devkulkarni> alright
17:33:44 <devkulkarni> any other bugs that need team discussion?
17:34:52 <devkulkarni> alright.. lets move to open discussion then
17:34:58 <devkulkarni> #topic Open discussion
17:35:06 <devkulkarni> Updates from upstream
17:35:13 <devkulkarni> 1) Gate failure due to changes to config generator namespace issue
17:35:17 <devkulkarni> http://lists.openstack.org/pipermail/openstack-dev/2016-March/089123.html
17:35:59 <devkulkarni> last week there was a gate failure in solum the cause of which was incorrect namespace usage by cors middleware related oslo patch
17:36:26 <devkulkarni> the issue was not isolated to solum
17:36:49 <devkulkarni> but was affecting all the projects which had the cors middleware patch merged
17:37:29 <devkulkarni> the issue was first detected in solum.. you can read above email about this
17:38:03 <devkulkarni> folks from oslo team submitted patches to fix the namespace issue in all the projects in which the cors middleware patch was merged
17:38:42 <devkulkarni> in the meanwhile, I had submitted a patch to our repo to not generate solum configuration on the fly, but use a predefined solum.conf file
17:38:59 <devkulkarni> we got it was merged asap so as to unblock our gates
17:39:26 <ashishjain> nice devkulkarni
17:39:42 <devkulkarni> once the namespace change patch is merged in all the projects, we can revert to generating solum.conf on the fly
17:40:03 <devkulkarni> for now, our gates are happy, so it is not an issue
17:40:38 <devkulkarni> apart from this particular topic, nothing major is happening upstream
17:41:06 <devkulkarni> may be the ptl nominations this week is the other topic
17:41:23 <devkulkarni> which I already covered in the announcements
17:41:52 <devkulkarni> is there anything else that we need to cover today?
17:43:25 <devkulkarni> if not, we can end the meeting early. you all can get back some time.
17:44:08 <devkulkarni> alright then..
17:44:19 <devkulkarni> thanks ashishjain, vijendar, james_li for joining today
17:44:25 <devkulkarni> have a great week
17:44:29 <ashishjain> thanks devkulkarni
17:44:33 <devkulkarni> #endmeeting