17:00:14 <devkulkarni1> #startmeeting Solum Team Meeting
17:00:15 <openstack> Meeting started Tue Apr 12 17:00:14 2016 UTC and is due to finish in 60 minutes.  The chair is devkulkarni1. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:19 <openstack> The meeting name has been set to 'solum_team_meeting'
17:00:25 <devkulkarni1> #topic Roll Call
17:00:31 <devkulkarni1> Devdatta Kulkarni
17:01:07 <devkulkarni1> hi vijendar
17:01:26 <vijendar> devkulkarni1: o/
17:01:47 <devkulkarni1> here is agenda for today's meeting: https://wiki.openstack.org/wiki/Meetings/Solum#Agenda_for_2016-04-12_1700_UTC
17:02:02 <devkulkarni1> lets wait for some time to allow others to join the meeting
17:02:13 <vijendar> sure
17:02:23 <adrian_otto> o/
17:02:30 <devkulkarni1> hi adrian_otto
17:02:34 <Ablu> hi ho
17:02:39 <devkulkarni1> hi Ablu
17:02:53 <devkulkarni1> here is agenda for today's meeting: https://wiki.openstack.org/wiki/Meetings/Solum#Agenda_for_2016-04-12_1700_UTC
17:03:08 <devkulkarni1> I think we have a quorum, so we can get started
17:03:16 <devkulkarni1> #topic Announcements
17:03:28 <devkulkarni1> 1) New TC members
17:03:35 <devkulkarni1> #link http://lists.openstack.org/pipermail/openstack-dev/2016-April/091702.html
17:03:53 <devkulkarni1> Last week the TC election results were out
17:04:10 <devkulkarni1> Check the above link for the new folks who will be joining the openstack tc
17:04:41 <devkulkarni1> 2) Austin summit tracks
17:04:48 <devkulkarni1> Solum Fishbowl session: April 28, Thursday, 4:10 - 4:50
17:04:54 <devkulkarni1> Solum Work room: April 28, Thursday, 5:00 - 5:40
17:05:00 <devkulkarni1> #link https://etherpad.openstack.org/p/solum-austin-summit-planning
17:05:24 <devkulkarni1> I have been announcing this in last couple of meetings too about our fishbowl session and the workroom session
17:05:57 <devkulkarni1> please feel free to add items to the etherpad that we should cover in the workroom session
17:06:22 <devkulkarni1> apart from these two announcements, I don't have any other announcement
17:06:39 <devkulkarni1> do any of the team members have anything that they want to share with the team?
17:07:39 <devkulkarni1> alright.. lets move to next topic then
17:07:51 <devkulkarni1> #topic Review Action Items
17:08:01 <devkulkarni1> (devkulkarni) (todo) Follow up with the devstack team
17:08:31 <devkulkarni1> I had a todo to follow up with the devstack team to figure out the issue with n-dhcp log file
17:08:43 <devkulkarni1> which was causing our gate tests to fail
17:08:59 <devkulkarni1> I haven't yet had time to follow up with the devstack team yet
17:09:19 <devkulkarni1> I will carry the todo forward
17:10:00 <devkulkarni1> #action devkulkarni to follow up with the devstack team regarding n-dhcp log file issue which is causing solum's devstack gate tests to fail
17:10:28 <devkulkarni1> were there any other action items that any of you had in mind which we haven't tracked?
17:10:45 <adrian_otto> I don't remember any from last week
17:10:56 <devkulkarni1> ok cool
17:11:24 <devkulkarni1> moving on to next topic then
17:11:35 <devkulkarni1> #topic Patches for Review
17:11:50 <devkulkarni1> there are no outstanding patches that need immediate attention :)
17:12:04 <devkulkarni1> https://review.openstack.org/#/q/project:openstack/solum+status:open,n,z
17:12:10 <devkulkarni1> https://review.openstack.org/#/q/project:openstack/python-solumclient+status:open,n,z
17:12:22 <devkulkarni1> client patch queue is empty
17:12:38 <devkulkarni1> the patches for the service side are non-blockers ..
17:12:52 <devkulkarni1> some of them are bit old
17:13:25 <devkulkarni1> vijendar, Ablu: are you working on any bug/code which needs review?
17:13:53 <Ablu> devkulkarni1: i only worked the last week. I did nothing really
17:13:56 <vijendar> sorry… I did not get a chance to work on bugs assigned to me. will work on this week
17:14:12 <devkulkarni1> Ablu, vijendar: no worries
17:14:24 <devkulkarni1> just wanted to check if there is anything in the pipeline that we should be aware of
17:14:35 <devkulkarni1> something that you might want to get reviewed..
17:15:01 <devkulkarni1> alright
17:15:16 <devkulkarni1> hi dimtruck
17:15:46 <dimtruck> hi sir
17:16:08 <devkulkarni1> now that I have caught your attention, wanted to quickly check up on this: https://review.openstack.org/#/c/264899/
17:16:09 <devkulkarni1> :)
17:16:41 <devkulkarni1> there was discussion last week on the mailing list about separating tempest tests in a different repository
17:16:47 <devkulkarni1> let me see if I can find that
17:17:05 <devkulkarni1> http://lists.openstack.org/pipermail/openstack-dev/2016-April/091295.html
17:17:20 <devkulkarni1> this was from designate team
17:17:53 <devkulkarni1> while the tempest team suggests/recommends that it is better to extract the tests in its own repository, no team seems to be doing that yet
17:18:14 <devkulkarni1> designate probably is the first team which is attempting that
17:18:28 <devkulkarni1> dimtruck: wanted to get your perspective on this..
17:19:01 <adrian_otto> why? What's the rationale behind that?
17:19:26 <adrian_otto> (reading the ML)
17:19:46 <devkulkarni1> pros/cons of both approaches have come up in that thread
17:20:24 <adrian_otto> the requirements argument seems persuasive, but I'd like to quantify what the difference would be
17:20:31 <devkulkarni1> one thing going for separating the repo is to separately manage the requirements of test repo and the main repo
17:20:39 <devkulkarni1> agree
17:20:58 <devkulkarni1> how is it being done in magnum adrian_otto?
17:21:05 <adrian_otto> in tree
17:21:18 <devkulkarni1> ok.. so same as most of the projects I believe
17:21:39 <adrian_otto> #link http://docs.openstack.org/developer/tempest/plugin.html#standalone-plugin-vs-in-repo-plugin
17:23:08 <dimtruck> devkulkarni1: so magnum uses in-plugin but we're one of the few
17:23:17 <dimtruck> because that was the approach from the last summit
17:23:23 <dimtruck> as you've mentioned, that changed a bit recently
17:23:27 <devkulkarni1> while the advantages for separating out are persuasive, as you were saying, landing two patches is something which can incur delays
17:23:30 <dimtruck> i still like the plugin approach
17:24:08 <adrian_otto> in a separate repo, dimtruck?
17:24:10 <devkulkarni1> dimtruck: I think the issue is not whether to use plugin or not.. the issue is where to keep the tests
17:24:11 <dimtruck> (i apologize for not answering promptly, in a physical meeting)
17:24:17 <dimtruck> adrian_otto: no, the way we did it in magnum
17:24:18 <dimtruck> in tree
17:24:27 <adrian_otto> yeah, that's the usual way
17:24:43 <dimtruck> the plugin approach has only been implemented by, i think 4 projects
17:24:51 <dimtruck> sahara, manilla, magnum, and ceilometer
17:24:58 <dimtruck> (may hve been more since i looked)
17:25:16 <adrian_otto> did Designate pull the plugin into another repo, devkulkarni1?
17:25:31 <dimtruck> oh, and designate
17:25:45 <devkulkarni1> adrian_otto: the last on that thread was that they were going to do that
17:25:51 <dimtruck> https://github.com/openstack/designate/tree/master/functionaltests/api
17:25:56 <dimtruck> they're still there
17:26:19 <devkulkarni1> adrian_otto: I will check with the designate team at rax about the latest on this
17:26:34 <dimtruck> actually, they don't have tempest-plugin implemented
17:27:04 <adrian_otto> so Solum would be the first if that approach were pursued?
17:27:18 <dimtruck> i believe so
17:27:28 <devkulkarni1> unless designate does it
17:27:29 <dimtruck> i haven't seen anyone else do this...i can ask around
17:27:50 <devkulkarni1> dimtruck: also, on your patch, curious what all things are required to push it forward
17:28:00 <dimtruck> devkulkarni1: just me rebasing
17:28:01 <dimtruck> i'm sorry
17:28:11 <dimtruck> i'll attempt to get this pushed through this week
17:28:16 <devkulkarni1> dimtruck: no worries.. I know you have been busy
17:28:16 <dimtruck> (time flies)
17:28:48 <devkulkarni1> dimtruck: if you can push it this week that would be awesome.. otherwise, after the summit is also fine
17:28:58 <dimtruck> i'll definitely try
17:29:03 <devkulkarni1> cool
17:29:50 <devkulkarni1> any other thoughts on this topic?
17:30:27 <devkulkarni1> alright
17:30:34 <devkulkarni1> #topic Bug review
17:30:42 <devkulkarni1> #link https://bugs.launchpad.net/solum/+bug/1566891
17:30:43 <openstack> Launchpad bug 1566891 in Solum "show-status-of-solum-services" [Undecided,New]
17:30:50 <devkulkarni1> I registered this bug last week
17:31:32 <devkulkarni1> it is about adding a command to get the status of solum services — if they are up
17:31:51 <devkulkarni1> other projects have this feature I believe
17:32:07 <devkulkarni1> vijendar: do you know how this is done in heat?
17:32:26 <devkulkarni1> dimtruck, adrian_otto: and in magnum?
17:32:27 <vijendar> devkulkarni1: I don't think heat has one
17:32:35 <devkulkarni1> vijendar: oh okay
17:33:37 <vijendar> devkulkarni1: so this will be implemented as a new endpoint and probably admin would use it …right?
17:34:10 <devkulkarni1> yes.. something along those lines
17:34:39 <devkulkarni1> although, looking at the thread from designate
17:34:48 <devkulkarni1> http://lists.openstack.org/pipermail/openstack-dev/2016-April/091548.html
17:35:09 <devkulkarni1> it looks like they are thinking of adding this feature as part of the cli commands
17:35:47 <devkulkarni1> are they locking down the commands only to admin?
17:35:50 <devkulkarni1> don't know..
17:36:15 <vijendar> ok
17:36:32 <devkulkarni1> something for us to think about
17:36:44 <vijendar> we can keep this bug around and think about it later
17:36:50 <devkulkarni1> agree
17:37:13 <devkulkarni1> Ablu, vijendar: are there other bugs that you had in mind but have not filed yet?
17:38:38 <vijendar> devkulkarni1: I remember you mentioend some time back about creating app and deploying in single api call
17:38:51 <vijendar> devkulkarni1: is there any bug to track that?
17:39:03 <devkulkarni1> vijendar: let me check
17:39:35 <Ablu> not for my part
17:40:07 <devkulkarni1> Ablu: ok
17:40:17 <devkulkarni1> vijendar: I don't see that bug
17:40:34 <devkulkarni1> vijendar: I can file it
17:40:45 <vijendar> devkulkarni1: thanks
17:41:01 <devkulkarni1> alright.. lets move on to open discussion
17:41:07 <devkulkarni1> #topic Open Discussion
17:41:25 <devkulkarni1> Some updates from the upstream
17:41:31 <devkulkarni1> 1) Eliminating the devstack layer
17:41:35 <devkulkarni1> http://lists.openstack.org/pipermail/openstack-dev/2016-April/091764.html
17:42:17 <devkulkarni1> This one is about issues that arise when configuring a service in devstack vs. when configuring it in a real deployment
17:42:49 <devkulkarni1> it is an interesting read
17:43:25 <devkulkarni1> 2) Common abstraction for different compute form factors (VMs, bare metal, containers)
17:43:34 <devkulkarni1> #link http://lists.openstack.org/pipermail/openstack-dev/2016-April/091947.html
17:44:12 <devkulkarni1> This one is about providing a common api to provision different kinds of compute things
17:44:21 <devkulkarni1> VMs, bare metal servers, containers
17:44:54 <devkulkarni1> lot of good points and discussion on this thread
17:45:57 <devkulkarni1> 3) Cross-project sessions
17:46:04 <devkulkarni1> #link https://etherpad.openstack.org/p/newton-cross-project-sessions
17:46:18 <devkulkarni1> I think the cross-project sessions have now been finalized
17:46:34 <devkulkarni1> above etherpad link contains all the sessions that were proposed
17:46:46 <devkulkarni1> only some of them have been selected for the summit
17:47:12 <devkulkarni1> I could not locate the email in which the final cross project session schedule was announced
17:48:07 <devkulkarni1> summit discussions on any of the cross-project sessions would be interesting imo
17:48:17 <devkulkarni1> I will definitely be attending them
17:48:40 <devkulkarni1> anyways.. that is all I had for open discussion
17:49:12 <devkulkarni1> anything you have on mind to discuss?
17:53:01 <devkulkarni1> alright then.. I can end early and give 10 minutes back to all :)
17:53:09 <devkulkarni1> thanks for joining the meeting today
17:53:17 <devkulkarni1> see you next week
17:53:23 <devkulkarni1> #endmeeting