17:00:18 <devkulkarni1> #startmeeting Solum Team Meeting
17:00:19 <openstack> Meeting started Tue Apr 19 17:00:18 2016 UTC and is due to finish in 60 minutes. The chair is devkulkarni1. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:22 <openstack> The meeting name has been set to 'solum_team_meeting'
17:00:26 <devkulkarni1> #topic Roll Call
17:00:32 <devkulkarni1> Devdatta Kulkarni
17:02:38 <vijendar> o/
17:02:39 <devkulkarni1> hi vijendar
17:02:46 <devkulkarni1> lets wait for few minutes
17:03:08 <devkulkarni1> here is the agenda for today's meeting: https://wiki.openstack.org/wiki/Meetings/Solum#Agenda_for_2016-04-19_1700_UTC
17:07:40 <vijendar> devkulkarni1: did any one else join the meeting?
17:07:57 <devkulkarni1> vijendar: no, right now its just you and me
17:08:06 <vijendar> ok
17:08:27 <devkulkarni1> Ablu said he will join later
17:09:04 <devkulkarni1> vijendar: lets wait for 10 more minutes.. if no one shows up we can end the meeting then
17:09:30 <vijendar> devkulkarni1: sure
17:09:43 <vijendar> devkulkarni1: as we are waiting, I have one quick question
17:10:03 <devkulkarni1> sure
17:10:28 <vijendar> is there any limit on length of the languagepack/app name?
17:10:54 <devkulkarni1> yes, there is
17:10:54 <vijendar> and also languagepack/app image name
17:11:00 <devkulkarni1> yes
17:11:10 <devkulkarni1> let me check the schema
17:11:12 <vijendar> do remember what that length is?
17:11:15 <vijendar> ok
17:11:29 <devkulkarni1> I remember we had put it in to get around some issue
17:12:13 <devkulkarni1> vijendar: https://github.com/openstack/solum/blob/master/solum/objects/sqlalchemy/image.py
17:12:25 <devkulkarni1> lp name can be 100 characters
17:12:37 <devkulkarni1> and so is du name
17:12:46 <devkulkarni1> lps and dus are stored in the image table
17:13:00 <devkulkarni1> app name also has same limit
17:13:00 <devkulkarni1> https://github.com/openstack/solum/blob/master/solum/objects/sqlalchemy/app.py
17:13:51 <vijendar> devkulkarni1: thanks
17:15:25 <Ablu> I am there
17:15:56 <devkulkarni1> hi Ablu
17:16:00 <devkulkarni1> we have vijendar as well
17:16:12 <vijendar> Hi Ablu
17:16:14 <devkulkarni1> cool, we can get started then
17:16:38 <vijendar> sure
17:16:39 <devkulkarni1> here is the agenda for today's meeting: https://wiki.openstack.org/wiki/Meetings/Solum#Agenda_for_2016-04-19_1700_UTC
17:16:48 <devkulkarni1> #topic Announcements
17:16:53 <devkulkarni1> Austin summit sessions related to/featuring Solum
17:17:00 <devkulkarni1> #link https://www.openstack.org/summit/austin-2016/summit-schedule/global-search?t=Solum
17:17:33 <devkulkarni1> If you check above link, you should see all the sessions related to Solum happening at the OpenStack summit next week here in Austin
17:18:34 <devkulkarni1> Ablu, vijendar: I am working on presentation for fishbowl session. In this presentation I would like to include your use-cases and experiences.
17:18:42 <devkulkarni1> would that be okay with you?
17:19:33 <Ablu> For me yes, though of course it is not "my" usecase really :p
17:19:45 <Ablu> afk 1 secod
17:20:31 <devkulkarni1> sure, it is the use case from the research group that you are part of
17:20:33 <devkulkarni1> :)
17:20:35 <devkulkarni1> thanks Ablu
17:21:34 <devkulkarni1> I will be also including use-case and experience of ashishjain and his colleagues/team from wipro
17:22:35 <devkulkarni1> if you have any thoughts on what worked for you in solum, what can be changed/improved, what was unexpected, etc. please send them my way
17:23:15 <Ablu> back
17:23:41 <devkulkarni1> Ablu: you did not miss much
17:23:41 <vijendar> sure
17:23:46 <devkulkarni1> thanks vijendar
17:23:55 <Ablu> devkulkarni1: i see all logs :)
17:23:55 <devkulkarni1> 2) Keystone cli is getting deprecated
17:24:06 <devkulkarni1> Ablu: +1 :)
17:24:15 <devkulkarni1> http://lists.openstack.org/pipermail/openstack-dev/2016-April/092611.html
17:24:33 <devkulkarni1> ^^ was sent out recently by Keystone PTL
17:24:47 <devkulkarni1> basically they are removing keystone cli from the keystone-client code
17:25:26 <devkulkarni1> they want everyone to move over to using openstack cli for doing things like, user creation, role creation, user-role association, etc.
17:25:45 <devkulkarni1> I checked this morning if we are going to be affected by this
17:26:02 <devkulkarni1> fortunately, we are not. we have already moved away from keystone cli a while back
17:26:28 <vijendar> devkulkarni1: that's good to know
17:26:35 <devkulkarni1> if you are curious, the place where we used to use keystone cli is: https://github.com/openstack/solum/blob/master/devstack/plugin.sh
17:27:03 <devkulkarni1> you can search for things like 'user create' in that file
17:27:15 <devkulkarni1> and you will see that we are using 'openstack user create' etc.
17:27:38 <devkulkarni1> this was the place where we earlier used to use the keystone-cli
17:28:11 <devkulkarni1> alright.. so those were the announcements that I had prepared
17:28:30 <devkulkarni1> are they announcements that any of you would like to make?
17:28:50 <vijendar> none from me
17:29:11 <Ablu> not from me either I guess :P
17:29:19 <devkulkarni1> alright
17:29:25 <devkulkarni1> lets move on to the next topic then
17:29:37 <devkulkarni1> #topic Review Action Items
17:29:42 <devkulkarni1> (devkulkarni) (todo) Follow up with the devstack team
17:30:04 <devkulkarni1> I haven't gotten around to doing this yet. Will carry it forward
17:30:19 <devkulkarni1> #action devkulkarni to follow up with the devstack team regarding n-dhcp log file issue which is causing solum's devstack gate tests to fail
17:30:40 <devkulkarni1> #topic Patches for Review
17:31:07 <devkulkarni1> there were couple of patches that I pushed last week
17:31:38 <devkulkarni1> https://review.openstack.org/#/c/306579/ — this allows creation of an app in solum without requiring a corresponding languagepack to be created first
17:31:56 <devkulkarni1> https://review.openstack.org/#/c/306580/ —> this is the corresponding cli patch
17:32:22 <devkulkarni1> the reason we need this functionality is explained in the bug description:
17:32:35 <devkulkarni1> https://bugs.launchpad.net/solum/+bug/1571011
17:32:37 <openstack> Launchpad bug 1571011 in Solum "make-languagepack-optional-in-app-create" [Medium,In progress] - Assigned to Devdatta Kulkarni (devdatta-kulkarni)
17:33:08 <Ablu> What is "DU" in this context?
17:33:26 <Ablu> (the issue mentions it)
17:33:37 <devkulkarni1> Ablu: good question.. a DU is short form for 'Deployment unit'
17:33:43 <Ablu> ah ok.
17:34:07 <devkulkarni1> it is basically Docker container formed from injecting application code into the languagepack docker container
17:34:28 <Ablu> Yep, got it.
17:34:31 <devkulkarni1> Ablu: cool
17:35:18 <devkulkarni1> the setup that ashishjain is working on needs this functionality
17:35:44 <devkulkarni1> the other patch that I submitted this to put a limit on the number of languagepacks that can be created
17:35:58 <devkulkarni1> #link https://review.openstack.org/#/c/306637/
17:36:06 <vijendar> devkulkarni1: so each deployment with DU specified will be a new app?
17:37:10 <devkulkarni1> vijendar: good question. I think the current code does not check whether an app exists or not. But I think I should check that
17:38:01 <devkulkarni1> right now, yes, it will have to be a separate app.. 'solum app create <app-name> —no-languagepack' will register the app
17:38:02 <vijendar> devkulkarni1: does that mean, app needs to be pre-created?
17:38:12 <vijendar> devkulkarni1: I see
17:38:21 <devkulkarni1> then 'solum app deploy <app-name> —du-id <du-id>' will deploy the app
17:38:27 <vijendar> devkulkarni1: probably that is not the right behavior..I am not sure
17:39:26 <vijendar> devkulkarni1: I take that back.. probably it is OK :)
17:40:18 <devkulkarni1> vijendar: the other behavior could be that we can create an app if it does not exist, something like: 'solum app deploy <app-name> —du-id <du-id> —no-languagepack'
17:40:41 <devkulkarni1> the problem is that 'solum app deploy' is actually a POST to /v1/apps/<app-id>/workflows'
17:41:15 <devkulkarni1> so we still have to first create an app (using POST /v1/apps) and then call the POST to workflows
17:41:25 <vijendar> ok
17:41:45 <devkulkarni1> but the —no-languagepack flag does not make sense for the 'solum app deploy' command
17:42:12 <devkulkarni1> oh, btw, let me take my earlier point back
17:42:37 <devkulkarni1> where I was saying that, for multiple deploys, we will end up creating an app.. that is actually not the case
17:43:02 <devkulkarni1> since you already have an app name, you can just call 'solum app deploy <app-name> —du-id <du-id-1>'
17:43:14 <devkulkarni1> solum app deploy <app-name> —du-id <du-id-2>
17:43:16 <devkulkarni1> and so on
17:43:53 <devkulkarni1> but good question vijendar
17:44:13 <devkulkarni1> Ablu, vijendar: please take a look at the code whenever you get a chance
17:44:27 <vijendar> devkulkarni1: sure
17:44:39 <devkulkarni1> alright
17:44:46 <Ablu> I quickly viewed it, but I do not know your code really...
17:45:22 <devkulkarni1> Ablu: sure.. can understand. you will get to know the code slowly as you get more familiar with it
17:45:27 <devkulkarni1> so no pressure
17:45:56 <devkulkarni1> are there any patches that you want to discuss?
17:46:59 <vijendar> no
17:47:12 <devkulkarni1> alright
17:47:22 <devkulkarni1> #topic Open Discussion
17:47:30 <devkulkarni1> Summit sessions
17:47:35 <devkulkarni1> https://www.openstack.org/summit/austin-2016/summit-schedule/#day=2016-04-25
17:47:46 <devkulkarni1> summit schedule is up
17:48:47 <vijendar> thanks devkulkarni1 for sharing the schedule
17:49:01 <devkulkarni1> btw, I propose we cancel next week's meeting as most of community will be at the summit
17:49:05 <devkulkarni1> what do you think?
17:49:15 <vijendar> devkulkarni1: +1
17:49:28 <Ablu> For me it is a hassle with the train always anyway :)
17:49:40 <devkulkarni1> Ablu: :)
17:49:44 <devkulkarni1> alright then.
17:50:20 <devkulkarni1> we will cancel next week's meeting. we can reconvene on May 3 2016
17:50:33 <vijendar> sure
17:51:30 <devkulkarni1> anything else that you want to discuss in open discussion?
17:51:45 <Ablu> nothing from my side :)
17:51:57 <stevemar> devkulkarni1: thanks for migrating over to openstackclient :)
17:52:42 <devkulkarni1> stevemar: :)
17:53:10 <devkulkarni1> stevemar: actually we did it long time back.. your email got me checking it again in our code base
17:53:20 <devkulkarni1> looks like we are safe
17:53:55 <stevemar> yep, looks like it - at least codesearch didn't find anything for solum :)
17:54:29 <Ablu> Have a nice evening (or day for america)
17:54:36 <devkulkarni1> yep.. btw, how are others progressing on it? reading your email I felt there were quite a few projects
17:54:40 <devkulkarni1> Ablu: thanks
17:54:48 <devkulkarni1> Ablu: have a great night
17:55:03 <devkulkarni1> Ablu: I will be available on irc throughout the week
17:55:24 <devkulkarni1> so if you want to discuss anything, share anything, you should be able to find me
17:55:34 <stevemar> devkulkarni1: its actually fewer projects than i initially thought :)
17:55:51 <Ablu> ok :)
17:55:52 <devkulkarni1> stevemar: I see.. that is good to know
17:56:03 <stevemar> devkulkarni1: ceilometer/ironic/murano/designate all tossed up fixes really quickly
17:56:16 <devkulkarni1> nice!!
17:56:20 <stevemar> the others... well, they are fairly disconnected anyway, i may just fix them myself
17:56:31 <devkulkarni1> oh
17:56:48 <stevemar> like gce-api and kiloeyes
17:57:08 <stevemar> *shakes fist at big tent*
17:57:27 <devkulkarni1> btw, just something that came to my mind when I read the email.. whether the client release could be postponed to after the summit? as many folks might not be able to take action..
17:57:31 <devkulkarni1> ha ha
18:00:15 <devkulkarni1> alright everyone
18:00:18 <devkulkarni1> thanks for joining today
18:00:29 <devkulkarni1> we will meet after the summit in two weeks
18:00:36 <devkulkarni1> #endmeeting