14:00:22 <devkulkarni1> #startmeeting Solum Team Meeting
14:00:23 <openstack> Meeting started Wed Jun  1 14:00:22 2016 UTC and is due to finish in 60 minutes.  The chair is devkulkarni1. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:27 <openstack> The meeting name has been set to 'solum_team_meeting'
14:00:40 <devkulkarni1> #topic Roll Call
14:00:45 <devkulkarni1> Devdatta Kulkarni
14:02:38 <zhurong> 0/ zhurong
14:02:44 <Ablu> hiho
14:02:44 <devkulkarni1> hi zhurong
14:02:47 <devkulkarni1> hi Ablu
14:03:05 <zhurong> hi devkulkarni1 Ablu
14:03:09 <devkulkarni1> good to see you
14:03:27 <devkulkarni1> here is agenda for today's meeting: https://wiki.openstack.org/wiki/Meetings/Solum#Agenda_for_2016-06-01_1400_UTC
14:03:44 <caowei> caowei
14:03:49 <devkulkarni1> hi caowei
14:03:56 <devkulkarni1> we have zhurong and Ablu as well
14:03:57 <zhurong> we have two meetings in one day :)
14:04:01 <devkulkarni1> :)
14:04:07 <devkulkarni1> sorry about that
14:04:11 <caowei> hi devkulkarni1
14:04:15 <devkulkarni1> the patch got merged this morning
14:04:19 <caowei> hi zhurong
14:04:35 <devkulkarni1> so thought of holding a meeting even though we had one yesterday
14:04:38 <zhurong> caowei hi
14:05:09 <devkulkarni1> we can keep it short
14:05:18 <devkulkarni1> #topic Announcements
14:05:49 <devkulkarni1> 1) Welcome
14:06:17 <devkulkarni1> I realized that we have not officially welcomed caowei and zhurong. So, welcome guys :)
14:06:40 <Ablu> welcome :P
14:06:45 <zhurong> Thanks, devkulkarni1
14:06:56 <zhurong> Thx Ablu
14:07:24 <devkulkarni1> Do you want to give some context and background about yourself?
14:07:33 <caowei> Thanks ,devkulkarni1 Ablu
14:08:22 <zhurong> Actualy we are colleague
14:08:31 <devkulkarni1> oh nice
14:09:09 <zhurong> We are all from china
14:09:24 <zhurong> and we work for 99cloud
14:09:31 <caowei> We are from the same company.
14:09:32 <devkulkarni1> zhurong: have you attended any openstack summits?
14:09:35 <caowei> yes
14:09:46 <devkulkarni1> caowei: cool.. which one?
14:09:57 <devkulkarni1> may be we have crossed paths earlier :)
14:10:10 <devkulkarni1> I was at the Atlanta summit, Tokyo summit, and Austin summit
14:10:43 <caowei> devkulkarni1: no,I didn't attend
14:11:06 <zhurong> actually I never been any of there
14:11:24 <devkulkarni1> zhurong, caowei: oh okay..
14:11:37 <devkulkarni1> that's fine .. there will be other opportunities
14:12:30 <devkulkarni1> btw, if you can share the usecases for which 99cloud is using/investigating solum, that can help us with building out feature roadmap
14:12:38 <devkulkarni1> no pressure though
14:12:50 <caowei> devkularni1: I've been watching your share.
14:13:10 <devkulkarni1> you mean slideshare?
14:14:16 <devkulkarni1> caowei: thank you. I am glad you found those presentations interesting.. as you might have realized, we are open community .. and I would like to support your use-cases
14:14:19 <caowei> And the summit
14:15:07 <devkulkarni1> caowei: for instance Ablu's use-case is to natively support VMs
14:15:27 <devkulkarni1> caowei: I remember you mentioning about such a use-case as well
14:15:28 <caowei> I would like to apply a APP Java in Solum
14:15:38 <devkulkarni1> caowei: ok cool
14:16:04 <devkulkarni1> caowei: have you looked at our Java sample app?
14:16:21 <devkulkarni1> caowei: https://github.com/rackspace-solum-samples/
14:16:30 <devkulkarni1> https://github.com/rackspace-solum-samples/solum-tomcat-app
14:16:40 <devkulkarni1> https://github.com/rackspace-solum-samples/solum-languagepack-java
14:16:52 <devkulkarni1> caowei: that is one example
14:17:04 <devkulkarni1> but personally if you ask me, it will be nice to have some more examples
14:17:08 <caowei> I want to support virtual machines or other driver
14:17:24 <devkulkarni1> so if you have time/bandwidth to add another Java app example that would be really helpful
14:17:51 <devkulkarni1> for instance, what I had in mind was, we can try to see if we are able to deploy heroku's sample Java application using Solum
14:18:08 <devkulkarni1> https://devcenter.heroku.com/categories/java
14:19:29 <devkulkarni1> caowei: about supporting virtual machines — you can collaborate with Ablu on it
14:20:12 <devkulkarni1> Ablu: I was wondering if you can add a blueprint to launchpad about your use-case and what you are planning to do
14:20:25 <devkulkarni1> https://launchpad.net/solum
14:20:40 <devkulkarni1> caowei: about other driver .. which other driver you have in mind?
14:21:00 <Ablu> devkulkarni1: sure. I guess I could copy/paste the stuff from my thesis once I am done there.
14:21:05 <Ablu> I am still at evaluating tools there
14:21:20 <Ablu> did not do a lot of progress over the long weekend
14:21:29 <devkulkarni1> caowei: there was a blueprint filed recently to support unikernel-based applications
14:21:32 <devkulkarni1> caowei: https://blueprints.launchpad.net/solum/+spec/unikernel-support
14:21:38 <devkulkarni1> Ablu: sure, sounds good
14:22:14 <devkulkarni1> caowei: thoughts/comments ?
14:23:01 <caowei> Just one of my thoughts
14:23:42 <caowei> I can only use nova-docker
14:24:21 <devkulkarni1> caowei: currently it is also possible to use a docker container with a VM
14:24:48 <devkulkarni1> the code is there but it has not been well tested in devstack environment
14:24:55 <devkulkarni1> I can help you with it
14:25:11 <devkulkarni1> in fact, it will be really nice to get it working on devstack
14:25:17 <devkulkarni1> the way it works is as follows:
14:25:56 <devkulkarni1> 1) store the application docker container in swift
14:26:07 <devkulkarni1> 2) generate a swift tempURL for it
14:26:10 <caowei> How to test support for virtual machines?
14:26:53 <devkulkarni1> 3) Spin up a VM via Heat.. Pass the swift tempurl to the VM via cloud-init
14:27:18 <devkulkarni1> 4) When the VM spins up, the container is started up
14:27:34 <devkulkarni1> all the above 4 steps are implemented in solum
14:27:53 <devkulkarni1> I can point you the code where all this is implemented
14:28:19 <devkulkarni1> the only issue is that we have not got these 4 steps to work in devstack environment
14:28:40 <caowei> Do you have a few blogs to share?Or instruction document
14:28:40 <devkulkarni1> but it all works fine in our setup at rackspace
14:29:16 <devkulkarni1> caowei: I do have instructions; let me take an action item to add them to the wiki
14:29:45 <devkulkarni1> #action devkulkarni to add instructions on how to use VMs for deployment to Solum wiki
14:29:48 <caowei> I'm interested in this
14:30:01 <caowei> Cool
14:30:14 <devkulkarni1> caowei: sounds good. I will add the instructions later today/tomorrow
14:30:36 <devkulkarni1> caowei: do you have an Openstack setup which is other than devstack?
14:30:59 <devkulkarni1> if so, it will be straightforward to try it there
14:31:09 <devkulkarni1> caowei: cool
14:31:41 <devkulkarni1> good discussion
14:32:23 <devkulkarni1> lot of patches got merged in last couple of days
14:32:55 <devkulkarni1> zhurong, caowei: have you worked on any other openstack projects before?
14:33:25 <devkulkarni1> you seem to have knowledge about things like projects.txt, requirements.txt, etc. .. that is awesome :)
14:33:39 <caowei> Solum is the first project
14:33:44 <devkulkarni1> s/requirements/global-requirements.txt/
14:34:10 <zhurong> devkulkarni1 we have own project last year, but nov did not have continue to do
14:35:28 <devkulkarni1> caowei, zhurong: oh I see.. I felt that it was impressive that you seemed to have the context about openstack projects' meta-level information, such as global-requirements, projects, etc.
14:36:11 <devkulkarni1> in any case I am glad that you chose Solum as your entrypoint to OpenStack
14:36:32 <devkulkarni1> hopefully you will have a great experience
14:37:07 <devkulkarni1> zhurong: thanks for various patches for solum-dashboard
14:38:05 <zhurong> devkulkarni1 actually Horizon is my first project
14:38:13 <devkulkarni1> zhurong: oh I see
14:38:45 <devkulkarni1> zhurong: that experience will be very helpful to us for getting the solum-dashboard code in shape
14:39:03 <caowei> I will spend more time on Solum
14:39:48 <devkulkarni1> zhurong: on a related note, can you educate us Horizon? what is the current status? what is the plugin model? how far solum-dashboard code is from where it needs to be?
14:41:03 <devkulkarni1> caowei: cool. its always good to have more eyes on the main engine
14:41:37 <zhurong> devkulkarni1 Horizon now switching to AnguarJS
14:42:48 <devkulkarni1> zhurong: currently the solum-dashboard code is in django
14:43:03 <devkulkarni1> zhurong: so you recommend that we switch over to using AngularJS?
14:43:24 <zhurong> yes, mostly of the dashboard are django
14:44:16 <devkulkarni1> zhurong: how much effort is it to switch over from django to angularjs?
14:45:30 <devkulkarni1> zhurong: you have looked at this patch https://review.openstack.org/#/c/289021/ .. is this patch in the right direction if we want to go the AngularJS route instead of Django route?
14:45:39 <zhurong> Not have to much effort, horizon guys will build a very good framework
14:46:41 <devkulkarni1> zhurong: I see
14:46:58 <zhurong> devkulkarni1 IMO this patch is not helpful
14:47:45 <devkulkarni1> tell me more .. in what ways is it not helpful? is it not following the horizon framework?
14:47:46 <zhurong> devkulkarni1 I can understand why to do this :)
14:48:24 <zhurong> devkulkarni1 I can not understand why try to do this :)
14:48:46 <devkulkarni1> zhurong: sure .. let me give bit of a context about this patch
14:49:27 <devkulkarni1> so one of the things that I want us to complete in this cycle is to get the solum-dashboard working again. this has several aspects
14:49:49 <devkulkarni1> 1) Get the dashboard to load without errors/issues in Horizon
14:50:21 <devkulkarni1> 2) Add support for using the 'app' and 'languagepack' abstractions to the UI
14:51:23 <devkulkarni1> pt_15 (who is not here today) was looking for a summer internship project, and I suggested this project to her
14:51:52 <devkulkarni1> and as a first step she has submitted above patch
14:52:53 <devkulkarni1> it does not mean that we want to proceed with this patch, or this approach
14:53:32 <devkulkarni1> based on your horizon experience if you think that we should approach this problem differently then I am completely open for that
14:54:15 <devkulkarni1> zhurong: let me create an etherpad where we can discuss and brainstorm high-level approach(es) for this problem
14:55:00 <devkulkarni1> https://etherpad.openstack.org/p/solum-dashboard
14:55:12 <devkulkarni1> I will add this to our list of etherpads
14:55:25 <zhurong> devkulkarni1 I think we should keep the origin framework which comes from horizon
14:55:38 <devkulkarni1> zhurong: can you add your thoughts to it about how you see this problem can be addressed
14:56:04 <devkulkarni1> zhurong: sure, let me add that comment to the etherpad
14:56:13 <zhurong> we need to do is make the solum-dasboard run normally
14:56:55 <devkulkarni1> lets use the etherpad to outline the architecture, the steps, changes to code, etc.
14:57:18 <devkulkarni1> once we have the high-level outline figured out, it will be easy to start implementing
14:57:37 <devkulkarni1> alright.. we are almost at the end of our meeting time
14:57:55 <devkulkarni1> are there any topics that you had in mind?
14:57:56 <zhurong> times fly
14:58:01 <devkulkarni1> yep :)
14:58:06 <devkulkarni1> #topic Open Discussion
14:58:24 <devkulkarni1> Submissions for Barcelona summit are now open
14:58:34 <devkulkarni1> Barcelona summit submissions are now open https://www.openstack.org/summit/barcelona-2016/faq/
14:58:34 <devkulkarni1> •	Deadline: July 13, 2016
14:59:05 <devkulkarni1> We have an etherpad where we are consolidating the topics that we can potentially submit presentations/papers for:
14:59:05 <devkulkarni1> https://etherpad.openstack.org/p/solum-barcelona-2016
14:59:46 <devkulkarni1> caowei, zhurong: please feel free to add any ideas that you may have for a paper/presentation to it
14:59:58 <zhurong> devkulkarni1 OK
15:00:05 <devkulkarni1> we can all collaborate to help build the required features, presentation outlines, etc.
15:00:11 <devkulkarni1> cool
15:00:18 <Swami> hi
15:00:21 <devkulkarni1> it is top of the hour
15:00:24 <devkulkarni1> hi Swami
15:00:26 <caowei> we need to do is make the solum-dasboard run normally
15:00:29 <devkulkarni1> we are just wrapping out
15:00:34 <devkulkarni1> caowei: +1
15:00:36 <devkulkarni1> wrapping up
15:00:48 <devkulkarni1> lets continue in solum channel
15:00:49 <Swami> devkulkarni1: I thought you had already ended your meeting.
15:00:55 <devkulkarni1> thanks all for joining the meeting
15:00:58 <devkulkarni1> #endmeeting