14:00:27 <devkulkarni> #startmeeting Solum Team Meeting
14:00:28 <openstack> Meeting started Wed Nov  9 14:00:27 2016 UTC and is due to finish in 60 minutes.  The chair is devkulkarni. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:30 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:32 <openstack> The meeting name has been set to 'solum_team_meeting'
14:00:46 <devkulkarni> #topic Roll call
14:00:57 <devkulkarni> Devdatta Kulkarni
14:01:08 <zhurong> zhurong
14:01:21 <devkulkarni> hi zhu
14:01:28 <zhurong> hey Dev
14:01:37 <devkulkarni> thanks for joining today
14:01:38 <caowei_> hi All
14:01:43 <devkulkarni> hi caowei_
14:02:09 <devkulkarni> I haven't heard from Ablu whether he will be joining or not
14:02:28 <devkulkarni> we can start
14:02:41 <devkulkarni> here is the agenda for today's meeting: https://wiki.openstack.org/wiki/Meetings/Solum
14:03:13 <devkulkarni> Let me jump to the discussion section
14:03:22 <devkulkarni> #topic Discussion
14:03:44 <devkulkarni> (zhurong) Barcelona summit updates
14:04:06 <devkulkarni> Zhu, floor is yours.. I am curious to know how was the summit experience for you..
14:04:20 <devkulkarni> what all sessions did you attend?
14:04:57 <zhurong> Prepare for my topic, spend a lot of time
14:05:15 <zhurong> so there not too much time to attend the session
14:05:49 <devkulkarni> ah I see.. apart from solum fishbowl, did you present other topics as well?
14:05:52 <zhurong> And due to my pool English... can not under most of the conent
14:06:45 <devkulkarni> ah okay. how was the marketplace? did you visit it?
14:07:00 <zhurong> I attended the release manage session, but can not understand all
14:07:09 <devkulkarni> ok great.
14:07:21 <devkulkarni> I wanted to ask you about it
14:07:37 <devkulkarni> was there any specific highlight from that session that you remember?
14:09:03 <zhurong> nop, just we need follow the email instructions
14:09:26 <devkulkarni> ah okay
14:09:55 <devkulkarni> we can keep an eye out for emails that are tagged with [release] tag
14:10:02 <zhurong> yep
14:10:16 <zhurong> this is the most import thing
14:10:34 <devkulkarni> here is the release schedule for this cycle
14:10:35 <devkulkarni> https://releases.openstack.org/ocata/schedule.html
14:10:58 <devkulkarni> I would encourage you to keep that link handy
14:11:24 <devkulkarni> for us the next important thing coming up is the "Ocata Community Goals Acknowledgement"
14:11:35 <devkulkarni> https://releases.openstack.org/ocata/schedule.html#o-goals-ack
14:11:55 <devkulkarni> the deadline for that is next week
14:12:16 <zhurong> and the summit will seperate into two, user and developer
14:12:18 <devkulkarni> lets discuss today about where we stand as far as the goal of removing incubated oslo code
14:12:29 <devkulkarni> zhurong: yep, that is a good point
14:12:48 <devkulkarni> did you read the email that thierry sent yesterday about Atlanta PTG
14:13:02 <zhurong> and next one in Boston, I think you will attend this one
14:14:03 <devkulkarni> well, I don't know yet..lets see. the PTG is for projects that have large distributed teams
14:14:50 <devkulkarni> but it was great for you to represent solum at Barcelona
14:15:29 <devkulkarni> I know you said that there were not many folks in the fishbowl.. that is okay.. it happens. for Tokyo also we had handful of folks.. but in Austin that number had increased substantially
14:15:44 <devkulkarni> so the attendance ebbs and flows
14:16:06 <devkulkarni> did you get any questions, either in the fishbowl session or during breaks, etc.?
14:17:27 <zhurong> I try to ping pt_15 to attend this meeting, but without reply
14:18:02 <devkulkarni> oh okay
14:18:11 <devkulkarni> yeah, I haven't heard from pt_15 in a while
14:18:32 <devkulkarni> any other thoughts/impressions about the summit?
14:19:37 <zhurong> the most hottest is container and baremetal
14:19:46 <zhurong> NFV
14:20:15 <devkulkarni> I see.. were there several talks/sessions on these topics?
14:20:43 <zhurong> so many topic about those
14:21:19 <devkulkarni> hope you were able to attend some of those sessions
14:22:07 <zhurong> I need improve English listening
14:22:36 <devkulkarni> hmmm.. you will as you keep attending such summits
14:22:57 <devkulkarni> overall seems like you had a good summit
14:23:56 <zhurong> yep, An unforgettable summit, and it is my first summit
14:24:27 <devkulkarni> great to hear that :) . I sincerely hope you are able to attend many more
14:24:54 <zhurong> hope so, and hope to meet you in next summit. :D
14:25:02 <devkulkarni> :)
14:25:39 <devkulkarni> lets switch topics a bit and discuss about our preparedness for satisfying the ocata goal of removing incubated oslo code from solum repositories
14:26:03 <devkulkarni> we have four repositories: solum, python-solumclient, solum-dashboard, and solum-infra-guestagent
14:26:22 <devkulkarni> lets talk about each of them one by one. lets start with solum-infra-guestagent
14:26:58 <devkulkarni> I don't know if you saw, but there was a mailing list thread about this repo recently
14:27:00 <devkulkarni> http://lists.openstack.org/pipermail/openstack-dev/2016-October/106387.html
14:27:19 <zhurong> I saw this
14:27:25 <devkulkarni> let me give background about this repository..
14:28:52 <devkulkarni> early in life of solum, there was a group of participants who wanted to investigate separating the building of app/lp from the main solum code.. their idea was that the solum-worker would send a notification to a build agent, which will build the DU.. this build agent would run separately from solum
14:29:45 <devkulkarni> but not much progress has been made in that direction after some initial work.. the folks who were interested in pursuing that direction are no longer active in solum
14:30:36 <zhurong> what a pity!
14:30:37 <devkulkarni> I had been thinking of removing this repo from official list of solum repositories anyways as it affects our contributor list
14:31:00 <zhurong> agree with this
14:31:10 <devkulkarni> zhurong: yeah.. I guess priorities change
14:31:22 <devkulkarni> zhurong: good to know that you agree as well
14:31:28 <devkulkarni> caowei_: what are your thoughts?
14:33:00 <zhurong> maybe he out of compute
14:33:54 <devkulkarni> ah okay
14:34:48 <devkulkarni> but since you agree to this plan as well, I will propose a patch to project-config to remove this repo from official solum repo list
14:34:55 <devkulkarni> make sense?
14:35:01 <zhurong> yep
14:35:09 <devkulkarni> cool.
14:35:30 <devkulkarni> #agreed we will remove solum-infra-guestagent repo from official list of solum repositories
14:35:47 <devkulkarni> ok, now lets discuss other repositories
14:36:12 <devkulkarni> and Zhu you will be able to update us on that as you have been leading the work on converting all of our repos
14:36:17 <devkulkarni> floor is yours
14:37:41 <zhurong> solum and python-solum are finished
14:38:02 <devkulkarni> awesome, that is good to know
14:38:16 <devkulkarni> and solum-dashboard does not have any incubated oslo stuff, right?
14:38:36 <zhurong> yep
14:38:39 <devkulkarni> great
14:39:09 <devkulkarni> so in the ocata goals acknowledgement patch I will mention all of this
14:39:10 <zhurong> this job had done
14:39:38 <devkulkarni> many thanks to you that we have been able to achieve this goal
14:39:53 <zhurong> :D
14:40:03 <devkulkarni> btw, if you look at the schedule https://releases.openstack.org/ocata/schedule.html
14:40:17 <devkulkarni> the deadline to complete this goal is Jan 23-37
14:40:24 <devkulkarni> s/37/27/
14:41:16 <devkulkarni> cool
14:41:30 <devkulkarni> any other thoughts/comments on this topic?
14:42:04 <zhurong> nop, we had finish this
14:43:15 <devkulkarni> alright
14:43:26 <devkulkarni> lets then discuss about some of the outstanding patches
14:43:58 <devkulkarni> zhurong: can you take a look at this https://review.openstack.org/#/c/384065/
14:46:33 <devkulkarni> and the change in this patch is already done in one of your patches, right?
14:46:34 <devkulkarni> https://review.openstack.org/#/c/387394/1
14:46:44 <zhurong> I think we can merge this
14:47:45 <devkulkarni> how about this: https://review.openstack.org/#/c/390701/1
14:48:22 <devkulkarni> which one did you say we should merge?
14:48:36 <zhurong> https://review.openstack.org/#/c/384065/ this one
14:49:20 <zhurong> https://review.openstack.org/#/c/387394/1 this one is earlier then mine's, I didn't saw this
14:50:05 <devkulkarni> can you add your comments/+2 to the devstack readme changes patch
14:50:36 <zhurong> OK
14:52:16 <devkulkarni> also, please add your comments to the coveragerc change patch
14:52:34 <devkulkarni> I think it is not needed as your patch addressed that issue
14:52:39 <zhurong> done, i leave the -1 with other comment about this https://review.openstack.org/#/c/384065/
14:53:06 <zhurong> yep, sorry for merge my fisrt
14:53:39 <devkulkarni> cool, saw your comments, make sense
14:54:16 <devkulkarni> for the coveragerc patch, you can put link to your patch in the review comment and mention that it covered the change being proposed
14:55:18 <zhurong> done
14:56:14 <devkulkarni> saw your comment
14:56:16 <devkulkarni> looks good
14:56:59 <devkulkarni> cool, so those were some of the outstanding patches that I wanted to discuss
14:57:06 <zhurong> about the py35, I think we should make this later
14:57:37 <devkulkarni> sure, we can hold off on it for a bit
14:57:41 <zhurong> we have some test failed in py35 test
14:58:07 <devkulkarni> do you know which patch had those failing tests?
14:58:24 <devkulkarni> btw, two minute warning
14:58:53 <zhurong> http://logs.openstack.org/02/389502/2/check/gate-python-solumclient-python35-nv/836f43d/testr_results.html.gz
14:59:19 <zhurong> we can discuss in solum channel
14:59:56 <devkulkarni> thanks for the link
15:00:07 <devkulkarni> sure, lets discuss in solum channel
15:00:16 <devkulkarni> its time
15:00:18 <devkulkarni> #endmeeting