21:00:13 <mriedem> #startmeeting stable
21:00:15 <openstack> Meeting started Mon Jan 18 21:00:13 2016 UTC and is due to finish in 60 minutes.  The chair is mriedem. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:18 <openstack> The meeting name has been set to 'stable'
21:00:25 <mriedem> anyone around?
21:00:26 <tonyb_stupidmac> o/
21:00:58 <rockyg> o/
21:01:32 <mriedem> alright, well, might as well get started
21:01:37 <mriedem> #link agenda https://wiki.openstack.org/wiki/Meetings/StableTeam#Agenda
21:01:41 <sigmavirus24> Hi
21:01:48 <mriedem> sigmavirus24: o/
21:01:55 <mriedem> #topic status
21:02:00 <jokke_> o/
21:02:12 <mriedem> #link periodic job failures: http://goo.gl/5qiw2U
21:02:25 <mriedem> there isn't much on there, the neutron *aas stuff is a known issue that tonyb is working on
21:02:32 <mriedem> err tonyb_stupidmac
21:02:40 <tonyb_stupidmac> Yeah I need to push for reviews
21:02:56 <mriedem> cinder had some random unit test failures in liberty on the periodic jobs, but it didn't look serious
21:03:00 <tonyb_stupidmac> or ask ihrachys why we can't just hard code the fix in tox_install
21:03:17 <tonyb_stupidmac> mriedem: Yeah I looked at NFI at the moment.
21:03:21 <mriedem> we can, we talked about that a few weeks ago
21:03:26 <mriedem> it's just gorpy
21:03:32 <ihrachys> tonyb_stupidmac: well... because we have a better fix up for review?
21:03:42 <mriedem> b/c you have to do it in like 3 neutron projects and remember to always do it when they cut a new stable branch
21:03:46 <tonyb_stupidmac> mriedem: but we're hardcoding the branch *anyway* in the pip case
21:04:28 <mriedem> https://review.openstack.org/#/c/245525/ is the review in question
21:05:13 <mriedem> so i guess just looking for infra reviews on that now
21:05:38 <mriedem> #link openstack-health dashboard: http://status.openstack.org/openstack-health/#/g/build_queue/periodic-stable
21:05:40 <tonyb_stupidmac> mriedem: yeah, my point is that http://git.openstack.org/cgit/openstack/neutron-lbaas/tree/tools/tox_install.sh?h=stable/liberty#n38 hard codes it anyway why not do somethign like http://paste.openstack.org/show/483833/
21:06:35 <mriedem> yeah, idk, decent point
21:06:56 <mriedem> i guess that's what people would use locally right?
21:07:16 <tonyb_stupidmac> mriedem: Yeah I think so
21:07:37 <mriedem> that's more clear to me anyway, and it's managed within the repo,
21:07:40 <mriedem> rather than in project-config
21:08:10 <mriedem> let's move on
21:08:21 <mriedem> #link etherpad of issues: https://etherpad.openstack.org/p/stable-tracker
21:08:37 <mriedem> the only newish thing in there is https://bugs.launchpad.net/openstack-gate/+bug/1534813 which came up last friday
21:08:38 <openstack> Launchpad bug 1534813 in OpenStack-Gate "gate-tempest-dsvm-neutron-src-*-liberty jobs are broken" [Undecided,Confirmed]
21:08:56 <mriedem> right now that's only affecting non-voting jobs in oslo master branch changes
21:09:07 <mriedem> i believe it's to test backward compat for oslo libs with stable/liberty
21:09:33 <mriedem> i did some digging on friday but it was really odd, and just started regressing but i couldn't figure out from what
21:09:40 <tonyb_stupidmac> mriedem: I think it's broken in stable not master
21:09:57 <jokke_> so anyone looked into it, is the tests broken or did oslo break backwards compat?
21:09:57 <mriedem> http://logs.openstack.org/95/267895/3/check/gate-tempest-dsvm-neutron-src-oslo.db-liberty/0c2f56e/logs/apache/keystone.txt.gz#_2016-01-15_12_05_55_056201
21:10:19 <mriedem> looks like oslo
21:10:28 <mriedem> when was oslo.config 3.1.0 released?
21:10:31 <tonyb_stupidmac> mriedem: I didn't run what-broke but keystone is barfing as it has 3.1.0 (from contstraints) but oslo.db [ on master] need >= 3.2.0
21:10:49 <mriedem> 3.1.0 was awhile ago
21:10:55 <tonyb_stupidmac> mriedem: so I'm guessing it was a merge form g-r that cause it
21:11:21 <mriedem> there were some keystone snafus on stable last week too....
21:11:43 <mriedem> also in the etherpad, i had asked stevemar to look into that break on friday but we deferred to monday to talk about it, because it was friday :)
21:12:20 <mriedem> #action run what-broke for https://bugs.launchpad.net/openstack-gate/+bug/1534813 to see what was released around 1/14 (keystone or oslo)
21:12:21 <openstack> Launchpad bug 1534813 in OpenStack-Gate "gate-tempest-dsvm-neutron-src-*-liberty jobs are broken" [Undecided,Confirmed]
21:12:46 <bknudson_> there's python-keystoneclient 2.1.1
21:12:57 <bknudson_> https://pypi.python.org/pypi/python-keystoneclient/2.1.1
21:13:44 <mriedem> https://github.com/openstack/python-keystoneclient/blob/2.1.1/requirements.txt#L12
21:14:18 <mriedem> anyway, we can debug that after the meeting, like i said, it's impacting non-voting jobs right now
21:14:22 <mriedem> so not critical
21:14:27 <tonyb_stupidmac> Cool.
21:14:40 <tonyb_stupidmac> I wont be around long after the meeting
21:14:51 <bknudson_> ominous
21:14:54 <mriedem> doesn't have to be you :)
21:15:10 <tonyb_stupidmac> mriedem: :)
21:15:10 <mriedem> #topic action items from previous meeting
21:15:18 <mriedem> 1. mriedem to talk to ppl about co-gating and what that means for big tent and projects with branches and w/o, like ceilometer + gnocchi
21:15:23 <mriedem> Nothing was changed in the docs. gordc/jd were going to look at installing gnocchi from pypi in the ceilometer devstack plugin which shouldallow upper-constraints to be enforced.
21:15:42 <mriedem> ^ was a thing that got somewhat hairy in #openstack-releases after the stable meeting last week,
21:16:05 <tonyb_stupidmac> ooo /me makes a note to read the logs
21:16:08 <mriedem> ceilometer on stable/liberty was installing gnocchi as a dependency which doesn't have a stable/liberty branch, so the gate tooling threw up in it's mouth a bit
21:16:29 <mriedem> so, i think the plan is basically ceilometer needs to install gnocchi as a lib, from it's devstack plugin
21:16:45 <tonyb_stupidmac> mriedem: Yeah I mentioned that to gordc last year and he said it's fine that's what it's supposed to do
21:16:46 <mriedem> and then upper-constraints can take care of the max version of gnocchi to use in the ceilometer stable/liberty integration job
21:16:50 <tonyb_stupidmac> mriedem: I didn't push on it
21:17:11 <mriedem> 2. ttx to go through the stable release process with Daviey to doublecheck tooling
21:17:18 <mriedem> i think that happened last week
21:17:26 <mriedem> because Daviey has already started the kilo freeze
21:17:32 <tonyb_stupidmac> Based on the -2's I'd say so :)
21:17:45 <mriedem> yup
21:17:51 <mriedem> 3. ttx to draft a stable:follows-policy tag definition for the team to discuss
21:17:55 <mriedem> i haven't seen that happen yet
21:18:06 <mriedem> 4. ttx to do the first stable release nagging round (done on 1/13)
21:18:25 <mriedem> which brings me to https://review.openstack.org/#/c/268709/
21:18:31 <mriedem> that's the nova 12.0.1 release request for stable/liberty
21:18:48 <tonyb_stupidmac> \o/
21:19:03 <mriedem> i'm not aware of any of the other projects that ttx emailed as having put up something similar yet
21:19:22 <mriedem> #action mriedem to circle back on the list of projects that might need to do a stable/liberty point release
21:19:38 <mriedem> that was it for action items from last week
21:19:43 <mriedem> #topic open discussion
21:19:53 <mriedem> i had one item, a call for tooling
21:19:55 <jokke_> I'll be checking what we have merged to glance and request release this week if so
21:20:02 <mriedem> jokke_: thanks
21:20:14 <mriedem> this was the list ttx had: Heat,  Mistral, Nova, Sahara, Designate and Horizon
21:20:27 <tonyb_stupidmac> mriedem: no cinder?
21:20:33 <mriedem> they've already done one
21:20:41 <sigmavirus24> jokke_: let me know if you want a hand :)
21:20:43 <tonyb_stupidmac> mriedem: Oh
21:20:49 <mriedem> those are projects that haven't done a release on stable/liberty since the GA
21:21:11 <mriedem> neutron, cinder and i think glance have already done those, and probably some others
21:21:14 <jokke_> sigmavirus24: thanks ... should be straight forward just checking what we have merged since last tag :P
21:21:34 <mriedem> http://docs.openstack.org/releases/releases/liberty.html
21:21:34 <sigmavirus24> jokke_: I'm a helper  ;)
21:21:53 <tonyb_stupidmac> sigmavirus24: can you help me fix me mac?
21:22:07 <sigmavirus24> tonyb_stupidmac: do I look like a genius to you?
21:22:07 <sigmavirus24> :P
21:22:09 * rockyg snickers
21:22:09 <mriedem> tonyb_stupidmac: i'll tell you what i tell my mac-loving wife,
21:22:14 <mriedem> mac's just work, duh
21:22:19 <jokke_> tonyb_stupidmac: simple, throw it away and buy a decent pc ;)
21:22:29 <sigmavirus24> tonyb_stupidmac: maybe, we'll chat after the meeting
21:22:31 <mriedem> jokke_: +1
21:22:37 <sigmavirus24> jokke_: with windows 11 right?
21:22:41 <mriedem> ok, so back to tooling,
21:22:50 <mriedem> i had 2 items - really just open-ended ideas
21:22:51 <mriedem> 1. script to check for unreleased changes (oslo has something like this?)
21:23:05 <mriedem> ^ would be helpful for what ttx was looking up last week
21:23:12 <mriedem> i think dims_ said that oslo has a script somewhere like this
21:23:24 <mriedem> but something to think about, should be simple
21:23:28 <anteaya> mriedem: I bet you leave the duh off when talking to your wife
21:23:36 <mriedem> anteaya: no ma'am
21:23:52 <mriedem> i relish in her mac agony
21:23:53 <anteaya> brave of you
21:24:08 <mriedem> 2. script to check for backport-potential bugs which are fixed on trunk but backports are not yet proposed
21:24:17 <mriedem> ^ is a bit more complicated
21:24:38 <mriedem> but i think (2) would help with ttx's plan for a revised stable tag
21:24:51 <mriedem> as in, tracking which projects are actually maintaining a healthy stable branch
21:24:57 <mriedem> and backporting high severity fixes
21:25:06 <jokke_> mriedem: the #1 is oneliner anyways so not sure where the script is needed
21:25:10 <tonyb_stupidmac> mriedem: I've done some scripting with launchpadlib so I can have a wach at #2
21:25:23 <jokke_> #2 would be nice
21:25:31 <mriedem> jokke_: well, git log is easy,
21:25:40 <mriedem> jokke_: but i was also thinking of tying that into LP bug severity,
21:26:01 <mriedem> like it's one thing to have 10 minor bug fix backports unreleased, but if one of those is a cve fix and you haven't released it yet, it's a red flag
21:26:18 <jokke_> mriedem: tru
21:26:47 <tonyb_stupidmac> feature creep!
21:26:55 <mriedem> tonyb_stupidmac: if you want to try starting something with (2) that's good
21:27:02 <jokke_> and if one wants to go to that route and start scripting that it would be nice to verify that the release notes are in place as well, just saying
21:27:18 <mriedem> the gap in 2 is if it's keying off the liberty-backport-potential tag and people aren't putting that in the bugs to begin with
21:27:45 <mriedem> so anyway, i figure we start small and build on it
21:27:58 <rockyg> I'd say a dash with all critical and above fixed bugs that could be reviewed weekly, like a triage
21:28:00 <mriedem> i just wanted to bring these up as ideas of things for people to hack on
21:28:05 <tonyb_stupidmac> mriedem: yeah also people adding it where it isn't really potential ;P
21:28:22 <mriedem> rockyg: yeah reports would be nice
21:28:23 <rockyg> Mark the ones for backport when triaged
21:28:41 <bknudson_> is there a repo for the tools?
21:28:46 <mriedem> bknudson_: that was another question
21:28:58 <rockyg> Dash should be pretty easy....
21:28:59 <mriedem> i don't have an answer off hand
21:29:15 <tonyb_stupidmac> lets get the tools and go from there
21:29:17 <bknudson_> maybe figure out where dims_ / dhellmann are stashing theirs
21:29:35 <tonyb_stupidmac> if we make them abstract enough they could go into release.git
21:29:37 <mriedem> bknudson_: yeah, that was going to be my suggestion too, ask the release team
21:29:57 <dhellmann> we keep tools in openstack-infra/release-tools
21:30:42 <mriedem> ahh, and there is the oslo script https://github.com/openstack-infra/release-tools/blob/master/list_oslo_unreleased_changes.sh
21:30:45 <jokke_> dhellmann: can we piggyback there at least to start with? ;)
21:31:16 <dhellmann> mriedem : yeah, that calls a more generic script you ought to be able to reuse for stable branches
21:31:31 <dhellmann> jokke_ : probably, let's see what you have/need
21:32:24 <mriedem> so we don't have to solve this here today, i just wanted to get people thinking about it
21:32:45 <mriedem> for when you can't sleep at 3am
21:33:06 <dhellmann> mriedem : somewhere near the middle of my todo stack is "write a script to show unreleased changes on stable branches", which you ought to be able to do by combining the python code that lists projects with the stable:managed tag with the bash code that lists unreleased changes
21:33:19 <tonyb_stupidmac> mriedem: that'll be you next week ;P
21:33:23 <mriedem> dhellmann: yup, i was thinking the same
21:33:33 <mriedem> dhellmann: i.e. getting hte list of projects based on the tag
21:33:37 <dhellmann> mriedem : yeah, the parts are there, it's just a matter of assembling them
21:33:46 <mriedem> tonyb_stupidmac: that was me last night
21:34:04 <mriedem> anyone want a specific action item on this?
21:34:13 <mriedem> or should we just circle back on it next week?
21:34:23 <tonyb_stupidmac> mriedem: circle back
21:34:28 <mriedem> k, sounds good
21:34:37 <mriedem> that's all i had, anyone else have anything to discuss?
21:34:51 <tonyb_stupidmac> mriedem: but next week's meeting is in the middle of the mid-cycle
21:34:55 <bknudson_> I'll be at the keystone meetup next week
21:35:09 <mriedem> oh right....i didn't think about what time next weeks' meeting would be
21:35:30 <mriedem> i'll sort that out and if i can't run it then i'll look for somone else to run it
21:35:33 <mriedem> or we skip a week
21:35:46 <bknudson_> shouldn't be too bad for gmt.
21:36:01 <anteaya> actually I think it will be 9 or 10pm in the evening
21:36:30 <anteaya> so in the middle of bar time
21:36:32 <jokke_> this is
21:36:39 <tonyb_stupidmac> UTC 15:00
21:36:40 <jokke_> next week is 1500
21:36:43 <mriedem> yeah
21:36:47 <mriedem> i have 3pm in london for that
21:37:07 <anteaya> oh sorry
21:37:09 <bknudson_> so if you can't sleep at 3pm you'll have something to do
21:37:13 <anteaya> the bi-weekly bit
21:37:17 <mriedem> bknudson_: heh
21:37:20 <tonyb_stupidmac> just depends how distracted we'll be with the in person stuff
21:38:03 <mriedem> yeah, it might just be worth skipping it
21:38:27 <anteaya> I'm trying to focus on two things at once and doing a poor job of it
21:38:41 <mriedem> so let's assume we'll skip next week, there are 3 meetups happening
21:39:02 <mriedem> if something comes up, ML and -stable irc per usual
21:39:06 <rockyg> anteaya, yup, me, too.  All my meetings seem to be double booked
21:39:24 <mriedem> i'll send an email to the ML
21:39:27 <anteaya> rockyg: yup
21:39:36 <mriedem> alright, i think we're done
21:39:45 <mriedem> thanks everyone
21:39:50 <mriedem> #endmeeting