20:59:24 <tonyb> #startmeeting stable
20:59:25 <openstack> Meeting started Mon Feb  1 20:59:24 2016 UTC and is due to finish in 60 minutes.  The chair is tonyb. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:59:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:59:28 <openstack> The meeting name has been set to 'stable'
20:59:34 <tonyb> Hi All who's heer for the stable meeting?
21:00:11 <tonyb> mriedem isn't able to make it and mtreinish is somewhere in Australia suffering from jetlag
21:00:30 <mrunge> o/
21:00:42 <tonyb> mrunge: hey!  I thought I was all alone :)
21:00:58 <mrunge> thank you for stepping up and covering the meeting tonyb
21:01:09 <tonyb> mrunge: np
21:01:20 <tonyb> #topic status
21:01:52 <tonyb> So mriedem has provided links fo the current failure rateas of periodic stable jobs
21:02:22 <tonyb> the long standing neutroin-*aas issues seem to be fixed (well thet passed overnight)
21:02:35 <tonyb> trove is still an issue.
21:02:49 <mrunge> true
21:02:50 <tonyb> the sahara gate is broken due to not actually runnign any jobs
21:03:07 <tonyb> but I'm workign on a fix for sahara
21:03:16 <mrunge> awesome
21:03:40 <tonyb> Daivey coordinated the Kilo release which went well
21:03:59 <mrunge> is ceilometer released now?
21:04:05 <tonyb> there's still a problem with telemetry but that's mostly in hand (IIUC)
21:04:43 <sigmavirus24> o/
21:04:48 * sigmavirus24 apologizes for being late
21:04:51 <tonyb> mrunge: I know that Daivey and fungi are workign onit but I don't have an upto the miniute status
21:04:58 <tonyb> sigmavirus24: np
21:05:11 <mrunge> tonyb, yes. same here
21:05:19 <mrunge> hey sigmavirus24 o/
21:05:25 <tonyb> #topic Action items
21:06:00 <tonyb> ttx has been out so I doubt there will have been progress on the new stable:follow-procces (or whatever) tag
21:06:16 <tonyb> mriedem has reached out to projects that might need to do a release
21:06:31 <mrunge> I released Horizon-8.0.1
21:06:40 <mrunge> although no mail has been sent out
21:06:42 <tonyb> mistral has at least one new feature that they've agreed to back out
21:06:49 <tonyb> mrunge: woot!
21:07:05 <tonyb> mrunge: not even from the release tools?
21:07:10 <mrunge> nope
21:07:41 <tonyb> mrunge: hmm okay, was it recent enough that it could still be in the post-release pipepline ?
21:07:57 <mrunge> it was on Jan 27th
21:07:59 <mrunge> http://tarballs.openstack.org/horizon/
21:08:18 <tonyb> mrunge: Hmm okay do you want to follow up with dhellman or shoudl I?
21:08:41 <mrunge> tonyb, let's actually do both
21:08:50 <tonyb> mrunge: okay
21:08:55 <mrunge> https://review.openstack.org/#/c/273033/ is the release request
21:09:12 <tonyb> #action mrunge to followup with dhellman re horizon release email
21:09:17 <mrunge> I mean, just to be sure to get an answer
21:09:21 <tonyb> #action tonyb to followup with dhellman re horizon release email
21:09:43 <tonyb> mrunge: yeah.  It's strange that it didn't just happen
21:09:48 <mrunge> tonyb, when I get an answer, I will let you know/cc you whatever
21:10:15 <tonyb> mrunge: cool
21:10:37 <tonyb> sigmavirus24: if IIUC glance a release for glance is in progress?
21:10:55 <tonyb> sigmavirus24: well the was a b2 tarball from Jan 21
21:11:05 <sigmavirus24> tonyb: I think jokke_ was working on one but I'm not sure of status
21:11:14 <tonyb> sigmavirus24: okay
21:11:27 <tonyb> anything else for release status/action items?
21:11:28 <sigmavirus24> I offered to help but he never roped me in :)
21:11:37 <tonyb> sigmavirus24: hehe, lucky!
21:11:42 <sigmavirus24> inorite?
21:12:12 <tonyb> sigmavirus24: inorite? I don't follow.
21:12:43 <sigmavirus24> inorite is shorthand for "I know, right?"
21:12:48 <sigmavirus24> You said I was lucky, I was agreeing
21:13:00 <tonyb> sigmavirus24: Ah okay
21:13:16 <sigmavirus24> Sorry
21:13:17 <tonyb> sigmavirus24: If I'd said it out loud it would have made sense ;P
21:13:27 <sigmavirus24> maybe
21:13:36 <tonyb> #topic stuck reviews
21:13:44 <tonyb> mriedem has highlighted one
21:13:56 <tonyb> #link https://review.openstack.org/#/c/229152/
21:14:04 <tonyb> Cleanup multipath ISCSI connections when disconnecting volumes
21:14:28 <tonyb> it's a massive backport from os-brick to nova to fix a bunch of multipath issues
21:14:44 <tonyb> It's pretty invasive BUT it does make a released feature more stable
21:14:56 <tonyb> it's a tough call on the risk vs benefit line.
21:15:00 <tonyb> opinions?
21:15:49 <mrunge> hmm :/
21:16:27 <tonyb> Pattrick East has done a lot of work to get it into shape but it's hard to review
21:16:48 <mrunge> it doesn't really feel right to vote on nova features; I'm actually faaaar away from nova
21:17:34 <tonyb> mrunge: Sure. mriedem and I are very conflicted
21:18:17 <tonyb> I guess well move on, but if y'all have any ideas of new ways to look at the problem (rtaher then by the letter of the policy) would be welcome
21:18:24 <tonyb> #topic tooling
21:18:38 <tonyb> last meeting mriedem suggested a couple of tools that would be good
21:19:02 <tonyb> 1) to list unreleased changes that might inform us on when $project is ready for a release
21:19:23 <tonyb> dhellman has a WiP for that but we're l=kinda blocked by the new stable tag
21:19:54 <tonyb> 2) a tool to find LP bugs tagged with $release-backport-potential that don't have a backport
21:20:00 <tonyb> I haven't started on that
21:20:06 <mrunge> would it be an idea to think about, which projects we're actually caring about?
21:20:10 <tonyb> volenteers very welcome :)
21:20:30 <tonyb> mrunge: that's the issue with dhallan's WiP patch
21:20:48 <tonyb> it looks at anything that has the 'has-stable-branches' tag which is too broad
21:21:05 <tonyb> mrunge: I think in the meantime we shoudl limit it those in the stable-dashboard
21:21:17 <tonyb> but the long term goal is anything with the new tag
21:21:50 <mrunge> as recently pointed out, projects are handling "stable" a bit different from each other
21:22:01 <tonyb> mrunge: Yeah.
21:23:05 <tonyb> mrunge: gotta start somewhere though.
21:23:13 <mrunge> yes right
21:23:32 <mrunge> in the past, I tried to keep an eye on stable backports for horizon
21:23:42 <mrunge> but that's not scaling at all
21:23:44 <tonyb> mrunge: cool.
21:23:49 <tonyb> mrunge: anyone else doing it?
21:24:04 <david-lyle> o/
21:24:04 <mrunge> me, of course
21:24:21 <mrunge> and david-lyle had an eye on that, too
21:24:33 <mrunge> :)
21:24:44 <mrunge> but I like the idea on tool support
21:24:51 <tonyb> mrunge: I keep an eye out and then poke r1chardj0n3s because I knwo he's close
21:25:00 <sigmavirus24> tonyb: stick's distance of you, right?
21:25:16 <tonyb> sigmavirus24: 500miles so it's a long stick
21:25:26 <tonyb> sigmavirus24: but he's in the "right" TZ :)
21:25:32 <mrunge> who can set the $release-backport-potential flag?
21:25:32 <sigmavirus24> shorter than the one you'd need to hit me with :P
21:25:41 <sigmavirus24> mrunge: anyone who can set a tag on an issue
21:25:46 <tonyb> mrunge: okay, so would the tools above help or do you need somethign else?
21:25:48 <sigmavirus24> (e.g., probably most registered launchpad users)
21:26:03 <tonyb> mrunge: do you have a dashbord for helpign tirage/prioritise reviews?
21:26:38 <tonyb> mrunge: it depends form project to project but the default is as sigmavirus24 says any LP user
21:26:45 <mrunge> tonyb, I must admit, I'm completely selfish and am primarily looking at downstream bugs
21:27:04 <mrunge> which means, bugs filed in Red Hats bugzilla
21:27:14 <tonyb> mrunge: fair enough gotta draw the line somewhere
21:27:31 <mrunge> or bugs I happen to see in launchpad, which I consider as being high impact
21:27:31 * tonyb wites a tool to mirror LP -> RH :D
21:27:41 <mrunge> heh :D
21:27:46 <sigmavirus24> tonyb: I'm thinking of the bug tags versus release series. release series can be nominated by anyone but usually need to be approved by someone on the right team for the project (in glance, that's the driver's team on LP)
21:28:08 <tonyb> sigmavirus24: right basically the same for nova
21:28:30 <mrunge> sometimes it's hard to draw a line between feature and bugfix
21:28:30 <tonyb> sigmavirus24: both are outlined in the stable policy
21:28:32 <sigmavirus24> glance has the problem now of every core being a driver, per-se so I'm not sure if flaper87 updated the LP permissions or not
21:29:21 <tonyb> sigmavirus24: it's easy to check.
21:29:58 <tonyb> #action tonyb check how glance drivers compares to gerrit cores and nagg flaper87 to sync them ;P
21:30:25 <tonyb> sigmavirus24: I guess anything that has been accepted for a serries *shoudl* have someone workign on it
21:30:38 <tonyb> sigmavirus24: that'd be worth checking
21:30:49 * tonyb will check nova
21:31:03 * sigmavirus24 nods
21:31:26 <tonyb> anyway other ideas for tools would be cool.
21:31:37 <tonyb> #topic open discussion
21:31:55 <tonyb> anyone have anything for discussion?
21:32:10 <mrunge> nope
21:32:55 <tonyb> mrunge: http://lists.openstack.org/pipermail/openstack-announce/2016-January/000944.html
21:33:10 <tonyb> mrunge: isn't that the announce for your horizon release?
21:33:15 <mrunge> tonyb, oh great
21:33:30 <mrunge> that's the exact announce I missed
21:33:42 <tonyb> mrunge: okay
21:33:49 <tonyb> mrunge: 2 action items done!
21:33:52 <tonyb> #winning
21:34:01 <mrunge> heh :D
21:34:24 <mrunge> #action mrunge to draw a cake for tonyb
21:34:30 <tonyb> Well if we don't have anythign else I'll close the meeting (and take my son to school)
21:34:43 <tonyb> mrunge: thanks
21:34:56 <mrunge> thank *you*
21:35:08 <tonyb> okay I think we're done
21:35:17 <tonyb> Thanks everyone
21:35:21 <tonyb> #endmeeting