15:00:22 <mriedem> #startmeeting stable
15:00:22 <openstack> Meeting started Tue Feb  9 15:00:22 2016 UTC and is due to finish in 60 minutes.  The chair is mriedem. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:25 <openstack> The meeting name has been set to 'stable'
15:00:35 <mriedem> will wait a few minutes for people to show up
15:00:48 <bknudson_> hi
15:01:07 <ttx> o/
15:02:31 <mriedem> tonyb: mtreinish: around?
15:02:52 <mriedem> mrunge: ?
15:03:04 <mrunge> hey o/
15:03:11 <mrunge> sorry for being late
15:03:19 <mriedem> np, we might as well get started
15:03:34 <mriedem> first, i want to thank tonyb for chairing last week while i was out
15:03:43 <mriedem> #topic status
15:03:58 <mriedem> i was following along with the testtools flare up on kilo
15:04:06 <mriedem> that's mostly under control as of late last week
15:04:25 <mriedem> #link issues https://etherpad.openstack.org/p/stable-tracker
15:04:38 <mriedem> i don't think there is anything new in there really, trove has some problems which people are working on
15:04:52 <mriedem> tonyb was helping sahara getting their tests running in kilo
15:05:05 <mrunge> great!
15:05:05 <bknudson_> keystone was also failing -- https://review.openstack.org/#/c/277022/
15:05:12 <bknudson_> stable/kilo
15:05:32 <mriedem> oh for testtools?
15:06:00 <bknudson_> I don't think it was because of testtools, but because of a change in infra master
15:06:25 <mriedem> ok so i guess we're just waiting for jenkins there
15:06:34 <bknudson_> y, I'll see if it works
15:06:49 <mriedem> were there any other known stable branch issues?
15:06:51 <bknudson_> I proposed a change to project-config -- https://review.openstack.org/#/c/277550/
15:07:45 <mriedem> #status action items from previous meeting(s)
15:07:50 <mriedem> mrunge to followup with dhellman re horizon release email
15:08:09 <mrunge> mriedem, I just missed the email
15:08:09 <mriedem> mrunge: did that happen?
15:08:13 <mriedem> ah, ok
15:08:21 <mrunge> mriedem, there was a automatic email
15:08:46 <mriedem> yeah this http://lists.openstack.org/pipermail/openstack-announce/2016-January/000944.html
15:08:47 <mriedem> right?
15:09:02 <mrunge> yes
15:09:07 <mriedem> ok
15:09:08 <mriedem> tonyb check how glance drivers compares to gerrit cores and nagg flaper87 to sync them ;P
15:09:12 <mrunge> but this mail is basically wrong
15:09:14 <mriedem> flaper87: are you around?
15:09:27 <mrunge> last horizon version on pypi is 2012.2
15:09:34 <mriedem> mrunge: yeah i saw that
15:09:34 <mrunge> and it was released there by accident
15:09:57 <mriedem> mrunge: was a bug reported to follow up on that? i saw apavec had a post to the -dev list
15:10:24 <mrunge> mriedem, unfortunately, I didn't had the time to report a bug or follow up there
15:10:34 <mriedem> ok
15:10:52 <mrunge> would you make it an action item for me then?
15:10:55 <mriedem> #action follow up on server projects (e.g. horizon) being released to pypi from stable branches
15:11:00 <mriedem> #undo
15:11:01 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x98417d0>
15:11:03 <mrunge> ack, thx
15:11:10 <mriedem> #action mrunge to follow up on server projects (e.g. horizon) being released to pypi from stable branches
15:11:21 <mrunge> thank you
15:11:43 <mriedem> there was an action item for the follows-stable-process tag, we'll come back to that
15:11:48 <mriedem> mriedem to circle back on the list of projects that might need to do a stable/liberty point release
15:11:56 <mriedem> i see someone updated the agenda with the latest point releases
15:12:02 <mriedem> i think mistral is then the only one that's not done
15:12:17 <mriedem> they have a change up in the release repo https://review.openstack.org/#/c/273223/ but it needs to be updated to include a revert of a feature backport
15:12:37 <mriedem> #action mriedem to nudge mistral stable CPL to update https://review.openstack.org/#/c/273223/
15:13:02 <mriedem> which reminds me,
15:13:13 <mriedem> neutron has been backporting A LOT of changes to stable/liberty
15:13:24 <mriedem> which is fine if they are following policy,
15:13:27 <mtreinish> how much is a lot?
15:13:50 <mriedem> i'd have to find the latest release request, but it's like several dozen per month i think
15:14:03 <mtreinish> that is a lot
15:14:29 <mriedem> anyway, dhellmann had asked that i review the latest neutron stable/liberty point release request and there were so many changes it was hard to review the change log to make sure they weren't leaking something bad in
15:14:44 <mriedem> so we had pinged mestery to release more often if that's going to be the neutron stable model
15:15:14 <mriedem> #action mriedem to follow up with mestery and/or ihar on releasing from stable more often if they are going to backport a lot of changes frequently
15:15:41 <mriedem> #status kilo 2015.1.4 version updates pending
15:15:49 <mriedem> #link open reviews https://review.openstack.org/#/q/Bump+stable/kilo+next+version+to+2015.1.4+status:open
15:16:16 <mriedem> so neutron, neutron-vpnaas and ironic on stable/kilo can't get their version updates in b/c of gate issues
15:16:39 <mriedem> the last i looked at ironic, there might need to be a devstack backport for a timeout issue
15:17:03 <mriedem> adam_g had worked around something in the ironic devstack plugin to fix master/stable/liberty, but that wasn't being used in kilo
15:17:09 <mriedem> i haven't dug into the neutron* ones
15:17:22 <mriedem> #topic stuck reviews
15:17:40 <mriedem> tony brought this up last week but there wasn't much discussion so i'll bring htis up again
15:17:40 <mriedem> Cleanup multipath ISCSI connections when disconnecting volumes - https://review.openstack.org/#/c/229152/
15:17:54 <mriedem> that is a large change for nova in kilo,
15:18:09 <mriedem> it essentially backports a bunch of changes from os-brick in liberty to nova in kilo to fix multipath bugs
15:18:23 <mriedem> ~400 LOC net change
15:18:36 <mriedem> which seems too risky for me,
15:18:44 <flaper87> mriedem: I'm now
15:19:15 <mriedem> flaper87: there was just an earlier item from tonyb about syncing glance drivers with glance core team in gerrit
15:19:25 <mriedem> flaper87: sigmavirus24 might have more context, it came up in last week's meeting
15:19:41 <mriedem> ttx: mtreinish: so if you have an opinion on https://review.openstack.org/#/c/229152/ please chime in
15:19:44 <mriedem> to the review i mean
15:20:08 <ttx> will have a look
15:20:12 * sigmavirus24 readss crollback
15:20:13 <mriedem> fwiw it sounds like this fixes some major issues with multipath storage in kilo, but at this point i think people are going to just have to patch that in
15:20:31 <mriedem> or upgrade nova/cinder to liberty
15:20:41 <bknudson_> all the gate failures are unrelated?
15:20:54 <mriedem> bknudson_: yeah probably, we don't test multipath in the gate
15:21:01 <bknudson_> Phase II (6-12 months): Only critical bugfixes and security patches are acceptable
15:21:32 <mriedem> yeah i know, this was more or less falling under the bug fix tent
15:22:04 <mriedem> as in critical if you're using multipath, but still, it's a very large change and i'm not really on board for bringing that in
15:22:04 <bknudson_> my understanding of critical is gate-breaking
15:22:06 <mriedem> at this point
15:22:25 <mriedem> yeah, or breaks upgrade, etc
15:22:34 <ttx> it is a significant change indeed
15:22:43 <mtreinish> mriedem: I think I'm -1 just on the fact it has 7 commits backported in one patch
15:22:54 <ttx> if that was exactly the code used in liberty/mitaka I guess the risk would be limited
15:23:13 <bknudson_> from the commit it's a copy of a file from the lib rather than really backporting all the changes
15:23:15 <ttx> but I have no idea how much of a snowflake it is
15:24:22 <mriedem> we can move on, i'm just bringing attention to it
15:24:39 <ttx> that said it seems to be isolated to use_multipath enough
15:24:41 <mriedem> softlayer was hitting multipath issues on kilo and i pointed that change out to them, so they were happy to see someone had done it,
15:24:46 <mriedem> but i told them to just upgrade nova to liberty
15:25:56 <mriedem> moving on
15:26:13 <mriedem> #topic proposed stable:follow-stable-policy tag
15:26:20 <ttx> ohai
15:26:22 <mriedem> #link https://etherpad.openstack.org/p/follows-stable-policy-tag
15:26:36 <ttx> So here is the tag definition I plan to push
15:26:59 <ttx> I'd rather have you all agree with it before we try to convince the TC that it would be a good idea
15:27:20 <mriedem> ok, i need to read through this quick (skim it)
15:27:46 <ttx> one bikeshed area is on the naming (obviously)
15:28:02 <ttx> the stable: prefix is there to mean that it's owned by the stable team
15:28:14 <ttx> so the second "stable" there is a bit redundant
15:28:25 <ttx> could be stable:follows-policy
15:29:02 <mriedem> i'm fine with that
15:29:36 <ttx> ok, renaming then
15:29:45 <bknudson_> the doc looks good to me.
15:31:30 * mtreinish slowly reads
15:34:02 <mriedem> ok, this looks like a good draft to me
15:34:26 <ttx> So ... "healthy CI jobs, routinely backporting bug fixes and reviewing them, doing releases" - we should put that in the stable policy itself
15:34:41 <mriedem> yeah, i can add that if you want
15:35:31 <mriedem> #action mriedem to update the stable policy with what it means to be actively maintaining stable branches for a project
15:35:34 <ttx> Let me include your "rationale" changes
15:36:04 <mriedem> ok
15:36:07 <mriedem> anything else on this?
15:36:37 <mriedem> i'll look forward to the governance review if not
15:36:44 <mriedem> ttx: thanks for taking the time to write this up
15:36:47 <mtreinish> not from me, looks good to me
15:36:47 <ttx> #action ttx to propose corresponding governance review
15:37:05 <ttx> will push today or tomorrow
15:37:10 <mriedem> i'm going to skip the tooling section of the meeting agenda since that's a WIP
15:37:17 <mriedem> #topic open discussion
15:37:23 <mriedem> anyone have anything?
15:37:48 <mriedem> i'll take that as a no and we can end early
15:37:52 <mriedem> thanks everyone
15:37:56 <mriedem> #endmeeting