15:01:24 <mriedem> #startmeeting stable
15:01:25 <openstack> Meeting started Tue Feb 23 15:01:24 2016 UTC and is due to finish in 60 minutes.  The chair is mriedem. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:29 <openstack> The meeting name has been set to 'stable'
15:01:30 <PaulMurray> sorry mriedem - my clock must be a minute slow
15:01:40 <paul-carlton> mdbooth, PaulMurray let's talk in nova room?
15:01:41 <mriedem> PaulMurray: np
15:02:45 <mriedem> who's around for the stable team meeting?
15:02:52 <bknudson> hi
15:02:56 <mriedem> ooo
15:03:03 <mriedem> i'm also fine to cancel as we're in the neutron meetup today
15:03:20 <breton> o/
15:03:57 <mriedem> alright, well let's breeze through this
15:04:05 <mriedem> #link meeting agenda https://wiki.openstack.org/wiki/Meetings/StableTeam
15:04:08 <bknudson> I do have a topic
15:04:18 <mriedem> leave it for open discussion
15:04:23 <mriedem> #status
15:04:52 <mriedem> so the newish thing this week is trying to reset upper-constraints for stable/liberty to get the src job working for oslo.config https://review.openstack.org/#/c/282347/
15:05:13 <mriedem> ^ just needs reviews, i haven't gone through it yet
15:05:24 <mriedem> we've done similar for oslo.service and oslo.messaging
15:05:27 <mriedem> this one has like 9 libs though
15:06:14 <mriedem> #topic action items from previous meeting
15:06:25 <mriedem> 1. tonyb to talk to lifeless about fixtures bug https://bugs.launchpad.net/python-fixtures/+bug/1542984
15:06:25 <openstack> Launchpad bug 1542984 in Python Fixtures "fixtures 1.2.0 isn't compatible with testtools 2.0.0" [Undecided,New]
15:06:35 <mriedem> there are no updates in the bug for that
15:06:46 <mriedem> Ihar capped testtools<2.0.0 in g-r on stable/kilo: https://review.openstack.org/#/c/276275/ but things are still failing:https://review.openstack.org/#/c/273274/
15:07:05 <mriedem> i'm not really sure why that is still failing,
15:07:18 <mriedem> since testtools should be capped, unless something else is pulling in testtools 2.0.0 there
15:07:27 <mriedem> 2. mriedem to send a reminder to -dev ML for stable CPLs/PTLs to hang out in #openstack-stable
15:07:33 <mriedem> done: http://lists.openstack.org/pipermail/openstack-dev/2016-February/086600.html
15:07:41 <mriedem> #topic release news
15:07:48 <mriedem> Check for stable/liberty point release candidates as we wind down to m-3: http://lists.openstack.org/pipermail/openstack-dev/2016-February/086362.html
15:08:01 <mriedem> i'm guilty of not doing that for nova yet
15:08:16 <mriedem> there are no stuck reviews in the agenda so we'll skip that
15:08:19 <mriedem> and no tooling updates
15:08:24 <mriedem> #topic open discussion
15:08:27 <mriedem> bknudson: go!
15:08:38 <bknudson> ok, this is related to stable/kilo
15:08:53 <bknudson> there's a requirements change from proposal bot to keystonemiddleware that's failing:
15:09:10 <bknudson> https://review.openstack.org/#/c/277022/2
15:09:50 <bknudson> oh, looks like this was fixed already
15:10:02 <bknudson> the requirements job was removed.
15:10:21 <mriedem> yeah i saw it was passing
15:10:37 <bknudson> gate-keystonemiddleware-requirements was failing, but now that's not running anymore
15:10:51 <bknudson> which is what I was going to discuss, whether this job was useful.
15:11:03 <bknudson> looks like it was already decided not useful
15:11:16 <mriedem> i'm looking for the change that removed the job
15:12:02 <mriedem> not finding it
15:12:07 <mriedem> so why was it failing?
15:12:11 <mriedem> or can you give a summary?
15:12:16 <bknudson> oh, wait https://review.openstack.org/#/c/277022/5
15:12:19 <bknudson> it's still failing
15:12:48 <mriedem> ah wrong patc hset
15:12:50 <bknudson> gate-keystonemiddleware-requirements doesn't show up in the summary probably due to odd formatting
15:12:57 <bknudson> the summary is:
15:13:19 <mriedem> http://logs.openstack.org/22/277022/5/check/gate-keystonemiddleware-requirements/6fa8646/console.html#_2016-02-12_16_05_55_677
15:13:23 <bknudson> when gate-keystonemiddleware-requirements runs, it uses master openstack-infra/project-config but stable/kilo requirenments!
15:13:42 <bknudson> and project-config tries to use fields that were only added in newer requirements
15:13:43 <mriedem> well, project-config is branchless
15:13:48 <mriedem> like extras
15:14:16 <mriedem> which causes this? AttributeError: 'Requirement' object has no attribute 'location'
15:14:31 <bknudson> yes, location was added in liberty or mitaka
15:14:42 <mriedem> so we just need to land the backports here? https://review.openstack.org/#/q/I146baa3ef94cc8bbf29af371786f3ea95a42cb9f,n,z
15:15:32 <bknudson> the stable/liberty backport required backporting a bunch of other changes
15:16:03 <bknudson> and, even once all these liberty backports are done, I'm not sure that the kilo requirements job is going to work
15:16:22 <bknudson> because the upper-constraints and requirements in stable/kilo are just inconsistent
15:17:05 <bknudson> so if we fix the requirements job I expect it's just going to tell us that the requirements are inconsistent and -V
15:17:06 <mriedem> so this tries to use upper-constraints and since the u-c file in stable/kilo is just a garbage stub, it finds that and tries to use that and blows up?
15:17:23 <mriedem> didn't we talk about deleting u-c in stable/kilo related to this at some point
15:17:28 <bknudson> y, I think that's what's going to happen.
15:17:29 <mriedem> i wonder how bad that would blow up
15:17:37 <mriedem> has anyone proposed that to see what the fallout is?
15:17:46 <mriedem> the test job should be able to handle that it doesn't exist
15:19:00 <mriedem> bknudson: you want to propose that?
15:19:12 <bknudson> remove upper-constraints.txt in stable/kilo?
15:19:17 <mriedem> yeah
15:19:17 <bknudson> I can do that.
15:19:19 <mriedem> just WIP
15:20:35 <mriedem> anything else we should know/do about this right now?
15:20:47 <mriedem> i can take a look at the backports at some point here
15:21:14 <bknudson> I don't know what affect removing u-c.txt will have, but if that works I'm fine with that as a solution
15:21:30 <mriedem> well let's just see what happens with it
15:21:39 <mriedem> it's vestigial in kilo and if it's causing issues with the job, we should fix that
15:22:13 <mriedem> #action bknduson to propose dropping upper-constraints from stable/kilo to see if the reqs job will work without it
15:22:21 <mriedem> #undo
15:22:22 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x98bbbd0>
15:22:28 <mriedem> #action bknudson to propose dropping upper-constraints from stable/kilo to see if the reqs job will work without it
15:22:46 <mriedem> alright, anything else from anyone?
15:23:17 <mriedem> well let's end it, we're doing introductions here now so i should pay attention
15:23:22 <mriedem> thanks for showing up
15:23:24 <mriedem> #endmeeting