20:00:24 <mriedem> #startmeeting stable
20:00:24 <openstack> Meeting started Mon Mar 14 20:00:24 2016 UTC and is due to finish in 60 minutes.  The chair is mriedem. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:28 <openstack> The meeting name has been set to 'stable'
20:00:39 <mriedem> hi, is anyone around?
20:01:07 <mriedem> tonyb: mtreinish: dhellmann: ttx: mrunge: jokke_: flaper87: Daviey: ?
20:02:02 * mriedem waits awhile
20:08:10 <rockyg> o/
20:08:22 <mriedem> do we have a quorum?!
20:08:42 <mriedem> rockyg: if you're willing to listen, i'm willing to go throug the agenda :)
20:09:12 <rockyg> I'm willing to listen...if you feel like typing ;-)
20:09:17 <mriedem> then let's do this!
20:09:20 <mriedem> #link agenda https://wiki.openstack.org/wiki/Meetings/StableTeam#Agenda
20:09:30 <mriedem> #topic status
20:09:35 <mriedem> #link known issues https://etherpad.openstack.org/p/stable-tracker
20:09:55 <mriedem> big things last week were (1) trove on liberty, and (2) ceilometer/oslo.db on kilo
20:09:59 <mriedem> both are more or less resolved
20:10:20 <rockyg> so, half yay?
20:10:41 <mriedem> mostly yay
20:10:52 <rockyg> even better.
20:11:07 <mriedem> yeah
20:11:20 <mriedem> there is a change up to reset upper-constraints in liberty for oslo.config: https://review.openstack.org/#/c/282347/
20:11:29 <mriedem> #link oslo.config reset for liberty upper-constraints https://review.openstack.org/#/c/282347/
20:11:35 <mriedem> i haven't gone through that yet
20:11:45 <rockyg> If I recall correctly, Trove needs to decide whether it gets the tag "follows integrated release" or whatever that tag is. Policy
20:11:50 * anteaya is here too
20:11:59 <mriedem> rockyg: the stable:follows-policy taG?
20:12:16 <mriedem> rockyg: they haven't proposed for that tag yet,
20:12:28 <mriedem> rockyg: but as of last week it would have been a -1 b/c of the backward compat changes they made in mitaka,
20:12:35 <mriedem> which we spent most of last week reverting
20:12:36 <rockyg> Yeah.  That one.  Too many tags floating 'round to remember them all precisely
20:12:59 <mriedem> #topic Action items from previous meeting
20:13:04 <mriedem> mriedem to check which projects haven't done a stable/liberty release since m-1
20:13:05 <rockyg> Right.  They haven't been following.  They need to decide whether they will.
20:13:24 <mriedem> so i've failed to do that check from last week,
20:13:30 <mriedem> Really need to get https://review.openstack.org/#/c/270273/ cleaned up to automate this.
20:13:58 <mriedem> #help need to get https://review.openstack.org/#/c/270273/ cleaned up to help automate checking for unrelated stable branch changes
20:14:05 <mriedem> #topic Release News
20:14:17 <mriedem> Nova and Ceilometer need to do a stable/kilo release (Nova has a CVE fix and Ceilometer released a regression). Does Daviey organize a mass stable/kilo release or should we just release those two projects? Note we plan on talking about Kilo EOL dates at the summit.
20:14:32 <mriedem> In the before-times we released en masse on pre-scheduled dates. Should we still do that even though we know we have CVE and breaking fixes?
20:14:55 <mriedem> by default, for kilo, i'm assuming we're waiting until the next scheduled mass release
20:15:05 <mriedem> i really need to talk to ttx and dhellmann about that
20:15:13 * anteaya nods
20:15:18 <mriedem> #action mriedem to talk to Daviey, ttx and dhellmann about a stable/kilo release
20:15:28 <anteaya> yes sounds like we have outgrown that model
20:15:31 <rockyg> With the bug hackathon, there may have been more backports.  Should check on the status of all projects before deciding mass or specific releases
20:16:07 <mriedem> rockyg: if we know we're going to do a kilo release, it would be good to flush out what is available and we want to get in,
20:16:21 <mriedem> but nova does have a cve fix and ceilometer has a regression fix from the last kilo release
20:16:22 <rockyg> Isn't kilo security only? Or has that changed
20:16:34 <mriedem> kilo is security / critical fix only
20:16:42 <rockyg> Ah.  Thanks.
20:16:46 <mriedem> but low risk / high user impact things make their way in at times
20:17:09 <mriedem> #topic tagging
20:17:16 <rockyg> Worth checking to see if any other project has candidates
20:17:24 <mriedem> #info projects still need to apply for the stable:follows-policy tag http://governance.openstack.org/reference/tags/stable_follows-policy.html
20:17:39 <rockyg> How many projects have it so far?
20:17:45 <mriedem> #link open stable:follows-policy reviews https://review.openstack.org/#/q/%22stable:follows-policy%22
20:17:48 <mriedem> rockyg: 0
20:17:54 <mriedem> there are 5 reviews up
20:18:15 <mriedem> nova, neutron, glance, horizon, django_openstack_auth
20:18:56 <rockyg> Do the projects have to specify whether their python clients also follow, or is it assumed or?
20:19:02 <mriedem> #action mriedem to start prodding other projects like keystone and cinder to  apply for the stable:follows-policy tag
20:19:15 <mriedem> rockyg: it's calld out specifically in the governance repo
20:19:25 <mriedem> the neutron one is hairy b/c of the stadium
20:19:41 <rockyg> Stadium is getting smaller, fortunately
20:20:04 <mriedem> yeah, ihar proposed that they hold off on the tag until the stadium discussion is wrapped up
20:20:12 <mriedem> i suggested they at least start with tagging neutron and neutronclient
20:20:15 <mriedem> keep it small and build out
20:20:18 <rockyg> +1 to that
20:20:38 <rockyg> to both
20:20:40 <mriedem> #topic tooling
20:20:51 <mriedem> really only one new thing here,
20:20:53 <mriedem> reviewstats; there is a 'stable' group but it's only for stable-maint-core, there isn't an easy way (that I can see) to check for stable branch reviewers on a given project (would have to add it).
20:21:13 <mriedem> I started playing with reviewstats last week and that's ^ what i found
20:21:35 <mriedem> which isn't bad for stable-maint-core stats, but isn't helpful for individual <project>-stable-maint teams
20:21:53 <mriedem> it also doesn't handle gerrit group inheritance,
20:21:59 <mriedem> which is probably an easy enough thing to fix
20:22:17 <mriedem> #topic Open discussion
20:22:27 <mriedem> two things here
20:22:28 <mriedem> 1. FYI, etherpad on stable branch EOL policy discussion for summit (please don't hack this up yet):https://etherpad.openstack.org/p/stable-branch-eol-policy-newton
20:22:43 <mriedem> that was my brain dump from last friday
20:23:37 <rockyg> I'll read it over without disturbing.  Thanks for posting it.
20:23:45 <mriedem> it's what i'll be using for the fishbowl session at the summit with the infra/qa/vmt teams
20:23:47 <mriedem> np
20:24:45 <mriedem> 2. my intentions for stable PTL for newton http://lists.openstack.org/pipermail/openstack-dev/2016-March/089289.html
20:25:07 <mriedem> so i'm running for nova PTL for newton,
20:25:24 <mriedem> which is why i didn't put up a candidacy for stable PTL
20:25:38 <mriedem> but if no one else does, it sounds like it would most likely come back to me anyway
20:25:42 <rockyg> Oooh!  Congratz.
20:25:44 <mriedem> and i'm fine with that
20:26:13 <mriedem> so this is just an FYI
20:26:33 <mriedem> did anyone else have anything for today?
20:26:33 <rockyg> I suspect jokke_ will put in for stable, especially if no one else does.
20:26:48 <anteaya> I don't have anything
20:27:05 <mriedem> ok, let's wrap up early then, thanks for attending
20:27:08 <mriedem> #endmeeting