21:00:51 <tonyb> #startmeeting stable
21:00:52 <openstack> Meeting started Mon Apr 11 21:00:51 2016 UTC and is due to finish in 60 minutes.  The chair is tonyb. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:54 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:56 <openstack> The meeting name has been set to 'stable'
21:01:07 <tonyb> roll call .. who's here?
21:01:17 <ihrachys> o/
21:01:20 <bknudson> hi
21:01:26 <mriedem> o/
21:01:35 <mriedem> #link https://wiki.openstack.org/wiki/Meetings/StableTeam#Agenda
21:01:42 * bauzas sitting at the back of the room
21:01:53 <tonyb> #topic status
21:02:04 <tonyb> peridoci jobs
21:02:19 <tonyb> asside from the conder one that was resolved overnight I think we're good there
21:02:29 <tonyb> there have been spotty failures but that's normal
21:02:46 <tonyb> #link periodic-stable job faliures (logstash): http://goo.gl/5qiw2U
21:02:57 <mriedem> nova liberty was broken last week but fixed now
21:03:12 <mriedem> we backported the constraints changes to tox.ini so nova unit test jobs on stable/liberty use upper-constraints now
21:03:37 <ihrachys> we did similar thing for neutron-*aas repos in Liberty too
21:03:41 <tonyb> mriedem: fixtures right? IIRC that hurt neutron as well
21:03:44 <ihrachys> so neutron is all constrained too
21:03:56 <bknudson> someday keystone might support constraints in tox.ini
21:04:00 <mriedem> yes, fixtures 2.0
21:04:11 <tonyb> I might do some checking to see who is constrained in liberty
21:04:15 <mriedem> tonyb: same idea here for cinder in liberty https://review.openstack.org/#/c/303932/
21:04:30 <ihrachys> on constraints, we really need to start expanding global-requirements CI to include project jobs.
21:04:49 <mriedem> ihrachys: yeah, i'm going to bring that up on the backward compat tuesday xp session at the summit
21:05:03 <tonyb> mriedem: I *think* that ones safe to abandon but I'll check during the day
21:05:03 <ihrachys> mriedem: cool. I have a patch on that
21:05:05 <ihrachys> #link https://review.openstack.org/303054
21:05:15 <ihrachys> though it needs a respin since it won't work as is
21:05:42 <tonyb> ihrachys: cool.  I was going to do somethign similar but post summit
21:06:04 <mriedem> there are 3 xp sessions on tuesday that impact stable
21:06:07 <ihrachys> let's just make sure we have agreement from other folks on the direction :)
21:06:08 <ihrachys> summit should be the right time
21:06:09 <mriedem> i have them in open discussion
21:06:09 <tonyb> we break all sorts of things with u-c changes, nova, neutron, horizon, magnum all bitten in the last cycle
21:06:39 <mriedem> i imagine the thurs fishbowl session for stable will be talking about the outcome of the tuesday sessions and making plans
21:06:47 <bknudson> it used to be everything broke when the lib was released
21:06:59 <tonyb> mriedem: Yeah do the planning on Tuesday and hash out the details then
21:07:06 <ihrachys> bknudson: now it's everything broke after 3hours :P
21:07:09 <tonyb> mriedem: was your Thursday conflict sorted out?
21:07:30 <mriedem> tonyb: yeah
21:07:35 <tonyb> \o/
21:07:47 <bknudson> I guess I shouldn't say when the lib was released, it was when the openstack cache was updated.
21:08:14 <tonyb> bknudson: it's really helping but still not perfect
21:08:22 <tonyb> moving on?
21:08:27 <mriedem> yeah
21:08:36 <tonyb> #topci release news
21:08:42 <tonyb> #topic release news
21:08:55 <tonyb> mriedem: nova 12.0.3?
21:08:58 <mriedem> yeah https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:stable/liberty
21:09:07 <mriedem> lyarwood was asking for that this week
21:09:15 <mriedem> there are some open +2ed reviews that i'd like to get in first
21:09:39 <ihrachys> mriedem: so nova plans to sort MTU out in L?\
21:09:55 <tonyb> mriedem: last time I looked there were 3-4 of your that had one +2 that looked like good candidates ....
21:10:40 <mriedem> ihrachys: this? https://review.openstack.org/#/c/285710/
21:11:04 <ihrachys> yeah
21:11:17 <mriedem> i haven't really decided since it introduced problems in mitaka for dpdk
21:11:30 <mriedem> but in mitaka neutron also changed the default mtu value which is what broke dpdk
21:11:37 <mriedem> it wouldn't be the same issue in liberty by default
21:12:05 <mriedem> the issue was this other change https://review.openstack.org/#/c/289370/
21:12:16 <ihrachys> ok. I also suspect it would require some more stuff on neutron side, but I would need to check. I just have not bothered to backport that assuming nova won't go with their part.
21:12:32 <mriedem> i don't think neutron can backport changing the default mtu value
21:13:01 <mriedem> basically, on the nova side, i think we'd have to make sure https://review.openstack.org/#/c/289370/ is in if we did https://review.openstack.org/#/c/285710/
21:13:13 <ihrachys> yeah. but we then can at least provide guidance to users on how to achieve proper setup
21:13:38 <ihrachys> it's a matter of some conf changes, but that should be ok for those who want it sorted for L
21:14:33 <mriedem> ihrachys: i don't know all of the mitaka mtu change details, but are you suggesting backporting the default mtu value config change in neutron from mitaka to liberty?
21:15:28 <ihrachys> mriedem: not really. but I think we had other fixes as well.
21:15:53 <ihrachys> mriedem: like the ones setting MTU on interface driver managed interfaces (f.e. for router or DHCP ports) based on network MTU
21:16:11 <ihrachys> so with those in, users would 'only' need to change config values to get proper behaviour
21:17:47 <mriedem> we can move on probably
21:17:59 <tonyb> ok
21:18:21 <tonyb> nothign for stuck reviews
21:18:33 <tonyb> and AFAICT no new changes in tooling
21:18:40 <tonyb> so ....
21:18:47 <tonyb> #topic open discussion
21:18:57 <anteaya> o/
21:19:12 <ihrachys> hi anteaya!
21:19:17 <mriedem> the open discussion stuff is just fyi
21:19:17 <anteaya> hello ihrachys
21:19:27 <tonyb> anteaya: is that hi or "I have something"?
21:19:29 <anteaya> I have an item
21:19:36 <anteaya> I have something
21:19:40 <tonyb> anteaya: you have the virtual floor
21:19:42 <anteaya> shall I just yell it out
21:19:43 <anteaya> thank you
21:20:04 <anteaya> in infra today robcresswell the horizon ptl was asking about how to add folks to horizon stable
21:20:11 <anteaya> we tried to guide them to you
21:20:18 <tonyb> anteaya: Yeah he poked me overnight
21:20:18 <david-lyle> http://lists.openstack.org/pipermail/openstack-dev/2016-April/091655.html
21:20:22 <anteaya> did anyone chat with anyone from horizon about this?
21:20:26 <anteaya> tonyb: awesome
21:20:27 <david-lyle> for reference
21:20:32 <anteaya> thanks david-lyle
21:20:40 <tonyb> anteaya: I haven't replied because meeting / 7am
21:20:42 <ihrachys> tonyb: is it documented anywhere?
21:20:57 <anteaya> tonyb: yup, I understand
21:20:59 <tonyb> ihrachys: it's loosley documented in the stable guide
21:21:01 <mriedem> there is sort of a thing
21:21:10 <tonyb> ihrachys: I'll work on nailign that down.
21:21:15 <mriedem> http://docs.openstack.org/project-team-guide/stable-branches.html#project-specific-teams
21:21:19 <anteaya> part of this is me saying hello, and participating in the stable meeting
21:21:28 <tonyb> anteaya: :)
21:21:31 <anteaya> :)
21:21:46 <mriedem> the stable maint team is mostly just a sanity check on project-specifc core team nominations
21:21:50 <mriedem> at least IMO
21:21:50 <tonyb> #action tonyb to sync up with Rob re horizon-stable-core
21:21:54 <mriedem> and that's how i treated it before
21:22:23 <anteaya> cool
21:22:24 <tonyb> Yeah I fell like we need to see $person doign stable reviews befoer they're added to core
21:22:26 <ihrachys> the text seems rather clear to me. if that's not enough for projects, I guess it's wise to ask for suggestions.
21:22:45 <tonyb> that part isn't called out specifically
21:22:52 <david-lyle> in the past (maybe long past) PTLs were added automatically
21:22:58 <mriedem> i don't think just because someone is the PTL of a project that qualifies them for stable core
21:22:58 <david-lyle> is that no longer the case?
21:23:03 <ihrachys> tonyb: I think it's an implicit part of the culture in the project that you don't get +2 before enough reviews are done
21:23:09 <mriedem> like tonyb said you have to actually be doing stable branch reviews and show you know the policy
21:23:32 <anteaya> yeah that makes sense, knowledge drift is a thing
21:23:41 <tonyb> ihrachys: sure but you can +2 on master so .... there is some argument :/
21:23:48 <anteaya> for instance I didn't know about the section in the project team guide until now
21:23:53 <anteaya> thanks mriedem
21:24:25 <mriedem> a core can +2 an api change on master, sure,
21:24:33 <mriedem> that does'nt mean that core should +2 a backport of said api change on stable
21:25:12 <tonyb> mriedem: I didn't say I agreed with the argument just that it happens
21:25:36 <mriedem> yeah, it's pretty weak imo
21:25:50 <mriedem> anywho'
21:26:00 <tonyb> mriedem: did you have something?
21:26:04 <mriedem> no
21:26:12 <tonyb> mriedem: or did I misunderstand you earlier comment?
21:26:15 <tonyb> ahh okay
21:26:17 <mriedem> about?
21:26:39 <tonyb> mriedem: nm I took it out of context
21:26:58 <tonyb> summit items ....
21:27:05 <tonyb> Stable team fishbowl session is scheduled for 1:30pm on Thursday of the Design Summit.
21:27:13 <tonyb> Tuesday cross-project session to discuss co-installability requirements: https://www.openstack.org/summit/austin-2016/summit-schedule/events/9473
21:27:21 <tonyb> Tuesday cross-project session to discuss stable branch EOL policy https://www.openstack.org/summit/austin-2016/summit-schedule/events/9474
21:27:28 <tonyb> Tuesday cross-project session to discuss backward compat for libraries: https://www.openstack.org/summit/austin-2016/summit-schedule/events/9475
21:27:43 <tonyb> lots of good stuff there and I expect some "robust discussion" :)
21:28:10 <anteaya> points for good use of robust
21:28:18 <tonyb> anteaya: :)
21:28:39 <tonyb> anthing else for the meeting?
21:28:46 <mriedem> apoplectic discussion?
21:28:53 <mriedem> i learned about apoplectic the other day
21:28:54 <anteaya> there's a good one
21:29:02 <anteaya> it also is a good word
21:29:13 <tonyb> mriedem: It's hard to work into a discussion so good job :)
21:29:19 <anteaya> ha ha ha
21:29:28 <tonyb> 3 ...
21:29:45 <tonyb> 2 ...
21:29:54 <tonyb> 1
21:29:58 <tonyb> Thanks everyone
21:30:03 <tonyb> #endmeeting