15:00:56 <mriedem> #startmeeting stable
15:00:57 <openstack> Meeting started Tue Apr 19 15:00:56 2016 UTC and is due to finish in 60 minutes.  The chair is mriedem. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:59 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:02 <openstack> The meeting name has been set to 'stable'
15:01:10 <dims> o/
15:01:20 <bknudson> hi
15:01:53 <mriedem> i wasn't planning on running this today, so the agenda is stale
15:02:09 <mriedem> #topic status
15:02:21 <mriedem> there is one new known issue for kilo
15:02:30 <mriedem> testresources 2.0.0 released yesterday and breaks stable/kilo dsvm jobs
15:02:32 <mriedem> there is a cap here https://review.openstack.org/#/c/307858/
15:03:02 <bknudson> makes sense to cap it
15:03:11 <mrunge> yeah
15:03:20 <mriedem> im just waiting for jenkins to pass on it
15:03:37 <mriedem> but the check queue is way backed up
15:03:39 <mriedem> so could be awhile
15:04:04 <mriedem> anything else on status or issues?
15:04:15 <dims> mriedem : just kilo for now?
15:04:21 <mrunge> I would have something else
15:04:28 <mriedem> dims: as far as i know
15:04:38 <dims> ack mriedem
15:05:08 <mriedem> yeah liberty u-c uses 1.0.0 https://github.com/openstack/requirements/blob/stable/liberty/upper-constraints.txt#L314
15:05:20 <mriedem> mrunge: ok
15:05:25 <dims> mriedem : we had to add upper-constraints to keystone master/liberty/mitaka over the weekend
15:05:50 <ihrachys> sorry, late o/
15:05:58 <mrunge> o/
15:06:07 <mriedem> dims: as in had to use u-c for the keystone unit test jobs?
15:06:15 <dims> mriedem : yep
15:06:18 <mriedem> ok, good
15:06:25 <mriedem> we did that for nova on liberty 2 weeks ago
15:06:36 <mriedem> mrunge: did you have an issue?
15:06:42 <mrunge> ah yes, http://lists.openstack.org/pipermail/openstack-dev/2016-April/091655.html
15:06:46 <dims> y, i copied over tox.ini snippets from nova
15:06:52 <mriedem> mrunge: can we hold that for open discussion?
15:06:58 <mrunge> ack
15:07:02 <mriedem> unless rob is breaking the gate
15:07:03 <mriedem> :)
15:07:12 <mriedem> #topic release news
15:07:23 <mriedem> nova 12.0.3 was released for liberty last week
15:07:34 <mriedem> that's about all i know, i don't have a list of any proposed stable branch releases on me
15:07:50 <mriedem> i'm assuming tonyb has been getting added to those reviews by the releases team
15:08:10 <mriedem> it's probably a good idea to run the unreleased changes script though to see which projects should consider doing a release
15:08:23 <mriedem> #action run the unreleased changes script to see which projects should consider doing a stable branch release
15:09:03 <dims> mriedem : https://review.openstack.org/#/c/306525/ cinder liberty needs input
15:09:08 <mrunge> mriedem, could you make that a more regular job?
15:09:20 <mriedem> mrunge: as in...?
15:09:23 <mrunge> maybe each week?
15:09:32 <mriedem> personally i don't want to be responsible for that
15:09:33 <mrunge> just a reminder for projects?
15:10:06 <mrunge> I understand. I just thought of it as a a nag-mail
15:10:15 <mriedem> yeah, i have other cats to herd now
15:10:19 <mriedem> so i don't have time for that
15:10:23 <mriedem> someone else could do it though
15:10:33 <mriedem> i also don't think it needs to probably be done weekly
15:10:42 <mriedem> for sure around milestones
15:10:59 <mriedem> dims: ok, i can look at that one
15:11:30 <mriedem> dims: note that tonyb did +1 it
15:11:44 <ihrachys> mriedem: I guess it's per project decision how often to make it
15:11:58 <mriedem> yeah, neutron for sure needs to do it more often
15:12:02 <mriedem> because of their rate of backports
15:12:20 <mriedem> anyway, i'll try to do it this week
15:12:23 <dims> mriedem : ack i missed that update from last night
15:12:28 <mriedem> #topic tagging
15:12:59 <mriedem> i haven't seen any new requests for the stable:follows-policy tag in the governance repo
15:13:00 <mriedem> ttx was adding stable PTL to those though
15:13:02 <mriedem> #topic tooling
15:13:18 <mriedem> #link ihrachys has a series of tooling changes here https://review.openstack.org/#/q/owner:ihrachys%2540redhat.com+status:open+openstack-infra/release-tools
15:13:50 <ihrachys> yeah, and we use those tools for neutron massive backports. people are welcome to start adopting for their needs.
15:14:14 <mriedem> #topic stuck reviews
15:14:22 <mriedem> anyone have anything for this?
15:14:34 <mriedem> ihrachys: i asked sdague to review the nova liberty MTU patches
15:14:36 <mriedem> he posted some questions
15:14:47 <ihrachys> great. I will check them.
15:15:00 <mriedem> #topic open discussion
15:15:09 <sdague> yeh, on the second one, I was a little concerned the ovs type being referenced is too new to be available in liberty
15:15:19 <bknudson> since we've got stable/mitaka is stable/liberty now in phase 2?
15:15:26 <bknudson> http://docs.openstack.org/project-team-guide/stable-branches.html#support-phases
15:15:54 <mriedem> bknudson: i'd prefer to wait until the summit to decide that, but probably
15:16:11 <sdague> it's probably fine to make summit the cutoff vs. a strict 6 months
15:16:28 <mriedem> #info we'll decide on the support phase for stable/liberty at the newton summit next week
15:16:40 <sdague> do we actually have kilo eol published somewhere?
15:16:42 <bknudson> I wasn't sure if it was 6 months or just the # of stable branches available
15:16:56 <mriedem> sdague: there is a thing in the releases repo yeah
15:17:16 <bknudson> the next line says: only one branch is in Phase I support and only one branch is in Phase II support.
15:17:22 <ihrachys> sdague: I thought there is a cross project discussion that may end up prolonging support for kilo
15:17:26 <mriedem> http://releases.openstack.org/
15:17:28 <sdague> ah, cool, 05/02
15:17:42 <mriedem> ihrachys: right, there is, on tuesday
15:17:49 <ihrachys> #link https://etherpad.openstack.org/p/stable-branch-eol-policy-newton
15:17:55 <mriedem> #link tuesday xp session on stable branch eol policy https://www.openstack.org/summit/austin-2016/summit-schedule/events/9474
15:18:38 <mriedem> there are some other stable related talks on tuesday at the summit, those are linked in the meeting agenda
15:18:51 <mriedem> like co-installability requirements and backward compat for libraries
15:19:23 <mriedem> mrunge: ok, you wanted to talk about that ML thread
15:19:26 <mrunge> I just wanted to ask about the process to add someone to be stable-maint for a project
15:19:39 <mrunge> this caused it: http://lists.openstack.org/pipermail/openstack-dev/2016-April/091655.html
15:20:04 <mrunge> in the past, we had the ptl as another stable maint for a project
15:20:14 <mrunge> but tonyb -1 it.
15:20:22 <mriedem> mrunge: and i agreed with the -1
15:20:23 <mrunge> ping robcresswell it's about you
15:20:30 <mriedem> mrunge: given the lack of reviews
15:20:34 <robcresswell> Yep, I'm here.
15:20:43 <mrunge> so: what to do to get someone to be stable maint for a project
15:20:53 <robcresswell> Yeah, stable in Horizon has in general been neglected.
15:20:55 <mriedem> the same way you get to be core on any project
15:21:01 <mrunge> I mean, ultimately, the PTL should be in charge
15:21:06 <mriedem> you devote time to reviewing changes
15:21:07 <robcresswell> We're now in a position where we have a single active stable core.
15:21:09 <ihrachys> yes, I don't believe +2 should be granted for any repo without prior successfull history of reviews.
15:21:11 * ttx lurks
15:21:32 <robcresswell> I agree, me and tony spoke privately at the time
15:21:33 <mriedem> there is a reason we have specific stable core teams on projects
15:21:38 <mriedem> which are not the main project core team
15:21:39 <ttx> not that I pushed a proposal to retire has-stable-branches
15:21:41 <robcresswell> Just wanted to explain the odd situation we've ended up in.
15:21:43 <mriedem> b/c the review rules are different
15:21:48 <ttx> as we discussed before
15:22:16 <mrunge> we have a *very* few cores for stable in horizon
15:22:19 <ihrachys> robcresswell: so be the first one, show that you are capable to apply policies. for the time being, other stable maintainers will need to merge patches.
15:22:36 <ttx> tonyb, mriedem: feel free to +1 https://review.openstack.org/#/c/305702/
15:22:46 <mriedem> right, the stable-maint-core team can also +2 stable branch changes for horizon
15:22:51 <ihrachys> it should not take much time. we probably need a mentor for the new candidate for horizon stable core-ship.
15:22:56 <mriedem> until the horizon stable branch team is more populated
15:23:03 <robcresswell> ihrachys: Indeed, and I have been for the past few weeks, Was planning on bringing it up again around June time.
15:23:42 <mrunge> that leaves us in a difficult situation
15:23:44 <ihrachys> robcresswell: nice. I guess you have a list of patches that you believe are ready, so you solicit help with merges for the time being from stable-core-maint members.
15:23:59 <mrunge> with only 2-3 stable cores in horizon
15:24:13 <robcresswell> ihrachys: Yes, just been pushing patches through and pinging the members of the stable horizon team that are sort-of around.
15:24:18 <mrunge> or more 2 and 2 changing positions
15:24:27 <ihrachys> mrunge: I don't think anyone is against expanding the team.
15:24:31 <mriedem> robcresswell: you can also be pinging the stable-maint-core team in #openstack-stable
15:24:44 <ihrachys> robcresswell: right. you can also reach global team, not just horizon folks.
15:24:48 <mriedem> +1 to everything ihrachys is saying
15:25:07 <robcresswell> Understood
15:25:16 <mrunge> I totally get that, it's not about lowering rules for stable backports
15:25:54 <mrunge> so, how many reviews will it take?
15:26:08 <mrunge> we don't have that many backports for horizon at all
15:26:09 <mriedem> you're missing the point
15:26:35 <mriedem> it's also quality of reviews, which for stable is really just about enforcing policy more or less
15:27:00 <mriedem> so i think at this point it's just a matter of the stable-maint-core team reviewing the stable branch stuff for horizon that the horizon team has already gone through
15:27:05 <ihrachys> and gate breakage chasing
15:27:07 <mriedem> then we should have a better idea of the state of things
15:27:44 <mriedem> btw, this is nothing against robcresswell
15:27:50 <mrunge> heh. the number of backports in horizon is rather small
15:28:22 <mriedem> #action stable-maint-core team needs to look at the horizon stable backports given their project-specific team has shrunk
15:28:28 <mrunge> that means, it will take a significant amount of time to get a reasonable number of reviews
15:28:31 <bknudson> stable reviewers don't have to limit themselves to horizon
15:28:52 <bknudson> if you want to practice on keystone, please do.
15:28:52 <mriedem> bknudson: no, they don't, but if other projects have at least 2-3 stable cores they aren't in this situation
15:28:57 * mrunge feels uneasy to review changes e.g for neutron
15:29:48 <mriedem> so we have a first step,
15:30:05 <mriedem> mrunge and robcresswell can keep chugging away at horizon backport reviews,
15:30:13 <mriedem> and then i think we can come back to this after the summit
15:30:22 <mriedem> because i'm not comfortable just adding robcresswell today
15:30:29 <robcresswell> Fair enough
15:30:34 <mriedem> and the stable-maint-core team can help out with the +W
15:30:45 <mrunge> yes, I did not expect any change today
15:30:47 <robcresswell> mrunge is one of stable cores that is leaving :) It's only david-lyle who is active now.
15:30:55 <mrunge> so thank you
15:31:02 <robcresswell> Thanks for your time
15:31:14 <mriedem> we should probably be cleaning out the group ACLs in gerrit if people are leaving too
15:31:31 <mriedem> https://review.openstack.org/#/admin/groups/537,members
15:31:43 <robcresswell> Its on the list, but many are in transitioning periods and are still reviewing.
15:31:44 <mriedem> i can literally walk down the hall and kick doug-fish =
15:31:46 <mrunge> I'm not completely away, but +2 for revisiting members based on reviews
15:32:04 <mrunge> just kick, or kick out?
15:32:09 <mriedem> literally kick
15:32:14 <mrunge> ;-)
15:32:37 <mriedem> ok, so we have our todos, and we can reassess after the summit
15:32:39 <mriedem> sound good?
15:32:48 <mrunge> yes, thanks
15:32:56 <mriedem> cool
15:33:00 <mriedem> anything else for open discussion?
15:33:21 <mriedem> nope, ok, let's end early
15:33:23 <mriedem> thanks everyone
15:33:25 <mriedem> #endmeeting