21:00:53 <tonyb> #startmeeting stable
21:00:54 <openstack> Meeting started Mon Jun  6 21:00:53 2016 UTC and is due to finish in 60 minutes.  The chair is tonyb. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:55 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:57 <openstack> The meeting name has been set to 'stable'
21:01:04 <tonyb> roll call
21:01:04 <mriedem> o/
21:02:11 <tonyb> I'm sure there are lurkers sigmavirus24 jroll mtreinish etc
21:02:21 <jroll> >.>
21:02:22 <sigmavirus24> woops, sorry
21:02:23 <sigmavirus24> got distracted
21:02:26 <jroll> \o
21:02:35 <sigmavirus24> o/
21:02:42 <tonyb> #topic status
21:03:20 <rockyg> o/
21:03:28 <tonyb> To be frank I haven't been looking at the status there were a bunch of failures octavia designate glace zaqar
21:03:44 <mriedem> tonyb: yeah i rang up a few of those in the etherpad
21:03:45 <tonyb> at least designate was kilo only which mriedem fixed (and we;ll cover in release news)
21:04:03 <tonyb> mriedem: Thanks
21:04:11 <mriedem> zaqar and ceilometer are due to uncapped deps
21:04:22 <mriedem> people are looking at octavia i'm told in the ML
21:04:30 <mriedem> don't know about glnace
21:04:31 <tonyb> *sigh* okay
21:04:32 <mriedem> *glance
21:05:00 <mriedem> well, deps are capped in upper-constraints, but the unit test jobs aren't using constraints for those projects on stable/liberty
21:05:11 <tonyb> mriedem: okay I'll start with glance today and pick up what ever I can to day is a long day for me so I shoudl be able to chatch up
21:05:50 <tonyb> mriedem: Ah, that's a common pattern I think neutron, *aas have a formula to fix that
21:06:53 <tonyb> #topic action items
21:07:18 <tonyb> The only one is drop kilo which we'll talk about in release news ....
21:07:33 <tonyb> #topic release news
21:07:46 <tonyb> Kilo EOL
21:08:03 <tonyb> mriedem: dropped the periodic and bitrot jobs for kilo :)
21:08:22 <tonyb> There is a thread to work out exactly what needs to be EOL'd
21:08:39 <mtreinish> tonyb: not really lurking. I just normally forget
21:08:51 <mtreinish> which I would have if you didn't ping me
21:09:17 <tonyb> so have it's everythign with a kilo branch *excpet* the OpenStackAnsible,packstack and Chef projects + murano-apps will stay open on kilo
21:09:47 <tonyb> with the first 3 dropping support pretty soon but they need the kilo-eol tags in $projects first
21:10:18 <tonyb> I'm goign to do a bulk abandon on (my) Thursday and hand the complete list to infra on Friday
21:10:55 <tonyb> I have a script to help manage this for next time which is overkill given that it turns out to be nearly everything
21:11:53 <tonyb> I guess at some point we need to go through zuul/layout.yaml and remove kilo from the various "(dont')run this on kilo" patterns
21:12:00 <tonyb> anything else?
21:12:07 <mriedem> tonyb: i could do the project-config things
21:12:28 <tonyb> mriedem: that'd be great if you have time.
21:13:48 <tonyb> #action tonyb, mriedem drop project-config stuff
21:14:00 <tonyb> (worst action item *ever*)
21:14:16 <mriedem> rm -rf project-config
21:14:18 <mriedem> got it
21:14:40 <tonyb> Oh and I need to run over the list-unrekeased0-stable-stuff script and poke various PTLs
21:14:50 <tonyb> mriedem: \o/
21:15:14 <mtreinish> mriedem: wfm, I don't think anyone would notice anyway
21:15:14 <tonyb> mriedem: what're your plans for nova* releases ?
21:15:44 <tonyb> mriedem: I've see you mention it but we haven't overlapped :(
21:15:51 <mriedem> oh yeah
21:16:02 <mriedem> was going to look at this early this week, which would be today, but got totally distracted
21:17:30 <tonyb> mriedem: okay, I'm goign to assume "late" thsi week and try to work through the review queue and poke other cores for help as needed
21:17:40 <mtreinish> mriedem: I think tomorrow still counts as early this week
21:18:20 <mriedem> sure
21:18:32 <rockyg> mriedem, anything before your halfway point on your Wednesday counts as early in the week;-)
21:18:33 <tonyb> sigmavirus24: As the newest glance CPL I''ll ping you about glance stuff later this week, so look out
21:18:45 <sigmavirus24> cool
21:18:57 <tonyb> mriedem: Did you handle that with private emails to PTLs / CPLs ?
21:19:13 <tonyb> mriedem: and or pings on IRC?
21:20:35 * tonyb assumes that mriedem got distracted
21:20:42 <tonyb> #topic tagging
21:21:01 <tonyb> the agenda says that there is a manila review but that merged in the last couple of days
21:21:53 <mriedem> handle what now?
21:21:56 <tonyb> Oh no it didn't I need to re-review that :(
21:22:08 <mriedem> bugging people about doing stable releases?
21:22:17 <tonyb> mriedem: poking the PTLs and CPLs about releaseing projects
21:22:22 <tonyb> mriedem: Yup
21:22:32 <mriedem> ttx did the first one, i don't remember actually sending any emails
21:23:09 <tonyb> mriedem: ok
21:24:03 <tonyb> #topic stuck reviews
21:24:14 <tonyb> Anyone have anythign that isn't on the agenda?
21:25:08 <tonyb> that sounds like a "no"
21:25:20 <tonyb> #topic tooling / Open discussion
21:25:43 <tonyb> stable: document the 'proactive' backporting workflow / https://review.openstack.org/#/c/322273/
21:25:51 <tonyb> please review that ^^^
21:26:20 <tonyb> Anthing for open discussion ?
21:26:33 <tonyb> or do y'all want 30mins back?
21:26:54 * tonyb wonders if I'll *ever* type anything correctly
21:27:53 <mriedem> i want that time
21:28:20 <tonyb> okay
21:28:30 <tonyb> anyone goign to stand in mriedem's way?
21:28:43 <tonyb> and earn his ire?
21:29:12 * rockyg scoots out of mriedem's way quickly
21:29:23 <tonyb> #endmeeting