10:00:33 <tonyb> #startmeeting stable
10:00:34 <openstack> Meeting started Mon Nov 28 10:00:33 2016 UTC and is due to finish in 60 minutes.  The chair is tonyb. Information about MeetBot at http://wiki.debian.org/MeetBot.
10:00:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
10:00:37 <openstack> The meeting name has been set to 'stable'
10:01:02 <tonyb> Anyone around for the newly rescheduled and revitalised stable team meeting?
10:01:09 <apevec> o/
10:01:33 <tonyb> apevec: Howdy
10:01:34 <apevec> tonyb, good evening?
10:01:38 <ttx> o/
10:01:51 <tonyb> ttx: hi there
10:02:01 <tonyb> apevec: Yeah 2100 here
10:02:10 <tonyb> apevec: hopefully closer to noon for you
10:02:15 <tonyb> (and ttx)
10:02:34 <apevec> yep 11am
10:03:12 <tonyb> \o/
10:03:20 <tonyb> Lets get started
10:03:24 <tonyb> #topic status
10:03:45 <tonyb> #link http://status.openstack.org/openstack-health/#/g/build_queue/periodic-stable
10:04:07 <tonyb> networking-odl, networking-midonet, heat are all failing
10:04:37 <apevec> midonet jobs should be removed
10:04:50 <tonyb> I think they all have inflight fixes so hopefully this time next week we'll be back to the "rock solid" we've come to knwo and live this cycle
10:05:00 <apevec> yep
10:05:11 <tonyb> apevec: Oh? They're working on a fix
10:05:21 <apevec> ah them I'm out of date :)
10:05:37 <apevec> I thought they did not branch newton yet
10:05:53 <tonyb> apevec: Well ihar sent them a polite email saying ... "is there anybody out there"
10:06:01 <tonyb> apevec: Ahh okay
10:06:11 <apevec> https://review.openstack.org/#/c/402334/
10:06:24 <tonyb> apevec: that's a point I'll check for that thing after we EOL liberty
10:07:29 <tonyb> apevec: Ahh okay I see, only the *newton* jobs that makes more sense
10:07:55 <apevec> thread that Ihar started continued: http://lists.openstack.org/pipermail/openstack-dev/2016-November/107946.html
10:08:08 <apevec> it ended up w/ question for release team about branching procedure
10:08:09 <apevec> ttx, ^
10:08:37 <ttx> yeah, I wanted to wait until dhellmann was back to discuss the details
10:08:43 <apevec> ack
10:09:31 <tonyb> Hmm somehow I only saw the first message in the thread
10:09:42 * tonyb will need to adjust workflow ....
10:11:43 <tonyb> Anything else for status?
10:12:45 <tonyb> #topic Action items
10:12:54 <tonyb> move this meeting ... check :D
10:13:16 <tonyb> #topic Liberty EOL starting
10:13:43 <tonyb> So last week I sent the lists out of EOL vs non-EOL repos:
10:13:50 <tonyb> #link https://gist.github.com/tbreeds/93cd346c37aa46269456f56649f0a4ac#file-liberty_eol_data-txt-L1
10:14:00 <tonyb> #link https://gist.github.com/tbreeds/93cd346c37aa46269456f56649f0a4ac#file-liberty_eol_data-txt-L182
10:14:25 <tonyb> This week I'll start doign the Abandons and tagging (with infra's help)
10:15:01 <tonyb> Do eitehr of you see anything strange in the first list?
10:15:24 <tonyb> It's harder to un-EOL a repo than to EOL one later ;P
10:15:58 <ttx> tonyb: you're EOLing non-official stuff too ?
10:16:03 <tonyb> .... Oh glance, would like to be EOL'd late this week as they have an important chnage they'd like in liberty
10:17:02 <apevec> networking-* might need double-check, since they've stadium/non-stadium varieties...
10:17:09 <tonyb> ttx: Yes, it's my understanding that that make things better for infra.
10:17:18 <tonyb> apevec: okay.  I
10:17:34 <tonyb> ll poke armax / and Ihar before I do those.
10:17:44 <apevec> I think GBP projects complained last time?
10:17:45 <tonyb> last time Ihar opted them in
10:17:58 <ttx> nothing jumps to me as wrong (beyond the pile of non-official projects
10:18:00 <ttx> )
10:18:28 <tonyb> apevec: Yes, that was becasue I said I wouldn't EOL them and then did ... because of a process failure.
10:18:30 <apevec> ok, you have *group-based-policy* on the 2nd (not yet) list
10:19:20 <tonyb> apevec: they also have a repo in the first list ... I shoudl double check
10:19:47 <apevec> ah yes, I missed that one
10:19:57 <tonyb> apevec: One issue is the GBP gate will be b0rked once we EOL devstack and requirements
10:20:17 <apevec> yeah, they should be aware of that
10:20:28 <apevec> btw why deb-* want to keep EOL branch?
10:21:08 <tonyb> apevec: Well they're not getting EOLd or do you mean those tools will fall over once e EOL the branch?
10:22:15 <apevec> yeah, I wonder how they'll keep it working
10:22:45 <apevec> also I thought they started later then liberty
10:23:11 <apevec> zigo, ^
10:23:21 <apevec> (we can take it offline)
10:23:45 <tonyb> apevec: spot checking openstack/deb-nova
10:23:46 <tonyb> balder:deb-nova tony8129$ gti branch -va | grep liberty remotes/gerrit/stable/liberty 090bff7 Add error handling for delete-volume API remotes/origin/stable/liberty 090bff7 Add error handling for delete-volume API
10:23:50 <tonyb> balder:deb-nova tony8129$
10:24:24 <apevec> tonyb, that's b/c they cloned nova ?
10:24:41 <tonyb> apevec: I think the repos have been on debian infra for $long_time but they took a while to be cloned in to our infra which caused a small problem about 6 months ago
10:24:42 <apevec> deb work is in debian/*
10:25:03 <apevec> stable/* are just upstream clones afaict
10:25:13 <apevec> in deb-*
10:25:15 <tonyb> apevec: Ahh yes so they are
10:25:24 <tonyb> I need to check for debian/*
10:25:30 <apevec> so they should be removed imho
10:25:33 <apevec> to avoid confusion
10:25:40 <apevec> also debian/newton is the only branch
10:25:51 <tonyb> so in this case there isn't a debian/liberty so it shouldn't be a problem
10:26:07 <apevec> yeap, but let's hear from zigo to confirm
10:26:17 <tonyb> apevec: Yeah I'll try again
10:26:25 <tonyb> (to reach him)
10:28:14 <tonyb> Once the liberty EOL is done I intend to find all the older branches that are still around and try to get permission to clean them up
10:28:54 <tonyb> and after that look for $repos that have mitaka and master branches but no newton branch
10:30:13 <tonyb> any other thoughts on EOLing / cleaning up?
10:30:17 <ttx> nope
10:30:44 <apevec> nope
10:30:55 <tonyb> \o/
10:31:25 <tonyb> #topic Open discussion
10:31:32 <ttx> o/
10:31:40 <tonyb> ttx: shoot
10:31:56 <ttx> Wanted to raise that the release team is interested in having more stable release managers
10:32:14 <ttx> Basically we can give anyone you bless +2 to the openstack/releases repo
10:32:23 <tonyb> ttx: Ahh so last week apevec and I discussed him doing just that thing
10:32:36 <ttx> Since we require +2 from a stable team member anyway
10:32:45 <tonyb> ttx: I was goign to bring it up with dhellmann
10:33:12 <tonyb> ttx: I was thinking we'd start with one and test the process / tools and then maybe add a 3rd
10:33:29 <ttx> sounds like The idea is that the person would agree to only work on stable/* releases
10:33:38 <ttx> (or would decide to join the releas eteam proper if they want to do more)
10:33:46 <tonyb> ttx: IIRC we were goign to use the honor system rather than complex gerrit ACLs
10:33:51 <ttx> yep
10:33:55 <tonyb> cool
10:34:13 <ttx> Just to let you know that I checked and the Gerrit group is already there
10:34:43 <ttx> https://review.openstack.org/#/admin/groups/977,members
10:34:59 <ttx> ready to add individual members :)
10:35:12 <tonyb> ttx: awesome! I was just checking that part
10:35:51 <apevec> ack, I'm fine w/ honor system (and I was in Release Mangers before based on the same system)
10:35:54 <ttx> tonyb: do you need to stay in the "release managers" group ? Probably if you want to create some tags/branches
10:36:13 <ttx> (to do EOLing)
10:36:36 <ttx> at least until we automate that :)
10:36:55 <tonyb> ttx: Yup automation all the way!
10:37:39 <tonyb> ttx: I'm not sure about what permissions I need.  I guess that's a discussion to bring fungi in on
10:38:16 <ttx> tonyb: let's keep it the current way
10:39:07 <tonyb> ttx: Sounds good.  We can re-assess at the PTG ;P
10:40:15 <tonyb> #action tonyb to talk to dhellmann about adding apevec to releases-core for stable approvals
10:41:13 <tonyb> anything else?
10:41:23 <ttx> nothing from me
10:41:24 <apevec> I'm good
10:41:50 <vgridnev> hello, meeting still in the progress?  I were asking to help with removing icehouse branches, anyone can help?
10:41:57 <vgridnev> #link http://lists.openstack.org/pipermail/openstack-dev/2016-November/107754.html
10:42:37 <tonyb> vgridnev: Sure I have an item for December to find those things and clean them up
10:42:46 <tonyb> vgridnev: I can start with yours if you like :)
10:43:00 <vgridnev> cool tonyb, thanks
10:43:11 <tonyb> vgridnev: you're very welcome
10:43:53 <tonyb> I wanted to float the idea of includeing constraints support as a pre-req for the stable:follows-policy tag
10:44:37 <tonyb> I think it's reasonable to include it by way of the active-maintence clauses
10:44:59 <tonyb> #link http://docs.openstack.org/project-team-guide/stable-branches.html#active-maintenance
10:45:27 <tonyb> My rationale is that projects that do that thing really are co-installable and generally easier to take care of
10:45:50 <tonyb> thoughts?
10:47:25 <apevec> sounds good
10:49:19 <tonyb> If there isn't anything else I'll give y'all back 12 mins :)
10:50:36 <tonyb> Thanks everyone
10:50:46 <tonyb> #endmeeting