15:00:39 <ilyashakhat> #startmeeting Stackalytics
15:00:39 <openstack> Meeting started Mon Dec 16 15:00:39 2013 UTC and is due to finish in 60 minutes.  The chair is ilyashakhat. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:40 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:42 <openstack> The meeting name has been set to 'stackalytics'
15:00:57 <hnarkaytis> yeahh!!! lets have some fun
15:01:07 <ilyashakhat> #topic news
15:01:27 <ilyashakhat> release 0.4 happened last Thur
15:01:43 <hnarkaytis> link plz
15:01:56 <ilyashakhat> https://wiki.openstack.org/wiki/Stackalytics#Release_Notes
15:02:14 <hnarkaytis> cool!
15:03:02 <hnarkaytis> what about plans for next cycle&
15:03:12 <ilyashakhat> #topic roadmap for the next release
15:03:36 <hnarkaytis> do we have any blueprints?
15:03:40 <ilyashakhat> let's take a look at bps https://blueprints.launchpad.net/stackalytics
15:03:53 <ilyashakhat> the first is https://blueprints.launchpad.net/stackalytics/+spec/extend-russell-report
15:04:06 <hnarkaytis> yeahh, I like this one
15:04:19 <hnarkaytis> approve
15:06:04 <hnarkaytis> so there would be a couple of additional metrics
15:06:15 <ilyashakhat> currently we have a good top of reviewers and want to extend it
15:06:17 <hnarkaytis> like number of commits and patchsets
15:06:40 <ilyashakhat> that will correlate more with what "cores" look like
15:06:54 <ilyashakhat> they do most reviews and do a number of commits
15:07:00 <hnarkaytis> I wonder if Russel is here right now
15:07:21 <russellb> sort of
15:07:31 <hnarkaytis> hi there
15:07:49 <hnarkaytis> we decided to extend your report
15:08:11 <hnarkaytis> so there would be more transparency for promotion to core
15:09:23 <hnarkaytis> so what about other BP?
15:10:07 <hnarkaytis> I see metric - patchset
15:10:09 <ilyashakhat> another candidate is https://blueprints.launchpad.net/stackalytics/+spec/metric-patchset
15:10:31 <hnarkaytis> yahh - this one is easy
15:10:42 <ilyashakhat> this metric shows a number of patchsets posted for review
15:11:44 <ilyashakhat> also we can add some module summary, like the ratio between posted patches and merged
15:12:02 <hnarkaytis> BTW, getting back to Russells report. There is another idea, to make it more interactive - add drop-down with report period in days, and drop-down with projects list
15:12:18 <ilyashakhat> yep, that's doable
15:12:33 <hnarkaytis> do we have this idea in BP?
15:12:46 <ilyashakhat> yep
15:13:04 <hnarkaytis> cool
15:13:18 <ilyashakhat> hnarkaytis: let's go further
15:13:46 <hnarkaytis> well - this is not enough for next release cycle
15:13:46 <ilyashakhat> https://blueprints.launchpad.net/stackalytics/+spec/openstack-status
15:13:53 <hnarkaytis> we need some killer feature
15:15:07 <hnarkaytis> this one doesn't look reasonable... there would be 99% of python and 1% of HTML
15:15:15 <ilyashakhat> agree
15:15:30 <hnarkaytis> number of downloads is not trackable
15:15:35 <ilyashakhat> and we don't have any info on download
15:15:39 <hnarkaytis> lets abandon this one
15:16:00 <hnarkaytis> so what ablut killer feature?
15:16:03 <ilyashakhat> move bp to deferred?
15:16:21 <hnarkaytis> yeah - lets move it to deferred
15:16:42 <hnarkaytis> there was an idea to add more functionality around timeline
15:16:56 <hnarkaytis> trends analysis
15:18:06 <ilyashakhat> what is that about?
15:18:08 <hnarkaytis> at least we need a decent legend for timeline
15:18:16 <SergeyLukjanov> o/
15:18:36 <ilyashakhat> legend is easy-doing-thing
15:19:01 <hnarkaytis> probably more controls to manipulate timeline
15:19:15 <hnarkaytis> something like Google analytics
15:19:15 <ilyashakhat> SergeyLukjanov: do you have any ptl requests?
15:19:38 <ilyashakhat> we are limited by library here
15:19:52 <ilyashakhat> they don't provide such functionality
15:20:00 <ilyashakhat> only static image
15:20:38 <hnarkaytis> I have an idea! lets track visits to personal pages and calculate popularity of developers
15:21:08 <ilyashakhat> or find the one who checks his stats most :)
15:21:23 <hnarkaytis> actually I can extract such report from google analitycs
15:22:07 <hnarkaytis> there was a request on projects grouping
15:22:08 <ilyashakhat> #topic Open Bugs
15:22:21 <ilyashakhat> here it is: https://bugs.launchpad.net/stackalytics/+bug/1244485
15:22:23 <uvirtbot> Launchpad bug 1244485 in stackalytics "Grouping used in stackalytics is inaccurate/incorrect" [High,New]
15:22:49 <hnarkaytis> lets discuss details
15:23:00 <chandankumar> hello
15:23:08 <chandankumar> sorry i got late
15:23:27 <hnarkaytis> we are talking about projects grouping
15:23:49 <ilyashakhat> hnarkaytis: for example tempest is currently in 'other' group, but should be in core
15:24:05 <hnarkaytis> right now we have 5 top level categories
15:24:21 <chandankumar> ilyashakhat, hnarkaytis hello
15:24:28 <ilyashakhat> chandankumar: hi!
15:24:34 <SergeyLukjanov> probably, I'd like to see some stats about code review latency, like http://russellbryant.net/openstack-stats/all-openreviews.html
15:25:00 <hnarkaytis> chandankumar: hi
15:25:21 <ilyashakhat> SergeyLukjanov: http://stackalytics.com/report/reviews/neutron/open
15:25:32 <hnarkaytis> I beleive that we already have this report
15:25:36 <SergeyLukjanov> and something like http://status.openstack.org/reviews/ but for projects groups
15:26:56 <hnarkaytis> SergeyLukjanov: tell us more about this report
15:27:35 <hnarkaytis> what is S and F?
15:27:43 <SergeyLukjanov> hnarkaytis, it's a prioritized list that could be used be reviewers to take the hottest CRs to review first
15:27:52 <SergeyLukjanov> by reviewers*
15:28:03 <ilyashakhat> hottest = most reviewed?
15:28:15 <ilyashakhat> do you know the criteria?
15:28:18 <SergeyLukjanov> that needs review
15:28:43 <SergeyLukjanov> S == some score of the importance
15:28:46 <chandankumar> SergeyLukjanov, CR means?
15:28:52 <SergeyLukjanov> F == feedback
15:29:00 <DinaBelova> chandankumar, Change Request
15:29:03 <SergeyLukjanov> chandankumar, code review
15:29:08 <DinaBelova> oh :)
15:29:39 <hnarkaytis> any ideas how this score is calculated?
15:29:45 <SergeyLukjanov> DinaBelova, change requests works too
15:29:57 <DinaBelova> SergeyLukjanov, yep, both appropriate :)
15:30:04 <chandankumar> :)
15:30:08 <SergeyLukjanov> hnarkaytis, it consists of importance of bugs/blueprints linked to this CR
15:30:49 <ilyashakhat> well, Stackalytics doesn't have bugs info
15:31:02 <hnarkaytis> well, we need to look into this report offline
15:31:07 <ilyashakhat> so it would be impossible to calc this
15:31:38 <SergeyLukjanov> and I think that it should depend on reviewers latency
15:31:42 <hnarkaytis> BTW, statistics on bugs is a good idea
15:31:51 <ilyashakhat> #action hnarkaytis to look at how http://status.openstack.org/reviews/ is calculated
15:31:53 <chandankumar> hnarkaytis, yes
15:32:36 <hnarkaytis> lets add a BP with bugs metric
15:33:00 <chandankumar> hnarkaytis, can we add a feature that a user can filed a bug on launch pad.
15:33:34 <chandankumar> is shown in stackalytics?
15:33:54 <hnarkaytis> chandankumar: I can't say that I understood you correctly...
15:34:21 <chandankumar> ok, i can tell about this after meeting
15:34:32 <hnarkaytis> ok, lets take this offline
15:34:58 <SergeyLukjanov> it'll be really cool to have some page 'to review' that'll show all change requests that are not yet reviewed by the current user atm especially if it'll be possible to specify several project groups to be shown
15:35:04 <SergeyLukjanov> with prioritie
15:35:34 <SergeyLukjanov> are there any plans to add user settings?
15:35:50 <hnarkaytis> for now Stackalytics is stateless
15:35:51 <SergeyLukjanov> you now all launchpad ids and it's really easy to impl launchpad-based auth
15:35:54 <ilyashakhat> user settings -- no
15:36:27 <ilyashakhat> SergeyLukjanov: list of reviews -- isn't it the same that gerrit shows?
15:36:28 <hnarkaytis> otherwise it would be impossible to deploy another copy and double check correctness of numbers
15:36:44 <SergeyLukjanov> ilyashakhat, the main thing is to correctly sort them
15:36:53 <SergeyLukjanov> and hide already reviewed by you
15:37:00 <ilyashakhat> ah
15:37:03 <ilyashakhat> got it
15:37:06 <ilyashakhat> it
15:37:25 <ilyashakhat> it's not possible to hide already reviewed in gerrit, right?
15:37:51 <SergeyLukjanov> yup, you can't specify filter like review by NNN
15:38:00 <SergeyLukjanov> sort isn't depends on user setting
15:38:18 <SergeyLukjanov> and to hide CR you just need the users launchpad id
15:38:47 <SergeyLukjanov> is it possible to see open CRs at stackalytics atm?
15:39:07 <hnarkaytis> yes - we have this information
15:39:25 <ilyashakhat> but we don't have report that shows all open
15:39:54 <ilyashakhat> maybe we can add report available with LP auth that shows smth like 'recommended for review'
15:40:07 <ilyashakhat> and that's gonna be a killa feature
15:40:19 <hnarkaytis> well - this sounds more reasonable
15:40:39 <hnarkaytis> lets put this idea into BP and sleep with it for a night
15:40:50 <chandankumar> ;)
15:41:05 <SergeyLukjanov> ping me when you'll think about the score calculation
15:41:15 <SergeyLukjanov> I think that I have some ideas
15:41:20 <hnarkaytis> ok, I'll find you
15:41:29 <ilyashakhat> plz add them to bp :)
15:41:56 <hnarkaytis> I want to get back to grouping
15:42:08 <hnarkaytis> right now we have 5 top level groups
15:42:40 <hnarkaytis> according to official documents - there should be only 3 - core, integrated, incubated
15:43:16 <hnarkaytis> originally we decided to extract documentation into dedicated group, beacuse it generates much more LOCs then any other
15:43:59 <hnarkaytis> infrastructure is listed as a part of core programms
15:44:02 <ilyashakhat> and what about projects like 'gitdm', 'statusbot'
15:44:11 <ilyashakhat> where do they go?
15:44:21 <hnarkaytis> 'other'
15:44:53 <ilyashakhat> and what goes as 'infra'?
15:44:58 <hnarkaytis> so there would be 4 categories: core, integrated, incubated, other
15:46:22 <SergeyLukjanov> do we really need core?
15:46:37 <hnarkaytis> https://bugs.launchpad.net/stackalytics/+bug/1244485
15:46:40 <uvirtbot> Launchpad bug 1244485 in stackalytics "Grouping used in stackalytics is inaccurate/incorrect" [High,New]
15:47:40 <hnarkaytis> core - is the main group. there is no option to remove it
15:47:44 <ilyashakhat> SergeyLukjanov: if not, where all core projects go?
15:47:57 <SergeyLukjanov> integrated
15:48:37 <ilyashakhat> officially integrated != core
15:48:40 <SergeyLukjanov> for me there are several groups: [official: [integrated],[incubated]] [others]
15:48:51 <SergeyLukjanov> core is the subgroup for integrated
15:49:17 <SergeyLukjanov> and afaiu it's not really clear def of core
15:49:25 <hnarkaytis> we don't want to have the 3rd level of classification
15:50:19 <hnarkaytis> probably we need to replace tree-like classification on tags
15:50:59 <ilyashakhat> super-groups like module-groups
15:51:05 <hnarkaytis> then it would not be a problem to calculate stats on documentation
15:51:13 <ilyashakhat> and remove project type selector completely
15:51:41 <hnarkaytis> lets discuss this offline. probably tags is a good idea
15:52:09 <ilyashakhat> #action discuss tags vs project types
15:52:31 <ilyashakhat> so I guess that's pretty all with agenda
15:52:40 <ilyashakhat> #topic open discussion
15:52:40 <hnarkaytis> ilyashakhat: do we have anything else if our backlog for today's meeting
15:53:00 <hnarkaytis> I have a question
15:53:05 <ilyashakhat> yes, please
15:53:45 <hnarkaytis> is there any sense to apply for incubated for Stackalytics?
15:54:22 <ilyashakhat> well, our mission is not related to OS, but related to community
15:55:01 <ilyashakhat> do you think we map to definition of Program?
15:55:02 <hnarkaytis> yeah - we are not tied to OS...
15:55:53 <hnarkaytis> I prefer to have Stackalytics more independent from official programs
15:56:09 <ilyashakhat> as it is now?
15:56:29 <hnarkaytis> yeah
15:56:54 <hnarkaytis> well - I think we are done
15:56:58 <hnarkaytis> lets wrap up
15:57:02 <ilyashakhat> ok, I think it's time to say goodbye)
15:57:06 <ilyashakhat> #endmeeting