#openstack-meeting: state-management

Meeting started by harlowja at 20:00:46 UTC (full logs).

Meeting summary

    1. https://wiki.openstack.org/wiki/Meetings/StateManagement#Previous_meetings (harlowja, 20:01:48)
    2. https://wiki.openstack.org/wiki/Meetings/StateManagement#Agenda_for_next_meeting (harlowja, 20:02:16)

  1. where-everyone-is-at (harlowja, 20:02:56)
    1. https://review.openstack.org/#/c/29862/ (patch set 8) (harlowja, 20:04:45)
    2. https://launchpad.net/~taskflow-dev and https://launchpad.net/taskflow (jlucci, 20:06:29)
    3. https://review.openstack.org/#/c/32036/ (jlucci, 20:07:31)
    4. https://review.openstack.org/#/c/32036/ (harlowja, 20:07:39)

  2. launchpad (harlowja, 20:08:23)
    1. https://launchpad.net/taskflow (harlowja, 20:08:57)
    2. ACTION: harlowja investigate dev openness (harlowja, 20:11:20)

  3. stackforge (harlowja, 20:12:54)
    1. https://github.com/stackforge/taskflow (harlowja, 20:13:06)

  4. fsm-pattern (harlowja, 20:19:08)
    1. https://review.openstack.org/#/c/32036/ This contains the entirety of the distributed code right now (jlucci, 20:27:20)
    2. https://review.openstack.org/#/c/32036/1/taskflow/distributed/DTClient.py (jlucci, 20:27:36)
    3. https://review.openstack.org/#/c/32036/1/taskflow/patterns/distributed_flow.py (jlucci, 20:27:56)
    4. https://review.openstack.org/#/c/32036/1/taskflow/tests/unit/test_distributed_flow.py (jlucci, 20:28:31)
    5. ACTION: jlucci think about how taskflow decorator/task object can be translated in the distriubted_flow pattern to something that celery can use (thus not exposing celery to everyone) (harlowja, 20:38:23)
    6. ACTION: bug josh if it makes no sense (harlowja, 20:38:51)

  5. cinder/nova integration (harlowja, 20:42:31)
    1. https://review.openstack.org/#/c/29862/ (harlowja, 20:42:48)
    2. ACTION: jlucci get overview of heat co-routine and report back? (harlowja, 20:55:37)
    3. ACTION: alexheneveld get sam corbett from our side to give you chapter and verse :) (alexheneveld, 20:56:29)

  6. action-items-that-should-of-been-done-at-the-start (harlowja, 20:57:29)
    1. https://wiki.openstack.org/wiki/StructuredWorkflowLocks#Databases (harlowja, 20:59:37)
    2. ACTION: drian_otto to update wiki with Galera as a SQL option (adrian_otto, 21:00:05)
    3. ACTION: adrian_otto to update wiki with Galera as a SQL option (harlowja, 21:00:14)


Meeting ended at 21:00:23 UTC (full logs).

Action items

  1. harlowja investigate dev openness
  2. jlucci think about how taskflow decorator/task object can be translated in the distriubted_flow pattern to something that celery can use (thus not exposing celery to everyone)
  3. bug josh if it makes no sense
  4. jlucci get overview of heat co-routine and report back?
  5. alexheneveld get sam corbett from our side to give you chapter and verse :)
  6. drian_otto to update wiki with Galera as a SQL option
  7. adrian_otto to update wiki with Galera as a SQL option


Action items, by person

  1. adrian_otto
    1. adrian_otto to update wiki with Galera as a SQL option
  2. alexheneveld
    1. alexheneveld get sam corbett from our side to give you chapter and verse :)
  3. harlowja
    1. harlowja investigate dev openness
  4. jlucci
    1. jlucci think about how taskflow decorator/task object can be translated in the distriubted_flow pattern to something that celery can use (thus not exposing celery to everyone)
    2. jlucci get overview of heat co-routine and report back?
  5. UNASSIGNED
    1. bug josh if it makes no sense
    2. drian_otto to update wiki with Galera as a SQL option


People present (lines said)

  1. harlowja (143)
  2. jlucci (41)
  3. adrian_otto (30)
  4. hemna (16)
  5. randallburt (13)
  6. kebray (10)
  7. alexheneveld (9)
  8. changbl (6)
  9. openstack (3)
  10. devananda (2)
  11. kchenweijie (2)
  12. dansmith (1)
  13. uvirtbot (1)


Generated by MeetBot 0.1.4.