19:59:37 <harlowja> #startmeeting state-management
19:59:38 <openstack> Meeting started Thu Jul 11 19:59:37 2013 UTC.  The chair is harlowja. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:59:39 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:59:41 <openstack> The meeting name has been set to 'state_management'
19:59:46 <harlowja> howday folks!
20:00:22 <harlowja> \o/
20:00:33 <jlucci1> hola
20:01:00 <harlowja> cómo estás
20:01:26 <harlowja> Es este el canal español
20:01:30 <jlucci1> Muy bien. Gracias. Y tu?
20:01:44 <harlowja> mu bein
20:01:46 <harlowja> haha
20:02:20 <harlowja> oh this is meeting time, not play around time, oops
20:02:20 <jlucci1> Si, si es el canal de espanol
20:02:26 <jlucci1> boo
20:02:29 <harlowja> ha
20:03:07 <harlowja> been a long time, hope had good 4th
20:03:09 <harlowja> #link http://eavesdrop.openstack.org/meetings/state_management/2013/state_management.2013-06-27-20.00.html
20:03:22 <harlowja> i made a few more tiny examples, nothing super major yet
20:03:55 <harlowja> #topic action-items
20:04:01 * harlowja i made a few more tiny examples, nothing super major yet
20:04:26 <harlowja> made https://wiki.openstack.org/wiki/Nova/TaskSystemRequirements brought that up during nova meeting, not much filled in there, guess i'll have to get creative and make more of my own nova requirements :(
20:04:39 <harlowja> johnthetubaguy1 might get some time to help, but depends on how busy he is
20:05:13 <harlowja> kebray u have any luck with the 'see if someone from Trove can provide a high level sentence or two (and link to code) on their task execution code, desires around a common library, etc.'
20:05:56 <kebray> dough… let me ping mbasnight via email right now… will copy you.
20:06:19 <kebray> doh!   sorry, got homemade pizza dough recipe on the brain… already planning ahead for the evening :-)
20:06:19 <harlowja> np
20:06:30 <harlowja> your brain has turned into pizza dough
20:06:31 <harlowja> not good
20:06:36 <harlowja> u might want to get that checked out
20:06:36 <kebray> nope.. not good at all.
20:06:47 <kebray> Traveling… that's what happens.  currently in ATL airport.
20:06:50 <harlowja> ah
20:07:10 <harlowja> friends don't let friends turn there brains into pizza dough
20:07:32 <harlowja> anyway, i'll continue working on more examples
20:08:00 <harlowja> think that covers action items, adrian not around it seems
20:08:10 <harlowja> #topic status-check
20:09:07 <harlowja> so i've just been chugging away at the parallel flow, doing reviews, updating taskflow with some mini-changes
20:09:57 <harlowja> jlucci1 how's the distributed goodness going
20:10:14 <jlucci1> Pretty good, pretty good. Only blocker left is the stuff I talked with you about yesterday
20:10:35 <harlowja> ya, the user-code stuff
20:10:52 <harlowja> or user-tasks and imports and all that
20:10:56 <jlucci1> Yeah, so for right now, just working on forcing a user defined-task at woker startup
20:10:58 <jlucci1> worker *
20:11:01 <jlucci1> Yupyup
20:11:10 <jlucci1> So, getting that in for the taskflow release
20:11:13 <kchenweijie> hey, sorry im a bit late. didnt see the time
20:11:32 <jlucci1> Then going back to change the impl to make it more customizable
20:11:38 <harlowja> sweet
20:11:41 <harlowja> kchenweijie np
20:11:41 <jlucci1> after initial taskflow release
20:11:58 <harlowja> ya jlucci1  i think we can spend quite a bit of time figuring out how to do what u guys want
20:12:09 <harlowja> in a way that won't require making a new python sandbox
20:12:21 <jlucci1> Yeah, I feel like this might be a couple-day's worth of discussion type thing
20:12:21 <harlowja> just depends on what u really want users to be able to do
20:12:29 <harlowja> arbitiray code execution *scary*
20:12:31 <jlucci1> So, just getting this first pass in so distributed exists
20:12:43 <jlucci1> Then going back and having all the fun talks. haha
20:13:00 <harlowja> sweet
20:13:09 <harlowja> u guys are coming to CA so we can have that fun then :-p
20:13:16 <harlowja> i think thats still happening, kebray ?
20:13:29 <jlucci1> It better be - I already bought my plane tickets. ha
20:13:31 <harlowja> lol
20:13:42 <harlowja> cool
20:14:09 <harlowja> well sounds pretty good, how much longer u think for that first pass?
20:14:14 <kebray> Yeah, it's a definite.. Thursday July 25
20:14:19 <harlowja> k
20:14:24 <harlowja> thx kebray
20:14:30 <harlowja> i'll try not to die in NY
20:14:32 <kebray> harlowja, you are welcome to visit the RS office Friday if you want.
20:14:35 <jlucci1> I'm just building up test cases at this point/hammering out fine details
20:14:45 <harlowja> kebray sure sure
20:14:56 <harlowja> jlucci1 cool
20:15:06 <jlucci1> Soo, I want to say tomorrow, but I also have an exam tonight and a final on Saturday
20:15:11 <harlowja> eck
20:15:19 <jlucci1> So it may not be until Monday/Tuesday next week
20:15:22 <harlowja> python exam?
20:15:24 <jlucci1> hahah
20:15:26 <jlucci1> I wish
20:15:43 <jlucci1> Electrochemistry/redox reactions and kinetics just aren't as much fun
20:15:47 <harlowja> woah
20:15:50 <harlowja> h20
20:16:04 <jlucci1> Done. I'll have your code in two hours
20:16:05 <jlucci1> ha
20:16:15 <harlowja> all good, i'll try to do some code reviews next week also, when i'm in NY
20:16:20 <harlowja> *unsure about wireless access*
20:16:47 <harlowja> kchenweijie how's your persistance stuff
20:17:00 <harlowja> mr.leading db expert kchenweijie
20:17:08 <kchenweijie> well i finished up working in the new design (no persistence for flows, jobs, tasks, etc)
20:17:26 <kchenweijie> now im just wrestling with git (i dont understand why im so bad) and getting ready to put up a code review
20:17:35 <harlowja> git has like a learning period i think
20:17:38 <harlowja> like 3months i think
20:17:44 <kchenweijie> i feel like i break git on a daily basis
20:17:51 <harlowja> ya, i felt that way a while ago also
20:18:09 <kchenweijie> but yeah, once i get git to do what i want, the code review will be up for you
20:18:12 <harlowja> anything we can help with
20:18:26 <harlowja> beat git with a stick?
20:18:31 <harlowja> *not literally*
20:18:39 <kchenweijie> if you could somehow explain to me why rebasing makes git think my branch is 5 commits behind and 4 commits ahead, that would be very helpful
20:18:41 * harlowja gonna get in trouble via anniec
20:19:04 <harlowja> so 5 commits behind, 4 commits ahead
20:19:22 <harlowja> thats 9 commits in the middle
20:19:26 <harlowja> or -1 commits behind
20:19:27 <harlowja> :-/
20:19:28 <kchenweijie> so i do an interactive rebase, re-push it, and all of a sudden bad things happen
20:20:01 <harlowja> hmmm, let me see if i can help u afterwards, sound good
20:20:01 <clarkb> I think that means you rebased atop something that was 5 commits behind and have 4 commits you added there
20:20:33 <kchenweijie> maybe
20:20:38 <kchenweijie> i really need to figure out this rebasing thing
20:20:40 <harlowja> ya clarkb could be right, but if pushing breaks, then it might not be able to rebase correctly
20:20:44 <harlowja> and u could be in the middle of a rebase still
20:20:51 <kchenweijie> thats wehre i keep breaking git
20:21:01 <kchenweijie> ill look into it after i get this code review in
20:21:02 <harlowja> ya, its a tricky part
20:21:21 <kchenweijie> other than that, thats it for me
20:21:31 <harlowja> cool, i'll see if i can help u with the git madness
20:22:19 <harlowja> any other status from folks, there is some neat work that i know about going with a 'block flow' concept
20:22:28 <harlowja> #link https://review.openstack.org/#/c/36472/
20:22:34 <harlowja> seeing how that can shape into something pretty useful
20:22:47 <harlowja> *see the tests for a good example or 2
20:23:29 <harlowja> it allows for a slightly more natural way to use flows (and subflow), so might be pretty nice
20:23:53 <harlowja> although we have to be careful to not start creating to much of a mini-dsl (domain specific language) ahead of time
20:24:40 <harlowja> so just something neat to comment on if u guys want to
20:25:03 <harlowja> #topic release
20:25:24 <harlowja> so for this one, seems like after next week, we can have a potential 0.1 ?
20:25:42 <jlucci1> I think so
20:25:55 <harlowja> and then we can start getting usage in cinder and nova (and heat?) and elsewhere, at least with said thing it becomes easier for them to try it
20:26:05 <jlucci1> I'd also really like to get some more robust docs/examples before release too
20:26:25 <harlowja> asalkeld keeps on suggesting to me that we shouldn't go on pypi and should go via a update.py (copy/paste) mechaism like oslo-incubator
20:27:14 <harlowja> pypi means some level of api stabilitiy i think in his point of view, which means we can't change stuff as easily
20:27:26 <harlowja> but with update.py we can more easily change things (?)
20:28:23 <jlucci1> mmm
20:28:39 <jlucci1> But this would have the potential to move over to pypi after more stabilization?
20:28:57 <harlowja> sure, thats afaik how the oslo-incubator path goes
20:29:14 <jlucci1> kewl
20:29:14 <harlowja> but it becomes a question of when is anything stable, ha
20:29:44 <harlowja> #link https://github.com/openstack/oslo-incubator/blob/master/update.py
20:30:01 <jlucci1> Right, right. But that's true for any project. : P
20:30:25 <harlowja> so the update.py approach would mean that if openstack project wants to use taskflow, we'd basically copy taskflow to there source directory, ie nova/taskflow
20:30:38 <jlucci1> :/
20:30:45 <harlowja> ya, so thats the downside
20:31:15 <harlowja> or u could make it more configurable, update.py --flows=linear,graph
20:31:21 <harlowja> and then just copy the pieces needed to use those
20:31:29 <harlowja> but its copy still
20:31:41 <jlucci1> mmm - I just hate the idea of this going to pypi one day, and then having 20 files break because your import path has changed
20:31:53 <jlucci1> And copy/pasting files
20:31:54 <jlucci1> haha
20:32:21 <harlowja> ya, i know what u mean
20:33:04 <jlucci1> But it sort of seems like the only option atm
20:33:22 <harlowja> well or release to pypi and deal with that
20:33:55 <jlucci1> I just don't think we're ready for a pypi release yet
20:34:05 <jlucci1> If we have to have a pretty-set API
20:34:06 <harlowja> but maybe we aren't ready for that, maybe if we get pretty good used adoption in cinder/heat for example then we can say 'its great now' and then pypi
20:34:44 <jlucci1> Yeah, that seems to be the way to go
20:35:30 <harlowja> k, it does make it a little more painful versioning wise, but might be ok to get adoption
20:35:38 <harlowja> tradeoffs either way i guess
20:36:29 <harlowja> i'm fine with trying it and seeing how it goes
20:36:34 <jlucci1> + 1
20:36:35 <harlowja> *the update.py approach
20:36:39 <jlucci1> yeah haha
20:37:23 <harlowja> ok, i'll see if i can create a  update.py *similar thing* sometime
20:37:34 <jlucci1> action item?
20:37:36 <harlowja> #action harlowja make update.py similar thing
20:37:42 <jlucci1> lol
20:38:22 <harlowja> :) sounds like we'll see what happens with that until proven otherwise
20:39:16 <harlowja> #topic use-cases
20:39:28 <harlowja> any new uses cases for folks interesting in trying taskflow out??
20:39:36 <harlowja> use cases (free by the dozen)
20:40:38 <harlowja> alright then, maybe next time :-P
20:40:41 <jlucci1> Not that I know of
20:40:41 <jlucci1> ha
20:40:56 <harlowja> sweet, open discussion then
20:41:02 <harlowja> #topic open-discuss
20:41:21 <harlowja> i'll be out next week btw, so jlucci1 i think will be leading the starship
20:41:30 <jlucci1> : D
20:41:51 <harlowja> phases at stun jlucci1
20:41:54 <harlowja> *phasers
20:42:00 <harlowja> lol
20:42:05 <jlucci1> :P
20:42:32 <harlowja> any awesome open discussions for folks?
20:42:37 <harlowja> *or not awesome is ok also
20:43:36 <harlowja> goiiing once
20:43:48 <harlowja> goiiiiing twiiice
20:44:03 <harlowja> sold
20:44:26 <harlowja> for refunds (or futher questions) please visit #openstack-state-management
20:44:31 <harlowja> 24/7 service
20:44:58 <harlowja> thx kchenweijie jlucci1 for coming :)
20:45:08 <jlucci1> haha yupyup
20:45:20 <harlowja> #end-meeting
20:45:27 <harlowja> #endmeeting