20:00:13 <harlowja> #startmeeting state-management
20:00:14 <openstack> Meeting started Thu Aug  8 20:00:13 2013 UTC and is due to finish in 60 minutes.  The chair is harlowja. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:17 <openstack> The meeting name has been set to 'state_management'
20:00:29 <harlowja> interesting, is the 'due to finish new'
20:00:40 <harlowja> maybe i just never paid attention
20:00:52 <harlowja> \0/
20:00:55 <jlucci> ?
20:01:03 <harlowja> "Meeting started Thu Aug  8 20:00:13 2013 UTC and is due to finish in 60 minutes."
20:01:06 <adrian_otto> hi
20:01:09 <harlowja> hi hi
20:01:26 <harlowja> i don't remember if due to finish was there before, ha
20:01:27 <jlucci> Yeah - it says "due to finish in 60 minutes"
20:01:30 <jlucci> Oh
20:01:32 <jlucci> haha
20:01:33 <harlowja> what happens at 61
20:01:34 <harlowja> :-/
20:01:45 <jlucci> The program divides by 0
20:01:47 <kchenweijie> hello
20:01:54 <melnikov> hi there
20:01:55 <harlowja> howday
20:02:02 <harlowja> melnikov thx for joining, know its late
20:02:18 <melnikov> not that late in fact
20:02:25 <melnikov> a midnight
20:02:33 <harlowja> lol
20:02:36 * harlowja thats late
20:02:47 <harlowja> ;)
20:03:25 <harlowja> alright, anyway, getting started
20:03:36 <harlowja> #topic announcements
20:03:51 <harlowja> ya for cinder
20:03:59 <jlucci> :D
20:04:01 <harlowja> #link https://review.openstack.org/#/c/29862/
20:04:17 <jlucci> Awesome awesome job
20:04:22 <harlowja> just wanted to throw that out there ;)
20:05:04 <harlowja> on this day in aug8, a giant leap for mankind, or a small step or something
20:05:13 <harlowja> ha
20:05:22 <jlucci> :P
20:06:00 <kebray> +1 on awesome job on the Cinder merge!
20:06:15 <adrian_otto> well done
20:06:18 <harlowja> ya, thx hemna and john g. and others
20:06:48 <harlowja> yup, step uno of a path to many more steps
20:07:20 <harlowja> alright onwards and upwards
20:07:27 <harlowja> #topic status
20:07:56 <harlowja> i'll go first i guess
20:08:27 <harlowja> resynced oslo code, fixed up cinder, hit oslo exception bug, continuing reading and trying out blocks, trying to see what others think about next steps
20:08:38 <harlowja> which i think is a good topic for a little later (next steps)
20:08:52 <harlowja> and putting more priority on me doing reviews
20:09:02 <harlowja> so that kchenweijie DB work is merged
20:09:13 <kchenweijie> hooray!
20:09:23 <harlowja> :)
20:09:46 <harlowja> what has everyone else been doing
20:10:27 <jlucci> devstack
20:10:28 <jlucci> lolz
20:10:41 <kebray> Don't forget videos.
20:10:45 <harlowja> oh ya!
20:10:52 <jlucci> Mostly sorting through trove code though
20:10:58 <jlucci> Oh, and I made a video. haha
20:11:03 <harlowja> crap can't go back to the announcement section
20:11:15 <jlucci> So that seemed to get some pretty good reception (brought down my dropbox :P)
20:11:21 <harlowja> we have our local actor
20:11:25 <harlowja> ---> jlucci
20:11:25 <jlucci> *bows*
20:11:29 <jlucci> haha
20:11:40 <harlowja> :)
20:11:44 <jlucci> So that was pretty cool - trying to generate some more interest in the project and what not
20:11:48 <harlowja> def
20:12:00 <jlucci> But next steps for me are working on integrating taskflow into trove for create instance
20:12:07 <harlowja> #link http://www.youtube.com/watch?v=SJLc3U-KYxQ
20:12:16 <jlucci> haha
20:12:20 <jlucci> 45 views *whatwhat*
20:12:41 <harlowja> hmmm, need to get that placed on www.yahoo.com somehow
20:12:41 <harlowja> that will shoot that number up
20:12:41 <harlowja> :-P
20:12:51 <jlucci> :P
20:12:51 <jlucci> Anyway - that's it for me!
20:13:05 <harlowja> :) thx jlucci
20:13:12 <harlowja> hollywood awaits
20:13:16 <harlowja> ;)
20:13:29 <harlowja> #action josh make some video to
20:13:30 <harlowja> ;)
20:14:11 <jlucci> haha
20:14:14 <harlowja> kchenweijie what have been up to, fighting with git i think is part of it :)
20:14:17 <jlucci> Make a cinder-taskflow video
20:14:22 <harlowja> ah, jlucci  good idea
20:14:26 <kchenweijie> yup, fighting with git was definitely part of it
20:14:43 <kchenweijie> so i got the (hopefully) final git review up for backend API and generic types
20:14:52 <harlowja> sweet
20:14:52 <kchenweijie> and made it into two (slightly) smaller separate reviews
20:15:01 <kchenweijie> also been working on rpc calls for distributed taskflow
20:15:23 <harlowja> cool, is that pretty involved?
20:15:24 <kchenweijie> fully functional except for the fact that the celery worker at this moment still cannot figure out the ip of the calling machine
20:15:29 <kchenweijie> working on that though
20:15:37 <harlowja> sounds neat
20:15:47 <kchenweijie> i switch between the two projects when i get tired or frustrated with one
20:15:52 <harlowja> i wonder how similar the oslo.messaging stuff is to what u are using
20:16:07 <kchenweijie> will be merged in with the distributed taskflow so that code can be added after a worker is already running
20:16:09 <harlowja> #link https://wiki.openstack.org/wiki/Oslo/Messaging
20:16:34 <jlucci> Only thing that's a little tricky is that we don't want to modify celery code
20:16:34 <kchenweijie> hmm. will take a look at that link
20:16:34 <harlowja> ^ just might be something to read over kchenweijie
20:16:34 <uvirtbot> harlowja: Error: "just" is not a valid command.
20:16:49 <jlucci> But the worker is the server listener
20:16:54 <harlowja> thx uvirtbot (no idea what u are talking about)
20:16:54 <jlucci> Have to get a little hacky
20:16:57 <jlucci> celery worker*
20:16:58 <jlucci> haha
20:17:30 <kchenweijie> yup, so im reading into celerys source code, which is actually really hard to follow at places...
20:17:53 <harlowja> ya, i looked at it a little once, i came to some of the same conclusion
20:18:33 <jlucci> :P
20:18:54 <harlowja> :) that it kchenweijie ?
20:19:01 <kchenweijie> thats it for me
20:19:04 <harlowja> sweet
20:19:05 <harlowja> thx!
20:19:14 <kchenweijie> also, internship ends next tuesday, but we already discussed that i htink
20:19:21 <kchenweijie> so slowly wrapping things up as well
20:19:22 <harlowja> ya, sad face
20:19:47 <harlowja> your work has been much appreciated :)
20:20:02 <harlowja> and i hope it was useful for u to :)
20:20:06 <kchenweijie> thank you. hope it winds up being useful and mostly problem free
20:20:15 <harlowja> def
20:20:21 <kchenweijie> it was. learned a lot about python, databases, message queues, and above all git
20:20:22 <jlucci> Yes, thanks so much for all your help kchenweijie!
20:20:30 <harlowja> good ole git, ha
20:21:05 <harlowja> melnikov yt
20:21:32 <harlowja> i think u've just been exploring the concepts and seeing what u think is good/bad/needs work (much appreciated) ya, maybe get soem coding in soon also
20:21:39 <harlowja> ?
20:22:06 <harlowja> fresh insight is something i think taskflow needs to encourage to be the best it can be :)
20:22:07 <melnikov> yes, pretty much that
20:22:32 <harlowja> woot
20:23:07 <harlowja> anastasia isn't around i think, but i've been messing around with here block stuff, so getting more comfortable there
20:23:13 <harlowja> but i think still some back and forth on that
20:23:29 <harlowja> she i think might be able to help continue on kchenweijie work
20:23:38 <changbl> Hi guys, sorry I am late
20:23:42 <harlowja> np changbl
20:23:45 <harlowja> :)
20:23:53 <jlucci> Yeah - can you post the link to that wiki that melnikov made?
20:23:56 <harlowja> yup yup
20:23:57 <adrian_otto> you missed the big news though
20:24:12 <changbl> let me read the logs
20:24:15 <hemna> big news? :P
20:24:20 <jlucci> haha
20:24:22 <harlowja> medium big
20:24:26 <harlowja> lol
20:24:50 <adrian_otto> I think it's important to recognize integration of taskflow with consider as a major milestone
20:24:51 <harlowja> small step for man, big leap for mankind
20:24:53 <changbl> great job, harlowja !
20:25:03 <harlowja> :)
20:25:05 <harlowja> thx changbl
20:25:08 <hemna> :)
20:25:16 <adrian_otto> so if we were all together I wold lead the room in a round of applause
20:25:20 <harlowja> haha
20:25:23 <harlowja> virtual clap
20:25:26 <harlowja> virtual high-five
20:25:33 <harlowja> ;)
20:25:41 * harlowja high-fived my laptop
20:25:42 * adrian_otto claps
20:25:45 <jlucci> hahaha
20:25:52 * melnikov claps too
20:26:01 <harlowja> lol
20:26:28 <adrian_otto> so special thanks to everyone, especially harlowja for this contribution
20:26:34 <harlowja> hemna jlucci had a neat idea, in the spirt of videos, could make one showing what cinder is now like, the log files would be the most interesting, and describing the changes, what do u think
20:26:50 <hemna> that'd be cool to see
20:26:52 <adrian_otto> it's a win for cinder, and a win for taskflow.
20:27:01 <harlowja> adrian_otto np, just doing my duty :)
20:27:33 <harlowja> #action item josh think of possible video situation
20:27:52 <harlowja> sweet
20:28:06 <harlowja> changbl just doing status also btw, have u been able to mess around at all?
20:28:18 <harlowja> also link for some of melnikov writeups
20:28:20 <harlowja> #link https://wiki.openstack.org/wiki/Taskflow/Patterns_and_Engines
20:28:24 <harlowja> and one that kchenweijie  made
20:28:34 <harlowja> #link https://wiki.openstack.org/wiki/TaskFlow/Persistence
20:28:45 <changbl> I am reading through your new examples, and trying to play with it
20:28:52 <harlowja> with some insights (the melnikov one) and the persistance work ( kchenweijie )
20:28:53 <changbl> also reading blocks and its code
20:29:06 <harlowja> cool
20:29:10 <harlowja> sounds great
20:29:34 <harlowja> any insights u have, or questions, or anything else we are all here to help
20:29:42 <harlowja> *almost anything else*
20:29:42 <harlowja> ha
20:30:19 <harlowja> so lets maybe jump it some of melnikov ideas, before he falls asleep
20:30:24 <jlucci> harlowja, melnikov - could one of ya'll still post the link to the wiki that melnikov made real quick?
20:30:43 <harlowja> i think i just did?
20:30:44 <harlowja> :-/
20:30:50 <jlucci> hurrr
20:30:55 <jlucci> I'm done talking now. :P
20:30:58 <harlowja> haha, np
20:31:04 <harlowja> #topic melnikov-ideas
20:31:20 <harlowja> i know everyone hasn't had time to read it
20:31:22 <harlowja> which is fine
20:31:29 <harlowja> melnikov could u maybe provide a summary quickly?
20:31:35 <melnikov> ok
20:32:25 <harlowja> thx :)
20:33:07 <melnikov> current flows do three things: describe flow structure, actually run the tasks and hold some runtime state for that
20:33:30 <melnikov> i'd like to see them separated
20:33:48 <harlowja> so seperation would be at which pieces?
20:33:52 <harlowja> flow structure + tasks
20:33:56 <harlowja> then runtime elsewhere?
20:35:55 <melnikov> tasks, you put into struture via *patterns* (like linear flow or parallel or graph), than give it to *engine* to execute
20:36:28 <harlowja> i think that makes sense
20:36:46 <harlowja> how much interaction/introspection do u think an engine will have to do to basically 'unravel' the pattern to run it
20:37:04 <harlowja> *the above being complex when subflows and such are used
20:38:16 <melnikov> that will depend on engine implementation imo
20:38:29 <harlowja> agreed
20:38:56 <melnikov> we can have several, some might explore structure like builder from blocks code, some will just extract deps from structure and use that, maybe other ways
20:39:08 <harlowja> agreed
20:39:15 <harlowja> do u want to maybe prototype that idea, i think it likely is the best direction forward, and now (at the early stages) is the best time for it i think
20:39:26 <harlowja> we aren't yet at a stage where its hard to make that change
20:39:55 <harlowja> and melnikov any idea how the logbook (or tasklog, or whatever u want to call it) will be used there
20:40:07 <harlowja> will the machine use the tasklog (as like a persistant memory)
20:40:16 <harlowja> *sorry engine, not machine
20:41:03 <harlowja> jlucci does the above seem pretty useful, i think its where we all want to go in the end
20:42:12 <harlowja> i just wonder about the engine/flow boundary (and how much introspection the engine will need to do to understand the pattern)
20:42:32 <harlowja> and then will machines themselves be saved/restored (so that we can resume/rollback)
20:42:52 <jlucci> It all sounds good, but I just worry that it might get too complicated
20:43:20 <harlowja> agreed, i think a prototype that shows it might help there to see it
20:43:39 <jlucci> Like, I agree that there are distinct parts in the project (flow structure, runtime state/persistance, what runs the tasks/patterns)
20:43:44 <melnikov> jlucci, i hope it would get simpler
20:44:14 <jlucci> I'm not sure that adding additional engines would simplify it though...
20:44:45 <melnikov> there are already engines hidden inside linear flow and graph flow
20:44:50 <jlucci> I think the patterns tell us enough of the "how" to run a flow, that we only need one engine to run them
20:45:01 <jlucci> Right, as of now, our patters are patterns/engines, right?
20:45:10 <jlucci> They define a flow structure, and how to run that structure
20:45:19 <jlucci> And they run said structure
20:45:24 <melnikov> patterns/engines/storage, all three
20:45:25 * harlowja wonders if we can get away with 1 engine, idk
20:46:14 <jlucci> Yeah - it might be too difficult to have one engine
20:46:23 <jlucci> Now that I think through how different the flows currently are
20:46:46 <adrian_otto> why would it be difficult? please elaborate further.
20:46:49 <jlucci> If we had one engine it would probably become all confusing/intricate/spaghetti
20:47:04 <harlowja> depends i think on the engine/pattern barrier right?
20:47:10 <harlowja> *and how that is done*
20:47:11 <jlucci> Well, each flow, as of now, has a very specific way that flows need to be run
20:47:14 <melnikov> i don't think one engine is the way
20:47:37 <jlucci> For instance, linear flows can only be running one task at a time
20:47:46 <jlucci> Where something like parallel flow needs to run multiple tasks at a time
20:48:00 <jlucci> Creating an engine that supports the needs of every flow, I think, would get too complicated
20:48:25 <adrian_otto> ok, I'm persuaded by that.
20:48:27 <jlucci> I'm all for keeping stuff simple, but the more I think about it, I think melnikov does has the right idea
20:48:33 <jlucci> have*
20:48:47 <harlowja> would a possible prototype help there, that might help explore it more deeply
20:49:09 <harlowja> that would make it pretty evident
20:49:35 <harlowja> melnikov do u think that u can attempt that?
20:50:01 <harlowja> then we can maybe discuss it next meeting and see what we all think
20:50:33 <harlowja> *or the meeting after
20:50:34 <melnikov> yes i think prototype will clarify the matters
20:50:42 <jlucci> Yeah, I'd like to see the organization of things. I'm pretty sure I understand the need for all the parts
20:50:48 <harlowja> agreed
20:50:50 <jlucci> Just want to see the big picture I guess
20:51:01 * harlowja same here
20:51:04 <jlucci> :P
20:51:07 <melnikov> also don't know if i'll be able to do something by the next meeting
20:51:12 <harlowja> thats fine
20:51:19 <harlowja> lots to do in the meantime :)
20:51:22 <harlowja> so no worries
20:51:26 <jlucci> Definitely. haha
20:51:46 <harlowja> and i think if engines go into taskflow, they should be mostly transparent to users of the library
20:52:01 <harlowja> just might be 1 or 2 new lines of code
20:52:07 <harlowja> *for the users*
20:52:25 <jlucci> The less the user has to know about the system, the better
20:52:28 <harlowja> ya
20:52:28 <melnikov> 2 to 5 lines in config file maybe
20:52:32 <harlowja> ya, or that :
20:52:50 <harlowja> 2-5, 1-2, 3-4
20:52:54 <harlowja> ha
20:53:13 <harlowja> sounds pretty good
20:53:32 <harlowja> anything else melnikov u want to mention?
20:53:37 <jlucci> <5 and we'll call it a day
20:53:42 <harlowja> ya
20:53:42 <melnikov> )
20:53:51 <harlowja> (
20:54:09 <jlucci> __________
20:54:09 <jlucci> < Success! >
20:54:09 <jlucci> ----------
20:54:09 <jlucci> \   ^__^
20:54:09 <jlucci> \  (oo)\_______
20:54:09 <jlucci> (__)\       )\/\
20:54:10 <jlucci> ||----w |
20:54:10 <jlucci> ||     ||
20:54:11 <harlowja> lol
20:54:15 <changbl> nice
20:54:16 <harlowja> bahaha
20:54:31 <jlucci> Anvil built btw
20:54:32 <jlucci> lol
20:54:34 <harlowja> sweet
20:54:45 <jlucci> Thus the cow. :P
20:54:49 <harlowja> #topic talk-about-whatever
20:54:53 <melnikov> i thik we're done with my stuff for now
20:54:59 <harlowja> sweet, thx melnikov
20:55:20 <harlowja> happy cow be happy
20:55:33 <jlucci> Yeah - thank you. I think your ideas are going to be really beneficial to taskflow. (:
20:55:35 * harlowja sorta wants to see what happens at minute 61
20:55:43 <harlowja> lol
20:55:53 <harlowja> def, more good inputs the better
20:56:01 <harlowja> *and even bad inputs
20:56:10 <harlowja> all inputs considered
20:56:47 <harlowja> alright, maybe i have to wait for next time to see minute 61
20:56:55 <harlowja> unless anyone wants to talk more about taskflow
20:56:56 <jlucci> *sad panda*
20:56:59 <harlowja> (or whatever)
20:57:13 <harlowja> how's whatever going for u jlucci
20:57:18 <harlowja> dandy?
20:57:23 <harlowja> how's the horse
20:57:36 <jlucci> Waiting for anvil to finish installing
20:57:42 <harlowja> :)
20:57:44 <jlucci> I will cry if it doesn't
20:57:46 <harlowja> ha
20:57:47 <harlowja> it should
20:57:55 <jlucci> I don't know man
20:57:58 <harlowja> lol
20:58:00 <jlucci> devstack should've worked
20:58:03 <jlucci> NOPE
20:58:22 <jlucci> Unexpected error while running command.
20:58:24 <jlucci> *sigh**
20:58:26 <jlucci> To the logs!
20:58:35 <harlowja> run again with -vv
20:58:52 <harlowja> anyway, end meeting, join us in our local home @ #openstack-state-management for more
20:58:55 <harlowja> #endmeeting