19:59:18 <harlowja> #startmeeting state-management
19:59:19 <openstack> Meeting started Thu Aug 29 19:59:18 2013 UTC and is due to finish in 60 minutes.  The chair is harlowja. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:59:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:59:23 <openstack> The meeting name has been set to 'state_management'
19:59:38 <harlowja> oops, 30 seconds to early, lol
20:00:07 <harlowja> hallooooooo
20:00:17 <harlowja> #link https://wiki.openstack.org/wiki/Meetings/StateManagement
20:01:02 <harlowja> hmmm, if nobody around then its a quick meeting, ha
20:01:25 <changbl> quick one? :)
20:01:42 <harlowja> sweet, hi changbl
20:01:50 <changbl> hey man
20:01:52 <harlowja> hey
20:02:05 <harlowja> might just be me and u, ha
20:02:15 <changbl> oops... what happened?
20:02:22 <changbl> vacation?
20:02:44 <harlowja> or busy, jessica i think is busy, i guess ivan to
20:03:21 <harlowja> let me see if we had any action items from last time
20:03:25 <harlowja> #topic previous-items
20:03:35 <harlowja> #link http://eavesdrop.openstack.org/meetings/openstack_state_management/2013/openstack_state_management.2013-08-22-20.00.html
20:03:41 <harlowja> so i did find a sock puppet app for iphone/ipad
20:03:54 <harlowja> #link https://itunes.apple.com/us/app/sock-puppets/id394504903
20:04:02 <harlowja> so i might mess around with that, haha
20:04:24 <harlowja> and i did go through the twiki and added a few more use-cases, cleaned up a few sections
20:04:35 <harlowja> #link https://wiki.openstack.org/wiki/TaskFlow#Further_use-cases
20:04:48 <harlowja> those are other things i think taskflow can help out with
20:05:18 <kebray> hello.
20:05:31 <changbl> at first glance, we will use taskflow to stop/upgrade/restart openstack services?
20:06:02 <harlowja> hmmm, not really, i think that taskflow can help those service actions not behave so badly
20:06:20 <harlowja> kebray hii
20:06:49 <harlowja> changbl let me see if i can readjust that, the description there was more about how the problem exists and how taskflow can help make it better
20:06:51 <changbl> all right, sounds like a good idea, not sure of the acceptance by others
20:07:45 <harlowja> changbl sure, i'll adjust that to make that more obvious
20:07:53 <changbl> harlowja, did you throw this idea into the mailing list to see what others think?
20:08:23 <harlowja> not yet, i always thought it was an inherent thing that taskflow offers, but might be worth a mailing list post
20:08:40 <changbl> ok
20:09:02 <harlowja> changbl when u stop say nova-compute, i guess the question is how does that work for u, does it sometimes leave hypervisors half-way completed?
20:09:36 <changbl> did not encounter this problem before ...
20:09:45 <changbl> seems smooth for me
20:10:10 <harlowja> hmmm, interesting, ok
20:10:36 <harlowja> seems like in general projects if they are forced to stop, when they are in the process of doing actions don't exactly handle that so well
20:10:47 <harlowja> and u typically force them to stop when doing an upgrade, when the hardware fails...
20:11:08 <harlowja> anyways
20:11:19 <changbl> ah, I see... never stop nova-compute when it was performing actions...
20:11:27 <harlowja> lol
20:11:45 <changbl> guess i have not had that much experience with openstack in production
20:11:48 <harlowja> so ya, thats not exactly something i personally believe is acceptable software design ;)
20:12:02 <harlowja> it should always be stoppable
20:12:10 <harlowja> and it should recover
20:12:17 <changbl> make sense to me
20:12:37 <harlowja> i'll update the wiki there to make that more obvious
20:12:45 <changbl> sounds good
20:13:02 <harlowja> cool
20:13:20 <harlowja> #topic status
20:13:51 <changbl> i see a lot of commits from Ivan
20:13:55 <harlowja> yup
20:13:57 <harlowja> he's been busy, ha
20:14:05 <changbl> with taskflow? or others?
20:14:11 <harlowja> taskflow afaik
20:14:29 <harlowja> talking to him i think we can start getting some of those in next week
20:14:35 <harlowja> and see how that goes
20:14:48 <changbl> i took a rough look at the code
20:14:58 <changbl> will need more time to review carefully
20:15:02 <harlowja> agreed, same here
20:15:10 <harlowja> i think thats his prototype review also (so its not finished)
20:15:23 <harlowja> he just wanted to get it out there so that we could start thinking about it
20:16:33 <harlowja> as for me, i've just been working on the persistance of flows and experimenting with how we can save tasks and flows to the backiing logbook changes done recently
20:16:40 <harlowja> and not just save them, but restore them
20:16:58 <harlowja> https://review.openstack.org/#/c/43814/ isn't up to date, but its a WIP
20:17:34 <harlowja> it gets complicated when u have arbitarily complex flows/tasks, which is why it will be interesting to see how ivan/anastasia will handle it
20:18:01 <changbl> yes, saw your recent changes, will keep an eye on it
20:18:10 <harlowja> cool :)
20:18:11 <harlowja> thx changbl
20:18:20 <changbl> what is this file "askflow/persistence/backends/sqlalchemy/alembic/versions/21da24117e42_add_task_and_flow_ty.py"?
20:18:46 <harlowja> ah, alembic migration
20:19:03 <harlowja> instead of 002_blah_db.py like in sqlalchemy-migrate
20:19:13 <harlowja> alembic uses this other way, so not 002
20:19:33 <harlowja> the naming i don't really like, ha
20:19:38 <harlowja> but it automatically creates those
20:19:39 <changbl> seems a very alien file to me...
20:20:08 <harlowja> ya
20:20:26 <harlowja> https://github.com/openstack/ceilometer/tree/master/ceilometer/storage/sqlalchemy/alembic/versions
20:20:33 <harlowja> i guess openstack is moving toward that alembic for migrations
20:20:41 <harlowja> so u'll see similar stuff more often i think
20:21:05 <harlowja> *for better or worse*
20:21:11 <changbl> ah, i see.... gonna learn yet another library
20:21:15 <harlowja> ya
20:21:21 <changbl> i learned quite some libraries these days
20:21:23 <harlowja> :)
20:22:17 <changbl> btw, how is the distributed task queue/celery work?
20:22:29 <harlowja> kebray do u have any update there, i guess jessica is out today
20:23:44 <ekarlso-> what are you gonna remove threaded flow ?
20:24:00 <harlowja> whattt
20:24:03 <harlowja> ha
20:24:25 <harlowja> ekarlso- not afaik, it might change a little with ivans work, but i don't think it will affect u at this moment
20:24:57 <harlowja> so no worries ekarlso- !
20:25:02 <harlowja> we got u covered
20:25:04 <ekarlso-> :/
20:25:08 <changbl> harlowja, anyway, i put some comments there on jessica's commit, will wait for her to respond.
20:25:14 <harlowja> changbl agreed
20:25:50 <harlowja> cool, so let me jump into a vote that ivan wanted
20:25:50 <kebray> harlowja  sorry, got distracted.
20:25:56 <harlowja> ah
20:25:57 <harlowja> np
20:26:12 <kebray> Yeah, school is back in session, so jlucci's schedule is sort of sporadic for a bit.
20:26:24 <harlowja> understood
20:26:37 <changbl> Is she a student ? :)
20:26:41 <kebray> She's still just plugging along at Trove.. I know she had a meeting w/Trove developers last week.  They got very excited.
20:26:49 <kebray> They liked what TaskFlow had to offer.
20:26:56 <harlowja> sweet
20:27:19 <kebray> changbl She is currently attending university.
20:27:30 <changbl> kebray, part-time I guess?
20:27:47 <kebray> So, I don't anticipate much push back on the work she will be doing in Trove... but, we'll keep monitoring that to make sure it goes smooth.
20:28:18 <kebray> full-time work, full-time school... but, she loads most of her classes on Tues/Thur.
20:28:32 <harlowja> busy bee, woah
20:28:32 <harlowja> lol
20:28:37 <changbl> double full-time, wow!
20:28:40 <kebray> technically part-time work... but, she manages to put in quite a few hours.
20:28:50 <changbl> i see...
20:28:53 <kebray> anyway.
20:29:08 <harlowja> kebray do u think we should see if anyone wants to jump on the distributed stuff to help out
20:29:15 <harlowja> i'm not sure who that might be, but i can look around, ha
20:29:49 <kebray> that would be great... I"m resource constrained.
20:29:58 <harlowja> k, let me see what i can do
20:30:42 <kebray> My hope is she can finish up Trove work soon, and then let those devs carry on with that... and, put her back on Distributed with intentions of figuring out how to work things into Heat in a way that the community will find valuable, through collaboration with them of course.
20:30:51 <harlowja> agreed
20:31:02 <harlowja> its the same with me and cinder i guess
20:31:04 <kebray> So, it might make sense if someone wants to help her with the Trove stuff first :-)
20:31:13 <harlowja> inspire them to see it, then hope that they can run with some of it
20:31:39 <harlowja> hmmm, so much to tackle
20:31:41 <harlowja> ha
20:32:29 <harlowja> changbl is anyone in your area interested the distributed pieces?
20:32:42 <harlowja> if not at this moment, thats fine also
20:32:43 <changbl> not as far as I know...
20:32:48 <harlowja> k
20:33:15 <harlowja> let me jump topics into the glance meeting that happened
20:33:19 <harlowja> #topic glance-meeting
20:33:29 <harlowja> so there was a meeting on monday morning with the glance folks
20:33:51 <harlowja> i think they are interested in using it for some of there task work, the meeting was more of a what is this, what are u trying to accomplish and all of that
20:34:02 <harlowja> so i think there is shared interest in making it work in someway inside glance
20:34:21 <changbl> harlowja, sounds great
20:34:27 <harlowja> the meeting was in #openstack-glance so it wasn't logged (sadly)
20:34:35 <harlowja> but i think positive involvement there
20:34:49 <harlowja> overall we just need to keep in touch with them, help them explore i think
20:34:56 <harlowja> and then we can be in glance (maybe in H, unsure)
20:35:04 <harlowja> kebray that means cough cough 2 core projects btw ;)
20:35:10 <kebray> :-)
20:35:42 <kebray> I'm meeting internally with John G. soon too, btw.  to talk more about nova integration.
20:36:20 <harlowja> so i'm going to try to continue working with them, if i can get some time to make that happen and help them see how much of taskflow they want/can use, which i think does align with there future goals of having a little task engine in glance to do import/export/convert (of images)
20:36:26 <harlowja> thx kebray that sounds great, let me know if u need me
20:36:36 <changbl> +1 kebray
20:36:56 <kebray> will definitely let you know harlowja.
20:37:24 <harlowja> great, thx kebray
20:37:51 <harlowja> nikhil yt
20:38:14 <harlowja> nikhil i think is the main person thats doing some of the glance -task work
20:38:40 <harlowja> ok, will chat with him later i think
20:39:04 <harlowja> kebray when u get a chance, would u check over https://wiki.openstack.org/wiki/TaskFlow#Further_use-cases also, let me know if they don't make sense
20:39:25 <harlowja> i think i have one modification to do there to make the 'Service stop/upgrade/restart' make more sense
20:39:31 <harlowja> adrian_otto might be interested also
20:39:47 <kebray> was reading that a minute ago... I'm not an expert on nova services (e.g. I don't have experience running openstack myself too much)... but, the use-case seemed good.
20:40:13 <adrian_otto> on a call. Will read scrollback later.
20:40:18 <harlowja> ok, its not really nova specific
20:40:30 <harlowja> its just generic openstack specific really
20:40:43 <harlowja> maybe i shouldn't mention individual services
20:41:08 <kebray> I did the read _very_ quickly.
20:41:11 <harlowja> np
20:41:12 <harlowja> :)
20:42:13 <harlowja> ok that covers my topics i think, ekarlso- i think has been working with billingstack and has been in touch also, so +1 there
20:42:15 <harlowja> thx ekarlso-  :)
20:42:27 <harlowja> #topic open-discuss
20:42:42 <harlowja> and the vote that ivan wanted, which might not be much of a controversy, ha
20:43:16 <kebray> harlowja, do you know when speaking submissions get accepted/rejected?
20:43:25 <harlowja> hmmm, kebray not sure
20:43:47 <harlowja> that would be useful to know i think, ha
20:43:54 <kebray> I'm looking for it.
20:44:08 <harlowja> #startvote change __call__() for tasks -> execute()? Yes, No, Maybe
20:44:09 <openstack> Begin voting on: change __call__() for tasks -> execute()? Valid vote options are Yes, No, Maybe.
20:44:10 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
20:44:17 <harlowja> ^ https://review.openstack.org/#/c/44008/
20:44:18 <uvirtbot> harlowja: Error: "https://review.openstack.org/#/c/44008/" is not a valid command.
20:44:24 <harlowja> #link https://review.openstack.org/#/c/44008/
20:44:30 <changbl> #vote Maybe
20:44:35 <changbl> i am fine with either...
20:44:37 <harlowja> #vote Yes
20:44:55 <harlowja> since i'm fine with seeing how it works, and i think __call__ might have to much inherent meaning
20:45:06 <changbl> aloo right
20:45:11 <changbl> s/aloo/all/
20:45:28 <harlowja> ya, i know ivan wants it, don't think it will be to harmful :)
20:45:35 <changbl> agreed
20:45:41 <changbl> i have some issues with execute_with and revert_with though
20:45:50 <changbl> remote "_with"?
20:45:55 <changbl> s/remote/remove/
20:46:12 <harlowja> hmmm
20:46:28 <harlowja> possibly
20:46:36 <changbl> that way specifying a task will need less typing :)
20:46:54 <harlowja> sure, and i guess when u do execute=blah, its inherent that the '=' means with
20:47:02 <harlowja> hmmmm
20:47:06 <changbl> right... kind of obvious
20:47:24 <harlowja> and less typing, ha
20:47:29 <changbl> exactly
20:47:38 <harlowja> seems like that makes sense to me
20:47:46 <harlowja> anyone else wanna vote, ha :-P
20:47:54 <changbl> haha, vote again
20:48:05 <kebray> harlowja:  Speaking submission notification will happen by email in mid-September.
20:48:09 <changbl> i can make a patch later, if people are not against it
20:48:10 <harlowja> thx kebray
20:48:18 <harlowja> #endvote
20:48:19 <openstack> Voted on "change __call__() for tasks -> execute()?" Results are
20:48:20 <openstack> Maybe (1): changbl
20:48:21 <openstack> Yes (1): harlowja
20:48:33 <changbl> :)
20:48:37 <kevinconway> harlowja: kebray: if you don't already, some of you folks might want to sit in on our trove meetings. we're talking a lot about scheduled tasks lately
20:48:57 <harlowja> #startvote remove '_with'? Yes, No, Maybe
20:48:58 <openstack> Begin voting on: remove '_with'? Valid vote options are Yes, No, Maybe.
20:48:59 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
20:49:01 <kebray> kevinconway when are those meetings?
20:49:03 <harlowja> kevinconway sure
20:49:12 <kevinconway> #link https://wiki.openstack.org/wiki/Meetings/TroveMeeting
20:49:15 <changbl> #vote Yes
20:49:16 <harlowja> #vote Yes
20:49:22 <harlowja> lol
20:49:26 <harlowja> thx kevinconway
20:49:31 <changbl> ^_^
20:49:32 <uvirtbot> changbl: Error: "_^" is not a valid command.
20:49:40 <harlowja> i'll see if i can make sure i attend kevinconway
20:49:57 <harlowja> scheduled tasks is an interseting area, still unsure if taskflow should get into that yet
20:50:07 <harlowja> or should something be built ontop of taskflow to do the scheduling
20:50:11 <kevinconway> harlowja: it's still in the design phase for tasks
20:50:23 <harlowja> sure sure
20:50:29 <harlowja> ok, any more voters??
20:50:32 <kevinconway> but it would be another opportunity to mention taskflow
20:50:37 <harlowja> agreed
20:50:59 <harlowja> #endvote
20:51:00 <openstack> Voted on "remove '_with'?" Results are
20:51:01 <openstack> Yes (2): harlowja, changbl
20:51:06 <harlowja> changbl there u go, ha
20:51:07 <changbl> cool!
20:51:18 * harlowja we need more voters, ha
20:51:22 <harlowja> #action harlowja find more voters
20:51:28 <changbl> lol
20:51:43 <kebray> The trove meeting is Wednesdays at 1pm Pacfic time?   that can't be... that's the same time as the Heat meeting.
20:51:57 * kebray maybe has his timezone conversations all confused again.
20:52:11 <harlowja> :)
20:52:11 <kevinconway> kebray: we meet in #openstack-meeting-alt
20:52:21 <harlowja> 20:00 is when this one is, so it would be yesterday
20:52:33 <harlowja> 20:00 is also when glances is (right now in #openstack-meeting-alt)
20:52:36 <kebray> ah, well, then that's the problem for me... I attend the Heat meeting... will have to work on my multitasking skills :-)
20:52:41 <harlowja> everyone choose like 2000 i think
20:53:38 <harlowja> anyways, any more things to chat about? if not then #openstack-state-management
20:54:23 <kebray> nothing more from me.
20:54:27 <changbl> ditto
20:54:32 <harlowja> cool, thx kebray changbl :)
20:54:35 <harlowja> till next time!
20:54:47 <harlowja> #endmeeting