20:00:09 <harlowja> #startmeeting state-management
20:00:10 <openstack> Meeting started Thu Oct 10 20:00:09 2013 UTC and is due to finish in 60 minutes.  The chair is harlowja. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:13 <openstack> The meeting name has been set to 'state_management'
20:00:23 <harlowja> #link https://wiki.openstack.org/wiki/Meetings/StateManagement
20:00:31 <harlowja> hi folks
20:01:15 <harlowja> anyone around today
20:01:20 <harlowja> or just me, short meeting if just me, ha
20:01:21 <melnikov> hi there
20:01:33 <harlowja> hi melnikov
20:01:40 <tsufiev> hi!
20:01:57 <changbl> hey guys
20:02:15 <harlowja> hey hey
20:02:46 <caitlin56> hi
20:02:49 <harlowja> hi hi
20:02:51 <harlowja> :)
20:03:11 <harlowja> #topic action-items-from-last-week
20:03:23 <harlowja> #link http://eavesdrop.openstack.org/meetings/state_management/2013/state_management.2013-10-03-20.00.html
20:03:34 <harlowja> so i was supposed to start best-practicies wiki
20:03:36 <harlowja> i haven't yet :(
20:03:49 <harlowja> i'll do it very soon/today, i swear
20:04:19 <harlowja> i don't think there was any other action items :)
20:04:24 <harlowja> *bad josh*
20:04:25 <harlowja> ha
20:04:52 <harlowja> #topic announcements
20:05:12 <harlowja> so i'd like to thank melnikov for getting the resumption stuff in, its pretty cool, and i recommend people try it
20:05:55 <changbl> +1 melnikov
20:06:09 <harlowja> https://review.openstack.org/#/c/50770/ is a neato example
20:06:26 <harlowja> *instructions at bottom of code
20:07:49 <harlowja> the other useful annoucement i think is that the distributed stuff i think might have to wait for 0.2, i think its been hard for jessica to work on it while also doing school work
20:08:05 <harlowja> and i'd rather get a release out soon and get that in when we can
20:08:31 <harlowja> it should be a complementary piece of code, so i think that seems fair
20:09:27 <harlowja> just wanted to let people know
20:10:13 <harlowja> #topic release
20:10:41 <harlowja> so in other news, i think we can get out a release like next week, does that seem fair to folks?
20:10:52 <harlowja> and was wondering what version number we should call it
20:10:53 <harlowja> 0.1?
20:10:57 <harlowja> 1.0?
20:11:13 <harlowja> 0.33333
20:11:16 <melnikov> yeah, let's release it next week, and call it 0.1
20:11:23 <changbl> 0.1?
20:11:25 <harlowja> k
20:11:51 <harlowja> sounds good to me
20:11:58 <harlowja> then we can finally get off the update.py stuff
20:12:04 <harlowja> +2
20:12:05 <melnikov> i'd like to add last missing bit for resumption before release
20:12:06 <harlowja> :)
20:12:10 <harlowja> melnikov ok
20:12:12 <harlowja> seems fair
20:13:02 <harlowja> 0.1 for next week (maybe around the same time)
20:13:05 <harlowja> *thursdayish
20:13:38 <harlowja> awesome!
20:13:53 <harlowja> #topic icehouse-integration
20:14:35 <harlowja> so before the summit, i was thinking we can see who might be interested in integrating vs taskflow-core, and see how we can make sure that goes successfully
20:14:50 <harlowja> i've signed up for a little more cinder work there, and hopefully nova
20:15:01 <harlowja> working with john there
20:15:03 <harlowja> #link https://etherpad.openstack.org/IcehouseConductorTasksNextSteps
20:15:17 <harlowja> but of course others can help to :)
20:16:14 <kebray> just got to my desk.. sort of tuning in :-)
20:16:17 <harlowja> *just something to think about before the summit*
20:16:19 <harlowja> kebray np
20:16:22 <caitlin56> Nexenta is interested in cinder optimizations via taskflow, starting with backup.
20:16:29 <harlowja> caitlin56 great
20:16:46 <harlowja> i know the cinder folks hemna and others i think want to see how far we can get
20:16:54 <harlowja> the resumption stuff is pretty powerful
20:17:03 <hemna> :)
20:17:07 <harlowja> and i think will work nicely when integrated
20:17:53 <harlowja> there is also some recent discussions around convection, tsufiev and others and i have been talking
20:18:08 <harlowja> hopefully we can solidify a plan/project that will also use taskflow there soon
20:18:13 <caitlin56> harlowja: have you had a chance to talk with bswartz of Netapp yet about Manila? He's planning it to be very derived from Cinder, so it should be easy to support Manila.
20:18:29 <harlowja> i haven't yet, i should though
20:18:48 <harlowja> let me see if i can get around to at least an invite and chat
20:19:06 <harlowja> #action harlowja bswartz, netapp, manila, taskflow chit-chat
20:19:09 <caitlin56> you can usually find him on #openstack-manila
20:19:11 <harlowja> k
20:19:13 <harlowja> great
20:19:17 <harlowja> thx caitlin56
20:19:59 <tsufiev> harlowja, yes, considering convection and future designs we have etherpad at https://etherpad.openstack.org/TaskServiceDesign
20:20:19 <harlowja> hemna jgriffith as for cinder, i was thinking with the current create_volume, if i plug in the resumption stuff for havana, that would be a pretty good goal ya
20:20:24 <tsufiev> just an initial version )
20:20:29 <harlowja> thx tsufiev
20:21:23 <harlowja> i'll add some comments there soon (After all these darn meetings, ha)
20:21:41 <harlowja> but i think the api and even definitions u guys have in that etherpad are nearly 1:1 matches for whats in taskflow, ha
20:22:59 <tsufiev> glad to hear that, that means we could easily use your library
20:23:03 <harlowja> ya, i think so
20:24:00 <harlowja> hopefully can be some 'task-service' sessions about this in HK
20:24:05 <harlowja> i'm sure kebray would be interested
20:24:35 <harlowja> since afaik he wrote up https://wiki.openstack.org/wiki/Convection :-P
20:25:41 <harlowja> kebray u probably want to be involved i would think, if u have free time
20:25:56 <harlowja> *just a suggetion*
20:26:22 <harlowja> anyways, thats a good transition to next topic
20:26:34 <harlowja> #topic keith-and-my-speaker-session-hk
20:26:46 <harlowja> so kebray and i will be doing a joint-speaker stuff
20:26:53 <harlowja> still collecting ideas for what to talk about @ https://etherpad.openstack.org/TaskflowHKIdeas
20:27:13 <harlowja> feel free to add anything u guys feel will be useful
20:27:34 <harlowja> as a dev, i of course like to see code, but maybe i should avoid that in this talk, ha
20:27:48 <harlowja> and just have a nice set of examples i can run, and documentation and slides
20:27:54 <harlowja> and pretty arrows and boxes
20:29:26 <harlowja> i think kebray and i will try to meetup the week after next, can hopefully have something around then, so that we aren't unprepared
20:29:39 <harlowja> can get some feedback from all u folks
20:29:41 <harlowja> beforehand
20:31:44 <harlowja> ok, feel free to add ideas there, hopefully can have more content soon :-P
20:31:49 <harlowja> #topic flow control strategies
20:32:14 <harlowja> so i created a little brainstorming etherpad for 'flow control' (think if statement) in a workflow
20:32:17 <harlowja> #link https://etherpad.openstack.org/BrainstormFlowConditions
20:32:31 <harlowja> i think its a useful feature to have, and am just collecting potential ideas on how to do it
20:32:42 <harlowja> if others want to ask questions, comments, please do
20:33:05 <harlowja> *ideas that don't reinvent to much of how python already does it
20:33:21 <harlowja> so suggestions and thoughts are welcome
20:33:56 <caitlin56> Are you thinking of building a state-machine from non-procedural xml, and just plugging code into the state machine?
20:34:33 <harlowja> caitlin56 was that for the convection service?
20:34:47 <harlowja> *was that a question releated to convection i mean
20:35:01 <caitlin56> Where are you thinking of doing conditions?
20:35:12 <harlowja> the flow conditions was more of how do u make the execution graph handle one path or another path based on a decision
20:35:21 <caitlin56> Because unless you are doing a full state-machine, why not leave conditions to python code?
20:35:47 <harlowja> python code doesn't have control over the underlying execution graph when running
20:36:29 <harlowja> let me make a simple example
20:36:55 <caitlin56> So you describe a state machine, and the state machine launches python sequences that are more or less straight-forward.
20:37:52 <harlowja> sure, so i think we are actually thinking the same thing, ha
20:38:01 <harlowja> just different terminology
20:38:32 <harlowja> http://paste.openstack.org/show/48244/ is an example
20:38:55 <harlowja> so task X and Y, when they run in the engine can't actually alter what the engine is running
20:39:41 <harlowja> what happens internally is that flow is converted into an execution graph, the graph doesn't yet have information about 'conditions' between nodes in the graph
20:39:54 <harlowja> i think this is where u are thinking of a statemachine (which would have those edge conditions)
20:41:48 <harlowja> but correct me if i am wrong
20:42:59 <caitlin56> From my previous experience with state machines, it is important that everyone has about the same idea of what should be an 'if' within a sequence, and what should be handled by the outer state machine.
20:43:11 <harlowja> sure
20:43:27 <harlowja> in the cases here i think we are talking about the outer state machine
20:43:38 <harlowja> and not internal to a task
20:44:23 <harlowja> so lets try to maybe continue this on the etherpad, make sure its all clear
20:45:29 <harlowja> and if its not clear, then we'll keep on working until it is, ha
20:46:32 <harlowja> alright, i don't have much else, anyone else have any topics?
20:47:54 <harlowja> #topic open-discuss
20:48:43 <harlowja> caitlin56 your thoughts would be very much appreciated on the https://etherpad.openstack.org/BrainstormFlowConditions :)
20:48:51 <harlowja> make sure its clear
20:50:55 <harlowja> alright, guess we can end 10 minute early :-P
20:50:58 <harlowja> thx all for coming
20:51:03 <caitlin56> ok, reading now.
20:51:25 <harlowja> np
20:51:31 <harlowja> much appreciated
20:51:45 <harlowja> #endmeeting