20:00:13 <harlowja> #startmeeting state-management
20:00:14 <openstack> Meeting started Thu Oct 24 20:00:13 2013 UTC and is due to finish in 60 minutes.  The chair is harlowja. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:17 <openstack> The meeting name has been set to 'state_management'
20:00:20 <harlowja> hi folks
20:00:27 <iv_m> hi there
20:00:30 <harlowja> hi hi
20:01:23 <harlowja> lets see who shows up, ha
20:02:02 <harlowja> i just noticed these, i think we can close them, as they don't need to be in nova anymore :-P
20:02:12 <harlowja> https://blueprints.launchpad.net/nova/+spec/structured-state-management-core-library
20:02:17 <harlowja> forgot i even made those, ha
20:02:37 <harlowja> guess we'll have a micro-meeting today then :)
20:02:53 <harlowja> #link https://wiki.openstack.org/wiki/Meetings/StateManagement
20:03:21 <harlowja> think a good think just to discuss https://blueprints.launchpad.net/taskflow
20:03:28 <harlowja> #link https://blueprints.launchpad.net/taskflow
20:04:23 <harlowja> was thinking checkpointing, a basic distributed engine, book-retention, and zk-logbook from changbl
20:04:38 <harlowja> and maybe a basic job-reference-impl
20:04:49 <harlowja> so those 5 things (if we can)
20:05:00 <iv_m> i think i've got some kind of plan for reversion strategies
20:05:10 <harlowja> k
20:05:26 * iv_m is prepearing design doce with colorful pictures of graphs)
20:05:29 <harlowja> ha
20:05:33 <harlowja> ponies included?
20:06:05 <iv_m> no, i thought we agreed ponies are out of scope of taskflow
20:06:08 <harlowja> damn it
20:06:12 <harlowja> :(
20:06:57 <harlowja> k, so checkpointing (which might include basic retention?), distributed engine (basic), reversion-strategies, zk-logbook
20:07:08 <harlowja> and of course integration into openstack
20:07:15 <harlowja> *cinder, glance, nova
20:07:22 <harlowja> *more integration that is
20:07:30 <changbl> hey guys,
20:07:35 <harlowja> hi changbl !
20:07:40 <changbl> sorry i am late
20:07:42 <iv_m> hi
20:07:43 <harlowja> np
20:07:58 <harlowja> also btw, 0.1 tag is almost made, there is some problem with gerrit that i am working with them on
20:08:07 <harlowja> something about permissions not being assigned correctly
20:08:15 <changbl> cool
20:08:25 <harlowja> we were just talking about what to try to do for 0.2
20:08:26 <changbl> look forward to 0.1
20:08:34 <harlowja> thinking so checkpointing (which might include basic retention?), distributed engine (basic), reversion-strategies, zk-logbook
20:08:39 <harlowja> and of course high priority on integration
20:08:41 <changbl> i see, i am scrolling back the log
20:08:43 <harlowja> np
20:09:11 <harlowja> those don't seem like to much (more priority on integration of 0.1 i think)
20:09:37 <harlowja> and if we can, DuncanT has a FSM we can try to work with him on
20:09:42 <harlowja> *or is working on*
20:09:59 <harlowja> #link https://etherpad.openstack.org/p/CinderTaskFlowFSM
20:10:14 <harlowja> the FSM would be a nice to have
20:11:06 <harlowja> seems reasonable?
20:11:28 <iv_m> sure
20:11:32 <changbl> did not read it into detail, but i like the idea of associating each entity with a state machine
20:11:52 <harlowja> changbl ya, its still a WIP, so i think we  can help make it appear, although what it is yet is TBD :)
20:12:02 <changbl> sure
20:12:59 <harlowja> i am hoping we dive the FSM into that at the summit (or maybe an unconference) with some cinder folks (and other interested parties)
20:13:20 <harlowja> #action harlowja talk to DuncanT about unconference (or similar)
20:13:31 <changbl> sigh, too bad i won't be there :(
20:13:36 <harlowja> :(
20:13:47 <harlowja> i will channel your good will
20:13:54 <changbl> :)
20:14:17 <harlowja> cool
20:14:24 <harlowja> #topic integration
20:14:37 <harlowja> i think this deserves a whole little session, just to share proposals/ideas
20:14:48 <harlowja> #link https://etherpad.openstack.org/p/TaskflowIcehouseWhoWhatWhereWhy
20:15:27 <harlowja> so i think we have a few cinder sessions, and i think anastasia (and i) want to continue doing work there (and others)
20:15:36 <harlowja> so cinder i feel is going good
20:16:12 <harlowja> glance, i've talked with markwash and explained taskflow ideas and such
20:16:21 <harlowja> and i think there will be some talks at the summit, http://summit.openstack.org/cfp/details/120 (and others)
20:16:34 <harlowja> i think good progress going there
20:17:19 <harlowja> nova i have a joint session with john garbutt and am forming some blueprints for nova to try to get some traction there
20:17:23 <gokrokve> You can cover not just import\export but image migration feature too.
20:17:50 <gokrokve> I saw some BP in glance about more smart image management and distribution.
20:17:52 <harlowja> gokrokve sure, i'm hoping the glance folks do the integration :)
20:18:00 * markwash is listening
20:18:11 <harlowja> markwash ^
20:18:35 <markwash> harlowja: review help would be nice of course
20:18:36 <harlowja> some summit talks and unconference and stuff i think are going well for glance
20:18:40 <harlowja> of course markwash :)
20:19:00 <harlowja> never fear! we are here , ha
20:19:53 <harlowja> so nova 'front', i  am hoping will have some stuff going there for icehouse, thinking harlowja and iv_m can see what we can do there :)
20:20:10 <harlowja> i'd be happy with basics :)
20:20:23 <harlowja> and then heat, http://summit.openstack.org/cfp/details/121
20:20:31 <harlowja> i think that will just be more information sharing and discussion
20:20:57 <harlowja> #action harlowja gotta work with zaneb on that
20:21:11 * harlowja damn i'm doing alot of sessions
20:21:11 <gokrokve> What do you think about nova using taskflow for VM instantiation. Potetnially user can extend workflow to add more actions during the creation of VM without rewriting nova code.
20:21:44 <harlowja> gokrokve so about a 9 months ago, taskflow version 0.00001 NTT and y! actually did that
20:21:55 <harlowja> and we showed it at the conference as a prototype
20:22:21 <harlowja> i think we have to take it a little slower though (for better or worse)
20:22:22 <gokrokve> That's cool. Why it still not in nova?
20:22:50 <harlowja> :)
20:23:11 <harlowja> so i think partially because me and others believed this is better as a library, so diverted path for a short period to build that library
20:23:23 <harlowja> and i think it was also to big of a change for nova at the time
20:23:48 <gokrokve> got it. Still it is valuable extension for nova.
20:23:50 <harlowja> totally agreed
20:24:18 <harlowja> and i hope we can get some traction there in icehouse
20:25:14 <harlowja> gokrokve make more sense now :)
20:25:23 <harlowja> * make more sense now?
20:25:29 <gokrokve> yes
20:25:55 <harlowja> oslo integration also, http://summit.openstack.org/cfp/details/118
20:26:11 <harlowja> i think that one will maybe be about what taskflow is, where does it fit in oslo (does it?)
20:26:49 <harlowja> is it just a naming association (taskflow is in oslo, when its still a library)
20:26:51 <gokrokve> I am not sure how it is related to oslo.
20:27:15 <harlowja> well oslo is a set of common libraries for openstack right?
20:27:28 <harlowja> set = [rpc, log, config]
20:27:39 <harlowja> set += [taskflow] ?
20:27:56 <gokrokve> Yep. Makes sense.
20:28:03 <gokrokve> oslo.taskflow
20:28:11 <harlowja> possibly, idk
20:28:18 <harlowja> to me thats just 'branding' in a way
20:28:21 <harlowja> *which has its uses
20:28:32 <harlowja> taskflow still exists no matter
20:28:43 <harlowja> with our without 'oslo.' prefix :)
20:28:46 <harlowja> *or
20:28:57 <harlowja> anyways, so thats oslo integration
20:29:06 <gokrokve> Yes. It looks like that being adopted by multiple projects is a requirement.
20:29:22 <harlowja> but is sqlalchemy part of oslo?
20:29:33 <harlowja> its used everywhere
20:29:41 <gokrokve> No. And it looks like because oslo is an API library
20:30:05 <harlowja> what libraries aren't API libraries?
20:30:06 <harlowja> :)
20:30:17 <gokrokve> I am probably confused with REAST API.
20:30:24 <harlowja> k, gotcha
20:30:45 <harlowja> ya, so i'm unsure what oslo buys us (besides sponsorship) so we'll see what happens in that session
20:30:48 <gokrokve> The API should be generally useful and a "good fit" - e.g. it shouldn't encode any assumptions specific to the project it originated from, it should follow a style consistent with other Oslo APIs and should fit generally in a theme like error handling, configuration options, time and date, notifications, WSGI, etc
20:31:17 <gokrokve> They actually also mix REST API (WSGI) and probably other API's like library interfaces
20:31:18 <harlowja> sounds like any library i've worked with :-P
20:31:50 <harlowja> ya, so we'll see what happens at summit related to that
20:32:33 <harlowja> so thats all the integration talks that i'll be pushing around :)
20:32:41 <harlowja> anyone else have any?
20:32:46 <harlowja> oh, and of course mistral
20:32:51 <harlowja> which is WIP :)
20:33:14 <harlowja> working with gokrokve and others for mistral
20:33:51 <gokrokve> Do you have time slot in taskflow sessions for Mistral?
20:34:09 <gokrokve> We can prepare etherpads with design proposals and other stuff to discuss.
20:34:23 <gokrokve> I believe we already did something in this direction.
20:34:38 <harlowja> gokrokve the only one i see partially releated to mistral is the heat one
20:34:50 <harlowja> #link http://summit.openstack.org/cfp/details/121
20:35:04 <harlowja> otherwise i think it will have to be unconference like (not official session)
20:35:19 <gokrokve> ok
20:35:50 <harlowja> for the speaker session i am doing (not design session) i have a slide for mistral :)
20:36:30 * harlowja can't find the link off hand for that
20:36:44 <harlowja> if u guys want to see a prototype (version 3.5) of those slides, email me (or ask later)
20:36:57 <harlowja> rather not publize them until earlier to the summt
20:37:04 <harlowja> *when i'll drop them on slideshare
20:37:54 <harlowja> hopefully the deck will be useful :)
20:38:16 <gokrokve> ok. I will ask Ruslan to prepare some data for you and then we can discuss this slide.
20:38:47 <harlowja> k
20:39:38 <harlowja> gokrokve do u want to give a little summary of your current thoughts for mistral (or should we wait?)
20:39:41 <harlowja> #topic mistral
20:41:16 <gokrokve> We are working on two major documents: 1) use cases with detailed description of how Mistral can be used
20:41:39 <gokrokve> 2) Q&A documents with answers for most common questions
20:42:17 <gokrokve> Also we are preparing initial etherpad page for Mistral design
20:42:43 <harlowja> awesome :)
20:42:52 <harlowja> looks like good progress, making sure the foundation is solid
20:43:46 <gokrokve> Also I see an invite for tomorrow for hangout meeting with taskflow team. But frankly, I don't see anyone from your team in this invitation.
20:43:52 <harlowja> i'm there :)
20:43:59 <harlowja> iv_m if he wants to be
20:44:10 <harlowja> at least i think i'm there, ha
20:44:48 <harlowja> *and if anyone else wants, please join
20:45:04 <gokrokve> Probably. My calendar shows only mirantis folks, though
20:45:10 <harlowja> hmmm
20:45:21 <harlowja> i'll double check
20:46:09 <harlowja> #action harlowja make sure hangout in
20:46:45 <harlowja> thx gokrokve , i'll make sure i'm there
20:46:59 <harlowja> #topic open-discuss
20:47:09 <harlowja> anything else for people to discuss? if not we can end early
20:48:00 <harlowja> goiiing once
20:48:43 <harlowja> goiiing twice
20:48:56 <harlowja> sold!
20:49:07 <harlowja> k, keep up the good work folks, and thanks for coming :)
20:49:18 <harlowja> more fun times of course in #openstack-state-management
20:49:30 <harlowja> questions, answers and more goodness there
20:49:46 <harlowja> #endmeeting