20:00:58 <harlowja> #startmeeting state-management
20:00:59 <openstack> Meeting started Thu Dec  5 20:00:58 2013 UTC and is due to finish in 60 minutes.  The chair is harlowja. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:01:00 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:01:02 <openstack> The meeting name has been set to 'state_management'
20:01:06 <harlowja> howdy folks!
20:01:11 <iv_m> hi there
20:01:14 <haruka_> hi
20:01:20 <harlowja> hi there
20:01:51 <harlowja> sooo i guess lets get started
20:02:00 <harlowja> #link https://wiki.openstack.org/wiki/Meetings/StateManagement#Agenda_for_next_meeting
20:02:15 <harlowja> #topic action-items
20:02:19 <harlowja> no action items, haha
20:02:32 <harlowja> #link http://eavesdrop.openstack.org/meetings/state_management/2013/state_management.2013-11-21-20.13.html :)
20:03:14 <harlowja> been 2 weeks, so let me know if i missed anything :), don't think so
20:03:18 <harlowja> #topic current integration
20:03:30 <harlowja> so this is a bigger topic :)
20:03:57 <harlowja> i think cinder is going through, thx anastasia and iv_m and folks :)
20:04:14 <harlowja> #link https://review.openstack.org/#/c/58724/
20:04:27 <harlowja> that should let others get started on there reviews, victor (and others)
20:04:39 <harlowja> and i think anastasia has a couple followup reviews also
20:05:09 <haruka_> I filed blueprint because I couldn't find same topic.
20:05:17 <iv_m> i think we are all waiting to get that merged
20:05:24 <harlowja> hmmm, what was the blueprint for haruka_ ?
20:05:44 <haruka_> #link https://blueprints.launchpad.net/cinder/+spec/create-snapshot-task-flow
20:05:44 <harlowja> #link https://etherpad.openstack.org/p/TaskflowIcehouseWhoWhatWhereWhy (is where i've been connecting everything together) - if u want to put a link there
20:06:09 <harlowja> k, thx haruka_ added to etherpad
20:06:17 <haruka_> thank you
20:06:37 <harlowja> np, launchpad doesn't have such a good way to connect everything as releated to taskflow
20:06:50 <harlowja> so that etherpad has been serving this purpose
20:07:09 <haruka_> ok
20:07:23 <harlowja> iv_m i'll see if i can bug the cinder folks for that review later
20:07:34 <iv_m> great
20:07:38 <harlowja> see if we can get them to approve it
20:07:43 <harlowja> since its got the +2
20:08:38 <MikeSpreitzer> o/
20:08:40 <harlowja> #link https://review.openstack.org/#/c/59327/ is also being worked on by the mistral folks
20:08:51 <harlowja> howdy MikeSpreitzer
20:09:18 <harlowja> and lots of other blueprints :)
20:09:56 <harlowja> iv_m i think u are working through https://blueprints.launchpad.net/nova/+spec/glance-snapshot-tasks (or part of it?)
20:10:04 <iv_m> yup
20:10:13 <iv_m> you're typing faster than me)
20:10:17 <harlowja> ;)
20:11:02 <harlowja> cool, haruka_ the steps in above bp glance-snapshot-tasks seem like they would be applicable for your create-snapshot-task-flow (and others also)
20:11:02 <iv_m> and aslo Alexander Gorodnev is helping me there
20:11:08 <harlowja> great
20:11:18 <iv_m> now we're still at #0 of that bp -- understanding and documenting
20:11:34 <harlowja> nikhil__ and markwash maybe can help ensure sanity there ;)
20:11:57 <harlowja> iv_m totally understood, #0 is a big part of it
20:12:05 <nikhil__> oh snap, that reminds me to take a look at the bp :)
20:12:09 <harlowja> :)
20:12:20 <iv_m> most of actual snapshoting workflow happens inside single nova's driver method -- so looks like we'll have to adjust driver api
20:12:33 <harlowja> ya, the blackbox problem
20:12:45 <harlowja> hard to make a blackbox reliable
20:13:13 <harlowja> #link http://en.wikipedia.org/wiki/Black_box (for those who have no idea what i am talking about, haha)
20:13:32 <harlowja> nikhil__ if u get some time that would be super appreciated
20:14:07 <nikhil__> sure harlowja (I've the link open in my browser, just need to visit it)
20:14:21 <iv_m> #action iv_m agorodnev document nova's snapshoting flow and what we want to do with it
20:14:24 <harlowja> i might see if boris-42 wants to take on https://blueprints.launchpad.net/nova/+spec/terminate-instance-tasks, if not i'll do that, gotta catch up with him on that
20:14:41 <harlowja> he's pretty familar with nova (so thats good)
20:15:05 <harlowja> #action harlowja catch up with boris-42 on https://blueprints.launchpad.net/nova/+spec/terminate-instance-tasks and if he wants to own it (or should i just own it)
20:15:49 <harlowja> the other new one for this week is https://etherpad.openstack.org/p/Rally_TaskFlow_Integration
20:16:02 <harlowja> also working with boris-42 there to see how it might fit
20:16:16 <harlowja> feel free to add any comments there :)
20:16:28 <harlowja> or #openstack-rally to
20:17:08 <harlowja> nikhil__ for glance itself, are u (or other?) still working on the async stuff
20:17:38 <harlowja> i think with the work @ https://review.openstack.org/#/c/59144/ (ongoing) taskflow gets closer to what glance desires
20:17:46 <nikhil__> harlowja: yeah, we'r actively working on it
20:17:59 <nikhil__> 3 patches went in and bunch are to follow
20:18:03 <harlowja> cool
20:18:35 <harlowja> https://blueprints.launchpad.net/glance/+spec/async-glance-workers still is the 'root' blueprint for all those right?
20:18:48 <harlowja> the dependency tree on that one really looks like a tree :)
20:19:02 <nikhil__> yeah, that sounds right
20:19:03 <harlowja> loopsided christmas tree, ha
20:19:06 <nikhil__> that looks scary
20:19:09 <harlowja> :)
20:19:11 <nikhil__> I prefer to not look at it
20:19:21 <harlowja> :)
20:19:59 <harlowja> k, np, i'll look at whats in glance, and maybe write up some ideas for taskflow (or in the future how said glance concepts might translate to taskflow)
20:20:16 <harlowja> thx nikhil__ !
20:20:50 <nikhil__> harlowja: sounds good
20:21:15 <harlowja> :)
20:21:22 <nikhil__> will keep looking into that MP
20:21:29 <harlowja> thx much
20:21:49 <harlowja> and current integration blockers that we can help resolve that people are facing (the cinder 0.1.1 should unblock folks)
20:22:05 <harlowja> *any current
20:22:54 <harlowja> if not, thats ok to (even better, ha)
20:24:07 <harlowja> #topic taskflow features
20:24:34 <harlowja> just a little overview of what i know about being worked on in taskflow (others feel free to add)
20:24:46 <harlowja> 1) zookeeper work (by me)
20:24:59 <harlowja> i was thinking i can make a little demo of this for folks, since it might not be obvious how neat it is :)
20:25:24 <iv_m> would be great
20:25:28 <harlowja> maybe some little tutorial or something
20:25:31 <harlowja> with some code
20:25:51 <harlowja> cool, iv_m i'll see what i can do :)
20:26:04 <harlowja> something that others can pretty easily also try
20:26:16 <iv_m> i was thinking to give it really serious and hard review soon, so being able to see it in action and play with it would help
20:26:21 <harlowja> agreed
20:26:36 <harlowja> #action harlowja make little tutorial/example (other) for zookeeper review
20:27:34 <harlowja> 2) the oslo.messaging worker distributed neato stuff - https://etherpad.openstack.org/p/TaskFlowWorkerBasedEngine (and review WIP @ https://review.openstack.org/#/c/59144/)
20:27:50 <harlowja> ^ above i think is waiting a little bit on oslo.messaging being a little more library like
20:28:17 <iv_m> we talked with Stanislav (who did most of that work) and decided to put it off a bit
20:28:26 <iv_m> because of oslo.messaging
20:28:45 <harlowja> ya, understandable
20:28:59 <iv_m> now we're looking on what interesting things we can do using kombu directly
20:29:12 <harlowja> kk, #link https://review.openstack.org/#/c/59728/ (and a few others) are underway
20:29:26 <harlowja> to try to make it more python3 compat, and oslo.cfg independent...
20:30:13 <harlowja> #link https://review.openstack.org/#/c/59758/ (for some more python3 stuff)
20:31:07 <harlowja> looking forward to see what that becomes (its a tough challenge)
20:31:46 <harlowja> iv_m for the reversion strategy stuff (which i think u are working on) is there any recommended link u have for that
20:32:16 <iv_m> not yet, sorry
20:32:27 <harlowja> np
20:32:32 <harlowja> all good
20:33:34 <harlowja> so one of the other ideas that happened yesterday (still being baked, not concrete)  is https://etherpad.openstack.org/p/async-taskflow-tasks
20:33:53 <harlowja> if people want to add any thoughts, questions, comments on there that'd be great
20:34:25 <harlowja> hopefully the use-case is clear (the ideas on how to solve might not be, if not, feel free to speak up)
20:34:55 <harlowja> so just throwing that out there (feel free to check it out)
20:35:24 <haruka_> ok. I will check it.
20:35:29 <harlowja> sounds great
20:36:13 <harlowja> any taskflow features that need any discussion, i think changbl is working on zookeeper stuff as well
20:36:31 <harlowja> #link https://blueprints.launchpad.net/taskflow/+spec/zk-logbook
20:37:31 <changbl> yes, working on it
20:37:35 <harlowja> sweet, thx changbl  :)
20:37:49 <harlowja> let me know if u get stuck, willing to help out wherever needed!
20:37:58 <changbl> sure
20:38:52 <iv_m> just a quick annonce -- me and Anastasia started work on refactoring engine internals, which is needed for worker-based engine, help in reversion strategies and may bring support of multiprocessing executors
20:39:15 <iv_m> too early to say anything, maybe next time we'll have something cool to show)
20:39:27 <harlowja> alright, lets see what happens there ;)
20:39:42 <harlowja> just internals i hope :)
20:40:35 <iv_m> ya, we are not intending to break anything (like api) right now
20:40:41 <harlowja> sweet
20:41:51 <harlowja> thx iv_m , eagerly awaits next week now, haha
20:42:43 <iv_m> )
20:43:02 <harlowja> any other new taskflow features/goodies that people want to talk about?
20:43:10 <harlowja> can just switch to open-dicuss for anything else
20:43:54 <harlowja> 3
20:43:59 <harlowja> 2
20:44:04 <harlowja> 1
20:44:11 <harlowja> #topic open-discuss
20:44:45 <harlowja> iv_m will your internal engine work have ideas from https://etherpad.openstack.org/p/async-taskflow-tasks (out of curosity)
20:45:49 <harlowja> if its to early to tell, thats fine
20:46:03 <iv_m> no, it started a bit earlier
20:46:18 <harlowja> np
20:46:44 <harlowja> http://www.python.org/dev/peps/pep-3156/ is an interesting read for folks also (the future of python concurrency in a way)
20:47:07 <harlowja> *or maybe the future (still hard to tell, ha)
20:47:14 <iv_m> yeah, it's already in python 3.4 alpha
20:47:43 <harlowja> lots of new concepts there, but a little overlap with taskflow (in a way)
20:47:51 * iv_m lost count of 'future of the futures' puns
20:47:56 <harlowja> :)
20:48:25 <harlowja> ya, i should grep for how many mentions that page has of 'future'
20:48:29 <harlowja> probably over 100
20:49:13 <iv_m> they have most of interface in common with concurrent.futures, so i think if we're nice with that we'll be prepared)
20:49:19 <harlowja> def
20:50:00 <harlowja> be interesting to see what happens in this area (especially with releation to openstack)
20:50:31 <harlowja> and how this works with eventlet (and eventlet+openstack...)
20:50:38 <harlowja> fun times ahead, ha
20:51:29 <harlowja> anyways, can chat more about this in #openstack-state-management so as not to keep people around if there isn't anything so useful to discuss :)
20:51:59 <harlowja> since i know iv_m probably wants to go to sleep, haha
20:52:44 <harlowja> other news, i think boris (from mirantis) will start getting some taskflow programemrs involved from his side, so +1 (+2 when i see the people, ha)
20:52:54 <iv_m> u know my weeknesses
20:53:19 <harlowja> :)
20:53:34 <harlowja> k, letting people go, 7 minutes left, ha
20:53:44 <haruka_> i filed one more bp #link https://blueprints.launchpad.net/nova/+spec/feature-of-cancel with using taskflow
20:53:46 <harlowja> ah
20:53:55 <haruka_> just under considering
20:53:58 <harlowja> intersting
20:54:10 <harlowja> cool, haruka_ will check it out
20:54:18 <harlowja> and will add some comments
20:54:23 <harlowja> much appreciated!
20:54:41 <haruka_> ok
20:55:30 <harlowja> just did a quick look over, seems to be the right kind of idea
20:56:01 <harlowja> i'd use that for like a top level blueprint and add in dependents for the pieces
20:56:23 <harlowja> that seems to be what russellb wants for that one (in whiteboard)
20:56:36 <haruka_> yes.
20:57:19 <harlowja> shall i help u there, or do u have that covered, can see if we can brainstorm how to make that possible
20:57:33 <harlowja> splitting the work and figuring out the pieces is not always easy :)
20:58:51 <harlowja> k, running out of time
20:59:10 <harlowja> haruka_ if u want to brainstorm on how to do this we're always in #openstack-state-management channel (most of us anyway)
20:59:11 <haruka_> yes. thank you. Your comment is always appreciated.
20:59:16 <harlowja> great
20:59:26 <harlowja> as for others, #openstack-state-management  also :)
20:59:33 <harlowja> until next time!
20:59:42 <harlowja> thx for coming folks :)
20:59:56 <harlowja> #endmeeting