20:00:55 <harlowja> #startmeeting state-management
20:00:56 <openstack> Meeting started Thu Dec 12 20:00:55 2013 UTC and is due to finish in 60 minutes.  The chair is harlowja. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:58 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:01:00 <openstack> The meeting name has been set to 'state_management'
20:01:02 <harlowja> hi folks!
20:01:07 <iv_m> hi there
20:01:09 <harlowja> hi hi
20:01:11 <k4n0> hi
20:01:17 <harlowja> just got out of sprint meeting, let me update agenda
20:01:56 <harlowja> *internal y! sprint stuff...
20:02:01 <mspreitz> hi
20:02:44 <harlowja> hi mspreitz iccha k4n0
20:02:51 <harlowja> ok, updated
20:02:53 <harlowja> #link https://wiki.openstack.org/wiki/Meetings/StateManagement#Agenda_for_next_meeting
20:03:21 <harlowja> guess lets do a quick last-action-items overview
20:03:27 <harlowja> #topic action-items
20:03:33 <harlowja> #link http://eavesdrop.openstack.org/meetings/state_management/2013/state_management.2013-12-05-20.00.html
20:03:49 <harlowja> so i haven't caught up with boris yet (will try to do today)
20:03:58 <harlowja> as for little zookeeper example (to help out with review)
20:04:22 <harlowja> paste.openstack.org/show/54861/ is my current incarniation of that
20:04:30 <harlowja> steps at top should help
20:04:57 <harlowja> #action harlowja really catchup with boris this time!
20:05:25 <iv_m> if u want i can try to catch him in skype
20:05:39 <harlowja> i can usually catch him on IRC, just i totally forget to ask him :-)
20:05:52 <harlowja> if i don't iv_m then lets skype
20:06:02 <harlowja> *hopefully today, if he's still on
20:06:05 <harlowja> or tommorow
20:06:16 <harlowja> thx iv_m
20:06:35 <harlowja> iv_m any update on the snapshot nova flow and work?
20:07:12 <iv_m> so, i failed my action item -- we are working on it, and came to some conclusion, and started to code it -- but no docs yet, sorry
20:07:31 <harlowja> np iv_m  :)
20:07:44 <harlowja> still being worked on, thats fine with me :)
20:08:09 * iv_m just needs to write everything down
20:08:12 <harlowja> :)
20:08:18 <harlowja> #action iv_m write all the things down!
20:08:18 <harlowja> ha
20:08:24 <harlowja> all the things please :-P
20:08:36 <harlowja> ha
20:09:01 <iv_m> well, that'll need a lot of space down there
20:09:15 <harlowja> :)
20:09:18 <harlowja> and alot of time
20:09:28 <iv_m> but i'll try to do my best anyway
20:09:41 <harlowja> haha, sweet
20:09:48 <harlowja> #topic current integration work
20:10:01 <harlowja> so i think we covered one of the current integration work that is ongoing (nova)
20:10:40 <harlowja> akarpinska1 is nearly there with the basic cinder work (thx akarpinska1 !)
20:11:10 <harlowja> although i think that one might be hitting some other major gate bugs
20:11:13 <harlowja> #link https://review.openstack.org/#/c/58724/
20:11:24 <harlowja> no so easy to tell
20:12:05 <iv_m> ya, looks like figting through gating bacame harder lately
20:12:10 <harlowja> ya
20:12:13 <harlowja> #link http://lists.openstack.org/pipermail/openstack-dev/2013-December/022052.html
20:12:16 <akarpinska1> is it necessary to do rechecks until I get +1 from Jenkins?
20:12:32 <iv_m> yup
20:12:45 <harlowja> akarpinska1 if there is an active gate bug that is being fixed, then u can sorta wait till its fixed
20:13:01 <harlowja> but ya, in general, jenkins needs to +1 it (which means the gate must not be broke)
20:13:15 <harlowja> the #openstack-infra team might have an idea whats going on (seems to change daily)
20:13:48 <harlowja> akarpinska1 so close though! :)
20:14:11 <harlowja> i think other folks that are getting involved with taskflow + cinder very much appreciate your work :)
20:14:39 <harlowja> anyone that is also working with cinder & taskflow want to add any questions/other (think there are others out there somewhere)
20:15:28 <harlowja> ok, well don't be shy folks :)
20:15:45 * akarpinska1 doing recheck
20:15:54 <harlowja> thx akarpinska1
20:16:07 <harlowja> as for other integration work, i think boris-42 is still experimenting with rally + taskflow
20:16:23 <harlowja> and same with mistral project
20:16:54 <harlowja> as usual
20:16:56 <harlowja> #link https://etherpad.openstack.org/p/TaskflowIcehouseWhoWhatWhereWhy
20:17:04 <harlowja> *where i track most of this
20:17:58 <harlowja> alright, keep up the integration work folks, slowly but surely :)
20:18:05 <harlowja> #topic new-use-cases
20:18:52 <harlowja> so any new issues or use-cases people want to talk about for taskflow
20:19:12 <harlowja> i started a little document that helps explain some of the mind-set change that taskflow might make happen
20:19:25 <harlowja> releated slightly to use-cases
20:19:26 <harlowja> #link https://wiki.openstack.org/wiki/TaskFlow/Best_practices#Mind-Altering_Substances
20:19:32 <harlowja> *no real substances there
20:19:55 <harlowja> nice little place to gather common ideas, patterns, and such
20:20:57 <harlowja> as for other new-uses, iv_m  and akarpinska1 and a few others have been continuing to work on the 'worker' engine model
20:21:03 <harlowja> which should enable some more neat use-cases
20:21:38 <harlowja> also i expect https://review.openstack.org/#/c/60499/ (the tooz project) when combined with taskflow will also add even more
20:21:46 <harlowja> #link https://github.com/stackforge/tooz
20:22:06 <harlowja> anyways, lots of room for new usage :)
20:22:25 <harlowja> #action harlowja describe jobboard mindset change on best practices page
20:23:54 <harlowja> cool, anyways, feel free to bring new usecases and patterns :)
20:24:20 <harlowja> always will to discuss them with folks
20:24:27 <harlowja> #topic open-discuss
20:24:41 <harlowja> iv_m do u want to give a little overview of the changes in the executor (futures) that u are thinkign about?
20:24:55 * harlowja needs to get around to reviewing the changes that u did
20:25:07 <harlowja> or maybe still to early for said discussion (which is fine)
20:26:17 <iv_m> well, the general idea is to have special entity that will know how to take task, its arguments, and apply one to another
20:26:55 <iv_m> it should have closer scope than current TaskAction, wich knows about storage and manages task state changes and suchlike
20:27:17 <harlowja> sure, makes sense, to more focus just on executing, not the rest of the stuff
20:27:45 <iv_m> so, #link https://blueprints.launchpad.net/taskflow/+spec/task-executor
20:27:57 <harlowja> ah, thx for sharing
20:28:04 <harlowja> good description there
20:29:04 <iv_m> next step is to allow task executor to run task asynchronously
20:29:15 <harlowja> :)
20:29:24 <iv_m> that's what worker-based engine will need to do, for example
20:30:01 <harlowja> right
20:30:11 <iv_m> so, the executor should return future that will in order return task result (or task reversion result) and some metadata
20:30:39 <harlowja> cool
20:30:53 <harlowja> what are u thinking about for the metadata?
20:31:24 <iv_m> well, in my experimental code it's task instance itself and what happend (was it reverted or executed)
20:32:29 <iv_m> something like that so that engine does not have to have some sophisitacted data structure to find out where result returned by future belongs
20:32:29 <harlowja> k
20:33:02 <harlowja> in experimental code, i guess listeners that are watching the state transitions still operate as before
20:33:27 <iv_m> of course
20:34:21 <harlowja> neats
20:34:59 <iv_m> then, the plan is to create new graph action that will be able to schedule all the tasks with task executor and wait on returned futures while tasks are executed (maybe in parallel), using no more than one thread
20:35:59 <akarpinska1> I'm not shure it is possible to do in one thread
20:36:11 <akarpinska1> because of feature implementation
20:36:16 <iv_m> hey, i almost already done that
20:36:38 <akarpinska1> do you implement your own feature?
20:37:07 <iv_m> no, i use concurrent.futures.Future in my code
20:37:44 <akarpinska1> but it waits until result is set
20:37:44 <harlowja> interesting
20:38:10 <iv_m> u can wait for several futures at once with concurrent.futures.wait()
20:39:25 <iv_m> wich makes everything really simple
20:39:44 <harlowja> something though blocks right? so for something to block u need something to block on (another thread?) - so that means 2 threads?
20:39:53 <harlowja> anyways, techinical detail, lol
20:40:09 <harlowja> *this might of been what akarpinska1 was asking (not sure)
20:41:39 <harlowja> oh ya, other thing i was going to bring up
20:41:41 <harlowja> #link https://etherpad.openstack.org/p/async-taskflow-tasks
20:42:07 <harlowja> i think with iv_m  work here, #3 becomes more natural (although #0 still seems like it would also be fine)
20:42:22 <harlowja> so i can try out #3 when iv_m executor stuff in place
20:42:26 <harlowja> see how that goes
20:42:39 <iv_m> yup
20:42:43 <harlowja> might not be so bad, not so sure yet
20:43:12 <harlowja> that will make mistral folks use-case work better (maybe?)
20:44:02 <harlowja> what else, oh ya, nearly forgot, changbl i think wasn't able to make it today, but he said offline that he is working on the zookeeper stuff (ongoing)
20:44:07 <harlowja> and getting closer!
20:44:24 <harlowja> will keep all of us posted
20:44:29 <harlowja> *changbl will
20:45:04 <iv_m> great
20:45:43 <harlowja> :)
20:46:09 * harlowja needs to track down some more of the cinder folks doing taskflow integration, see where that is at
20:46:34 <harlowja> #action harlowja see if can track them any of those folks down (to see if they are doing ok)
20:46:52 <harlowja> i know they exist somewhere :-P
20:47:12 <iv_m> )
20:47:56 <harlowja> will see if i can fire some folks an email that might know
20:48:28 <harlowja> anything else people want to talk about, i think i'm all good
20:49:15 <harlowja> goiinnng once
20:49:56 <harlowja> goinnng twice
20:50:15 <harlowja> going thriceeee
20:50:23 <harlowja> sold to iv_m for 500$
20:50:26 <harlowja> ha
20:50:50 <iv_m> np, but what did i get?
20:50:52 <harlowja> ha
20:50:57 <harlowja> secret prize
20:51:34 <harlowja> anyways #openstack-state-management for any further questions, issues, problems, q/a, chit-chat, prizes...
20:51:54 <harlowja> until next time folks, and thanks for coming for those that did :)
20:52:00 <k4n0> thanks guys
20:52:03 <harlowja> np :)
20:52:22 <harlowja> #endmeeting