20:00:17 <harlowja> #startmeeting state-management
20:00:18 <openstack> Meeting started Thu Dec 19 20:00:17 2013 UTC and is due to finish in 60 minutes.  The chair is harlowja. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:19 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:22 <openstack> The meeting name has been set to 'state_management'
20:00:28 <harlowja> hi folks!
20:00:38 <jd__> o/
20:00:50 <harlowja> hi hi
20:00:59 <jd__> (is there an agenda?)
20:01:22 <harlowja> not to much to talk about but ya, just basic stuff i guess this time
20:01:24 <harlowja> #link https://wiki.openstack.org/wiki/Meetings/StateManagement#Agenda_for_next_meeting
20:01:53 <jd__> thanks!
20:02:03 <harlowja> think most people are either getting on xmas vacation, or heads down
20:02:12 <harlowja> might be really short if not to many others, ha
20:02:43 <jd__> hehe I admit I'm here by chance, I didn't even know there was this meeting, but that sounds interesting
20:02:54 <harlowja> lol
20:03:02 <harlowja> jd__ u so sneaky
20:03:12 <jd__> lol
20:03:55 <jd__> oh oh don't all you speak at the same time I'm having a hard time following
20:03:58 <harlowja> haha
20:04:04 <harlowja> lol
20:04:09 <harlowja> #topic action-items-from-last-time
20:04:13 <harlowja> #link http://eavesdrop.openstack.org/meetings/state_management/2013/state_management.2013-12-12-20.00.html
20:04:24 <harlowja> so i really did catch up with boris this time
20:04:49 <harlowja> and think boris and team are still sorting things out on there end, but still interest in getting more involvement in taskflow
20:04:53 <harlowja> right boris-42 :-P
20:05:40 <harlowja> and i also did track some folk down for work listed @ https://etherpad.openstack.org/p/TaskflowIcehouseWhoWhatWhereWhy
20:05:52 <harlowja> anastsia got her cinder patch in, so thats superduper
20:06:08 <harlowja> folks that i tracked down should have reviews up soon (or thats what they said, ha)
20:06:45 * harlowja i didn't though add stuff to the mind-shift page
20:06:51 <harlowja> oops, bad me
20:06:53 <harlowja> #link https://wiki.openstack.org/wiki/TaskFlow#Mind-shifts
20:07:03 <harlowja> #action really add jobboard stuff to mind-shift page
20:07:10 <harlowja> #action harlowja  really add jobboard stuff to mind-shift page
20:07:49 <harlowja> and that was my stuff, haha, if nobody else around then i guess we can skip :-P
20:07:57 <harlowja> jd__ what action items did u complete, haha
20:08:11 <jd__> I approved the first patch on tooz!
20:08:16 <harlowja> ohh, is it in?
20:08:19 <jd__> it is!
20:08:20 <harlowja> nice
20:08:28 <harlowja> coolness
20:08:38 <harlowja> #link https://github.com/stackforge/tooz for folks
20:08:44 <harlowja> very cool
20:09:31 <harlowja> jd__ hopefully we can figure out how to share that zk stuff, not exactly sure how yet, hopefully not copy/paste
20:09:38 <harlowja> *zk/kazoo stuffs
20:09:45 <jd__> yassine's working on that, so feel free to hint him
20:09:50 <harlowja> k
20:09:55 <jd__> that's his next patch AFAIK
20:10:01 <harlowja> nice
20:10:16 <harlowja> hard to tell where that kind of shared testing library shoud/would go
20:10:31 <harlowja> *should
20:10:56 <harlowja> #topic integration
20:11:05 <harlowja> so just a quick summary of the intergration that i am aware of
20:11:17 <jd__> (harlowja: maybe build that as a lib on PyPI?)
20:11:24 <harlowja> jd__ ya i was thinking that too
20:11:34 <harlowja> tinylib though, ha
20:11:47 <jd__> there's no size policy!
20:11:53 <harlowja> :)
20:12:04 <harlowja> so integration, nova snapshot case seems to be getting good work, hopefully something to show there soon
20:12:17 <jd__> nice
20:12:19 <harlowja> nova terminate case, i am working through the thinking/writing up stage and seeing how it alll works
20:12:26 <yassine> A lib on PyPi sounds cool :)
20:12:44 <harlowja> cinder create_volume move to 0.1.1 taskflow library  done, think anatasia has a couple follow-up changes
20:12:46 <harlowja> yassine agreed
20:13:06 <harlowja> a few other cinder refactoring flows should showup soon (or i was told)
20:13:13 <haruka> btw, taskflow has persistence system.
20:13:27 <haruka> How about create volume 0.1.1?
20:13:39 <harlowja> haruka is the question about persistence + create_volume?
20:13:47 <haruka> yes
20:14:01 <harlowja> so ya, thats an interesting area that i don't think anastasia has touched yet
20:14:11 <harlowja> it'd be interesting to see where we can take that
20:14:13 <haruka> ok
20:14:42 <harlowja> the initial work by her was to just get rid of the taskflow copy/paste code (like oslo) and move to library instead
20:15:03 <haruka> ok. I've got.
20:15:04 <harlowja> haruka i do agree we should start the conversations around the persistence work and using it
20:15:16 <haruka> :-)
20:15:23 <harlowja> since it offers some nice stuff (when used correctly)
20:15:48 <harlowja> like spiderman, taskflow with great power comes great responsiblity (or something, haha)
20:16:36 <harlowja> haruka let me see if i can find some time to write down some notes about this, maybe u'd & anatasia & others would be interested to
20:16:56 <harlowja> #action harlowja start brainstorm about using taskflow persistence model in cinder
20:17:08 <haruka> oh thank you.
20:17:23 <harlowja> cool
20:17:54 <harlowja> #action harlowja work with yassine to create minilib for zk like stuff on pypi (name TBD)
20:18:03 <harlowja> *zk+kazoo stuff
20:19:23 <harlowja> k, lets see what else
20:19:54 <harlowja> #topic open-discuss
20:20:06 <harlowja> anything to talk about otherwise, nice short meeting if not :-P
20:20:10 <harlowja> i do like the short-meetings, ha
20:20:43 <harlowja> btw, for other integration stuff, feel free to modify/adjust https://etherpad.openstack.org/p/TaskflowIcehouseWhoWhatWhereWhy
20:20:57 <harlowja> since its hard to track via BP this kind of work
20:22:11 <harlowja> *BP == blueprint
20:22:21 <harlowja> (sometimes i forget what BP stands for, haha)
20:23:20 <harlowja> ok, short meeting then i think :)
20:23:26 <harlowja> clooosing in 3
20:24:21 <harlowja> 2
20:24:40 <harlowja> 1
20:25:23 <harlowja> 0
20:25:25 <harlowja> poof
20:25:29 <harlowja> thanks for coming folks
20:25:34 <haruka> thank you. bye
20:25:36 <harlowja> :)
20:25:44 <harlowja> always findable in #openstack-state-management
20:25:50 <harlowja> *usually findable
20:25:57 <harlowja> #endmeeting