08:00:22 <eranrom> #startmeeting storlets
08:00:23 <openstack> Meeting started Tue Sep 13 08:00:22 2016 UTC and is due to finish in 60 minutes.  The chair is eranrom. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:24 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:00:26 <openstack> The meeting name has been set to 'storlets'
08:00:35 <eranrom> Hi
08:00:39 <takashi> Hi
08:01:08 <eranrom> Congrats for our first official meeting :-)
08:01:24 <eranrom> takashi: Do you know it Kota plans on joining?
08:01:29 <takashi> eranrom: yes! :-)
08:02:09 <takashi> eranrom: I don't know.
08:02:18 <eranrom> takashi: ok, so lets start
08:02:27 <eranrom> #topic python update
08:02:30 <takashi> eranrom: maybe we need to ping him in storlets channel
08:02:39 <eranrom> takashi: good idea.
08:03:31 <takashi> eranrom: I think we can go ahead. I already shared the current status about python storlet work to him.
08:04:05 <eranrom> takashi: ok, sure. So I see that the next step is the StorageFile calss.
08:04:19 <eranrom> I will review
08:04:25 <eranrom> That is:
08:04:43 <eranrom> #action eranrom to review Add StorletFile class: https://review.openstack.org/#/c/367560/
08:05:22 <takashi> eranrom: thanks
08:05:45 <eranrom> takashi: Do you want to land the doc patch and do the Application doc in a follow up?
08:06:26 <takashi> eranrom: IMO it is better to write doc based on that StorletFile interface
08:06:35 <takashi> if we do not have big objections on it
08:06:40 <eranrom> #agreed
08:07:05 <takashi> so I'd like to land StorletFile class first, and submit a doc to depend on that change
08:07:23 <eranrom> takashi: sure. anything else on the topic?
08:08:11 <takashi> eranrom: no big other things now. After we land doc changes, I'll work about remaining items listed on the python-storlet etherpad
08:09:06 <eranrom> takashi: ok, great. I will move to the next topic then.
08:09:16 <eranrom> #topic bit tent work
08:09:36 <eranrom> First, thanks for the Java coding style patch
08:09:53 <eranrom> I guess its high time we added a style check for java
08:10:10 <takashi> eranrom: ++
08:10:29 <eranrom> Still, I guess we first need to replace the build.xml with a pythonic build
08:10:31 <takashi> it was not so hard work to replace tabs as expected, because I can use sed for that :-)
08:10:51 <takashi> eranrom: agree
08:11:38 <eranrom> takashi: right, the thing is, there was a mixture of spaces and tabs with IMO sometimes 8 spaces per tab and sometimes 4 - agrrrr
08:12:45 <eranrom> Also there is 367477 which IMO will be the next step
08:13:06 <eranrom> 367477 Create storlets package
08:13:17 * eranrom acting as patchbot
08:14:01 <takashi> eranrom: I'm drafting some patches to integrate all build stuffs into setup.py
08:14:05 <takashi> This one https://review.openstack.org/#/c/367477/
08:14:14 <takashi> and this one https://review.openstack.org/#/c/368177/
08:14:42 <takashi> IMO, we can integrate buiding/installing of c/java module to setup.py using Extentions
08:15:17 <eranrom> takashi: I thought Extensions only support c, but will recheck
08:15:49 <takashi> eranrom: I still need to check that, or at least I think we can kick some script, maybe.
08:15:59 <eranrom> If indeed Extensions support c only, there is another trick to extend the default behavior of the setup process to add arbitrary functionality
08:16:13 <takashi> eranrom: yes
08:16:49 <takashi> I think it does not take so much time to create the setup.py mechanism itself,
08:17:08 <takashi> but I need more time to update ansible playbook based on that.
08:17:57 <eranrom> takashi: what do you have in mind regarding the ansible part?
08:19:34 <takashi> eranrom: I'll first create a framework with single setup.py, and after that I'll try to address how we should update current ansible scripts
08:20:01 <takashi> eranrom: At that time I'd like to ask you comments/help
08:20:23 <eranrom> takashi: ok, gotcha. So actually you are taking the setup.py action item :-)
08:21:23 <takashi> eranrom: I'll submit a draft of setup.py first, which at least passes unit tests (maybe updated version of 367477)
08:21:39 <eranrom> takashi: ok great thanks.
08:21:52 * eranrom looking for something else to do. Ah - spark-storlets
08:22:40 <eranrom> takashi: Will be looking out for the setup.py and review.
08:22:43 <eranrom> Thanks!
08:22:59 <takashi> talking about ansible, we still have another big one
08:23:14 <takashi> functional tests on swift/keystone master
08:24:11 <takashi> EOL for Liberty is coming soon (when Newton is released), and at least we need to migrate to Mitaka or later
08:24:28 <eranrom> takashi: right. The change itself is changing a single line of code in the storlet-swift-install repo.
08:24:55 <eranrom> #action eranrom to make that change and see all hell breaks loose
08:25:03 <takashi> Is there anything we need to do for keystone v3 before that migration?
08:25:13 <takashi> keystone v3 API
08:26:10 <eranrom> takashi: Well, since keystone is backward compatible, we can start with Keystone master using v2 auth API and then migrate to V3 API
08:26:23 <takashi> eranrom: ok
08:26:39 <takashi> I'm just afraid we need to finish that work before the migration because I tried it and found it may take some time for me... :-(
08:26:47 <eranrom> takashi: I will need to update joss in between to support V3 API so that spark-storlets does not break
08:27:10 <takashi> eranrom: great to hear that
08:27:27 <eranrom> takashi: you mean that you tried Keystone master with v2 API and it did not work?
08:28:28 <takashi> eranrom: Akihito tried it and failed to run ansible scripts, because v2 API is disabled. I'm currently supposing he missed some configration to turn on v2.
08:28:52 <takashi> v2 API
08:29:07 <eranrom> takashi: could be. ok Let me do this in 2 steps (with a third one that follows):
08:29:15 <eranrom> 1. Update to swift master
08:29:24 <eranrom> 2. update to keystone master
08:29:40 <eranrom> That is keystone master with v2 API
08:29:51 <eranrom> 3. update joss / keystone V3 API
08:29:55 <takashi> eranrom: makes sense
08:30:30 <eranrom> takashi: next topic?
08:30:40 <takashi> eranrom: ok
08:30:48 <eranrom> #topic java code style
08:31:45 <eranrom> I do not have much to say on the topic, other then it would be good to introduce so as not to loose the work on the tab expansion
08:32:12 <eranrom> which can be overriden by mistake if we do not have a stlyle checker
08:32:54 <eranrom> I will try to make progress on this next week
08:33:34 <takashi> eranrom: totally agree
08:33:55 <eranrom> takashi: ok, anything else?
08:34:02 <eranrom> #topic open discussion
08:35:17 <takashi> eranrom: As I added to the agenda, I think we need to care about long existing patches
08:36:16 <takashi> mainly I'm little bit warried about installation in docker patch, which exists long time on gerrit
08:37:00 <eranrom> takashi: right. We had a problem were I could not run this on my VM, and it took quite a while till be overcome all problems
08:37:13 <eranrom> In fact I spent a lot of time yesterday and today to
08:37:22 <eranrom> ignore last line
08:37:32 <eranrom> Doron and I spent a lot of time finding this.
08:37:44 <eranrom> that is overcoming this problem
08:38:12 <eranrom> Today I uploaded an updated patch, and Doron has fixed merge problems...
08:38:27 <eranrom> So hopefully it will land soon.
08:38:35 <eranrom> Thanks very much for bringing this up.
08:38:45 <eranrom> Looking at the other two.
08:39:14 <takashi> eranrom: please ping me if you need some review
08:39:24 <eranrom> takashi: sure, thanks
08:39:41 <takashi> about the other two things, I'll ask kota_'s plan.
08:40:21 <eranrom> takashi: sure. Myimpression was that they are still W.I.P but please let me know is I got it wrong.
08:40:56 <takashi> If we start working about packaging, it may cause so may merge conflict on existin items
08:41:05 <takashi> s/may/many
08:41:35 <takashi> so I'd like to land things we can merge first, if we only have small improvements remaining.
08:41:46 <eranrom> takashi: right. Good point!
08:42:25 <takashi> eranrom: I'll have a meeting with kota_ this week, so will ask him there.
08:43:03 <eranrom> takashi: ok please update me, in the meantime I will work on reviewing and landing all other stuff that AFAIK is not W.I.P and is not in conflict.
08:43:44 <takashi> eranrom: ok, thanks
08:44:00 <eranrom> takashi: Thanks for bringing up this topic
08:44:51 <eranrom> takashi: anything else for today?
08:44:51 <takashi> eranrom: :-)
08:45:29 <takashi> eranrom: no
08:45:43 <takashi> I still need to update design summit etherpad, sorry.
08:46:11 <takashi> I think I can take some time for that next week
08:46:17 <eranrom> takashi: that's ok. Its not that urgent
08:46:35 <eranrom> takashi: great.
08:46:56 <eranrom> Thanks for joining (our first official meeting)
08:47:20 <eranrom> See you on #openstack-storlets
08:47:32 <takashi> eranrom: thank you
08:47:37 <eranrom> #endmeeting