08:00:06 <eranrom> #startmeeting storlets
08:00:07 <openstack> Meeting started Tue Sep 20 08:00:06 2016 UTC and is due to finish in 60 minutes. The chair is eranrom. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:00:10 <openstack> The meeting name has been set to 'storlets'
08:00:12 <kota_> yey
08:00:16 <eranrom> Hi
08:00:18 <takashi> hi
08:00:18 <eranrom> :-)
08:00:46 <eranrom> Lets start! Agenda is here: https://wiki.openstack.org/wiki/Meetings/Storlets
08:00:55 <eranrom> do you want to add anything?
08:01:45 <takashi> I'll talk little about python package in 2nd topic
08:01:59 <kota_> looks good to me on the agenda
08:02:10 <eranrom> ok.
08:02:11 <takashi> but no big change is needed
08:02:18 <kota_> i thought to add my multiinput thing but it exists in :D
08:02:29 <eranrom> :-)
08:03:02 <eranrom> takashi: So I take it there are no python updates other then package - right?
08:03:20 <kota_> eranrom: and i think, i and takashi should be today's meeting quickly beause, a big typhoon is comming to Japan
08:03:38 <takashi> kota_: yes :-(
08:03:41 <eranrom> wow. sure. do you want to cancel?
08:03:45 <kota_> eranrom: so we should be back home as soon as possible
08:03:56 <takashi> eranrom: you mean, python storlet, right?
08:04:08 <eranrom> right.
08:04:09 <kota_> eranrom: no worries, we can do maybe ,that comes to early moning tmorrow
08:04:15 <eranrom> but seems we best end now.
08:04:44 <takashi> np for me. I was thinking to go back home after this meeting. :-)
08:04:57 <kota_> takashi: me too!
08:05:00 <takashi> it is not hard wearther now
08:05:02 <eranrom> alright so lets be quick.
08:05:14 <takashi> go back to python storlet thing
08:05:20 <eranrom> #topic Big tent work
08:05:37 <eranrom> takashi: its all yours
08:05:51 <takashi> just a little about python storlet. I still need to work about docs, but still need to take some time for that
08:06:00 <takashi> and about big tent
08:06:29 <takashi> I submitted the patch for python packaging, patch 370332
08:06:56 <takashi> In this patch, we can install all things, including java codes and c codes using simply calling python setup.py
08:07:03 <takashi> 370332
08:07:12 <takashi> sorry, this one https://review.openstack.org/#/c/370332/
08:07:57 <takashi> I'm still trying to find what is the best practice to do so, but I hope I don't need so big change from current one
08:07:57 <eranrom> ok, Is it switll WIP?
08:08:13 <takashi> eranrom: At least I need to fix ansible script, based on the change
08:08:14 <eranrom> takashi: ok gotcha. So I will start looking
08:09:11 <takashi> eranrom: At first, I'd like to ask some feadback about new directory structure.
08:09:55 <eranrom> ok. The current structure can sure use some refactoring...
08:10:16 <eranrom> #action eranrom to first look at the dir structure
08:10:48 <takashi> Currently I'm checking if it is really good idea to merge java codes installation totally to setup.py
08:11:19 <takashi> As far as I check monasca, which also has python codes and java codes, they have independent maven setting only for install java codes
08:12:43 <takashi> but about directory structure I basically follow some existing projects which have java/c codes
08:13:23 <eranrom> takashi: ok. Do you think that we will need to switch from ant to maven? (not now)
08:14:21 <takashi> eranrom: I don't know so much about maven, but it makes sense to me at some points. Maven seems to be used generally
08:14:26 <takashi> but currently ant is enough for us
08:14:34 <eranrom> takashi: ok.
08:14:44 <eranrom> takashi: anything else on the topic?
08:15:10 <takashi> eranrom: nothing from my side
08:15:44 <eranrom> ok. Lets defer the discussion on big tent and switch to long lasting patches.
08:16:05 <eranrom> #topic Long existing patches
08:16:26 <eranrom> kota_: all yours
08:16:37 <kota_> k
08:16:54 <kota_> the first thing multiinput
08:17:19 <kota_> this morning, I was working on rebasing/addressing for takashi's comment
08:17:36 <kota_> the rebasing succeeded, the patch got +1 from jenkins at the gerrit
08:18:06 <kota_> in the perspective for takash's comment, I think only one thing is remaining to discuss
08:18:17 <kota_> what I didn't get yet
08:18:40 <kota_> takashi: https://review.openstack.org/#/c/347258/23/Engine/swift/storlet_gateway/gateways/docker/runtime.py@582 this one.
08:18:49 <takashi> kota_: ok
08:20:44 <takashi> kota_: When I checked the code, I noticed you don't pass metadata of extra sources from gateway to sdaemon
08:21:35 <kota_> from extra resourcces?
08:21:51 <takashi> yes
08:21:59 <takashi> kota_: Currently metadata of input object is included in the metadata of the read fd of input object
08:22:01 <kota_> and you mean user metadata of extra objects
08:22:10 <takashi> kota_: right
08:23:20 <kota_> takashi: good point. maybe just my lazy implementation
08:23:43 <takashi> kota_: IMO we need to refactor DockerRequest somehow to manage multiple input
08:23:56 <takashi> kota_: so I currently just make sure it is intended or not
08:24:12 <takashi> just want to make sure
08:24:34 <kota_> takashi: exactly it might be useful to include user meta, just it was unecessary for my use case.
08:25:20 <eranrom> do you want to have it as a follow on or not (I am good with both)
08:25:22 <kota_> either is fine to me, to do in the patch or later though. if we try to address right now, I need to update some functional tests to assert it
08:26:10 <takashi> kota_: I'm also good with both
08:26:15 <eranrom> kota_: takashi: What do you say about:
08:26:24 <eranrom> 1. land it now (unless there are other issues)
08:26:47 <eranrom> 2. have a doc update patch that specifies user metadata of extra resources is not available
08:27:01 <eranrom> 3. follow on patch that adds yuser metadata to code and doc
08:27:10 <eranrom> s/yuser/user
08:28:07 <takashi> eranrom: maybe we do not have paticular order about 2 and 3
08:28:18 <eranrom> takashi: ok with me
08:28:48 <eranrom> Its just that I would like the doc updated sooner then later...
08:29:16 <eranrom> but its not a big deal anyway.
08:29:24 <eranrom> Also, I can help with the doc.
08:30:35 <kota_> yey, that definately helps me :)
08:30:42 <eranrom> kota_: with pleasure
08:31:09 <eranrom> anything else on this topic?
08:31:53 <takashi> about multi input?
08:31:56 <eranrom> yes
08:32:40 * kota_ is thinking we can move to the next
08:34:55 <kota_> ok, on the next thing for long exiting patches
08:35:07 <eranrom> Improve file_manager: https://review.openstack.org/#/c/349834/
08:35:16 <eranrom> takashi: you still here?
08:35:18 <kota_> yes
08:35:46 <kota_> but nothing progress, I need more time for rebasing and consideration with current master.
08:35:56 <takashi> last week I rebased the patch to validate file_manager option, to prevent unsafe status at least
08:36:12 <kota_> maybe, I can take a time to work on that after Newton Swift released
08:37:05 <eranrom> kota_: Just curious, when is the release planned for?
08:37:59 <kota_> eranrom: notmyname is planning around this week (he said in the swift meeting)
08:38:15 <eranrom> kota_: ok, thanks
08:38:17 <takashi> As far as I know about other projects, Oct 5 seems to be a deadline
08:38:17 <kota_> in the last meeting
08:38:55 <takashi> https://releases.openstack.org/
08:39:15 <takashi> It seems that Oct 6 is Newton release data
08:39:36 <kota_> looking at SwiftPriority reviews https://wiki.openstack.org/wiki/Swift/PriorityReviews, it's close to cut a release (almost priority patches have been landed)
08:40:09 <eranrom> ok thanks. Takashi, would the python packaging work cause a painful merge to the file manager stuff?
08:40:52 <takashi> eranrom: I tested some rebasing this week, and I already confirmed the way to rebase my package patch
08:40:58 <takashi> eranrom: so I don't think so
08:41:04 <eranrom> takashi: ok, greate!
08:41:08 <eranrom> great!
08:41:23 <eranrom> So anything else on this?
08:41:50 <takashi> eranrom: just a thing. I saw you had some discussion about design summit slot in dev ml.
08:42:24 <takashi> sorry not on this. should be talked in open discussion
08:42:25 <eranrom> takashi: yes. I think that the 'math' is not done yet, and Thierry is still gathering information.
08:42:37 <takashi> eranrom: ok
08:43:37 <kota_> eranrom: nice
08:44:02 <eranrom> If I do not hear from him, I will ask later this week.
08:44:08 <ttx> eranrom: so far we have more requests than we have available free slots
08:44:26 <ttx> So I don't think you would end up with more than one
08:44:40 <ttx> but then you can use it as a gathering point and then meet up in the hallway somewhere :)
08:44:41 <eranrom> ttx: I was afraid this is the situation. Thanks anyway.
08:44:59 <ttx> I expect teams to liberate some slots later this week though
08:45:08 <ttx> I'll keep you posted anyway
08:45:13 <eranrom> sure, I think that fb is what we are really after. We are a small team and will find a space to do the workings.
08:45:21 <eranrom> ttx: Thanks very much!
08:45:31 <ttx> so far nobody released a fishbowl
08:45:40 <ttx> those are precious :)
08:45:54 <eranrom> ttx: I see. ok
08:46:12 <ttx> Will try to give it to you if I get one
08:46:24 <eranrom> ttx: Thanks!
08:46:41 <eranrom> ok, so lets move on.
08:46:53 <eranrom> #topic open discussion
08:47:20 <eranrom> From my side, would be happy if someone looked at the recent storlet acl patch
08:47:42 <takashi> eranrom: will have a look. I saw you updated your bp
08:48:22 <eranrom> takashi: Thanks. I wanted to have it in two patches, but ended up with one as I have changed course during the implementation.
08:48:36 <eranrom> Anyway the spec reflects the implementation
08:48:42 <eranrom> Thanks!
08:48:49 <takashi> eranrom: I see
08:49:02 <eranrom> Anything else?
08:49:45 <takashi> nothing from my side
08:50:12 <eranrom> Take care with the typhoon. How many time a year do you get one?
08:51:00 <kota_> nothing else for me.
08:51:48 <kota_> aproxymately 2-3 hit Japan for a year, this year is more than usual :/
08:52:03 <eranrom> I see.
08:52:12 <takashi> we already have 5 for this year...
08:52:16 <eranrom> wow.
08:52:22 <eranrom> So do take care.
08:52:30 <takashi> eranrom: thanks!
08:52:31 <eranrom> Thank you very much for joining!
08:52:53 <takashi> thank you.
08:53:06 <eranrom> Ending a few minutes earlier :-)
08:53:11 <eranrom> #endmeeting