08:00:18 <eranrom> #startmeeting storlets
08:00:19 <openstack> Meeting started Tue Oct 11 08:00:18 2016 UTC and is due to finish in 60 minutes.  The chair is eranrom. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:00:22 <openstack> The meeting name has been set to 'storlets'
08:00:34 <eranrom> Hi.
08:00:47 <takashi> o/
08:01:18 <eranrom> Hi Takashi. Should we wait for Kota or start?
08:01:58 <takashi> eranrom: just pinging kota_
08:02:05 <eranrom> takashi: thanks!
08:04:56 <takashi> eranrom: no replies
08:05:05 <eranrom> takashi: ok, so lets start.
08:05:08 <takashi> eranrom: I think we can start. I think he'll join if he can
08:05:19 <takashi> eranrom: +1
08:05:20 <eranrom> #topic design session
08:06:12 <eranrom> So we have a fb and a wr one after the other on Wed. and I would like to update the schedule with the the topics
08:06:26 <takashi> eranrom: great!
08:06:46 <eranrom> I think that other then those two sessions we can decide there.
08:07:46 <eranrom> I was thinking to devote the fb for spark - which may interest a broader group and the wr to deep dive. If no one comes to either of them we can just use the time for our selves
08:08:07 <eranrom> alternatively, we can split the fb to spark and deep dive
08:08:44 <eranrom> depending on poeple's interest
08:08:55 <takashi> eranrom: agree
08:09:26 <eranrom> ok, so maybe I will write spark and deep dive for both sessions and we will split the time according to interest
08:09:34 <eranrom> does it make sense?
08:09:58 <takashi> eranrom: +1
08:10:06 <eranrom> great.
08:10:15 <eranrom> #action eranrom to update schedule
08:10:42 <eranrom> #topic beg-tent updates
08:10:59 <eranrom> takashi: anything from your side?
08:11:41 <takashi> eranrom: no big updates. I still have some problem around package installattion, which seems to be caused some updates in dependency packages
08:12:09 <takashi> I'm going to set up clean environment to test that, but still need some more time
08:12:25 <eranrom> takashi: ok, thanks!
08:12:47 <takashi> IMO it is better to discuss about its overview in design summit, before merging it
08:13:14 <eranrom> takashi: sure!
08:13:49 <eranrom> takashi: I believe you have placed it on the etherpad.
08:14:09 <takashi> eranrom: I already added the one
08:14:30 <eranrom> takashi: yep. thought so. thanks
08:15:11 <takashi> I think we can also start dicsussing some ideas about storlets host-only installation, based on the packaging work
08:15:27 <eranrom> I have been working on testr integration - no big deal. I could not, however, find a way to see progress as we see with nosetests
08:15:39 <eranrom> I will try to look at other projects
08:15:58 <eranrom> Swift does not seem to use it at all (although it has .testr.conf)
08:16:38 <takashi> eranrom: I think swift is using testr for functional tests
08:16:50 <takashi> if I remeber correctly
08:16:59 * eranrom looking
08:17:10 <takashi> eranrom: I will check it and let you know if I find any information
08:17:38 <eranrom> takashi: I think you are right. it is there.
08:17:55 <eranrom> This is basically all I had.
08:18:20 <eranrom> Anything from your side?
08:18:52 <takashi> eranrom: nothing for today
08:19:08 <eranrom> takashi: ok so we gewt back 40 mins :-)
08:19:09 <takashi> maybe we should check the existing work items for big-tent joining at design summit
08:19:58 <takashi> I think you previously tried to bring some topic around keystone version used for gate testing
08:20:17 <takashi> eranrom: ^^^ Is that already solved?
08:20:35 <eranrom> takashi: not yet.
08:20:39 <eranrom> Here si the plan
08:20:51 <eranrom> s/si/is
08:21:03 <eranrom> Step 1: Have joss support v3
08:21:20 <eranrom> Step 2: Update installation to work with v3
08:21:46 <eranrom> I hope to do step1 in the coming days
08:22:26 <eranrom> The question I had was: Once step2 is completed. Should we take upstream Keystone or Newton Keystone
08:23:06 <eranrom> Since so far Keystone has been a non-easy item in terms of dependencies, I'd rather take Newton.
08:23:19 <eranrom> But we can try and see how this goes.
08:23:30 <eranrom> end of text :-)
08:24:02 <takashi> eranrom: As far as I understand about the policy of gate testing, they use master version for all projects for integrate testing
08:24:04 <takashi> but
08:24:23 <takashi> on the otherhand using Newton still makes sense to me, to make gate job testing stable
08:24:43 <takashi> In that case, I think we should care about compatibility with latest Keystone in release step
08:24:53 <eranrom> takashi: Agree!
08:25:28 <takashi> I saw that you added items about releasing, so I think we can discuss our plan related to that topic.
08:25:37 <takashi> in Barcelona
08:26:04 <eranrom> takashi: sure. I actually left it from previous weeks. Lets discuss in Barcelona!
08:26:12 <eranrom> Its on the etherpad as well :-)
08:26:20 <takashi> eranrom: :-)
08:27:04 <takashi> eranrom: That's all about big tent work today.
08:27:25 <eranrom> takashi: regarding big tent. I will put some order to the etherpad. Copying the items left to the top of the page
08:27:26 <takashi> from my side
08:28:24 <takashi> eranrom: on big tent etherpad page?
08:28:31 <eranrom> yes
08:29:23 <takashi> eranrom: makes sense. It helps us to find what is the remaining items, and what should be fixed next
08:30:34 <eranrom> #action  eranrom to make order in big-tent etherpad
08:31:18 <takashi> eranrom: thanks!
08:33:01 <eranrom> takashi: anything else for today?
08:33:14 <takashi> eranrom: I'd like to talk about releasing
08:33:28 <takashi> which is still remaining on agenda fortunately
08:33:34 <eranrom> takashi: please go ahead
08:33:43 <eranrom> takashi: right :-)
08:34:00 <takashi> In previous meetings, we agreed to merge python storlets doc before our rlease
08:34:05 <takashi> and currently they are merged
08:34:28 <takashi> Is it time to have our Newton release, or is there remaining items which should be merged before that?
08:34:55 <eranrom> takashi: not from my side.
08:35:44 <takashi> eranrom: neither from me
08:35:57 <takashi> patch 375884, merging SBusDatagram can be merged, but I think it is not required
08:36:29 <eranrom> takashi: agree.
08:37:11 <eranrom> takashi: I can create a branch & 'freeze' dependencies on it
08:37:46 <takashi> eranrom: Can I ask you to create that, if it does not take so much time? maybe we can ask comments from other cores on the patch.
08:38:18 <eranrom> you mean the dependencies patch?
08:39:21 <eranrom> sure
08:39:44 <eranrom> Let me do that by the end of the week (Thur.)
08:40:13 <takashi> I'm afraid that I don't really understand the meening of dependencies patch
08:40:22 <takashi> but I intend something like this https://review.openstack.org/#/c/375755/
08:41:18 <takashi> no, not this... sorry
08:41:20 <eranrom> oh, ok, gotcha.
08:41:29 <eranrom> I think we have two steps here
08:42:04 <eranrom> 1. A storlet patch for freezing the dependencies (taking swift newton, and perhaps Keystone newton)
08:42:32 <eranrom> 2. the patch you have referred to
08:42:51 <eranrom> regarding 2, I hope it will be accepted, given that we are not yet official
08:43:24 <takashi> eranrom: makes sense. and I currently understand how we 'freeze dependencies'
08:43:59 <eranrom> I will do this on the branch (not on master)
08:44:02 <takashi> eranrom: I think you already cut off the stable/mitaka branch. I don't know the precise way for unofficial projects, but at least we can do the same thing for newton release
08:44:16 <eranrom> right\
08:44:17 <eranrom> right
08:44:36 <eranrom> I will do that by Thu.
08:45:03 <takashi> eranrom: thank you for working about that
08:45:28 <eranrom> sure.
08:45:50 <takashi> With that releasing, you can mention 'Storlets Newton release' in your summit session, I suppose.
08:46:10 <takashi> (just checking your e-mail. sorry to be late
08:46:40 <eranrom> takashi: good idea.
08:47:02 <eranrom> thanks!
08:47:45 <eranrom> Anything else for today?
08:47:58 <takashi> eranrom: nothing else from my side
08:48:24 <eranrom> ok, so thanks for joining!
08:48:27 <eranrom> talk to you later
08:48:36 <takashi> eranrom: thank you!
08:48:47 <eranrom> #endmeeting