16:03:12 <cody-somerville> #startmeeting storyboard
16:03:13 <openstack> Meeting started Thu Jan 23 16:03:12 2014 UTC and is due to finish in 60 minutes.  The chair is cody-somerville. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:03:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:03:16 <openstack> The meeting name has been set to 'storyboard'
16:03:28 <cody-somerville> Good morning everyone!
16:03:37 <miqui> hello ....
16:03:49 <NikitaKonovalov> hi!
16:03:51 <ruhe> hi
16:04:14 * miqui passing out cookies...
16:04:35 <cody-somerville> #topic Storyboard sprint
16:04:55 <cody-somerville> I hope everyone is excited for next week's storyboard sprint in Brussels.
16:05:02 <gothicmindfood> we're going to sprint next week!
16:05:16 * gothicmindfood thinks she'll be sprinting to the coffee maker, really
16:05:30 <cody-somerville> gothicmindfood: Do you have a schedule/outline proposal to share?
16:05:31 <SergeyLukjanov> o/
16:06:00 <ruhe> bad news from NikitaKonovalov, SergeyLukjanov and ruhe. our visas got stuck in Belgium embassy and there is a chance we will not be able to attend the sprint
16:06:08 <cody-somerville> Oh no!
16:06:16 <miqui> ooh.....
16:06:19 <krotscheck> WHAAAAA
16:06:22 <krotscheck> NO GOOD
16:06:54 <cody-somerville> ruhe: Is there anything that can be done? Would a invitation letter from Open Stack Foundation help (not that I can provide one or offer one)?
16:07:14 <miqui> so that begs the question...what about remotes conf line....etc..etc
16:07:15 <ruhe> cody-somerville: invitation letter might help
16:08:03 <cody-somerville> #action cody-somerville to see if ttx can get invitation letters to help expedite visas for  NikitaKonovalov, SergeyLukjanov and ruhe.
16:08:15 <cody-somerville> Right, remote conf lines
16:08:18 <ruhe> cody-somerville: thank you!
16:08:33 <ttx> cody-somerville: invitation wouldneed to cmoe from a Belgian company
16:08:46 <cody-somerville> In that case, maybe the invite should come from HP.
16:08:47 <gothicmindfood> cody-somerville: is my HP line good everywhere?
16:09:01 * gothicmindfood means HP conference line
16:09:03 <cody-somerville> miqui: HP will happily make audio conferencing services available so that those who can't attend can dial in for specific discussions.
16:09:13 <ttx> cody-somerville: that would look better coming frmo HP Belgium than my one-man shop in France, for sure.
16:10:04 <cody-somerville> Will make details around audio conferencing services available closer to the event.
16:10:11 <miqui> tnx cody-somerville..
16:10:15 <cody-somerville> #link https://wiki.openstack.org/wiki/StoryBoard/Brussels_Sprint
16:11:39 <cody-somerville> The above is link to wiki page on details on the sprint. gothicmindfood has added a proposed outline schedule. I'd like to propose that we adopt it. We can of course we as flexible as we need to be but some structure I think can help us have time to prepare (get our thoughts in order before the event) and stay on track while we're there.
16:12:12 <cody-somerville> Any objections?
16:12:26 <krotscheck> Nope.
16:12:34 <krotscheck> We could do a vote and be all official and stuff
16:13:23 <cody-somerville> That sounds like fun. :)
16:13:44 <cody-somerville> #vote Adopt proposed schedule?
16:13:56 <cody-somerville> #startvote Adopt proposed schedule?
16:13:56 <miqui> no objections, exception there is no mention of onboarding others.... say for example when am ready to start contributing..
16:13:56 <openstack> Begin voting on: Adopt proposed schedule? Valid vote options are Yes, No.
16:13:57 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
16:14:04 <ttx> schedule looks good. I shall have time to explore a number of use cases in those empty slots
16:14:10 <ttx> #vote Yes
16:14:12 <cody-somerville> #vote Yes
16:14:16 <ruhe> #vote Yes
16:14:18 <krotscheck> #vote Yes
16:14:21 <NikitaKonovalov> #vote Yes
16:14:28 <miqui> #vote yes
16:14:56 <mordred> #vote Yes
16:15:03 <gothicmindfood> #vote Yes
16:15:15 <gothicmindfood> miqui - excellent point
16:15:18 <cody-somerville> miqui: re: onboarding, like having some help getting started hacking on it? That's a good idea.
16:15:40 <cody-somerville> #endvote
16:15:41 <openstack> Voted on "Adopt proposed schedule?" Results are
16:15:46 <gothicmindfood> I wanted to start with the big team/documents so we could have guidance when prioritizing the technical work
16:16:08 <gothicmindfood> miqui - maybe we can include that as an item in the team contract?
16:16:39 <gothicmindfood> so we have a process or set of goals around what it is
16:16:45 <gothicmindfood> (onboarding)
16:17:22 <miqui> gothicmindfood: sure... thats a start...
16:17:33 <gothicmindfood> or - did you want to actually be onboarded DURING the sprint, miqui ?
16:17:38 * gothicmindfood might be misunderstanding
16:18:28 <cody-somerville> #action gothicmindfood to follow-up with miqui on onboarding idea.
16:18:35 <gothicmindfood> thanks cody-somerville
16:18:39 <cody-somerville> Next, HP is going to be happy to sponsor a team dinner Thursday evening. So please keep your calendars open. Please put on wiki asap if you have food concerns/allergies/requirements.
16:19:02 <cody-somerville> You might also want to e-mail me if they're hard requirements.
16:19:04 <krotscheck> Yay food!
16:19:12 <krotscheck> I like eating.
16:19:58 <cody-somerville> Also, on Friday starting at 6pm (and finishing laaate) there is the famous FOSDEM Beer Event.
16:20:49 <cody-somerville> As you probably already know, FOSDEM is taking place 10:30am-7pm on Saturday, 9am-6pm on Sunday. No registration necessary. Lots of people.  No marketing talks. No sponsored talks. You love it or hate it I'm told.
16:21:15 <ruhe> evil embassy, doesn't want to let me drink beer
16:21:19 <cody-somerville> :(
16:21:20 <miqui> githicmindfood:  not sure,  perhaps just start hacking on it, onboarding during a sprint might slow things down...
16:22:25 <cody-somerville> If you have any awesome amazing ideas or proposals on the direction to take storyboard, I'd like to recommend that you share in ADVANCE of the sprint to let people have time to digest. Also please speak with gothicmindfood if you'd like to have specific time to pitch and discuss.
16:22:38 <cody-somerville> Any other topics/comments/etc. on the sprint?
16:23:00 <krotscheck> Can we make it an annual thing?
16:23:12 * krotscheck likes asking really premature questions
16:23:22 <krotscheck> No questions here.
16:23:24 <gothicmindfood> krotscheck should pick out our next 5 sprint locations
16:23:29 <cody-somerville> krotscheck: annual! You can't be serious. That's clearly not often enough!! ;)
16:23:34 <krotscheck> ....
16:23:37 <krotscheck> WELL THEN
16:23:47 <cody-somerville> I say every two weeks we have a sprint
16:23:49 <miqui> cody-somerville: how do we share ideas for sb ? send you email? wiki post?
16:23:49 <cody-somerville> OH!!!
16:24:32 <miqui> in my other project we have a two week sprint... back to back
16:24:37 <cody-somerville> miqui: e-mail to openstack-dev with [storyboard] in subject, ccing people you might think to be particularly interested
16:24:45 <miqui> then a hip sprint (nothing but fixing bugs)
16:24:58 <miqui> and the we start again with a new sprint x....
16:25:14 <miqui> cody-somerville: thanks...
16:25:18 <NikitaKonovalov> miqui, you may also create etherpads
16:25:29 <cody-somerville> +1 to etherpads
16:25:32 <cody-somerville> just be sure to share the link :)
16:25:34 <miqui> ah yes...
16:25:38 <miqui> ofcourse...
16:25:39 <cody-somerville> #topic storyboard-webclient current state (and how to test)
16:25:45 <cody-somerville> krotscheck! You're up!
16:25:46 <cody-somerville> :)
16:25:49 <krotscheck> RIGHT
16:26:17 <krotscheck> So the last few commits move us into the world of "Client and API are talking together" world
16:26:56 <krotscheck> THere's several patches out on infra/config that seem to have been sidelined by the current zuul jenkins crazyiness that has been going on.
16:27:18 <krotscheck> So while jenkins is still trying to use our build bash scripts, the codebase has already moved on to using tox
16:27:37 <krotscheck> Also, ruhe's work on the puppet module is still awaiting a +2.
16:27:47 <krotscheck> Though Kai did add some good comments yesterday.
16:28:03 <krotscheck> Things that we really need to get done:
16:28:05 <ruhe> yeah, i was so happy to see first comments on my patch
16:28:29 <krotscheck> 1- Sit on infra's head to get our patches through. (I've got clark)
16:28:44 <krotscheck> 2- Start writing a few integration tests to make sure those work.
16:29:07 <krotscheck> 3- Get things onto a server (wahtever that takes)
16:29:12 <krotscheck> everything else is feature development.
16:29:33 <krotscheck> We need to talk about authentication/authorization, and NikitaKonovalov  just submitted a patch for that
16:29:48 <NikitaKonovalov> that is a kind of a stub
16:29:59 <krotscheck> NikitaKonovalov: It's a good starting point :)
16:30:01 <cody-somerville> It seems like we're talking a lot about auth/auth? Isn't it really a solved problem? Or is this just us figuring out what that is?
16:30:28 <cody-somerville> Also, are we able to get things easily running standalone to try out? ie. Can I spin this all up easily enough in HP cloud? Is that documented?
16:30:32 <krotscheck> cody-somerville: Ehn, there's a lot of unkonwns because only NikitaKonovalov 's actually sat down and written something.
16:30:55 <NikitaKonovalov> there are no out-of-box solutions for pecan to handle oauth
16:30:57 <krotscheck> cody-somerville: We're not on a server yet, but you can use tox to spin up the client and the API independently
16:31:25 <krotscheck> cody-somerville: Though the current master versions won't work with one another - we need to land some patches first.
16:31:33 <cody-somerville> ouch
16:31:36 <krotscheck> NikitaKonovalov: Want to talk more about auth?
16:32:23 <NikitaKonovalov> krotscheck, that would be nice
16:32:28 <krotscheck> cody-somerville: To be honest, the whole "install path" question is only now starting to come together.
16:32:35 <krotscheck> Got it.
16:33:04 <krotscheck> #action krotscheck NikitaKonovalov Talk about auth, auth, and auth.
16:33:10 <cody-somerville> krotscheck: What can I (or others) do to get client and API server working together again?
16:33:19 <krotscheck> cody-somerville: Code review
16:33:27 <ruhe> +1 for code review
16:33:31 <cody-somerville> krotscheck: Do you have links handy so we can add them to meeting minutes?
16:33:35 <NikitaKonovalov> agree, we need code reviews
16:34:07 <krotscheck> Also, we need to get someone other than ttx and mordred with python chops to have +2
16:34:14 <ruhe> #link https://review.openstack.org/#/q/status:open+storyboard,n,z
16:34:25 <cody-somerville> #action cody-somerville to take two hours to do code review later this afternoon.
16:34:47 <krotscheck> Preferably a non-HP person.
16:35:06 <cody-somerville> Acknowledged.
16:35:19 <krotscheck> ANyway: Big goal before the sprint is to get our two pieces talking to each other and onto a server.
16:35:19 <cody-somerville> gothicmindfood: ^^ Can you make sure we discuss core-reviewers at sprint?
16:35:29 <gothicmindfood> cody-somerville yup
16:35:35 <cody-somerville> krotscheck: Agreed.
16:35:40 <cody-somerville> krotscheck: I'll do what I can to help with that.
16:36:00 <krotscheck> So everyone who wants to help with figuring out our install path, please feel free.
16:36:03 <ruhe> jfyi http://russellbryant.net/openstack-stats/storyboard-reviewers-30.txt :)
16:36:22 <cody-somerville> ruhe: You're making me look bad! ;P
16:36:25 <cody-somerville> Anything else on this topic?
16:36:33 <krotscheck> ruhe's point on the puppet module.
16:36:34 <krotscheck> But that's it
16:37:24 <cody-somerville> ruhe: Anything to add on puppet module bit before we move on?
16:37:27 <ruhe> on puppet module: i'll resolve Kai's comments asap
16:37:32 <cody-somerville> Awesome.
16:37:40 <cody-somerville> #topic npm repository mirror
16:37:51 <cody-somerville> krotscheck: I believe this is you as well.
16:37:52 <mordred> things don't work in the infra systems if they need to regularly talk to the internet
16:38:01 <mordred> as in, the internet doesn't work
16:38:04 <krotscheck> RIght
16:38:06 <cody-somerville> mordred: :(
16:38:09 <krotscheck> Someone's sitting on the tubes
16:38:22 <mordred> we run a LOT of testing - the percentages are against us
16:38:29 <mordred> so what we do for other system is make sure that we have a local mirror
16:38:30 <krotscheck> To stabilize our build, it's probably best that we set up an NPM mirror..
16:38:33 <mordred> yah
16:38:41 <mordred> the pypi mirror we have is selective
16:38:48 <mordred> that is, it only mirrors the thigns we need it to mirror
16:38:59 <cody-somerville> Can we easily mirror the pypi mirror model?
16:39:05 <mordred> possibly -
16:39:07 <krotscheck> Sortof
16:39:15 <mordred> I don't know enough about the pure mechanics of bower and npm
16:39:18 <krotscheck> NPM's repo is basically CouchDB with a replication job
16:39:30 <NikitaKonovalov> btw, is there a way to commit all the required npm stuff to the repo and use it from local storage?
16:39:38 <krotscheck> That replication script can be filtered.
16:39:38 * cody-somerville blinks.
16:39:45 <mordred> NikitaKonovalov: no. we will not do that
16:39:46 <krotscheck> NikitaKonovalov urrrrr.... yeees
16:39:48 <mordred> no
16:39:51 <ruhe> other option (not yet utilitized in infra) might be to bake images with disk-image-builder. those images will have everything pre-installed
16:39:57 <krotscheck> NikitaKonovalov: But that might nto be a great idea
16:40:10 <mordred> ruhe: we're not to the place where we can do that in the infra systems yet
16:40:23 <mordred> we also need to solve this genearlly for horizon as well
16:40:48 <mordred> krotscheck: you're saying that anybody can set up an npm mirror just by connecting a local couchdb?
16:41:05 <krotscheck> mordred: Yup. On your laptop, it's super easy
16:41:13 <cody-somerville> https://npmjs.org/package/npm-mirror <-- this looks useful.
16:41:18 <mordred> krotscheck: ok. let's just look at setting one of those up for infra in general
16:41:21 <mordred> next question
16:41:30 <cody-somerville> "npm-mirror is a utility for mirroring a subset of npm packages from another npm registry. It syncs all of the dependencies for a particular node module and writes them to the local filesystem so that a simple webserver can behave like a commonjs compliant package registry."
16:41:46 <mordred> my god. js has such better tools tahn we do
16:41:52 <mordred> krotscheck: how easy is it to tell a local environment to use a mirror and not the internet?
16:42:02 <krotscheck> mordred: .npmrc
16:42:11 <mordred> home or local dir/
16:42:13 <mordred> ?
16:42:21 <krotscheck> Urrr... ~/.npmrc?
16:42:33 <krotscheck> I think we can do a local one.
16:42:35 <mordred> ok. so - at some point - you shoudl look at select-mirror
16:42:36 <krotscheck> Oh, wait.
16:42:49 <krotscheck> YEah, we can tell nodeenv to use something different.
16:43:13 <mordred> ./modules/jenkins/files/slave_scripts/select-mirror.sh
16:43:17 <mordred> in openstack-infra/config
16:43:32 <mordred> this is how we tell pip to use our mirror instead of global
16:43:41 <mordred> because we dont want to set it directly in the repo itself
16:43:52 <mordred> because we'd like for devs at home to use the internet - our mirror is just for our build system
16:43:58 <mordred> and is a build system impl detail
16:44:02 <cody-somerville> To setup a npm mirror, is this just a patch we need to submit to something or will it be more involved?
16:44:26 <mordred> so we want the build system to be able to inject build env information tellinga  job to use a mirror
16:44:39 <mordred> cody-somerville: we'll need to spin up a server in infra and we'll need to make puppet to run the mirror
16:45:04 <cody-somerville> mordred: no good to reuse same server as pypi mirror?
16:45:28 <mordred> cody-somerville: no - the pypi-mirror is built differently - it's just running on static.o.o because it's just static files
16:45:34 <mordred> we have jenkins jobs that publish to it
16:46:25 <krotscheck> #action krotscheck Figure out the details of hosting our own NPM Mirror.
16:46:25 <krotscheck> cody-somerville: That sounds good... will that install into the filesystem on the throwaway jenkins slave though?
16:46:27 <krotscheck> cody-somerville: Oh. No. Neat. So that's a thing.
16:46:29 <krotscheck> Does anyone else have questions on ths?
16:46:40 <cody-somerville> a little off topic, but have we ever considered just setting up a squid proxy to do all these caches/"mirrors"?
16:46:48 <mordred> cody-somerville: yes. it's not good enough
16:46:53 <cody-somerville> kk
16:47:00 <mordred> sadly
16:47:03 <mordred> cause that would be easier
16:47:10 <cody-somerville> (plus it can cause all sorts of tricky issues with apt repositories)
16:47:15 <mordred> yup
16:47:35 <cody-somerville> #topic Any Other Business
16:47:55 <cody-somerville> Great meeting today. Floor is now open for any other business / topics before we finish up.
16:47:59 <mordred> yeah - I'd like to talk about the integration testing real quick
16:48:15 <mordred> krotscheck wrote a great patch to make webclient install storyboard and then integration test that
16:48:34 * cody-somerville hi5s krotscheck.
16:48:37 <mordred> there are a couple of larger issues I'd like to bring up to make sure we can achieve them as we move this into infra
16:48:58 <mordred> we need to make sure that whatever we run as the default tox testing env is isolated
16:49:42 <mordred> so - we should probably sort out if there is either a) a way to run it with sqlite or b) if we can just use the openstackcitest credentials for mysql that are on the test nodes already
16:50:07 <mordred> (we _do_ have infra set up already with existing mysql db's prepped for tests)
16:50:31 <krotscheck> mordred: The current approach is to use mysql. I don't see why SQLite would be an issue other than apparently alembic doesn't like it.
16:50:37 <ruhe> mordred: my patch for alembic testing already uses mysql and postgres with openstackci_test credentials
16:50:38 <NikitaKonovalov> the API can work with sqlite
16:50:59 <cody-somerville> alembic doesn't like sqlite because sqlite doesn't do scheme migrations that well
16:51:00 <ruhe> it shouldn't be difficult to expand other tests
16:51:02 <NikitaKonovalov> actually it can work with whatever sqlalchemy wokrs with
16:51:15 <mordred> ruhe: awesome
16:51:23 <krotscheck> NikitaKonovalov: I stand corrected. Neat
16:51:24 <mordred> so, let's just continue to use openstackci_test then
16:51:38 <mordred> like ruhe's patch
16:51:50 <cody-somerville> #agreed Continue to use openstackci_test like ruge's patch to run against mysql and postgres
16:52:16 <mordred> I _think_ that there is a variable set somewhere (you can look in the nova tests) that indicates the presence of the openstackci_test db
16:52:22 <mordred> also ...
16:53:01 <mordred> we'll want to make use of zuul so that changes to storyboard and storyboard-webclient test against each other
16:53:08 <cody-somerville> +1
16:53:14 <krotscheck> +1
16:53:38 <NikitaKonovalov> +1
16:53:42 <mordred> which means ... we might want to make a version of the integration testing which doesn't pull master.tar.gz but instead assumes that somehting has put storyboard somewhere
16:53:47 <cody-somerville> #agreed we'll want to make use of zuul so that changes to storyboard and storyboard-webclient test against each other
16:54:05 <mordred> OR - just make an integration test script which grabs the two repos from zuul and then configures one to use the other
16:54:30 <mordred> cool. that all soudns sane then
16:54:47 <cody-somerville> Schweet.
16:55:00 <cody-somerville> Thank you mordred.
16:55:10 <cody-somerville> Anything else before we end today?
16:55:26 <krotscheck> I'm good
16:55:54 <cody-somerville> Really looking forward to meeting folks next week and having a chance to hack on storyboard for two days.
16:56:03 <mordred> ++
16:56:21 <gothicmindfood> me too! I hope we can get everyone into Belgium!
16:56:33 <krotscheck> Silly belgians, trying to protect their beer
16:56:36 <cody-somerville> For those of it that can't make it, we will try our best to include you. If you're feeling excluded, we're not being mean intentionally - do poke!
16:57:47 <cody-somerville> You're all awesome, Storyboard is awesome, and Open Stack is awesome. :) So have an awesome day!
16:57:51 <cody-somerville> #endmeeting