16:06:26 <krotscheck> #startmeeting storyboard
16:06:27 <openstack> Meeting started Thu Mar  6 16:06:26 2014 UTC and is due to finish in 60 minutes.  The chair is krotscheck. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:06:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:06:30 <openstack> The meeting name has been set to 'storyboard'
16:06:40 <krotscheck> #topic MVP
16:07:34 <krotscheck> So lots of progress on auth last week, and barring this morning's issue, we seem to be in pretty good shape.
16:07:51 <krotscheck> I've already been dogfooding some stories to get used to the UI, and am starting to iterate.
16:08:20 <krotscheck> In particular though I want to call out NikitaKonovalov for his ridiculous amount of work on the auth stuff
16:08:45 * krotscheck gives NikitaKonovalov a round of... uh... applause? bitplaus?
16:09:18 <krotscheck> Anyway -
16:09:30 <krotscheck> There's a few things I would like to land before everyone starts dogfooding
16:09:55 <krotscheck> The first is the deletion patch - which is currently passing but I'm uncomfortable loading it for reasons I will explain in a bit.
16:10:10 <krotscheck> The second is mordred's work loading projects from projects.yaml
16:11:10 <krotscheck> And the third is an as-yet-unhandled change to our tests after we update oslo
16:12:06 <krotscheck> I got a bunch of feedback yesterday that said "update oslo and your tests and all your migration woes will disappear like magic"
16:12:11 <krotscheck> I have no idea whether that's true.
16:12:56 <ttx> krotscheck: it's our local pixie dust
16:13:25 <krotscheck> Given that everything except for mordred's  description-longer patch is passing, we could just land them all and fix it later.
16:13:26 <NikitaKonovalov> krotscheck, I'm not sure but that big change to oslo db module has introduced some new apis to connect to databse
16:13:30 <ttx> krotscheck: but the people claiming it helps have way more clue on that dept. than I have
16:13:59 <NikitaKonovalov> so, if we adopt that apis, our tests should pass
16:14:12 <krotscheck> NikitaKonovalov: That's reassuring.
16:14:26 * SergeyLukjanov lurks too
16:15:09 <krotscheck> Ok, so current priority is oslo, land all our migrations, and then get the project loader up and running.
16:15:26 <krotscheck> Does anyone want to create the story for that? :)
16:15:32 <mordred> yah. then I think we can dogfood infra
16:15:35 <mordred> :)
16:15:43 <mordred> krotscheck: how do I mark tasks complete? :)
16:15:53 <krotscheck> mordred: That was never part of the mvp :)
16:15:59 * mordred punches krotscheck
16:16:38 <krotscheck> #action krotscheck file story/tasks to finish mvp
16:17:00 <krotscheck> Any other thoughts ron the MVP right now?
16:17:15 <ttx> haven't even had time to log in. should try now
16:17:35 <krotscheck> ttx: There's a bug with the auth at the moment, it's our next topic
16:17:46 <ttx> yep, slightly disappointing.
16:17:54 <ttx> It's like NICE! Oh wait
16:18:06 <NikitaKonovalov> we need to set some basic roles or policies or whatever to manage who can do what
16:18:28 <krotscheck> #topic Auth
16:18:28 <NikitaKonovalov> I've sent some CR to add superusers check
16:19:14 <krotscheck> NikitaKonovalov: It looks good, too.
16:19:24 <krotscheck> NikitaKonovalov: Just needs a rebase
16:19:42 <NikitaKonovalov> so if we have a list of superusers, that will at least not allow everyone to create projects and calling themselves PTLs
16:20:20 <krotscheck> I would LOVE it if we supported people calling themselves PTL's :)
16:20:43 <krotscheck> But right now we can't even log in.
16:20:57 <krotscheck> #link http://paste.openstack.org/show/72784/
16:21:08 <NikitaKonovalov> I've seen the error
16:21:17 <krotscheck> Any ideas?
16:22:03 * krotscheck thinks it's probably his fault
16:22:29 <NikitaKonovalov> I think I've missd if len(request.authorization) < 2 return False
16:22:47 <NikitaKonovalov> I'll make a fix
16:23:02 <ttx> would help if my attention span was above 30 sec
16:23:13 <mordred> ttx: you and me both
16:23:18 <krotscheck> NikitaKonovalov: THat'll be necessary to catch the error, however I'm actually sending an authorizatino header with the failing request
16:23:20 * mordred is going to try to help more today between meetings
16:23:34 <NikitaKonovalov> hmm
16:24:27 <krotscheck> Let me paste my http request
16:25:06 <krotscheck> #link http://paste.openstack.org/show/72788/
16:25:42 <krotscheck> We can do some investigation - it could be that the client's wending the wrong kind of whitespace or something
16:26:02 <krotscheck> Once that's resolved, the next Auth step is superusers.
16:26:42 <krotscheck> ...which is ready to go
16:27:06 <krotscheck> It sounds like NikitaKonovalov's going to take a look at the auth issue, do I have that right?
16:27:16 <NikitaKonovalov> I am
16:28:03 <krotscheck> Excellent.
16:28:16 <krotscheck> Next question on Auth, more for mordred. Can we have an SSL cert?
16:28:22 <krotscheck> #topic SSL Cert
16:28:47 <krotscheck> And, perhaps, not host over http anymore?
16:29:53 <krotscheck> ....I think we lost mordred
16:30:08 <ttx> he is pretty volatile those days
16:30:24 <krotscheck> He's in the office, I'll go sit on his head.
16:30:32 <krotscheck> (in seattle)
16:31:03 <krotscheck> I have nothing else on my agenda, anyone want to bring something up?
16:31:24 <krotscheck> #topic Open discussion
16:32:10 <sarob_> You guys heard about the operators meeting on Monday?
16:32:52 <krotscheck> sarob_: I have not. Can you give us more details?
16:33:16 <sarob_> Like a big user group meeting
16:33:27 <sarob_> Was at eBay in San Jose
16:33:42 <sarob_> Biggest issue out of it
16:34:17 <sarob_> Operators don't have visibility into blueprints
16:34:39 <ttx> sarob_: yes
16:34:50 <krotscheck> I think we all feel that pain
16:34:51 <sarob_> Cause they don't participate in the projects week to week
16:34:53 <ttx> (heard about it, as in encouraged its creation)
16:35:31 <ttx> sarob_: so one thing we are trying to have in storyboard is the expression of complex priorities. So operators can have their own views of priorities and communicate them
16:35:49 <sarob_> That would be awesome
16:35:54 <ttx> rather than scream to have the PTL plans include their prios
16:36:10 <ttx> sarob_: but all using the same tool
16:36:55 <ttx> sarob_: so it's easy to feed them back in
16:37:01 <sarob_> Having attrib like risk
16:37:51 <sarob_> So all the blueprints could be rolled up into a proposed release summary
16:38:24 <krotscheck> Overview dashboards and things like that are exactly what storyboard is about
16:38:31 <sarob_> Operators also need to be more engaged
16:38:56 <sarob_> I'm working on that with the training project
16:39:01 <ttx> sarob_: the idea is to let anyone (or any group) present stories and tasks that matter to them in ordered dashboards
16:39:06 <krotscheck> So, next time you see a disgruntled operator, send them our way - getting some actual user feedback on needs and wants will be useful
16:39:27 <ttx> it's a bit complex (ad novel) so still very much at brainstorming stage
16:39:30 <ttx> and*
16:39:38 <ttx> i'll start blogging more about it
16:40:19 * krotscheck wonders if a graph-like data structure might be a better way of modeling storyboard's "things"....
16:40:23 <sarob_> Not disgruntled but eager to get more involved
16:40:33 <krotscheck> sarob_, My mistake :)
16:40:34 <sarob_> Pictures are good
16:40:47 <ttx> krotscheck: my next step is to do wireframes to try to see how that would look like
16:40:53 <ttx> and then loop in the UX team
16:41:08 * sarob_ it's all good in the hood
16:41:16 <ttx> because the picture in my head is pretty crazy
16:41:21 <krotscheck> ttx: Looking forward to seeing what you come up with :)
16:41:24 <krotscheck> Crazy or not.
16:41:40 <krotscheck> Seems like things are starting to head towards kibitzing, any objections to endoing th e meeing?
16:42:13 <krotscheck> 3....
16:42:17 <krotscheck> 2....
16:42:20 <krotscheck> 1....
16:42:25 <sarob_> Wait
16:42:29 <krotscheck> #endmeeting storyboard