15:00:32 <krotscheck> #startmeeting StoryBoard
15:00:33 <openstack> Meeting started Mon Jun  2 15:00:32 2014 UTC and is due to finish in 60 minutes.  The chair is krotscheck. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:34 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:36 <openstack> The meeting name has been set to 'storyboard'
15:01:13 <SergeyLukjanov> o/
15:01:29 <krotscheck> Hey there SergeyLukjanov. Anyone else here?
15:01:52 <fungi> lurking
15:01:57 <krotscheck> Agenda: https://wiki.openstack.org/wiki/StoryBoard#Agenda
15:02:10 <krotscheck> Last Meeting’s agenda: https://wiki.openstack.org/wiki/StoryBoard#Last_Meeting
15:02:24 <NikitaKonovalov> Hi
15:02:50 <krotscheck> Ok, so we have 4 specs out there waiting for approval. Unfortunately, nobody in StoryBoard can actually approve storyboard specs.
15:03:07 <krotscheck> Or rather, StoryBoard Core can’t approve storyboard specs.
15:04:18 <krotscheck> Which means we’re more or less dead in the water.
15:04:23 <krotscheck> Options are:
15:04:27 <SergeyLukjanov> krotscheck, I found NikitaKonovalov :)
15:04:34 <krotscheck> SergeyLukjanov: Thanks for finding him :)
15:04:37 <krotscheck> Options are:
15:04:45 <krotscheck> 1- Annoy infra-core so that they approve things
15:05:02 <krotscheck> 2- Just make sure we have consensus on code contributors and start dev anyway.
15:05:10 <krotscheck> 3- Create storyboard-specs.
15:05:20 <krotscheck> I’m sure there are others.
15:05:25 <krotscheck> #topic Specs
15:05:30 * krotscheck forgot the subject
15:05:58 <SergeyLukjanov> so, we have storyboard-core team that add ttx, krotscheck and NikitaKonovalov to the infra-core folks
15:06:18 <SergeyLukjanov> current position re -specs repos is to have per-program specs repo
15:06:51 <krotscheck> SergeyLukjanov: Do you have any alternatives?
15:07:21 * SergeyLukjanov thinking now
15:07:31 <krotscheck> I understand that there are certain in-place policies. I’m saying that as a result of these policies, nobody actually working on storyboard has design approval rights on storyboard.
15:07:36 <SergeyLukjanov> I'm ok with the infra-specs
15:08:04 <SergeyLukjanov> I didn't expect specs DDoS for storyboard
15:08:17 <SergeyLukjanov> so, #1 lgtm
15:08:29 <SergeyLukjanov> correction - #1 + #2
15:08:57 <SergeyLukjanov> so, like if we have enough positive marks from sb-core than start working
15:09:11 <SergeyLukjanov> and than someone from infra-core will approve
15:09:26 <krotscheck> Ok, I’ll put that on the infra meeting agenda
15:09:27 <SergeyLukjanov> (probably, we should wait for approval anyway to avoid last min -1's)
15:09:45 <krotscheck> To be honest, I feel that infra-core is intentionally making our work hard so that we build the tools to make their existing toolchain obsolete.
15:09:48 <SergeyLukjanov> yup, krotscheck, please, add it to the infra meeting agenda
15:10:11 <krotscheck> Alright.
15:10:22 <NikitaKonovalov> should we set a special topic for our specs?
15:10:35 <NikitaKonovalov> that whould make searching easier
15:10:43 <SergeyLukjanov> krotscheck, sb isn't making infra toolchain obsolete, only lp-related stuff
15:10:56 <SergeyLukjanov> it's a very small part
15:11:27 <krotscheck> SergeyLukjanov: We’ve just had two pushbacks from infra-core. One on using screenshot markup tools that aren’t in storyboard, now specifications.
15:12:00 <krotscheck> Well, pushback is a strong word
15:12:13 <krotscheck> I think the spec thing was an unintended consequence.
15:12:29 <krotscheck> Anyway: NikitaKonovalov- I like that idea.
15:12:35 <krotscheck> NikitaKonovalov: Any suggestions?
15:12:43 <NikitaKonovalov> git review -t storyboard
15:13:10 <NikitaKonovalov> and search with project:infra-spec topic:storyboard
15:13:34 <krotscheck> That works for me.
15:13:44 <krotscheck> Any objections?
15:13:55 <krotscheck> That’ll at least make it easier until tuesday
15:14:21 <SergeyLukjanov> ++ for topics
15:14:37 <NikitaKonovalov> krotscheck: what's going to happen in tuesday?
15:14:40 <NikitaKonovalov> on
15:14:46 <krotscheck> NikitaKonovalov: Infra meeting.
15:14:53 <NikitaKonovalov> got it
15:14:57 <SergeyLukjanov> -specs has been created because people want to have review tool for specs and it's not clear when it'll be possible in sb (or even will it possible or not)
15:15:26 <krotscheck> #agreed Submit storyboard specs with “-t storyboard"
15:16:06 <krotscheck> We have 4 specs out there right now. Does anyone want to bring up a specific specification, or shall we leave discussion in gerrit?
15:17:55 <krotscheck> I have a +1 from Nikita on Storyboard subscription, and a comment +1 from Thierry both on channel and in the history. Does anyone have any objection to us considering that spec approved?
15:18:32 <krotscheck> Actually, that’s voteworty
15:19:04 * krotscheck can never remember that syntax
15:19:48 <NikitaKonovalov> here it is http://ci.openstack.org/meetbot.html#voting
15:20:35 <krotscheck> #startvote Consider #95307 ready for development? Yes, No, More Discussion
15:20:37 <openstack> Begin voting on: Consider #95307 ready for development? Valid vote options are Yes, No, More, Discussion.
15:20:38 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
15:21:08 <krotscheck> Urm, let’s assume “More” == “More Discussion” and ignore that last vote.
15:21:13 <krotscheck> #vote Yes
15:21:14 <NikitaKonovalov> #vote Yes
15:21:50 <krotscheck> #endvote
15:21:52 <openstack> Voted on "Consider #95307 ready for development?" Results are
15:21:53 <openstack> Yes (2): NikitaKonovalov, krotscheck
15:22:06 <krotscheck> Ok. We’ve got two other specs that I feel are high priority, search and tagging.
15:22:16 <krotscheck> Everyone try to make some time to look over those.
15:22:25 <krotscheck> #topic Ongoing Work
15:22:25 <SergeyLukjanov> IMO we should decide after tomorrow's discussion @ infra meeting re handling specs
15:23:44 <krotscheck> SergeyLukjanov: We can always backtrack.
15:23:45 <krotscheck> #topic Ongoing work (krotscheck)
15:24:10 <krotscheck> Ok, so I’ve been doing approvals, rebases, minor tweaks and specs, but not a whole lot of code last week.
15:24:36 <krotscheck> I did commit a new puppet module for puppet-storyboard though
15:24:42 <krotscheck> I still have to backport that.
15:24:56 <fungi> for the record, the lack of specs approval at this point shouldn't block actually working on things defined in those specs. we're still debating the layout of the specs repo in https://review.openstack.org/94440 which is why *none* of the actual infra specs have been approved yet. it's not an attempt to make things hard on anyone, it's just that it's not ready for use yet
15:25:15 <krotscheck> fungi: Fair point
15:25:42 <krotscheck> No real other updates for me.
15:26:04 <krotscheck> My hope is that I’m going to get the puppet module backported this week, as well as initial work on the subscriptions.
15:26:30 <krotscheck> #topic Ongoing Work (NikitaKonovalov)
15:27:04 <NikitaKonovalov> I've been reviewing code and specs
15:27:15 <NikitaKonovalov> Some minor fixes also
15:27:34 <NikitaKonovalov> I've updated the refresh token support on the client side
15:27:57 <NikitaKonovalov> now it is based on a $timeout, not an $interval
15:28:12 <krotscheck> Cool.
15:28:33 <NikitaKonovalov> So my plan is to start working on search
15:29:02 <krotscheck> Scanning....
15:29:23 <krotscheck> That query string format is from oslo’s array notation?
15:29:32 <krotscheck> Or is that a pecan thing?
15:30:12 <NikitaKonovalov> well, it's neither
15:30:30 <NikitaKonovalov> I think we should discusll it
15:30:41 <krotscheck> I agree.
15:30:53 <krotscheck> Ok, cool, I’ll comment there.
15:31:03 <NikitaKonovalov> I was thinking about gerrit style search
15:31:23 <NikitaKonovalov> but that may appear to be a bit complicated to implement
15:31:47 <krotscheck> Well, your approach leaves us open to easily adding search-by-tag once Thierry’s spec solidifies.
15:32:03 <krotscheck> It’s definitely something to discuss
15:32:27 <krotscheck> #action Everyone Go look at the search spec and discuss there.
15:32:34 <krotscheck> Anything else?
15:32:46 <NikitaKonovalov> that's all I guess
15:33:27 <krotscheck> Cool.
15:33:32 <krotscheck> #topic Ongoing Work
15:33:44 <krotscheck> I think ttx is traveling
15:33:56 <krotscheck> Also, yolanda is in spain and likely at home already
15:34:38 <krotscheck> #topic Open Discussion
15:35:38 <krotscheck> Anything?
15:36:02 <NikitaKonovalov> I think I can make some more auth improvements, like remove tokens on logout
15:36:27 <krotscheck> You mean an explicit destroy method?
15:36:31 <NikitaKonovalov> And may be  a button "Log out on all devices"
15:37:01 <NikitaKonovalov> The OAuth spec says that there should be a way to revoke both access and refresh tokens
15:37:43 <NikitaKonovalov> So if a User clicks Log Out it means his token should no longer be usable
15:38:19 <krotscheck> That makes sense. Perhaps adding DELETE and GET /? to oauth/token to allow more generic management?
15:38:35 <NikitaKonovalov> yep, something like that
15:38:52 <krotscheck> I agree that that’s a good idea.
15:39:04 <NikitaKonovalov> I'll make a story for that
15:39:09 <krotscheck> Awesome.
15:39:51 <krotscheck> The “Hiring someone else for storyboard” has taken a twist, I’m currently interviewing interns.
15:40:11 <krotscheck> 2 more candidates this afternoon, after which I’ll send my report to our recruiter.
15:40:31 <SergeyLukjanov> krotscheck, cool, new blood for sb :)
15:40:37 <krotscheck> Indeed.
15:41:13 <krotscheck> I can’t go into more detail because of Lawyer things.
15:41:34 <krotscheck> Oh, one note: The initial UX team meeting is in 2 hours.
15:42:13 <krotscheck> If you have the time, take a look :)
15:42:20 <krotscheck> Anything else?
15:42:41 * NikitaKonovalov has no more ideas for today
15:43:00 <krotscheck> Alrightey
15:43:04 <krotscheck> #endmeeting